Cookies op Tweakers

Tweakers maakt gebruik van cookies, onder andere om de website te analyseren, het gebruiksgemak te vergroten en advertenties te tonen. Door gebruik te maken van deze website, of door op 'Ga verder' te klikken, geef je toestemming voor het gebruik van cookies. Wil je meer informatie over cookies en hoe ze worden gebruikt, bekijk dan ons cookiebeleid.

Meer informatie

Door , , 127 reacties

Met de invoering van de uitbreiding Cataclysm is World of Warcraft niet langer speelbaar op Apple-computers met een PowerPC-processor. Dat heeft een woordvoerder van ontwikkelaar Blizzard via het forum van de mmog laten weten.

Het was aan Jessicalu, een woordvoerder van Blizzard, om het slechte nieuws naar buiten te brengen via de Mac-supportsectie van het officiële World of Warcraft-forum. De woordvoerder maakt duidelijk dat Blizzard, vlak voordat Cataclysm in de winkel verschijnt, een patch uitbrengt die een einde maakt aan de ondersteuning van de PowerPC-processor. De mmog is vanaf dan niet meer speelbaar op Apple-computers die op de PPC zijn gebaseerd. "Als de game wordt gestart nadat de update is geïnstalleerd, verschijnt een boodschap waarin duidelijk wordt gemaakt dat de hardware niet langer wordt ondersteund, en de game zal niet starten", aldus Jessicalu. Het installeren van de update is verplicht voor alle spelers van World of Warcraft, dus ook voor spelers die Cataclysm, de derde uitbreiding van de mmog, niet zullen aanschaffen.

Blizzard staat bekend als een ontwikkelaar die Apple een warm hart toedraagt. Alle games van de ontwikkelaar die voor Windows verschijnen, zijn vanaf de lancering ook speelbaar op computers van Apple en World of Warcraft is een van de populairste games onder Apple-gebruikers. Toch komt de aankondiging van Blizzard niet onverwacht. Apple zelf stuurde de PowerPC al in 2006 met pensioen, om over te stappen op processoren van Intel. Apples OS X draait vanaf versie 10.6, die een jaar geleden verscheen, al niet meer op PowerPC's.

Gerelateerde content

Alle gerelateerde content (24)
Moderatie-faq Wijzig weergave

Reacties (127)

Dit is echt enorme onzin. Een geforceerde update die een werkend systeem vernaggeld? Waar slaat dat op?
Dat de nieuwste update niet kan worden gespeeld: ok begrijpbaar, maar dit?

Als je toevallig thuis nog een Dual Power G5 hebt staan ga je niet ineens in een haverklap door deze update besluiten maar 'even' een nieuwe computer te kopen sinds het nog aan jouw eisen voldoet. Zie meer dat die mensen maar hun abbo opzeggen...
Ook al koop je wow cataclysm niet, je krijgt nog steeds wel een content en grafische update.en worden dus de systeemeisen zwaarder. PPC zullen het gewoon niet meer kunnen redden met de nieuwe wow update..
ik snap de reactie van teh_twisted wel. Op mijn PC met AMD structuur uit 2005 kan ik wel gewoon nog Wow spelen (het zei op hele lage grafische settings) waarom zou een Apple met een IBM processor uit hetzelfde jaar dat dan niet kunnen?

edit om commentaar voor te zijn: ik snap dat de ppc structuur vraagt om het (deels) hercoderen van de game en dat daar tijd en geld mee gemoeid is. Daarom is in mijn ogen de stap van Blizzard ook logisch. Maar feit blijft dat als je een pc gekocht had in 2005 ipv een Mac dat je wat WoW betreft beter af was geweest.

[Reactie gewijzigd door Sum op 31 augustus 2010 10:41]

Maar kan je na de update WoW ook nog spelen op je machine?
Als de systeemeisen met de update omhoog gaan dan heb je best kans dat je machine dit ook niet meer red. Hetzelfde dus als de ppc macs.
Enige aanpassing is VRAM van 32MB naar 64MB. WoW had al minder eisen op hardware voor de pc en dat gat wordt nu enkel groter.
Hercoden? Nee.
Er zijn gewoon een aantal trucjes die niet mogen als je je code endian-independent wil houden.
Wil je die trucjes toch gebruiken, dan is het een kwestie van een check inbouwen of die trucjes 'linksom' of 'rechtsom' moeten.
Omdat Blizzard al zo lang de Mac support is dit allemaal koek en ei voor ze.

Het droppen van de support heeft denk ik ook niets met endianness te maken, maar gewoon met het niet willen bijhouden van een extra versie voor een dood platform.
Het platform is niet dood, maar de gebruikers op dat specifieke platform zijn niet zo veel meer als aan het begin.
Hoezo enorme onzin? Andere 'moderne' games kun je toch ook niet meer op je G5 spelen?
Met diens verschil dat WoW voor deze ongein wel gewoon bespeelbaar is op de G5
Teh_twisted heeft wel gelijk dat het onzin is. Ineens wordt je een patch door de strot geduwd die dan ook nog eens ervoor zorgt dat men met zulke systemen niet meer kan spelen. Die mensen worden nu genaaid.
In zekere zin misschien wel, maar aan de andere kant krijg je waarvoor je hebt betaald: patches met nieuwe content en grafische updates. Vooral dat laatste zal op een gegeven moment ervoor zorgen dan sommige pc's de game niet meer kunnen draaien. Als Blizzard ervoor gekozen had om alleen Cataclysm gebruikers uit te sluiten, dan zouden ze dus in feite twee games bij moeten gaan houden. Het is daarom heel erg begrjipbaar dat Blizzard er voor kiest om deze zeer kleine doelgroep links te laten liggen.
En dat is wat je krijgt met een online game die met DRM dichtgenageld wordt - je moet gewoon de patches blijven volgen en geforceerd upgraden als dat nodig is anders kun je niet meer spelen.

Dat is een van de vele redenen dat ik Starcraft 2 niet ga aanschaffen - teveel geintegreerd met Battle.net en eenmaal ze Battle.net gaan vervangen (net zoals ze gedaan hebben met StarCraft 1) of ze gaan een maandelijkse som vragen om je account actief te houden (zoals WoW) kun je het spel niet meer spelen.

Een van de oplossingen zou zijn om je eigen Battle.net servers op te zetten maar Blizzard/Activision wil dat niet meer toelaten.

[Reactie gewijzigd door Guru Evi op 31 augustus 2010 14:52]

Let even op dat WoW al een stuk zwaarder werd met de komst van de eerste expansion, en nog zwaarder tijdens de tweede expansion.

Het basis gebied is bij cataclysm nu onder handen genomen waardoor je ook in de begin gebieden ineens meer rekenkracht nodig hebt (en er zijn al wat vernieuwing gesignaleerd zoals shaders voor het water).

[Reactie gewijzigd door sdk1985 op 31 augustus 2010 15:14]

Aangezien de servers ook van een update voorzien worden moet de software volgen. Als men dan beslist van een verouderd platform niet meer te ondersteunen dan is dat hun recht. Uiteindelijk kost het onderhouden van de ppc versie ook geld, als blijkt dat er te weinig spelers op dat platform zitten, waarom nog investeren?
Zouden deze mensen dan wel (een deel van) hun geld voor de aanschaf terug kunnen krijgen? Een deugdelijk product is voor hen opeens niet meer deugdelijk door toedoen van de fabrikant.
Vast niet, zoiets staat altijd heel mooi in de algemene voorwaarden van een product vermeld waardoor de fabrikant dit soort acties gewoon kan uithalen.
Algemene voorwaarden van een product zijn nog steeds onderhevig aan consumenten recht. Dus de door Iceman gestelde vraag is een hele terechte.

Stel in de voorwaarden zegt een leverancier, als je dit product koopt mag ik je opsluiten wanneer ik wil zo lang ik wil, is dat nog steeds onderhevig aan, in ons geval, Nederlands recht. Wanneer een leverancier je dan daadwerkelijk wil gaan opsluiten mag hij dat niet volgens Nederlands recht.

[Reactie gewijzigd door Gizzy op 31 augustus 2010 13:43]

Wat denk je zelf? Eerst het spel jaren gewoon kunnen spelen en dan nog geld terug verwachten ook? Jij hebt humor.
Lijkt me sterk, immers je world of warcraft spel en account zijn niet aan je hardware gekoppeld. Je kunt het bijvoorbeeld in een internet cafee spelen.

Ik heb ook geen schadeclaims bij kpn zien binnenkomen na de aankondiging van het opheffen van GSM support (dan MOET je dus een nieuwe telefoon kopen om te kunnen bellen met je abbonement).

http://www.allaboutphones...jaren-met-GSMnetwerk.html

[Reactie gewijzigd door sdk1985 op 31 augustus 2010 15:18]

De mensen die nog op een PowerPC spelen hebben wel een contract. Dit wordt eenzijdig door Blizzard gewijzigd. Op zijn minst zou Blizzard deze spelers een schadevergoeding moeten betalen.
Tja ik heb dit een aantal jaar terug gehad met een andere MMO, EVE, waarbij er een graphical update kwam waardoor je grafische kaart een minimaal shader model moest ondersteunen. Geen probleem voor mijn desktop, maar mijn laptop met mobo grafische chip kon dit niet aan.

Hierbij werden over het algemeen best veel mensen geraakt die bijvoorbeeld wel allemaal WoW konden (en kunnen) spelen met hun systeem. Ik vond het zeker jammer en er is wat verzet tegen geweest, maar uiteindelijk moet zo'n spel ook meegaan met de tijd en daarbij hoort ook het opzeggen van support voor verouderde systemen.

Als je weet hoeveel tijd het kan kosten om alles backwards compatible te maken en hoeveel tijd het kost om nieuwe dingen te bouwen/coden, snap je dat in de afweging die je als bedrijf moet maken, die paar procent (als dat al) mensen met echt verouderde systemen waarbij zelfs een fabrikant al support gestaakt heeft, de rest van de spelers belangrijker zijn.

Geloof maar dat als 10% of meer van de WoW spelers op zo'n apple PPC systeem zouden spelen dit niet zou gebeuren..
In EVE was dat wel op te lossen door die feature te faken wanneer het spel ging kijken of het werd ondersteund.
Heb zelf EVE gedraaid met 'Intel Extreme Graphics 2 Shared Video Memory' op de eerste laptops met de nieuwe Pentium M. Ook na de update werktte het (na die kleine hack).
Het orginele spel wijzigt ook van zodra Cataclysm uitkomt (het verhaal is immers weer een stapje verder gegaan, en dat heeft ook zijn invloed op de wereld die enkel toegankelijk is voor vanilla WOW spelers die de uitbreiding niet hebben).

Vandaar dat die update ook impact heeft voor iedereen, en niet enkel de mensen die cataclysm hebben aangeschaft.
Teh_Twisted: het is om bepaalde redenen bij MMO's erg belangrijk dat iedereen dezelfde versie gebruikt ;-)
Dus ze moeten maar lekker doorontwikkelen voor een systeem dat sinds 2006 gestorven is? Fijn hoor! :+

Ik was er vorig jaar allang mee gekapt! Het kost alleen maar geld en levert geen flikker op!
Dat je het geen leuk nieuws vind als gebruiker van een PPC kan ik me voorstellen, maar dat maakt dit nog geen "geforceerde update die een werkend systeem vernaggelt".

Het systeem wordt nota bene door Apple zelf al niet meer ondersteund sinds OS X 10.6 een jaar geleden uit kwam. Blijkbaar is de userbase die op PPC systemen speelt dusdanig klein geworden dat Blizzard besloten heeft om hier geen tijd in te stoppen (er van uitgaande dat Cataclysm überhaupt geschikt gemaakt zou kunnen worden hiervoor).

"Dat de nieuwste update niet kan worden gespeeld: ok begrijpbaar, maar dit?"
Dat ligt aan de manier waarop WoW werkt. Alle spelers in een bepaalde regio (EU, US, etc) spelen onderling altijd allemaal dezelfde versie van het spel. Dit principe is natuurlijk ook van toepassing op andere online multiplayers.

Als je nog steeds de oorspronkelijke WoW zou spelen (zonder uitbreidingen) kun je evengoed in bijvoorbeeld het Auction House items tegen komen uit Outland (eerste uitbreiding) en Northrend (tweede uitbreiding). Ook zul je andere spelers tegen komen die gear dragen uit die gebieden. Om dat alles weer te kunnen geven moet je dus wel degelijk alle patches en updates geïnstalleerd hebben, ook al heb je zelf geen toegang tot die gebieden.
Wist je dat Windows 98 ook al een tijdje niet meer ondersteund wordt? Echt heel stom, vind ik. Schande!
Maar Windows 98 werkt nog wel prima. Blizzard introduceert nu een verplichte patch die het spelen onmogelijk maakt. Daar zouden ze best toch een iets slimmers voor kunnen bedenken. Maakt niet uit hoe lelijk de oplossing is.
Ja het feit dat er minimum requirements zijn voor de game is er een van..
:X
Alleen veranderen nu de minimum requirements voor een game die al gekocht is. Zou jij het pikken als je PC tijdens het kopen voldoet aan alle minimum requirements, en je dan opeens die game een jaar later niet meer kan spelen op dezelfde PC omdat de requirements zijn aangepast?

Ik zie dit enigszins als een eenzijdige contractwijziging. Tijdens het aangaan van het "contract" (de game kopen) ging je akkoord met bepaalde voorwaarden (de minimum requirements). En nu worden die voorwaarden opeens eenzijdig aangepast waardoor je de dienst (gamen) niet meer kan gebruiken.
Bij gewijzigde voorwaarden hoort degene die benadeeld wordt te kiezen deze overeenkomst te beëindigen, niet degene die de voorwaarden wijzigt. Het zou anders mooi worden: Ziggo* besluit de downloadsnelheden te verlagen en sluit meteen maar iedereen die 10GB per maand download af. Dat is natuurlijk de omgekeerde wereld.

* Ik noem maar een partij.
Het is geen 'contractwijziging' aangezien duidelijk op de verpakking staat dat het spel ten alle tijde kan wijzigen. Als je een spel als WoW koopt dan weet je gewoon dat je een dynamisch spel koopt en dus vroeg of laat of je systeem moet upgraden (als het spel succesvol blijft), de spelervaring verandert of het spel volledig gesloopt wordt (wegens niet genoeg spelers meer).

Los daarvan blijft het natuurlijk dubieus, vooral voor spelers met een powermac die het spel nog maar zeer recent gekocht hebben.
Tja, en die minimum requirements voor het originele spel waren blijkbaar een PowerPC. Beetje lame dat ze dat achteraf gaan wijzigen. Voor de nieuwe expansion, ok, maar wat nu draait moet blijven draaien vind ik.
Pas in 2006 is dat gebeurd. Dus iets waar meeste mensen €40 voor hebben betaald bij aankoop, hebben ze 8jaar support voor gekregen. Met extended support nog eens jaren extra bij.
Als je WoW 4jaar hebt gespeeld ben €100 kwijt aan spel + 2 expansions en €500 aan subscriptions. Maar je kan wel niets meer doen met je account behalve op een veiling verkopen.
Maar dat is 12 jaar oud - de overstap van PowerPC naar Intel nog maar 4. Beetje een verschil daar.
Gezien de hoeveelheid mensen die nog oude windows-versies draait, vind ik het nog niet eens zo vreemd. Er zijn sowieso al minder Macs, en blijkbaar vindt Blizzard het nu niet meer lonend om voor de 4 Mohicanen nog ondersteuning te bieden.
Er was al eerder aangekondigd dat WoW een grafische update krijgt met Cata.

Toen Entropia een grafische update kreeg kon je het ook niet meer draaien zonder shader 3.0
Dus als WoW fan kan je na 4 jaar je apple afschrijven... en dat terwijl WoW toch niet echt een grafisch hoogstandje is en met een simpele windhoos-prutsbak uit het jaar 0 ook nog goed draait.

Ben geen Apple gebruiker maar deze stap vind ik voor de AppleWoW fans toch wel sneu.
voor wow heb je sinds TBC al een redelijk dikke bak nodig hoor, je red het niet meer met je p4 en een 64mb videokaart.. Er zitten inmiddels 2 patches overheen die de grafische engine stevig hebben verbeterd en er komt een 3e aan
P4 met 512MB kaart ging anders nog heel goed.
Met een P4 en een iets dikkere videokaart draait die boel wel hoor.

We hebben het hier nogmaals niet over een enorm grafisch gebeuren zoals de nieuwste CollinMekGrey Rally games e.d. die je op geen enkele een "oude" bak kan draaien. Tenzij je dat schokkerig op postzegelformaat wilt doen.

[Reactie gewijzigd door BUR op 31 augustus 2010 11:02]

Mijn PPC G5 1.8 GHz met een 64 MB GeForce FX 5200 draait WoTLK best redelijk (20 FPs) :o
Mja en in orgrimmar/ironforge of dalaran? daar red je die 20 fps niet :Y) en zeker niet met de nieuwe engine dan zit je constant op <10 fps.

Het is blizzard kennende een weloverwogen keuze geweest...
Als jij die PPC doos net op het einde van de maak periode kocht dan is het jammer voor je omdat jou systeempje dan ruim 4 jaar oud is (vermoedelijk 5 want ik verwacht cataclism pas tegen 2011)

Waar jij echter helemaal geen rekening me houd is dat de hele WoW wereld verandert met uitzondering van Outland (BC) en Northend (WotLK)
Ook gaat het hele programma zelf een grondige revizie beurt krijgen.
Ga ik dit nu vergelijken naar de systemen die het dan nog gaat ondersteunen dan krijg ik het volgende.
PC: Windows 7, Vista, XP -> JA (Direct X 9c moet werken voor de huidige versies als 10 verplicht wordt vervalt XP ook)
PC: Linux (versies weet ik niet maar die staan niet op de doos vermeld)
Apple:Intel CPU ->JA
Apple: PPC ->NEE
Voor Apple kan dit te maken hebben met de versie van het opperating systeem?

XP is aan de gang te schoppen op een P4-800 maar om daar ook nog eens WoW op te draaien in een 25 man raid dungeon gedurende een Boss fight lijkt mij veragen om problemen richting speelbaarheid, 1 frame per 30sec. of minder zou dan zwaar in de richting komen.
Nu hoor je dus niemand klagen als die processor niet meer ondersteund wordt maar schijnbaar wel als een PPC het zelfde lot ondergaat.
Ik denk dus dat jij in dit geval niet echt realistisch meer bezig bent.
Ik neem even aan dat jij een P3 800mhz bedoeld? Of heb je het over de fsb van de P4?

De P4 met 2,nogwat Ghz met een dikke videokaart zal het klusje wel klaren. Misschien niet full on graphics. Maar speelbaar. En nee ik verwacht inderdaad geen mega schermresolutie en dito framerate... het gaat om een computer van 4 a 5 jaar oud weet je nog?

De graphics van de omgeving mag dan aardig zijn maar de figuren zagen er voorheen grafisch niet bijster vet uit.

Wat staat er op "je WoW doos" bij minimale systeem eisen qua proc's ed.?

[Reactie gewijzigd door BUR op 31 augustus 2010 13:03]

Och Apple gebruikers moeten niet zeuren, als je wilt gamen kun je ook een gewone PC aanschaffen, want de meeste games draaien toch niet op een Apple.
Mensen kopen een Apple voor andere dingen dan voor games, je mag al blij zijn dat er uberhaupt een paar games willen draaien op een Apple.
PowerPC mac

blizzard is altijd alleszins schappelijk met systeemeisen, ze willen zoveel mogelijk mensen bereiken, dus alleen als het echt niet meer gaat wordt de ondergrens verhoogd.

Daarbij, het gaat om computers uit 2003 tot 2005! komaan mensen, ik vind het in geen enkel geval realistisch om te verwachten dat je een spel uit 2011 kunt spelen op een 6 tot 8 jaar oude pc. mensen die dat raar vinden moeten maar een voorbeeld noemen van een recent spel wat nog fatsoenlijk draait op een oude 7 jaar oude compu.

m.a.w. deze macs kun je opzij zetten om ernaar te kijken; en dat is nou net iets waar iedere mac heel goed voor geschikt is (om bekeken te worden). Niets verloren, toch?
Is ook sneu maar dat komt uiteindelijk door de 'exotische' hardware die Apple destijds heeft gekozen met de PowerPC. Daar kan Blizzard dan weer niks aan doen. En als ik lees dat Apple zelf al sinds een jaar geen ondersteuning meer biedt voor de PowerPC dan vind ik het niet onlogisch dat Blizzard deze beslising neemt.
Een gamer schrijft zijn PC sowieso na 4 jaar af toch? Afgezien daarvan, is het ongelukkige dat je hier net in de overstap van PPC naar X86 zit, en dat is een unieke situatie.. Dit is dus geen algemene regel voor alle Apple gebruikers ;)

[Reactie gewijzigd door chucky op 31 augustus 2010 10:49]

De gemiddelde WoW speler is niet de standaard "gamer". Volgens mij wordt WoW veel gespeeld door casual spelers, die niet dag en nacht hun pc aan het tweaken zijn, maar enkel een "thuis" pc hebben.
Het zou nog sneuer zijn als een groot deel van de spelers features niet krijgt omdat er nog een paar spelers zijn met oude hardware.
Ik vind het een beetje raar om met terugwerkende kracht de game onspeelbaar te maken, ook als je niet van plan bent de nieuwe uitbreiding te kopen.

Dat je het niet langer ondersteunt, en het de nieuwe expansion niet laat werken snap ik, maar waarom de game die wel werkte niet meer laten werken?

Naast het feit dat je natuurlijk wel hopeloos achterloopt met zo'n bak.

[Reactie gewijzigd door Alpha Bootis op 31 augustus 2010 12:05]

Tja, maar dat komt door de structuur van WoW, ook als je deze uitbreiding niet koopt, gaat er heel erg veel veranderen tov de originele versie (of de wotlk uitbreiding). Met name de engine, maar ook de hele speelwereld veranderd gewoon, en de 'oude' speelwereld wordt de nieuwe speelwereld, en moet dus ook de nieuwe snufjes ondersteunen. Cataclysm kopen is eigenlijk niets meer of minder dan een level cap naar 85, en twee nieuwe races; de rest krijgt de huidige client ook (ook al kunnen ze van het meeste niet gebruik maken omdat ze level 80 zijn, en niet hoger kunnen).

Blizzard is nooit van plan geweest om 'oude' servers op te zetten, die bijvoorbeeld alleen maar Wotlk draaien, of TBC of vanilla.
Je kan niet doorspelen zonder de patches, en die moeten ook getest worden. Dat lijkt me de grootste besparing.
Omdat de hele wereld geupdate wordt. Ook wanneer je de expansion niet koopt zal je de grafische en content (gedeelteijk) update krijgen.
Misschien een hele domme vraag, maar kan je Windows niet emuleren op een PowerPC en zodoende alsnog WoW spelen?
In theory... maar dan heb je dus een intel processor emulator nodig in combinatie met een windows emulator. qemu zou het waarschijnlijk kunnen.

Maar traag is een understatement voor dit soort emulatie werk.
Dat wordt dan een hele trage boel, waarna wellicht notepad het nog doet, maar ieder serieus spel gaat nog trager draaien dan je ooit hebt meegemaakt. Emuleren is nou niet echt een snelle oplossing, aangezien het hier ook om totaal andere hardware gaat.
Q

[Reactie gewijzigd door Ocelot op 31 augustus 2010 11:02]

Staat alleen een beetje lullig geschreven alsof Blizzard express vlak voor Cataclysm de patch uitbrengt zodat je die niet meer kan spelen.
Waarschijnlijk zal het met de pre-patch van Cataclysm worden doorgevoerd.

"De woordvoerder maakt duidelijk dat Blizzard, vlak voordat Cataclysm in de winkel verschijnt, een patch uitbrengt.."

Het bevestigd naar mijn idee ook dat Cataclysm voor het einde van het jaar nog verschijnt. November lijkt mij een geschikte release date?
Gezien de huidige status van de Beta, zou ik er niet al te veel op rekenen. Tel pakweg een week of twee tot drie op na het eindigen van de Beta en je hebt een goede release-datum.

Op dit moment lijkt de level-cap pas begin September naar 85 te worden verhoogt en dus moeten alle raids, classes, BG's en PvP related content nog worden bekeken en aangepast. En dat gebeurd waarschijnlijk in een open beta, terwijl het op dit moment alleen nog via invites gaat. Lange weg te gaan, me thinks...

Halverwege december lijkt mij reëeler (spelling?). Hoewel mensen ook bij deze expansion wel weer massaal zullen roepen "blizz will release before christmas!!!1 cuz dey get extra $$$ then" geldt bij Blizzard nog steeds "it's done when it's done". Ze zulen dus niet bewust een half-asses product nog voor de feestdagen uitbrengen, alleen omdat het extra zou verkopen :)


Edit: Tiepo

[Reactie gewijzigd door KiKiA op 31 augustus 2010 11:09]

in WotLK was er ook geen open-beta en Blizzard was ook niet van plan om een open-beta te houden.

BG's waren inmiddels al een keer getest meen ik en class changes worden altijd al in de pre-patch doorgevoerd. De belangrijkste veranderingen aan classes (tevens wat je het meest zal gaan gebruiken) wordt al een hele poos getest in de closed beta.

Hoe het qua raids zit weet ik niet. Het lijkt me wel dat ze dit ook gaan testen, maar hoe?

[Reactie gewijzigd door Hiroj op 31 augustus 2010 11:24]

Wees er maar zeker van dat het voor kerst in de winkels ligt. Vivendi heeft liever dat ze een maand klachten hebben en moeten patchen, dan de kerstperiode missen.
Ik snap Blizzard wel dat zij de PowerPC ondersteuning eruit halen.
Met Cataclysm gaat het spelletje heel erg veel vereisen indien je een oude PowerPC processor hebt. Het is dus een verstandige keuze.

Het is weliswaar erg treurig voor de personen die WoW fan zijn en op een PowerPC Mac spelen, maar ter gelijke tijd kan het hun ook pushen om naar nieuwere en betere machines over te stappen. Ergens dus ook wel een stukje slimme marketing.
Marketing doe je doorgaans omdat je er zelf beter van wordt. En ik geloof niet dat Blizzard en/of Activizion een division heeft die computers verkoopt :)

Indirect, ja. Mensen die een betere computer gaan kopen, zien dan ook WoW voor het eerst op hogere settings. En hoewel de graphics niet spectaculair zijn, zie je wel dat vooral extra effecten toch de kwaliteit omhoog halen van de graphics. Al blijft het natuurlijk cartoon-ish :)
Ik doelde meer op Apple v.w.b. marketing.

Maar nu de gaming markt qua games op de Mac eindelijk ook op gang komt, is het gewoon logisch dat Blizzard nu ook zegt: wij gaan met de tijd mee.

En de cartoon-ish achtige uiterlijk is ook zo bedoeld. World of Warcraft is ooit bedoeld om 12-16 jarige aan te spreken om het spel te gaan spelen. Mij apart blijft het ook lekker zo, het vereist niet teveel van mijn videokaart en processor. Al moet ik wel eerlijk zijn dat ik graphics wel erg belangrijk vind. Maar voor zo'n grote wereld vind ik het knap dat Blizzard dit voor elkaar heeft gekregen.
Ik ben best nieuwsgierig hoeveel mensen die WoW spelen op hun Mac dat deden op een PowerPC. Ik neem aan dat een groot aantal sowieso al in het bezit is van een Intel systeem en voor een groot aantal zal dit een aanleiding zijn om over te stappen naar een nieuw Apple systeem. Voor anderen zal het wellicht het einde zijn van hun WoW carrière.
Alle PowerPC-based systemen met vast ingebouwde GPU (zoals de iMac, PowerBook, iBook, Mac Mini) waren zowiezo al ver verouderd qua GPU, zodat Cataclysm zowiezo een diashow zou worden zelfs al zou het al mogelijk zijn om het te spelen.

Het zouden dus alleen de mensen zijn met een PowerMac (en dus upgradeable GPU) die het uberhaupt zouden kunnen spelen en volgens mij worden de nieuwe grafische kaarten voor de Mac Pro ook niet meer ondersteund op de PowerMac.
Was te verwachten ivm de hoeveelheid werk het was om compatibel te maken in vgl met het aantal spelers die een ppc systeem hebben. Valt hun natuurlijk niets te verwijten vermits apple zelf de support er al voor heeft gestaakt.
Met de winst die ze op Wow maken mag er rustig wel een klein beetje geld ingestoken worden om het compatible te houden.. Overigens als ze zulke moeite hebben om het compatible te houden dan is er IMHO sowieso al iets goed fout met de onderliggende code....
Tsja, dat is natuurlijk het nadeel van een MMO die met de techniek mee ontwikkeld. Met discrete spelletjes kun je nog oude games op oude hardware spelen. Uiteindelijk valt de eerdere ondergrens van hardware af.
Logisch process. De vereisten van de game worden ook zwaarder door de updates aan textures etc. Dus waarschijnlijk draait het sowieso niet echt geweldig op powerpc's.

Op dit item kan niet meer gereageerd worden.



Apple iOS 10 Google Pixel Apple iPhone 7 Sony PlayStation VR AMD Radeon RX 480 4GB Battlefield 1 Google Android Nougat Watch Dogs 2

© 1998 - 2016 de Persgroep Online Services B.V. Tweakers vormt samen met o.a. Autotrack en Carsom.nl de Persgroep Online Services B.V. Hosting door True