Cookies op Tweakers

Tweakers maakt gebruik van cookies, onder andere om de website te analyseren, het gebruiksgemak te vergroten en advertenties te tonen. Door gebruik te maken van deze website, of door op 'Ga verder' te klikken, geef je toestemming voor het gebruik van cookies. Wil je meer informatie over cookies en hoe ze worden gebruikt, bekijk dan ons cookiebeleid.

Meer informatie

Door , , 283 reacties

Samsung geeft de Galaxy S3 en S3 mini geen update naar Android 4.4. Het voormalige Galaxy-vlaggenschip en zijn kleinere broertje zouden te weinig intern geheugen hebben voor de upgrade. De lte-versie van de S3 krijgt wél een update.

Samsung heeft tegenover Samsung-fansite Sammobile aangegeven dat bezitters van de normale S3 en S3 mini, die nog geen twee jaar geleden uitkwamen, dat ze geen Android 4.4-update hoeven te verwachten. Het Koreaanse bedrijf voert aan dat het interne werkgeheugen van de S3 en S3 mini de oorzaak is: dat zou te klein zijn om Android 4.4 aan te kunnen. Dat is dan ook meteen de reden dat de lte-versie van de S3 wel een update krijgt: die beschikt over 2GB aan intern geheugen.

Er zijn echter wat vraagtekens bij de motivatie van Samsung te plaatsen: Android 4.4 is vergeleken met Android 4.3, dat wel op de S3 en S3 mini draait, juist geoptimaliseerd om ook op goedkopere hardware met weinig geheugen te draaien. Android 4.4 vereist maar 512MB aan ram; de S3 en S3 mini beschikken over twee keer zoveel intern geheugen.

Bovendien zijn er andere telefoons met maar 1GB aan intern geheugen die wel een update naar Android 4.4 hebben gekregen. Mogelijk is de eigen Touchwhiz-interfacelaag die Samsung over Android legt de oorzaak, maar het is onduidelijk waarom dat geen probleem was bij voorgaande Android-versies, die minder goed geoptimaliseerd waren voor telefoons met weinig ram.

Eind april bracht Samsung wel Android 4.4 voor de Note II uit. Ook andere oudere modellen als de S4 mini, twee Galaxy Mega-modellen en de Galaxy Grand 2 krijgen een update; volgens Sammobile zullen die updates in juni worden uitgerold.

Moderatie-faq Wijzig weergave

Reacties (283)

1 2 3 ... 8
Het is inmiddels al meerdere malen genoemd, maar cyanogenmod (11) draait al lange tijd stabiel op 4.4 kitkat.

De s3 wordt officieel ondersteund door Cyanogenmod, en is dan ook via http://get.cm/ te downloaden en installeren.

De s3 mini wordt officieel niet ondersteund, maar er is een uitstekende onofficiele versie beschikbaar op http://maclaw.pl/. Draait hier als een zonnetje, en de handleiding is makkelijk te volgen.

Neemt niet weg dat dit in mijn mening uitstekende support slechte zaak is van samsung. Als iets technisch niet mogelijk is alas, maar dit is pure, zeer brak vermomde geldklopperij.
Hoe bedoel je 'stabiel'?
Op de downloadpagina van CM is nog steeds geen stable versie te vinden. Sinds er aan CM11 (android 4.4) wordt gewerkt, zijn er alleen nog maar daily's en snapshots uitgekomen voor de galaxy3.

De inhoud van die snapshots is weer te zien in het issue tracking systeem. Ze fixen ongeveer 10 issues per maand en er zijn er nog 1400 niet opgelost (daar zullen ws een hoop dubbele of irrelevante issues in zitten en het betreft hier elke versie van CM).

Ik heb nog niet gevonden wat de CM makers opgelost willen hebben voor er een stable uitkomt, maar gegeven dat er uberhaupt nog geen milestone of release candidates uit zijn gekomen, zie ik het nog wel een paar maanden duren voor we een stable kunnen verwachten.

Aan de andere kant, gegeven het gebrek aan echt verstorende bugs in de lijst met meest populaire issues lijkt er geen reden te zijn om niet met een CM11 snapshot te gaan werken..
Cyanogenmod heeft zelf ook aangegeven dat er voor het eerst geen stable releases meer zullen komen:
http://www.cyanogenmod.org/blog/cyanogenmod-11-0-m6-release

TLDR: Ze hebben hun release cycles aangepast om maandelijks snapshots te releasen en daarop bug reports aan te nemen in plaats met release candidates/stable builds te werken.
Op deze manier gaan ze meer incrementeel blijven developen en niet meer naar een stable release toewerken waardat er geen nieuwe features toegevoegd kunnen worden voor een bepaalde tijd (vroeger was het enkel bugfixen vanaf ze een RC wilden uitbrengen totdat de stable er was)
Ah, dat verklaart eea. Thanks :)
Ik heb altijd begrepen dat veel van de drives van de S3 closed source zijn waardoor écht goede ondersteuning nooit mogelijk zal (kunnen) worden? Misschien heb ik dit verzonnen want ik kan even geen bronnen meer vinden maar de laatste keer dat ik CM11 draaide kon ik wel merken dat het toch niet helemaal vlekkeloos liep. Máár dat zou ook kunnen liggen aan het feit dat ik toen al klaar was met Samsung. Ook was dat het moment van de eerste geruchten wat betreft het uitblijven van de update (die overigens toen al door Sammobile serieus genomen werden, zo'n 3 maand geleden?).

Ik heb gezworen nooit meer een toestel anders dan een Nexus te kopen (overigens niet waargemaakt want momenteel ter overbrugging een Moto G), maar ik kan naast HTC nu ook Samsung toevoegen aan het rijtje van merken waar ik voortaan uit de buurt blijf. Ik was al niet heel erg gelukkig met het hele Touchwiz (en update) gebeuren maar dit is toch wel een bevestiging.

Uiteindelijk hebben we het wel over een toestel met een winkelwaarde van over de 650 euro bij release. Daar mag je toch wel wat van verwachten? Ik heb nota bene nog 80 euro bijbetaald bij mijn 2 jarige verlenging (42,50/maand) omdat ik zo nodig een keer met een actueel toestel wou rondlopen (destijds paar maanden oud). Welgeteld heb ik een jaar met het toestel rondgelopen voordat hij per ongeluk kennis had gemaakt met de stoep (vandaar de Moto G). Het feit dat ik dat heb laten gebeuren zegt al genoeg over het toestel.
Ik denk dat dit een kosten-baten analyse is. Men moet voor ieder toestel de Touchwiz laag veranderen aan het aantal features. Zo heeft de S3 minder features dan de S4, dus een op een overzetten gaat niet. Dan is het tweede probleem: de soc. Voor sommige socs worden geen drivers meer geschreven en Samsung heeft de neiging een model soms met twee verschillende socs te leveren, afhankelijk van het land. Die moeite voor het updaten is, ondanks de populariteit van de S3, dan gewoon niet meer waard. Een derde reden die Samsung zeker zal overwegen is dat er twee jaar voorbij zijn, wat al meer is dan de belofte die ze Google deden. Ik probeer hun keuze niet te rechtvaardigen, persoonlijk vind ik het schandalig voor een toestel dat nog best veel kost om aan te schaffen, maar Samsung en ook andere fabrikanten letten alleen op cijfers. Als het hun geld en moeite kost, dan komt de kosten-baten analyse, valt die negatief uit: geen update. Voor deze twee toestellen is het dan ook uit. Het maakt de telefoons zonder update niet minder goed, het is alleen jammer. De telefoon blijft even goed of traag als die was na de laatste update. Het is alleen jammer om te zien dat een bedrijf dat miljarden winst maakt niet meer ondersteuning geeft. Wat tegelijkertijd een argument is voor hun grootste concurrent voor sommige.
De Samsung Galaxy S3 LTE krijgt wel weer Android 4.4 terwijl de LTE versie en de niet-LTE versie allebei dezelfde SoC gebruiken. Ik heb helaas geen verkoopcijfers, maar ik verwacht toch wel dat de niet-LTE versie vaker verkocht is. De LTE versie is alleen in bepaalde landen verkrijgbaar en ook later op de markt gebracht.
Maar het toestel is pas eind 2012 gelanceerd (volgens wikipedia november 2012, dus het zal wel) en wordt nog steeds verkocht. Dat je als bedrijf stopt met de ondersteuning van een toestel na twee jaar, bon, met wat goede wil kan ik daar nog wel inkomen. Maar toch niet voor een toestel dat nog steeds gemaakt en verkocht wordt...
Wat een vreemde redenering is me dat. Een aantal maanden geleden heb ik mijn S3 mini geroot, en er een versie van CyanogenMod 11 opgezet. Dus helemaal gebaseerd op Android 4.4.2 Zelfs als ik dat toestel urenlang intensief gebruik, blijft er meer dan genoeg werkgeheugen over. Bij normaal gebruik komt het zelfs amper tot nooit boven 40-50% gebruikt geheugen.

In die tijd heb ik het toestel eens een aantal keren getest op dagenlang gebruik van een zo kaal mogelijk toestel. (KitKat, wat google apps, en daarbuiten hooguit een aantal apps van derden. Boottijd was op die manier gehalveerd, geheugengebruik kwam amper boven de 20% uit, batterijgebruik werd bijna uitsluitend bepaald door schermgebruik. Fenomenaal snel toestel op dat moment.

Er zijn wel degelijk tekortkomingen aan het gebruik van CM11 of KitKat 4.4.2 op die S3 mini. Maar geen daarvan kan ik terugleiden tot te beperkte specificaties. Het gaat bijna uitsluitend om softwareproblemen doordat die CM-port nogal amateuristisch wordt onderhouden, en bij elke flash/update tot nieuwe/andere/onverwachte problemen leidt. Daarnaast mis ik nog steeds iets als H/W+-ondersteuning, waardoor een S3-mini icm videoweergave een en al amateurisme is, en tot veel crashes leidt. Maar dat zijn stuk voor stuk zaken die door Samsung of door de opensource community best aan te pakken zijn. Mits wat goede wil.

Naja, dan maar hopen dat deze het nog een tijdje uithoudt, want de overschakeling naar nog een groter toestel/scherm zie ik niet direct zitten.
Over de mensen die de Galaxy Nexus als voorbeeld noemen voor de onkunde van Android toestellen om geupdated te worden. De GN heeft een Texas Instruments chip. Voordat Kitkat nog was aangekondigd, heeft TI bekend gemaakt dat zij zouden stoppen met het uitbrengen van SOC's. Hierdoor hebben ze er ook voor gezorgd dat er geen drivers meer worden geschreven voor hun huidige soc's, waardoor er dus ook geen drivers konden worden uitgebracht voor de GN.

Over de SOC van de S3, deze is gebaseerd op het Exynos 4 platform. En recentelijk heeft Samsung ervoor gezorgd dat Exynos 4 support standaard in de Linux kernel zit (Bronnen: http://www.phoronix.com/s...page=news_item&px=MTY1NDE , de betekenis van wat er in deze link staat:

It means that the Exynos 4 platform is supported out of the box in the mainline kernel. Thus future versions of the vanilla Android kernel will integrate these drivers. It means that at some point we could merge the other devices drivers (MMC, battery, touchscreen, etc) to this kernel and rebase the Omni ROM kernel on that. This will likely happen in a distant future, and it's not really interesting for now. I guess that future Android versions may require a recent Linux kernel, so it will facilitate the switch.
Dit staat hier: http://forum.xda-develope...ead.php?t=2397000&page=55

Ook is de S3 geintroduceerd op 29 mei 2012 in Europa. (Bron: http://nl.wikipedia.org/wiki/Samsung_Galaxy_S_III) en dat zou betekenen dat Samsung alsnog voldoet aan de gestelde voorwaarde voor Android fabrikanten om een toestel minimaal 18 maanden te ondersteunen. Bron: http://www.tomsguide.com/...e-Updates,news-11146.html

Dat de Note 2 wel Kitkat heeft gekregen is dan ook begrijpelijker, want die heeft wel 2GB aan RAM. Alle andere toestellen die worden geupdated hebben ook minimaal 1,5GB RAM. Dus aan de ene kant voldoet Samsung aan al haar verplichtingen, terwijl zij ook haar resources moet indelen (er valt gewoon weinig te halen bij het updaten van de S3, mensen zijn altijd huiverig om hun toestel te updaten, gaat mijn data verloren en dat soort crap...) en zij moet ook gewoon een ervaring garanderen. Ik vind het ook niet fijn dat de S3 niet wordt gedated, maar ze kunnen er rechtmatig mee wegkomen, dus doen ze dat maar...
Wat een onzin.. 4.4 zou juist zuiniger met het geheugen om moeten springen..
Ja en nee. Zoals in het artikel staat vereist Android 4.4 maar 512MB RAM. Hierbij moeten ontwikkelaars het betreffende apparaat wel als 'low-ram device' flaggen. Dat heeft tot gevolg dat bepaalde features niet werken, iets dat Samsung misschien niet wil beperken bij een voormalig vlaggenschip.
Zie hier: https://source.android.com/devices/low-ram.html

Hoewel het alsnog erg vreemd is omdat de S3 niet 512 maar 1024MB RAM heeft :?
Edit: met alle Touchwiz-meuk erbij is 1GB misschien nog steeds te weinig

[Reactie gewijzigd door r100 op 8 mei 2014 19:47]

4.4 full draait prima op apparaat met 512MB of meer, low ram is voor apparaten <512MB, 256MB bijvoorbeeld.

4.4 draait draait beter dan samsung 4.2 rom op mijn Galaxy S advance met 768MB. En nog punt 4.4 zou ook beter moeten draaien dan huidige 4.3rom van de S3 die ze nu gebruiken. ;)

Wel tijd om 101 verschillende modellen te ontwerpen maar geen tijd om even fatsoenlijk rom in elkaar te zetten. :(
In de praktijk heeft de Galaxy S3 slechts 832MB werkgeheugen beschikbaar voor het systeem.
je kan altijd nog cynanogenmod erop zetten om altijd de nieuwste android te hebben..
we zijn tweakers dit zou makkelijk moeten lukken :)

[Reactie gewijzigd door pummetje op 8 mei 2014 19:36]

Mja, Cyanogenmod is ook geen groot feest voor dit toestel. De S3 heeft een Exynos SOC en Samsung is zo lief geweest naar de community om geen enkele informatie over de werking hiervan vrij te geven. De AOSP gebaseerde roms werken dus "okay" maar hebben wel vage quirks. Een spontane reboot, geheugen problemen of de camera die plotseling niet meer aangeroepen kan worden zijn enkele voorbeelden.
Ondanks dat de dev's hun best doen zal er nooit een 100% stabiele S3 rom op AOSP komen zolang Samsung geen sources, binairies of informatie verstrekt.

[Reactie gewijzigd door Miki op 9 mei 2014 00:24]

Nog een reden om geen Samsung te kopen :)
En dit is de reden dat ik geen Samsung gebruik. Wat een belachelijke actie weer dit. Ik vind.dit gewoon erg slecht en vervelend voor de klanten.die dit toestel hebben.
Wat een onzin, het gaat om de hardware niet om wat Samsung wel of niet levert. De kwaliteit van de telefoons is uitstekend.
Het rooten is simpel en je behoud je garantie. Ik heb de S2 op op cyanogenmod gezet d S3 heeft ook een stable versie. Je koopt de telefoon toch niet om de bloatware van en samsung of een HTC.
Mensen die niet kunnen rooten die hebben toch weinig aan de update.

*edit neit in niet veranderd :)

[Reactie gewijzigd door Linke-soep op 8 mei 2014 19:42]

Dat is natuurlijk onzin, je koopt niet alleen de telefoon voor de hardware maar ook voor de software...
En het is belachelijk dat een telefoonfabrikant al zo snel de stekker uit een een toestel haalt onder het mom dat het toestel het niet aankan...
Oftewel, ze willen heel erg graag dat je upgrade naar de nieuwe S5.
Dit is geen Samsung iets hoor. Dit is een Android iets.
https://support.google.com/nexus/answer/4457705?hl=en
Dit komt van https://support.google.com , de Android maker
Nexus devices

Nexus 4, Nexus 5, Nexus 7, and Nexus 10 receive the latest version of Android directly from Google. Once an update is available, it can take up to two weeks for it to reach your device.

Devices may not receive the latest version of Android if they fall outside of the update window, traditionally around 18 months after a device release.

Google Play edition devices

Updates to Google Play edition devices are managed by the device manufacturers, not by Google. Google works closely with the manufacturers to provide system updates shortly after a new version is released. Once an update is available, it can take up to two weeks for it to reach your device.

Devices may not receive the latest version of Android if they fall outside of the update window, traditionally around 18 months after a device release.

Dit is al 2 jaar zo, dus de "woede" is onzin.
Struisvogel effect.

Ik kan iets roepen over cupertino, maar dan krijg ik nog meer min kudo's.
(Kuch *48 maanden* http://arstechnica.com/ap...good-as-its-going-to-get/ met de nodige limieten)
The Apple A4 that powers the phone is now nearly four years old,

[Reactie gewijzigd door weeraanmelden op 8 mei 2014 21:06]

Ja, Apple update wel nog na 48 maanden, maar zelfs nog in dezelfde zin waar je een deel van hebt gequote staat dat dat niet bepaalt iets was om over naar huis te schrijven, aangezien de iPhone 4 nogal traag werd van iOS7. Ik zie niet hoe dat beter is dan de (ook niet bepaald fantastische) manier van updaten die bij Android gehanteerd wordt.
iPhone 4 met iOS 7.1 is zeer goed bruikbaar, weet ik inmiddels uit eigen ervaring :)
Nee dat is niet zo. De iphone 4 is gewoon onwerkbaar geworden in iOS 7. En dat weet ik maar al te goed uit eigen ervaring.
Is dat zo? Een vriend van me heeft iOS 7 op z'n 4S en moet nu een lader meenemen naar school omdat hij de laatste les van de dag niet eens haalt.. Of doe je iets speciaals met je iPhone waardoor die batterij langer meegaat?
Dat lijkt me heel sterk hoor! Dan weet ik niet wat jouw vriend uitsteekt met zijn 4S, maar ik heb nog een zeer geruime tijd met een 4 op IOS7 gewerkt waarna ik 's avonds thuiskwam met genoeg batterij om de avond door te komen. Ben intussen wel overgeschakeld op een 5S mits mijn waterschade had, maar heb nooit problemen gehad met te trage of te korte batterij op mijn 4.
Misschien is gewoon nieuwe batterij erin ?
Instellingen => Algemeen => Ververs apps op achtergrond => Facebook off
opgelost :+
Apple geeft de update juist zodat de klanten merken dat ze een oud toestel hebben die langzaam is en een nieuwe iphone kopen en dan weer de wow factor hebben omdat die veel sneller is.
Dat is al een fabeltje dat al heel lang meegaat hoor... Ik ben afgestapt van alles wat bij Microsoft komt voor de reden dat het traag werd zonder nog maar een update, en zou dan op iets overstappen dat bewust iets vertraagd? haha ja... Ik denk niet dat ik iets zou kopen van een merk waar ik in het verleden traag mee heb moeten werken. En ja IOS7 op iPhone 4 is inderdaad wat trager, maar IOS 7 brengt heel wat veranderingen, zowel zichtbaar als onzichtbaar, maar je kan tenminste nog Updaten, en niemand verplicht je ook omdat te doen. En zo traag is het niet. En dat fabeltje, sorry maar dat geloof ik echt niet hoor... Dat zou je heus wel merken, en zou zeker niet werken!
Volgens mij werd je toch redelijk verplicht volgens de nieuwsberichten? Update werd automatisch gedownload en bleef op je toestel 1 of 2 GB ruimte innemen zonder het te kunnen verwijderen?

Iemand die bv van een Galaxy S4 naar S5 overstapt om de nieuwste van de nieuwste te hebben, zegt vervolgens ow tis gewoon hetzelfde, heb voor niks zoveel uitgegeven.
Als je bij iPhone overstapt heb je eerst de langzamere (na de update), ookal is dat niet heel erg. Vervolgens als je de nieuwe hardware koopt die eigenlijk ietsje sneller is heb je voor je gevoel een veel snellere. Het gaat om het gevoel dat je niet voor niks veel geld hebt uitgegeven.

Dit is mijn mening uit ervaringen dat ik bij klanten en mensen om me heen heb gezien. Geen copy/past internetfabeltje. Ik vind het plausible en goed gespeelt. Ik gebruik zelf trouwens BB10, telkens nieuwe updates+opties zonder dat het trager wordt. Net als op mn linux bak extra programma's mijn systeem niet trager maakt.

[Reactie gewijzigd door HakanX op 8 mei 2014 23:42]

Volgens mij is het vrij normaal dat als je komt van hardware die 3-4 jaar oud is, en dan gaat overschakelen op de nieuwste hardware dat je gsm sneller is? Dat mag ik toch verwachten hoop ik? Dat is toch juist hetzelfde met je computer? Gebruik een computer van 5 jaar oud in de prijsklasse van ¤500. Installeer en gebruik daar heel wat software op. Gebruik daarna juist hetzelfde op een systeem van ¤500 dat recent is. Dan heb je ook een heus snelheidsverschil. Ik heb zelf tot op 4 maand geleden een iPhone 4 gehad, en die heb ik verkocht aan iemand die van Samsung kwam. Zowel ikzelf als die persoon hebben nooit problemen gehad met de Accu. Vergeet wel niet dat die Accu dus 4 jaar oud is. Ik zelf heb weinig verschil gemerkt met het updaten van mijn iPhones, ja IOS7 was soms iets trager, maar brengt dan ook heel wat veranderingen/verbeteringen mee zowel visueel als niet. Ik vindt het echt wel gewaagd om te zeggen dat Apple bewust apparaten laat vertragen. Zoals ik al eerder zei, moest ik werken op een apparaat dat na een jaar echt traag is, koop ik dat niet opnieuw, dus dat zou een verkeerde marketing strategie zijn. Dit fabeltje is hetzelfde als zeggen dat printer makers iets insteken dat je na X aantal jaar je printer verplicht moet worden binnengebracht voor onderhoud...
Wat Apple betreft heb ik mijn bevindingen al verteld, zelfde herhalen heeft geen zin, ieder zijn eigen ervaringen.

Wat alle andere hedendaagse electronica betreft, ik geloof echt niet dat het een fabeltje is dat electronica tegenwoordig gemiddeld veel korter meegaat dan vroeger. Al koop je de duurste modellen er worden altijd onderdelen in gebruikt met een duidelijk beperkte levensduur. Van wasmachine tot tv. Bij mij is het meest recent na 5jr mijn tv Samsung A656 46" eruit geklapt. Ik had het direct bij lancering gekocht en toen ik op internet zochte zag ik dus dat het bij heel veel mensen is gebeurd omstreeks zelfde periode. Een high end tv moet minimaal 10jr meegaan dus als je daar goedkope condensatoren die 5jr meegaan in gebruikt is dat opzet. Nieuwe condensatoren solderen heeft mij geen 20¤ gekost en het werkt weer perfect. Als je hem officieel zou willen laten repareren vragen ze er honderden euro's voor en dan overwegen mensen een nieuwe omdat deze toch al oud is, kachink! Zo werkt dat tegenwoordig.
Mijn pc is ook 5jr oud met een Phenom II 955+SSD in de 500¤ categorie, niks traag aan als je weet waar je mee bezig bent. Software installeren maakt een pc niet traag. Alle software in de achtergrond draaien terwijl je het niet gebruikt maakt het traag.

[Reactie gewijzigd door HakanX op 9 mei 2014 20:16]

Wil je nu zeggen dat de overstap van de S4 naar de S5 kleiner is dan die van de 5 naar de 5S?

Qua snelheid en features zal er weinig verschil zijn bij beide, om over design nog niet te spreken..

Maar jij zegt dus dat Apple de iPhone 5 expres langzamer maakt met een update zodat de overstap (5->5S) groter lijkt? En dat zie je als positief?
Dit is geen Samsung iets hoor. Dit is een Android iets.
Als dit een een Android iets is, waarom zegt Samsung dan dat het komt vanwege een gebrek aan intern geheugen?

Als het van tevoren duidelijk wordt gemaakt dat een telefoon maar voor 18 maanden updates kan verwachten dan is dat een overweging die je moet maken. Maar als Samsung een slechte reden smoes bedenkt om de opdates te stoppen is dat een heel ander verhaal.
ik quote Google in mijn zin. En post van de Google site?
Welk gedeelte is daar onduidelijk van :?
Omdat je aanname niet klopt denk ik. Support op de Nexus staat los van de support van Samsung.
"Devices may not receive the latest version of Android if they fall outside of the update window, traditionally around 18 months after a device release."

Ik vind jou reactie veel toevoegen aan alle andere informatie +3

[Reactie gewijzigd door hmartino op 8 mei 2014 22:22]

Dit is geen Samsung iets hoor. Dit is een Android iets.
Google zorgt inderdaad voor de updates op de Nexus toestellen. Welk verband je met Samsung probeert te leggen is me niet helemaal duidelijk.

De support op de Nexus lijn staat helemaal los van support op de toestellen van de fabrikanten, die zijn daar zelf voor verantwoordelijk. Dat quote je zelf ook:
Updates to Google Play edition devices are managed by the device manufacturers, not by Google.
Het staat een fabrikant vrij om hun toestel van updates te voorzien zolang ze daar zelf zin in hebben.

Maar misschien snap ik niet wat je probeert duidelijk te maken met je reactie.
Snel? De S3 heeft gewoon zijn 18 maanden updates gehad. We zijn ondertussen al 2 generaties verder met de S5.
volgens de 18 maanden regel moet de galaxy S3 gewoon een upgrade krijgen naar 4.4.x.
De galaxy s3 (I9300) is uitgekomen op 29 Mei 2012 in europa,
android 4.4 is uitgebracht op 31 October 2013.
Dus 17 maanden na dat de galaxy S3 is uitgekomen is android 4.4.x uitgekomen, dus theoretich zou er gewoon een update moetten komen.

"The device was released in 28 European and Middle Eastern countries on 29 May 2012, before being progressively released in other major markets in June 2012."

[Reactie gewijzigd door jeffrey268 op 8 mei 2014 22:07]

Ja? Dat Android 4.4.x 17 maanden na de release van de S3 is uitgekomen wil niet zeggen dat Samsung die dan meteen klaar heeft. Meestal duurt het meerdere maanden voor een update van Android klaar is voor release naar het algemene publiek (3 maanden of langer is geen uitzondering).

Dus tegen de tijd dat Android 4.4.x aangepast/geoptimaliseerd was voor de S3 waren we allang voorbij de 18 maanden die telefoonmakers toestellen ondersteuning horen te geven volgens Google.
Je vergeet een detail. De S3 is nu nog te koop. Dus de 18 maanden zijn nog niet begonnen.
onzin, de 18 maanden beginnen te lopen zodra een toestel op de markt komt
Voor mensen die er vroeg bij waren wel, maar vergeet niet dat de S3 nog steeds verkocht wordt. Iemand die dit toestel dus nu haalt zit eigenlijk vanaf dag 1 zonder ondersteuning. Het lijkt erop dat op smartphone gebied de innovatie steeds minder snel gaat maar de fabrikanten verwachten wel dat mensen net zo vaak hun nog prima functionerende smartphone vervangen.

Als je dan bedenkt dat er massaal geklaagd werd toen de Windows XP ondersteuning stopgezet terwijl dat besturingssysteem al vele jaren van de markt was, dan wordt er duidelijk met twee maten gemeten.
Inderdaad, moeten ze maar niet zo'n goede toestellen bouwen. Ik heb nog steeds een S2, en met CyanogenMod 10.3 draait deze nog steeds fantastisch. Nieuw kopen we wanneer de oude stuk gaat, al hoop ik daar stiekem wel op ;)
Precies, de enige die zeuren over het gebrek aan updates zijn Tweakers, juist de mensen die er makkelijk een andere rom op kunnen zetten. En als je dat wilt zijn er maar genoeg te vinden.

Mijn zus en vriendin hoor ik echt niet klagen over het gebrek aan updates want hij doet het toch gewoon? Liever geen update dan wel zelfs.

Overigens wil ik je wel helpen als je hoopt dat hij stuk gaat ;)
Ding is al 100x gevallen, ben hem al 2x verloren, hij wil niet gewoon stuk of weg :+
Haha geef me 10 seconden ;)
Als je ook voor de software kiest, waarom kies je dan voor de overduidelijke "bloated" samsung software?

Dan kan je dit soort uitspraken/acties verwachten.

[Reactie gewijzigd door Mister Advance op 9 mei 2014 11:15]

Heeft GEWOON zijn 18 maanden van updates gehad?

Je krijgt dus al geen update meer voor je 2 jarige abbo afgelopen is??
En dat accepteer jij maar of vind jij maar normaal??
Moet je zelf weten natuurlijk, maar kom op zeg, ik vind dit echt schandalig en slecht naar je klanten toe!
je kunt er verbolgen over zijn, maar dit is bij andere Android telefoonmerken hetzelfde hoor. In het verleden was het soms nog korter (HTC heeft bij sommigen niet voor niets een slechte naam).
En dat is een van de redenen dat ik geen HTC toestellen meer koop. Dat en het feit dat ze steeds weer domme beslissingen nemen bij het opzetten van hun specs.

Ik snap nog steeds niet wat de logica was achter slechts 512 MB flash geheugen in de HTC Desire.
De iPhone 4 heeft na 47 maanden nog steeds updates. Dat is pas fatsoenlijke support !
Ja, mij vrouw heeft mijn oude iPhone 4. Met nieuwste updates. Dat ding is zo traag dat er gewoon niet mee te werken valt.
Dit ding is zeker al ruim een jaar heel traag en wordt na elke update nog trager gemaakt door Apple.

Overigens vond ik de performance al traag toen ik 'm nieuw kocht, dat terzijde. Na 1 jaar toen de 4S uitkwam was het al duidelijk dat het een kat in de zak was (veel features waren uigesloten voir de 4), en na kleine 2 jaar was ie helemaal afgeschreven door traagheid.

Daarbij is de iPhone 4 het toestel die voor mij het snelst afgeschreven toestel ooit is. Ik heb er slechts 3 maanden mee gedaan en was er toen helemaal klaar mee. Alle overige toestellen die ik tot op heden gehad heb, heb ik altijd langer dan 2 jaar gedaan. De laatste keer dat ik een nieuwe kocht was eigenlijk niet vanwege de performance van mijn oude, maar meer de kriebels om een groter scherm te willen, en meer opslag ruimte.

Dat laatste heeft mijn vrouw ook als probleem, 32gb is vol, geen uitbreiding mogelijk.
zeker omdat 4.4 speciaal voor telefoons met oa weinig geheugen gemaakt is
Voor telefoons met weinig ram ja. Hier bedoelen ze weinig opslag geheugen.
Nog steeds onzin, CM11 die ik op mijn Xperia Z heb staan is gezipt nog geen 150 MB. Je kunt mij gewoon niet wijsmaken dat een Galaxy S3 dat niet kan draaien.

Als ze te lui zijn om een 4.4 ROM te maken vind ik dat geen probleem, maar laat ze er dan wel eerlijk over zijn.
Ja want de Samsung Galaxy S III is helemaal niet te langzaam om Android 4.4 KitKat te draaien, mijn vader heeft FNF ifive X2 8.9" en die kwam ook met Android 4.1 uit en later kreeg het een update naar 4.2 en nu al weer een tijdje terug naar Android 4.4 KitKat, die erg lekker en soepel draait op een Rockchip RK3188 1.6GHz.

Als een Tablet van ¤ 160,- (toen) ook gewoon Android 4.4 kan draaien kan de Samsung Galaxy S III dat ook met gemak.
mijn 3 jaar oude Tegra 2 Acer Icona A500 draait super goed 4.4 dus Samsung verkoopt gewoon bullshit maar ze willen dat je een nieuwe telefoon (S5) koopt bij je nieuwe abonnement dus geen upgrade voor oude toestellen.

Het is gewoon een verkoop strategie in een mooi verhaal gestoken.

Maarja gewoon rooten en flashen die dingen dan kunnen ze nog makkelijk 2 jaar lang mee.
Het is sowieso niet correct van samsung. Ik heb hier de eerste Galaxy Note, met android 4.4.2, met runtime ART in plaats van Dalvik. Ik heb mijn smartphone nog nooit zo snel geweten. De ROM is 134MB groot bij mij. Android is zoals hierboven al vernoemd is, nog nooit zo licht en klein geweest als android 4.4.2
Die tablet heeft geen Touchwiz.
Zoals in het artikel staat is die TouchWiz de boosdoener. Vele Tweakers, waaronder mij, zullen op hun S3 al KitKat draaien, zij het een gestripte versie, AOSP of iets anders.

Toch blijft het een belachelijk argument van Samsung zelf. Dit toestel is nog geen twee jaar geleden uitgebracht en kan nu al fluiten naar updates...
Te lui zijn ze ook niet, want de 2gb modellen krijgen wel een update.
ik heb zelf CM 11 op mijn S3 en het draaied zonder problemen.
dus kitkat zonder bloat ware past en werkt op een S3.
Als Samsung er eerlijk over zou zijn waarom ze geen update willen uitrollen dan zou het als volgt klinken:

"Beste klant, we hebben besloten om geen KitKat update uit te brengen voor alle Galaxy S3 en S3 mini bezitters. Hiermee hopen we de huidige gebruiker te motiveren om een nieuw toestel uit onze peperdure serie te kopen. Mocht je al zijn overgehaald om een nieuw toestel te kopen, verwacht ook dan limited support voor updates van onze kant, over twee jaar halen we weer hetzelfde trucje uit."
Nog steeds onzin, 4.4 is juist bedoelt dat het lichte toestel moet draaien.

Wat Samsung nu zegt is pure onzin. 1g RAM moet makkelijk te draaien zijn kijk maar op bepaalde forums, dat 4.4 al op de s3 draait.
Zeg dan op zijn minst eerlijk van góh " we willen gewoon niet " ipv dat ze zeggen van dat het onvoldoende ruimte is.

Wat krijg je straks bij de samsungtoestel die al 2g/3g ram ondersteunen? Android 5.3 te weinig ram geheugen om te draaien.

Sorry vind het maar achterbaks.

[Reactie gewijzigd door aygul12345 op 8 mei 2014 22:22]

4.4 wel, de nieuwe touchwiz zeker niet.
Oftewel, ze willen heel erg graag dat je upgrade naar de nieuwe S5.
Uiteraard wilt Samsung dat je hun nieuwste telefoon koopt. Echter kan ik 't me goed voorstellen dat menigeen dat juist niet doet, na zo te zijn afgepoeierd door Samsung.
Juistem!

Ik ben het geklooi van Samsung ondertussen goed zat. Dat je dan geen updates meer geeft is al beroerd, maar dan ook nog niet eens fatsoenlijke sources geeft aan de openscource community is wat mij betreft slecht op slecht :(
Liever een update niet dan een update doe alleen het nieuwste toestel verbeterd en de rest die "ouder" zijn vertraagt
Vind ik ook. Hoewel je natuurlijk niet op een punt x een telefoon koopt en er automatisch van uit mag gaan dat je versie y ook krijgt maar je hebt wel gelijk dat zo snel de stekker eruit gaat, zeker omdat 4.4 lichter zou zijn.
Ik vind dat men zoals bij oa Apple zich wat meer mogen uitgeven hoe het met toekomstige releases zit. Bij Apple kun je meestal nog wel 2 of 3 updates installeren en de laatste mist dan een aantal (zware) opties. Dan heb je duidelijk waar je aan toe bent.
Ben ik niet met je eens, software is wel degelijk belangrijk en juist voor de mensen geen idee hebben. Software die niet ge-update word is gevoeliger voor hacks. Hoe langer dit duurt hoe erger het word. Zoals al vaker word gezegd is 4.4 juist gemaakt voor de "mindere" telefoons dus zouden deze telefoons makkelijk mee moeten kunnen. De S3 is een telefoon die erg goed verkocht is, en om dan nu de ondersteuning al te laten vallen voor dit toestel vind ik niet erg positief voor het bedrijf.
Op antwoord van servertje en NivaProx refereer ik naar mijn opmerking op HummerHealy.

aan de andere kant ben ik het ook eens met DaanHetEendje, Samsung had het ook kunnen doen zoals Apple, de 4s van mijn vriendin kon niet eens meer een kaartspelletje draaien omdat het te langzaam draaide en de telefoon op een gegeven moment gewoon uitviel. Dit alles na de laatste Apple update. Wat betreft lekken in de software, die verzorgd Google gewoon en daarvoor zijn er gewoon updates. Zelfs mijn S2 waar 4.1 op staat kreeg nog een update voor een fix. Zie het als windows Me en Windows 7 verschillende versies maar beide krijgen gewoon netjes updates.
Raar, mijn oude 4s draaide juist weer een stuk sneller. Mijn dochter is er nu erg blij mee.
Ook mijn oude 4S heeft nergens last van op iOS7.
Er staat toch niet dat er geen security updates meer komen? Alleen geen 4.4 update meer dus met die hacks zal het wel meevallen.
Je apps krijgen nog wel updates worden alleen de kernel en drivers niet meer. Dus je wordt dus wel degelijk steeds kwetsbaarder.
Dat is onzin. Ik kan op mijn HTC Desire zelfs Andoid 4.4.2 draaien.
Samsung wil er gewoon te veel bloatware in stoppen wat het geheugen vol drukt.
Ja. Laten we custom ROMs vergelijken met door de OEM uitgebrachte, ondersteunde ROMs.....
Jouw 4.4.2 is ook niet officieel door HTC uitgebracht, sterker nog, die heeft nooit hoger dan 2.3 gekregen en als ik het goed heb was het maar tot 2.2 ondersteund.

[Reactie gewijzigd door Smultie op 8 mei 2014 20:07]

Ja dus? die Custom roms werken vaak beter, gebruiken minder memory en halen meer uit je hardware. Bieden ook nog eens meer features. Prima alternatief als OEM's falen.

Ze zouden wat van die jongens in dienst moeten nemen. Die lui doen in hun eentje soms beter werk dan een heel def team van Samsung.
Ben het met je eens dat custon ROMs een meerwaarde (kunnen) zijn, maar het is geen eerlijke vergelijking om officiële ROMs te vergelijken met custom ROMs.
Het ging er om dat Samsung zegt dat het vanwegen hardware niet kan. En dat is niet zo het kan wel. Samsung kan niet zijn software er op krijgen omdat die te veel geheugen gebruikt 4.4.2 kan prima draaien op die toestellen. Dat is eigenlijk waar het om gaat.
@Smultie & Astennu: Jullie hebben beiden gelijk.

4.4. kan prima draaien op een s3 of htc desire via een custom rom en waarschijnlijk een kale android 4.4
En een officiele rom is een grote meerwaarde, niet alleen voor de gebruiker maar ook voor de restwaarde. Echter komt de officiele rom vaak met andere meuk waardoor ..... er redenen aangevoerd worden dat het niet op oude toestellen gezet kan worden.

Ik denk echter dat samsung veel gebruikers gaat verliezen door deze beslissing. Vooral in NL/BE waar de meeste gebruikers rond deze tijd (en deze bekendmaking) een nieuw toestel mogen uitkiezen ivm een 2 jarig contract.
Het kan zeker maar word het toestel er beter van? Samsung zal dan 4.4.2 met hun eigen zware touchwiz willen gebruiken en ik denk niet dat de gebruiker daar blij van word. Kijk naar gebruikers van een iPhone 4 met iOS 7. Dan liep iOS 6 veel lekkerder.

Als ik een rom installeer pak ik er meestal een waar die rommel uit is, dan draait het heerlijk, maar dat gaat Samsung niet doen.
Ik vind touchwizz geen verbetering. Dat was het eerste wat uit ging op mijn Samsung telefoons. Maar dat is natuurlijk persoonlijk.
Jij niet en ik in veel gevallen ook niet. Er zitten alleen wel een aantal erg goede functies in (S-pen, Multiwindow bijv.) die ik mis nu ik cyanogenmod heb draaien.

Uiteindelijk blijft het de look en feel van Samsung die ze echt niet zomaar laten vallen.
S-Pen bij de note inderdaad wel. Maar echt een must is het niet. Want daar zijn ook alternatieven voor te krijgen.
Daarnaast start S-Pen niet standaard op. dus dat zou het geheugen dan niet hoeven te belasten. En Multi window gebruik ik amper. leuke feature maar kan ook wel zonder. Ik vind het nog te beperkt. Het werkt niet met alle apps samen. Op die manier heb ik er vaak niets aan.

Er zijn mensen die de Samsung skin geweldig vinden en die om die rede weer een Samsung kopen.

[Reactie gewijzigd door Astennu op 9 mei 2014 11:08]

Nee een must is het zeker niet maar wel een pluspunt van de Note serie, ik gebruikte de pen best vaak..

Bij Multiwindow had ik een kleine tweak geïnstalleerd zodat het wel met alle apps werkte en dat gebruikte ik dan ook bijna altijd.
Waarom niet? Serieuze vraag, want er zijn volgens mij meer voordelen bij custom roms dan officiële.
Omdat je op een S3 en een S3 mini ook prima een custom 4.4.2 ROM kunt zetten.
Deze hele thread gaat over het feit dat Samsung geen officiële ROM uitbrengt.
Ik snap nog steeds niet waarom je dan geen vergelijking mag maken? Omdat het custom wel werkt, en officieel niet? Dat vind ik geen reden.

En dat het kan, weet ik wel. Heb het zelf draaien :)
Je mag het van mij prima vergelijken en ik draai ook custom roms, maar daar gaat het helemaal niet over. Het grote publiek gaat geen custom rom installeren omdat het teveel moeite kost.
Een update boeit heel veel mensen niet, laat staan dat ze er moeite voor gaan doen. Op een knopje drukken en 5 minuten wachten om vervolgens ook nog opnieuw op te moeten starten vind de gemiddelde Nederlander al vervelend. Helemaal als je de ervaring hebt dat het toestel langzamer werd na een update doe je dat niet zomaar nog een keer.
En wat maakt een ondersteunde ROM zo anders dan een custom ROM?

Het enigste verschil dat ik zie is dat de fabrikant geen controle meer heeft over welke software erop komt te staan. Uiteindelijk gebruikt Samsung een kale Android versie om hem zodanig te customizen naar hun wens, om deze te ondersteunen.

Ik heb ook TakTik draaien (4.4.2) op mijn Desire HD en ik wil niet zeggen dat alles soepeltjes loopt maar deze telefoon heeft minder werkgeheugen en een 2x langzamere CPU dan de S3 en nu claimt Samsung dat de hardware niet goed genoeg is? Onzin. Hun eigen aanpassingen zijn veeleisend.

Ik begrijp best van een fabrikant dat oudere producten ondersteunen tijd kost en dus geld; maar als je zo'n beslissing neemt geef dan de community de mogelijkheid om dit zelf aan te passen op een officiële manier en niet op deze manier het boek sluiten.

Wat ik me wel afvraag, volgens mij had Google en policy wijziging aangebracht dat telefoons die na datum xx/xx/2014 Android 4.0 erop moeten hebben staan want anders zal de Appstore niet meer werken (of zoiets). Ik was van plan om volgende maand bij de prijs verlanging er eentje te halen, dus hoe zit dat?
Ja, hun eigen aanpassingen zijn veeleisend en hebben meer nodig. Ze brengen geen kale versie van Android uit en hebben daar hun redenen voor (die ik prima snap). Tuurlijk kan je zelf een kale versie van Android installeren, en dat adviseer ik je ook zeker als je touchwiz wilt en kan missen.

Wees blij dat ze geen update uitbrengen die de S3 zo traag maakt als een iPhone 4 met iOS 7.
Welke Android telefoon van eerste helft 2012 krijgt nu nog 4.4 dan? Volgens mij geen één. Twee jaar in mobiele telefoonland is gewoon een eeuwigheid.
2 jaar geleden misschien
de Samsung S5 heeft voor mij bitter weinig meerwaarde dan de S3
de ontwikkelingscurve is overduidelijk zwaar aan het vervlakken, nog even en de grote groeimarges zijn iets van het verleden
Tsja dat gaat eigenlijk al vanaf de eerste iPhone zo.. Telkens een klein stapje vooruit, iets sneller, betere camera, betere accu en een mooier/groter scherm.

Wat hebben we nu meer gekregen? Een vingerscanner, hartslagmeter(, pennetje) en een front camera. Oh en een aantal half afgewerkte gimmicks. Ik ben wel benieuwd naar flexibele schermen bijvoorbeeld.
Mensen die niet kunnen rooten die hebben toch weinig aan de update.
Inderdaad: die willen geen verbeteringen op het gebied van accu, gebruiksvriendelijkheid en functionaliteit en bugfixes. 8)7

Bijzonder slechte service van Samsung dit. Heb zelf een S3 (tot volle tevredenheid) en zat eraan te denken om naar een S5 over te gaan, maar dit vind ik toch wel bijzonder matig; zou er bijna een iPhone van gaan kopen...
Wauw, dat is inderdaad met álle S3's zo 8)7

Ik zou langs de winkel gaan als dat gebeurt, tenzij je hem hebt ingepakt in zn winterjasje, dan is het je eigen schuld :+
Dan had je hem terug moeten brengen naar de winkel. Want jij bent een van de weinige die daar last van heeft daar is duidelijk iets niet goed. Ik kan hier makkelijk uren achter elkaar navigatie of zelfs zwaardere apps draaien. Geen enkel probleem.
De andere Android aanbieders zijn niet veel beter. Dan kun je beter bij Apple aankloppen. Gelukkig zijn er wel mogelijkheden om de S3 aan Kitkat te helpen. Wat me meer stoort is de lul- smoes van Samsung dat 1Gb niet genoeg is voor Kitkat.
Bij Apple is het juist erger.
Ze verplichten je zowat door je op de nieuwste iOS versie te laten werken omdat bijna geen enkele app op een oudere versie werkt.

iPhone 4 kan niet soepel de nieuwste iOS draaien en oudere kunnen de nieuwste iOS niet eens installeren.

Daarmee verplichten ze je eigenlijk om telkens een nieuwe telefoon te kopen
iOS 7.1 draait prima op een iPhone 4. Beter dan het gemiddelde Samsung toestel met touchwiz. En oudere toestellen kunnen de nieuwste iOS niet installeren? De iPhone 4 komt uit 2010(!!), hoeveel meer ondersteuning wil je ontvangen?

En als je een update niet kunt installeren omdat 1GB RAM te weinig is, moet je toch echt iets aan je software gaan doen... De iPhones hebben maar maximaal 1GB en draaien daarmee als een zonnetje.

[Reactie gewijzigd door RobbieB op 8 mei 2014 19:56]

Dan heb jij toch een hele andere definitie van prima. 7.1 is een verbetering op de iPhone 4 tov 7.0 maar nog steeds traag en een heel stuk trager dan 6. En het gaat hem niet er om dat de iPhone 4 geen update krijgt, maar dat je wel naar 7.x moet updaten.

[Reactie gewijzigd door RebelwaClue op 8 mei 2014 20:03]

Waarom MOET je naar 7.x updaten dan?
Dat hoeft helemaal niet met een iPhone 4.
Het mag, maar hoeft niet.
Veel nieuwe apps of updates werken alleen op iOS7. En update je niet, zit je vaak opgescheept met een download bestand op je iPhone die vrij groot is. Tenzij je dat natuurlijk voor was en de automatische download hebt uitstaan.
De iPhone 4 komt uit 2010(!!), hoeveel meer ondersteuning wil je ontvangen?
No offence, maar hij was nog véél recenter te bestellen op de website van Apple. Als je hem vorig jaar van Apple hebt gekocht, dan mag je er als koper dus ook wel vanuit gaan dat hij nog de apps van nu kan draaien. En dat betekent dat je niet al te ver achter kunt lopen met iOS, omdat oude iOS versies inderdaad niet meer de meest recente apps kunnen draaien. Het is dus niet alleen aardig van Apple om deze telefoon nog te voorzien van de laatste versie van iOS, maar het is ook echt nodig. En ik heb zelf al vele jaren iPhones (werk), en deze worden door sommige updates toch echt heel traag. Je telefoon geheel wipen werkt soms, maar is voor een doorsnee gebruiker ook niet duidelijk/goed te doen, en zou ook niet nodig moeten zijn.

Bij Android zit je daarentegen redelijk snel met een telefoon die niet meer officieel de laatste versie van Android kan draaien (met soms alle security-problemen van dien), maar nog wel de laatste apps (apps worden doorgaans voor Android vanaf versie 2.3, 4.0 en in sommige gevallen 4.1 gemaakt. Maar in ieder geval niet alleen voor de recentste versies). Je kunt aan de slag met custom roms om dit op te vangen, wat sommigen nog leuk vinden ook (zoals ik: ik heb privé ook een Android en het blijft leuk om het maximale uit je hardware proberen te halen... :) ), maar dat is voor de meesten toch niet weggelegd. Beide modellen zijn wat mij betreft dus niet ideaal.

[Reactie gewijzigd door displaciamento op 8 mei 2014 22:13]

Hmm, je zegt eerst m.b.t. de iPhone: "Je telefoon geheel wipen werkt soms, maar is voor een doorsnee gebruiker ook niet duidelijk/goed te doen, en zou ook niet nodig moeten zijn."

Om vervolgens over een Android toestel te zeggen: "Je kunt aan de slag met custom roms om dit op te vangen"

Zou het wel nodig moeten zijn dan om op Android te klooien met Custom Roms en Rooten en meer van dat geklooi?
Is voor het merendeel van de mensen ook niet te doen of duidelijk.

Je toestel ff wipen is af en toe goed voor zowel Android en Apple toestellen.
Ik quote mijzelf even: "Je kunt aan de slag met custom roms om dit op te vangen, wat sommigen nog leuk vinden ook (zoals ik: ik heb privé ook een Android en het blijft leuk om het maximale uit je hardware proberen te halen... :) ), maar dat is voor de meesten toch niet weggelegd. Beide modellen (=iOS en Android) zijn wat mij betreft dus niet ideaal."

Volgens mij zijn wij het dus met elkaar eens.

[Reactie gewijzigd door displaciamento op 8 mei 2014 22:44]

Excuus, u heeft gelijk.
Af en toe wil het begrijpend lezen nog wel eens falen ;)

Uiteraard hebben beide merken voor en nadelen.

Maar blijft staan dat je je iPhone 4 niet perse hoeft te updaten naar iOs 7.x om de apps te kunnen blijven draaien.
Inderdaad: heb twee iPhone 4 (niet de S) in huis draaiend op 7.1, en dat gaat prima.
Persoonlijk geen klachten, het is ietsje trager dan IOS 6, maar tja, wat verwacht je dan?

En daarbij kan je wat opties uitzetten wanneer je wat snelheid wilt winnen.
Ook helpt het soms om je toestel helemaal te wipen, kost wat tijd, maar je moet er wel iets voor over hebben.
Gelukkig heb ik de LTE- versie :D
Zegt meer over Touchwizz dan android.
Bij andere heb je wel een soepele ervaring.
Klanten zoals jou hebben ze graag!
Alle apps op mijn HTC wildfire met Android 2.2 werken nog steeds. Idem voor m'n iPad 2 met OS 6.1 (die ik niet ga updaten), hierop krijg ik zelfs nog steeds updates voor 95% van de apps.
Ik word toch wel een beetje verdrietig als ik weer dit soort reacties lees. Meng je gewoon niet in discussies als je geen flauw benul hebt waar over je zwetst :/
Apple gaat het bij de release van iOS 7 mogelijk maken voor gebruikers van oudere iOS-versies, om de laatste geschikte versie van een applicatie te installeren op hun iPhone, iPad of iPod touch. Zo blijven ook oudere Apple-apparaten compatibel met veel apps.

Bron: nieuws: 'Apple laat oude iOS-apparaten oude apps installeren'
Hoezo wordt je door Apple gedwongen, je kunt dus prima bij iOS 6 blijven!

En dan nog wat... dit gaat over Samsung, waarom moet het dan toch weer over Apple gaan :?

En om wat -1 tegen alvast tegen te gaan, ik heb dus een S3

[Reactie gewijzigd door Miki op 8 mei 2014 20:05]

ik begrijp je frustratie dat je iphone nu iets trager is door deze update
ergens heb je gelijk maar uit mijn standpunt is het beter updates te krijgen dan er geen te krijgen

ik heb zelf enkele iphones gehad (jammer genoeg gestolen)
nu heb ik een galaxy s4 en voorlopig ben ik hier tevreden mee
maar uit het verleden heb ik nog andere android high-end toestellen gehad
merken zoals HTC, Sony, Acer

na mijn eerste android tablet van Acer heb ik ingezien een dikke miskoop te begaan
door software fouten wat de tablet onhandelbaar, toen ik een galaxy tab 2 kocht
dan had ik weer dezelfde problemen
en updates of fixes bleven altijd uit

dan heb ik een ipad2 gekocht toen deze afgeprijst stonden door de nieuwe ipad3
en deze tablet gebruik ik vandaag nog steeds met iOS7 loopt die nog vlotter dan voordien en de batterij gaat ook langer mee

mijn conclusie tussen android vs iOS
apps werken altijd op iOS, op android heb ik altijd minstens 1 of 2 apps die niet correct werken of helemaal niet
elke android tablet nieuw komt met een reeks irritante bugs die nooit ofwel heel laat gefixt worden
bij iOS is dat niet zo
iOS heb je regelmatig updates, bijvoorbeeld overlaatst de heartbleed security bug
bij android op mijn galaxy s4, galaxy tab2 tot de nieuwe tablets van samsung
is er nog steeds geen update en voor oudere toestellen zal er nooit een fix komen

nexus toestelen zullen deze fix misschien wel krijgen/hebben maar dat is weer een ander verhaal
Onzin. De iPhone 4 is inderdaad wat langzamer, maar hij keeg wel iOS 7 (=drie major updates). Hoezo is dat erger? Daarnaast verplicht Apple je niets, ondanks dat je tot twee keer toe het woord gebruikt.

En ja, het is nou eenmaal een gegeven dat software na verloop van tijd zwaarder wordt. Voor Apple is het een 'damned if you do, damned if you don't'-scenario. Als ze de stekker uit de iPhone 4 trekken, krijgen ze daar kritiek op. Ondersteunen ze de iPhone 4 wel, dan zeurt men over de performance. Tja, je kan niet alles willen.
Bij Apple erger? Ze verplichten helemaal niks en het siert Apple juist dat ze de iPhone 4 niet laten stikken.

Dit in tegenstelling tot...
Veel app ontwikkelaars profiteren graag van de nieuwe API's i.c.m. het (zeer) hoge iOS 7 gebruikersaandeel. En vanzelfsprekend moedigt Apple zowel gebruikers als ontwikkelaars aan om te profiteren van de nieuwste iOS versies.

De iPhone 4 draait iOS 7.1 tamelijk goed, zeker wanneer je de leeftijd in aanmerking neemt. Wanneer je ook de animaties uitschakelt, dan werkt het nagenoeg prima. Het is echter pertinent onjuist dat "bijna geen enkele app op een oudere versie werkt".

Hoe verplicht Apple je in hemelsnaam om "telkens een nieuwe telefoon te kopen"? Net zoals iedere andere fabrikant kunnen ze dat alleen maar hopen. Het enige dat in hun voordeel werkt is je motivatie om bestaande iOS apps te willen blijven gebruiken.
De laatste 2 updates van ios7 hebben de iphone4 juist een enorme speed gegeven zodat het weer bruikbaar is.
Apple maakt maar een zeer beperkt aantal apps. De apps die iedereen dwingen om naar 7.1 te upgraden worden door heel veel developers gemaakt. Blijkbaar vinden de developers het acceptabel om iedereen te dwingen tot de upgrade. Die keuze kan je Apple niet in de schoenen schuiven.
Daar ben ik het inderdaad mee eens. Het zou wel te maken hebben met de contracten die Samsung met derden heeft. Tja en dan is het nog niet eens een smoes die ze hebben verzonnen. Ik kan me voorstellen dat een evernote en tripadvisor geld betalen om die zooi te pushen.
Helemaal eens! Samsung verkoopt liever nieuwe apparaten dan support te geven op oude. Ben zelf eigenaar van de allereerste Galaxy Tab (P1000) en die is nooit verder gekomen dan Gingerbread, terwijl die prima draait op latere versies van Cyangenmod.
Geldt overigens ook voor de Galaxy Tab 7.7, die is nooit geupgrade naar ICS of Kitkat. Wel uitgevoerd met een mooi Amoled scherm.

1Gb moet ruim voldoende zijn voor Kitkat er worden volop nieuwe toestellen uitgebracht met niet meer geheugen en Kitkat.

Voor mij voldoende reden om nooit meer een Samsung telefoon of tablet te kopen.
En dit is de reden dat ik geen Samsung gebruik. Wat een belachelijke actie weer dit. Ik vind.dit gewoon erg slecht en vervelend voor de klanten.die dit toestel hebben.
Was voor mijn ook eenmalig uitstapje, Samsung en software gaan niet samen, wat prutsers. Heb er al vaker over gepost afgelopen jaren, drama. En communicatie naar de klanten toe, ook echt drama, laten je gewoon maanden wachten nadat ze update in paar landen vrij geven, laten alle klanten gewoon in duister.

En nu dit weer, wat leugen! 4.4 is beter geschikt voor apparaten met wat minder geheugen dan 4.2. hardware mag misschien prima zijn(zoals van bijna alle merken!) maar meeste mensen willen ook dat software goed werkt.

[Reactie gewijzigd door mad_max234 op 8 mei 2014 21:04]

Android Kitkat 4.4.2 is juist gemaakt voor toestellen die niet zo veel RAM-geheugen hebben. Als je toestel 4.3 Jelly Bean draait kan deze dus ook Kitkat draaien. Tenslotte draait mijn Galaxy S3 ook (redelijk) probleemloos de CM11 (Cyanogenmod) firmware die op 4.4.2 Kitkat baseert. Alleen de camera wil het wel eens op de heupen krijgen - iets waar ik bij iedere custom firmware last van heb.

Samsung wil gewoon dat je een S4 of S5 koopt. Dat ga ik dus mooi niet doen nu ik weet hoe belabberd kort kun ondersteuning is. Mijn S3 is van November 2012, dus heb ik amper 1,5 jaar ondersteuning gehad d.m.v. software-updates.

Eind van het jaar loopt mijn contract bij T-Mobile af. Eens kijken of er dan ander interessant spul is waarbij het zich loont om mijn abonnement te verlengen, anders koop ik gewoon een Chinees toestelletje met stock-Android (de "One Plus" met Snapdragon 801 gaat rond de ¤ 269 kosten) en pak een ander SIM-only contract.

Ben eerlijk gezegd wel een beetje klaar met Samsung. Niet alleen vind ik de S4 en S5 weinig verrassend qua design, maar het software-beleid vind ik wel de grootste domper. Nog wel zitten twijfelen over de Z2 van Sony, maar daar bleken kiertjes in te zitten waardoor de waterdichtheid niet gegarandeerd kon worden en bovendien had de voorganger (de Z1) het probleem dat er klaarblijkelijk diverse soorten LCD-panelen werden gebruikt waardoor je dus de pech kon hebben dat dit voor irritatie kon zorgen.

[Reactie gewijzigd door Titan_Fox op 8 mei 2014 21:11]

Mijn s3 heeft geen 4g, dus die 4.4 kan mij gestolen worden. Tijd voor een nieuwe :)
Voor die 90MB die ik per maand aan 3G data verstook loont het zich voor mij helemaal niet om over te gaan op 4G. Het mobiele internet is puur om bereikbaar te zijn (via Whatsapp / Hangouts / social media) en te internetbankieren op plekken waar ik niet de beschikking heb over een draadloze router of hotspot. Door de huidige prijzen en bijbehorende datalimieten maak ik zo veel mogelijk gebruik van WiFi. Afgezien daarvan biedt T-Mobile geen 4G in Roermond.

[Reactie gewijzigd door Titan_Fox op 9 mei 2014 08:22]

Dan is het een ander verhaal. Het is wel jammer dat 4.3 de RAM van de telefoon om zeep heeft geholpen.
Dat is absoluut waar; de 4.3 firmware is stukken langzamer als de 4.1.2 die ik daarvoor had. Goed, de 4.4.2 firmware (Cyanogenmod CM11) is het snelst van allen. Die heb ik maar geïnstalleerd omdat Samsung na lang treuzelen en onduidelijke toezeggingen niet met een officiële Kitkat ROM op de proppen wil komen voor de S3.

Ik vind het sowieso vreemd; de Galaxy S3 en de Note 2 werden altijd in het zelfde zinnetje genoemd als het om de Kitkat update ging. Gek genoeg krijgt de Note2 wél de update en de S3 niet. Samsung's redenen zijn reinste onzin; Kitkat draait beter dan Jelly Bean en heeft bovendien minder systeembronnen nodig.

Het enige nadeel aan de CM11-firmware is dat de camera het af en toe op de heupen krijgt. Dat schijnt aan de Exynos SoC te liggen; zover ik weet hebben alle custom firmwares hier een probleem mee.
Is dat makkelijk te installeren of he je daar kennis voor nodig?
Er zijn op YouTube voldoende filmpjes te zien hoe je dat moet doen :*)
Op XDA developers zijn de ROMs te verkrijgen, en daar zijn ook geschreven instructies. Persoonlijk vind ik de filmpjes op internet wel erg handig, dan kun je stap voor stap meedoen. :9

Succes met Tweaken! 8-)
thx, ik mag geen plusjes meer geven O-)
Mijn S3 is momenteel in de verkoop in Vraag & Aanbod. Bij de opbrengst leg ik nog wat geld bij en haal de 64GB versie van de OnePlus One zodra deze beschikbaar is.

Op zich ook wel lekker om na al die jaren Samsung eens op een ander merk over te stappen :-D
OnePlus One ken ik niet. Ik heb nu zelf de LG G2 in gedachten. :)
http://oneplus.net/nl/one

Snapdragon 801 + Adreno 330, 3GB RAM, 5,5" FHD IPS scherm, 64GB interne opslag voor ¤ 299 ... Dan ga je toch geen LG kopen ?

Bekijk de pagina maar eens. De OnePlus One heeft in feite de CPU van de Samsung Galaxy S5 en het RAM-geheugen van Sony's Xperia Z2, voor grofweg de helft van de prijs.

Ik was onder de indruk ...
Lees dat het op uitnodiging is?
Nog wel, maar eind Mei zou dit toestel in Nederland verkrijgbaar moeten zijn omdat wij een van de 16 (of 17) release-landen zijn.
nice, enig nadeel is dat die telefoon mijn provider met 4g niet ondersteunt .
Je moet de Cyanogenmod Installer installeren via de Play Store. Eenmaal gestart krijg je alle aanwijzingen op het scherm van je telefoon om deze te installeren. Het enige wat je moet doen is de USB-foutopsporing inschakelen op je smartphone en de Samsung USB drivers installeren. Het wijst zich vanzelf. Als je er niet uit komt kun je mij een privébericht sturen, dan zet ik even de aanwijzingen in een reactie.

Als alternatief kun je de Cyanogenmod firmware downloaden (ZIP-file), deze op de SD-kaart in je toestel zetten, toestel inschakelen met "volume-up" + "home" + "power" (Recovery-modus) en vervolgens "Install ZIP from SD-card. Zorg wel dat de accu voldoende is opgeladen. Succes !
Niet om te zeuren, maar HTC is nog beroerder qua software ondersteuning. ;)
Ben ik met je eens wat de actie betreft.

Ik draai nu al vanaf het begin een cyo mod 4.4 helemaal top geen vertragingen

Samsung wil gewoon zijn eigen software die dus te zwaar is blijven draaien

Samsung prima telefoon Alleen beginnen ze ben ik bang een beetje naast de schoenen te lopen.

Maakt goed spul niet overdrijven dus.
Ik gebruik wel een Samsung (S4) maar met het huidige beleid van Samsung is dit wel de allerlaatste die ik koop. Na het schandalige omruilbeleid van accu's (he, we hebben slechte accu's geleverd die bol gaan staan maar om in aanmerking te komen voor een nieuwe accu ben je wel ruim twee weken je accu kwijt ipv direct omruilen in een service centre), de immense hoeveelheid bloatware (krijg s planner maar niet weg), en het gebrekkige update beleid is het voor mij wel duidelijk: Samsung voortaan links laten liggen!
Check. Mijn Motorola G van 170 euro draait al een paar maanden android 4.4.

Ik ga niet eens de moeite nemen dat ding te rooten, want ik zou niet weten waarom.
Voor de mini heeft dat niks met het geheugen te maken, er worden gewoonweg geen drivers meer geschreven voor de aanwezige SOC in dat toestel.
En dus? Dat ding draait toch al onder Android 4.1? Diezelfde drivers kun je zonder veel aanpassingen ook wel op 4.4.2 aan de praat krijgen. Op XDA forums zijn er genoeg 4.4.2 roms te vinden voor de S3 mini, zoals hier: http://forum.xda-developers.com/showthread.php?t=2521593
Voor zover ik weet is er maar eentje, inderdaad degene waar je naar verwijst. Meestal werkt die, maar de manier waarop die rom ontwikkeld wordt, is niet echt goede reclame voor opensource-ontwikkeling... De enige roms die je kan vinden voor een S3 mini zijn een soort van aan de lopende band geproduceerde nightlies, die ongetest op de gebruikers losgelaten worden.

Het klinkt allemaal wel leuk, als je zo hun first post en hun changelogs bekijkt. In werkelijkheid geeft die rom (toch voor een S3 mini) meer issues en bugs dan features, en loopt die changelog nu niet echt samen met hetgeen er werkelijk in die rom zit.
In de gelinkte thread staan er al 3 genoemd:
De CyanogenMod 11, Android Open Kang Project, en Chameleon OS.
Okee, wel allemaal door dezelfde developer, dus qua code zal er veel leentjebuur zijn... maar toch, er zijn meerdere 4.4.2 roms voor de S3 mini.

Hoe goed het allemaal is, weet ik niet. Ik heb zelf geen S3 mini, dus heb deze roms ook niet geprobeerd.
Ik wilde alleen aangeven dat de SoC wel degelijk onder Android 4.4.2 te gebruiken is.
Ik gaf ook geen tegenmening. Ik hoopte eigen stiekem dat er andere roms waren dan degene die ik kende. Blijkbaar niet. En jep, niet alleen de SoC, maar zowat alles aan de S3 is nog steeds redelijk futureproof wat KitKat (en misschien zelfs een volgende editie) betreft.

De drie versies die je opnoemt zijn trouwens niet de enigen. Ze bestaan ook nog onder de vorm van een PAC Android, SlimROM, Carbon en OmniROM. Qua code zit er weinig verschil in. Het zijn echt hooguit verschillende CM-versies met een eigen smaakje erbovenop. Geen verschil qua operating system, hier en daar een aangepaste flavour que wat je/waar je kan customizen, of wat er uitgestript kan worden.
Daar ben ik van op de hoogte, echter zijn deze zelf gefabriceerd/aangepast. Dit is niet regulier voor een fabrikant, die laat ze voor zover ik weet aanleveren door de SOC maker. Kijk bijv. naar de MSM8260, die heeft ook geen drivers voor na 4.1 gemaakt, en Sony en HTC hebben daar ook geen latere Android versie's voor uitgebracht (Xperia S/Acro S/ion/HTC Sensation/-XE/Evo 3D).
En dus? Dat ding draait toch al onder Android 4.1? Diezelfde drivers kun je zonder veel aanpassingen ook wel op 4.4.2 aan de praat krijgen. Op XDA forums zijn er genoeg 4.4.2 roms te vinden voor de S3 mini, zoals hier: http://forum.xda-developers.com/showthread.php?t=2521593
Ja lukt andere ook, lijkt me voor beetje bedrijf met fatsoenlijke software afdeling met genoeg kennis normaal geen probleem. En ze hebben ook veel meer toegang tot kennis en hulp.
Android 4.4 is vergeleken met Android 4.3, dat wel op de S3 en S3 mini draait,
Is dat zo? De S3 mini van mijn vrouw draait 4.1.2 wat niet verder te updaten is via het toestel zelf of doe ik wat verkeerd?

"De laatste updates zijn geinstalleerd" zegt ie bij software update

[Reactie gewijzigd door RodeStabilo op 8 mei 2014 19:37]

De S3 kan je updaten via deze link (op eigen risico!)
http://beta.download.cyanogenmod.org/install
Bij mijging het altijd goed, ik kan je niet 100% garantie geven dat dat bij jou ook goed gaat. Het is eenkale versie van Android, play store Google apps en dergelijke dien je er zelf weer op te zetten.
Misschien is het een branded toestel. Kennelijk heeft ze de update naar 4.2 ook gemist. Je kunt naar een servicepunt gaan en de nieuwste firmware er op laten zetten.
Raar dat mijn S2 kitkat dan wel super kan draaien en de S3 zou dat dan niet kunnen ??
Willen dus gewoon maar mensen pushen naar de S5 :)
Die kitkat ROM is ook geen officiële ROM van Samsung. Mijn S3 draait ook op 4.4.2 maar dit is geen ROM van Samsung. ;)
Maar werkt alles goed en soepel?
Alles werkt zelfs zeer goed en soepeler dan de originele sammie roms hier.
Allemaal aan de hartslagmeter! :D
1 2 3 ... 8

Op dit item kan niet meer gereageerd worden.



Apple iOS 10 Google Pixel Apple iPhone 7 Sony PlayStation VR AMD Radeon RX 480 4GB Battlefield 1 Google Android Nougat Watch Dogs 2

© 1998 - 2016 de Persgroep Online Services B.V. Tweakers vormt samen met o.a. Autotrack en Carsom.nl de Persgroep Online Services B.V. Hosting door True