Cookies op Tweakers

Tweakers maakt gebruik van cookies, onder andere om de website te analyseren, het gebruiksgemak te vergroten en advertenties te tonen. Door gebruik te maken van deze website, of door op 'Ga verder' te klikken, geef je toestemming voor het gebruik van cookies. Wil je meer informatie over cookies en hoe ze worden gebruikt, bekijk dan ons cookiebeleid.

Meer informatie

Software-update: Drupal 8.2.5

Door , 19 reacties, submitter: TwiQ_Media, bron: Drupal

Drupal logo Versie 8.2.5 van Drupal is uitgebracht. Drupal is een in php geschreven, gebruiksvriendelijk en krachtig contentmanagementplatform, waarmee bijvoorbeeld websites kunnen worden gemaakt. Nieuw in versie 8.2 is onder meer dat er blokken voor tekst of media op pagina's geplaatst kunnen worden zonder dat je daar eerst voor naar een andere administratiepagina hoeft te gaan. Verder is er ondersteuning voor tijdsperiodes toegevoegd, waar voorheen alleen een specifiek tijdstip kon worden gebruikt. De release notes voor deze uitgave zien er als volgt uit:

Release notes
This is a patch release of Drupal 8 and is ready for use on production sites. See the CHANGELOG.txt for a summary of changes and improvements since the last minor release.

Versienummer 8.2.5
Releasestatus Final
Besturingssystemen Scripttaal
Website Drupal
Download https://ftp.drupal.org/files/projects/drupal-8.2.5.tar.gz
Bestandsgroottes 11,50MB - 19,10MB
Licentietype GPL

Reacties (19)

Wijzig sortering
Voor diegene die benieuwd zijn waarom de changelog zo -kort- is, hier vindt je de security changelog: https://www.drupal.org/SA-CORE-2016-005
Die is bijna 2 maanden oud en opgelost in v8.2.3. Zie https://www.drupal.org/project/drupal/releases/8.2.5 voor de wijzigingen.
Nitpick: dat is geen security changelog, maar een security advisory.
Ik vroeg me af of Drupal al met PHP7 werkt, juist omdat de support van de 5.6-branch binnenkort afloopt. De meest recente melding in de changelog t.a.v. PHP vind ik bij versie 8.0.0 (2015-11-19)
en daar staat:
Core branch nightly tests include PHP 5.5, 5.6, 7, sqlite and PostgreSQL.
Interpreteer ik daarmee correct dat ze aan het testen zijn met 7 en de laatste twee versies van 5.x en alleen volledige juiste werking is gegarandeerd met versie 5.4 (en ouder) waarvan de support is geëindigd in 2015?
PHP 7 wordt expliciet ondersteund. Het is zelfs zo dat Drupal 8 steeds tegen PHP 7 HEAD getest wordt, en dat al zo'n twee jaar (dus ook zowat een jaar voor de release van PHP 7 en Drupal 8, ze kwamen beiden eind 2015 uit). Op die manier heeft Drupal 8 al vele PHP 7 bugs gevonden. En dus PHP 7 beter gemaakt voor iedereen.

Zo is er op dit eigenste moment bijvoorbeeld een regressie in PHP 7 (alle PATCH requests falen owv een recente verandering in PHP's Apache integratie) en dus falen momenteel enkele van de twintigduizend testen in Drupal 8. Het PHP team is dat momenteel aan het fixen :)
EDIT: link: https://www.drupal.org/node/2840974.

Die zin betekent eenvoudigweg dat élke commit tegen PHP 5.5, 5.6 én 7 getest wordt!

[Reactie gewijzigd door Wim Leers op 6 januari 2017 09:51]

Bedankt. Dat is duidelijk.
Zo is er op dit eigenste moment bijvoorbeeld een regressie in PHP 7 (alle PATCH requests falen owv een recente verandering in PHP's Apache integratie) en dus falen momenteel enkele van de twintigduizend testen in Drupal 8. Het PHP team is dat momenteel aan het fixen
Is dit nog iets waar je serieus rekening mee moet houden als je een eerste site wilt bouwen?
(in de zin dat je dus tegen minder onverwachte problemen aan zult lopen door 5.6 te kiezen en dan bedoel ik van die soort problemen waar je als beginner niet snel een oplossing voor vindt.)
PHP versie is echt een van je minste problemen ;) 5.6 voldoet, 7 ook. Alleen is 7 sneller en zal het langer ondersteund worden.
Tooling eromheen om de hele boel voor je development- en releaseproces te optimaliseren is echt een hel als je dat nog niet eerder gedaan hebt, daar zit de uitdaging.
Volgens mij garanderen ze juist de werking met 5.5 en hoger, omdat ze daarmee continu de werking testen. Voor 5.4 en lager voeren ze geen tests uit, dus weten ze ook niet of de versie in de core branch daar op gaat werken.
Volgens mij garanderen ze juist de werking met 5.5 en hoger, omdat ze daarmee continu de werking testen.
Dat klinkt logisch, ik kon er echter niets concreets over vinden. Inmiddels zou 5.5 ook wel uitgefaseerd mogen worden. (al is het natuurlijk altijd zinvol om de mogelijkheid te bieden iets bestaands te migreren naar een nieuwe versie)
Voor 5.4 en lager voeren ze geen tests uit, dus weten ze ook niet of de versie in de core branch daar op gaat werken.
Ook dat is logisch, immers is php5.4 het end-of-life en dus zou het niet meer ingezet moeten worden, al zullen er ongetwijfeld nog sites zijn die er op draaien.

[Reactie gewijzigd door BeosBeing op 6 januari 2017 09:52]

Neen, 5.4 en lager worden *niet* ondersteund. 5.4 was al niet meer ondersteund toen Drupal 8 uitkwam. En performance is een stuk slechter omdat er pas vanaf 5.5 OpCache standaard in zit :)
Dat zeg ik toch?
PHP 5.x is officieel EOL maar eigenlijk heb ik alles (behalve Drupal 6) gewoon op 7 kunnen installeren. Upgraden dus!
Vooral Drupal 8 draait echt als een tierelier op PHP 7.
Als je daarnaast alle cache, JS- en CSS compressie aanzet laadt de pagina al voordat je hebt geklikt. Bij wijze van spreken dan natuurlijk.
Drupal 8 werkt prima op PHP7. En merkbaar sneller ook.
We zijn momenteel bezig met het beta testen van PHP7+D8 op een Acquia omgeving, en dat werkt inmiddels vrij soepeltjes.
Mijn ervaring is dat zowel Drupal 7 als 8 intussen meestal perfect werken met php7. En dat je een enorme prestatiewinst haalt.
Elke Nederlandse scheet in een fles komen komt er in het groot de naam en land van herkomst in en wordt helemaal bewierookt .

Mag hier ook wel gezegd worden dat dit van Belgische oorsprong. Go Dries!!
Och, valt wel mee. Het CMS Bolt is Nederlands en dat wordt er ook niet bij vermeld.
Vergeet niet dat Tweakers toch wel uit Nederland komt hè. Met grotendeels Nederlandse bezoekers die het natuurlijk ook leuk vinden om te horen dat iets nieuwswaardigs van eigen bodem komt.
.. en deze Nederlander sprak Dries van Buytene zo rond 1997 in de trein van Amsterdam naar Rotterdam, en zei hem dat ie veel verwachtte van de net ontwikkelde "internettool" PHP voor het maken van websites in combinatie met databases. Inclusief het feit dat elke webpage in wezen is ingedeeld in header, footer, tekst, linkerkolom, rechterkolom (zoals je een A4 gebruikt bij het schrijven van Essays)
Heeft 'ie z'n naam veranderd naar Buytaert of zo? :)

Heb je vaak met zulke hobby projecten waar je niets van verwacht, voordat je het weet is het mateloos populair en gaat het in een sneltreinvaart.
Drupal 1 is van 2000, dus je beweert dat hij daar al ruim 3 jaar mee bezig was?

Op dit item kan niet meer gereageerd worden.


Nintendo Switch Google Pixel XL 2 LG W7 Samsung Galaxy S8 Google Pixel 2 Sony Bravia A1 OLED Microsoft Xbox One X Apple iPhone 8

© 1998 - 2017 de Persgroep Online Services B.V. Tweakers vormt samen met o.a. Autotrack en Hardware.Info de Persgroep Online Services B.V. Hosting door True

*