Cookies op Tweakers

Tweakers maakt gebruik van cookies, onder andere om de website te analyseren, het gebruiksgemak te vergroten en advertenties te tonen. Door gebruik te maken van deze website, of door op 'Ga verder' te klikken, geef je toestemming voor het gebruik van cookies. Wil je meer informatie over cookies en hoe ze worden gebruikt, bekijk dan ons cookiebeleid.

Meer informatie

Door , , 12 reacties
Bron: Joomla!, submitter: skai21

Versie 3.4 van Joomla! is uitgekomen. Joomla! is een dynamisch, in php geschreven contentmanagementsysteem, dat kan worden gebruikt om bijvoorbeeld een weblog, website of collaboratiesite te maken. Om het programma in het Nederlands te gebruiken kun je onder andere op Joomla Community terecht. In versie 3.4 is onder meer front end module editing verbeterd en Googles nieuwe reCaptcha toegevoegd. Daarnaast zijn meer dan 700 bugs geplet. De release notes voor deze uitgave kunnen hieronder worden gevonden.

What's in 3.4?

The 3.4 release introduces new features into the CMS such as improved front end module editing, decoupling of weblinks, composer integration, Google new reCaptcha and security improvements by implementing UploadShield code which can detect most malicious uploads by examining their filenames and file contents. Please note: Due to technical reasons we have had to disable the Install from Web Service. We are working to get it back online as soon as possible. To find extensions please use the Joomla! Extensions Directory.

Thanks to the hard work of over 130 different volunteer contributors, over 700 bugs have also been resolved with the 3.4 release of the Joomla! CMS. See the list of fixed GitHub issues for details of the tracker items fixed.

For known issues with the 3.4.0 release, see the Version 3.4.0 FAQ in the documentation site.

Joomla! 3.0 dashboard screenshot (620 pix)

Moderatie-faq Wijzig weergave

Reacties (12)

IDD heel fijn CMS. Maar... Eind 2014 is ondersteuning voor 2.5.x gestopt. Heb afgelopen weken besteed aan het migreren naar 3.3.6 (vrij veel componenten moesten opnieuw geinstalleerd worden.) En dan komt nu 3.4 uit. Kan ik weer allerlei installaties opnieuw doen. En templates aanpassen.
Is dit nu een LTS versie? Het lijkt alsof het LTS/STS verschil verdwenen is.
Tja, ik zit voorlopig nog even vast op 2.5 aangezien mijn hoster zegt nog niet compatible te zijn met Joomla 3. Ik vraag me af wat het zou kunnen zijn, te oude versie van MySQL of PHP?
Tijd voor een nieuwe hosting partij?
Joomla 2.5 werkt nog op PHP 5.2.4+, vanaf Joomla 3.x is de minimale PHP versie 5.3.10. Dat zal je probleem waarschijnlijk zijn. Als ik me niet vergis is de ontwikkeling van 5.3 in augustus 2014 gestopt en is dus al EOL. Als jou hoster dat al niet ondersteund...
Er is geen lts of sts meer, ontwikkeling gaat anders, zie https://docs.joomla.org/Release_and_support_cycle/nl
Hoe zit het met de veiligheid, ik lees regelmatig dat joomla gewoonweg onveilg is, zelfs zonder 3rd party plugins, modules en componenten.
Zolang je niet op een antieke versie zit en gewoon alle patches bijhoudt is er niets aan de hand. Er zijn online zelfs how-to's te volgen hoe je het veiliger kan maken.

De verhalen dat het onveilig is komen deels nog uit de 1.6 tijd, aan de andere kant: iedere applicatie die vanuit internet kan bereiken is onveilig. Zeker een open source applicatie, want iedereen kan de code bekijken en zoeken naar foutjes die misbruikt kunnen worden. Ook Wordpress en Drupal hebben zo hun issues of hebben ze in ieder geval gehad.
Als je het hebt over de Joomla! core, die is gewoon veilig mits je de laatste versie gebruikt. Waar lees je dan regelmatig dat dit niet het geval is? Want dit soort praatjes blijven rondgaan zonder dat er gecontroleerd wordt of het ook het geval is.

Ik kwam gisteren nog een Joomla 2.5.8 versie tegen, die mist natuurlijk al 20 updates waarin mogelijk veiligheidsproblemen in zijn opgelost. Even een CMS installeren en denken dat je verder geen onderhoudt hoeft te plegen, daar krijgt een CMS de slechte naam van. En dat zijn vaak ook de mensen die hard schreeuwen dat het CMS onveilig is terwijl ze zelf schuldig zijn.
Cool! Ze zijn met de 3.x (vooral vanaf 3.2) weer een goede weg ingeslagen. Vooral de API-documentatie wordt stevig verbeterd, merk ik! Dat was met 2.5< echt rampzalig, maar met 3.x is daar een goede inhaalslag gemaakt.
Ik werk al met Joomla sinds 2005. En deze versie is echt geweldig. Het word beter en beter, en het was al een heel fijn CMS. Jammer alleen dat Bootstrap 2 geintegreerd is en niet 3. Maar ook dat is makkelijk te "omzeilen".
Voor de volledigheid, de link naar de downloadlocatie op joomlacommunity.eu is een verkeerde verwijzing. Dit is de juiste: http://download.joomlacommunity.eu/volledige-versie-34.html
Zal het ook even doorgeven. :)
Heel vroeger vond ik persoonlijk Joomla niet zo goed werken. Als ik Joomla nu zie is het veel gebruiksvriendelijker geworden en veel verbeteren. De moeite waard om joomla weer te gebruiken :)

Op dit item kan niet meer gereageerd worden.



Apple iOS 10 Google Pixel Apple iPhone 7 Sony PlayStation VR AMD Radeon RX 480 4GB Battlefield 1 Google Android Nougat Watch Dogs 2

© 1998 - 2016 de Persgroep Online Services B.V. Tweakers vormt samen met o.a. Autotrack en Carsom.nl de Persgroep Online Services B.V. Hosting door True