Cookies op Tweakers

Tweakers maakt gebruik van cookies, onder andere om de website te analyseren, het gebruiksgemak te vergroten en advertenties te tonen. Door gebruik te maken van deze website, of door op 'Ga verder' te klikken, geef je toestemming voor het gebruik van cookies. Wil je meer informatie over cookies en hoe ze worden gebruikt, bekijk dan ons cookiebeleid.

Meer informatie

Door , , 7 reacties
Bron: Joomla!, submitter: Mschamp

Joomla! logo (75 pix) Versie 3.6.1 van Joomla! is uitgekomen. Joomla! is een dynamisch, in php geschreven contentmanagementsysteem, dat kan worden gebruikt om bijvoorbeeld een weblog, website of samenwerkingssite te maken. Om het programma in het Nederlands te gebruiken kun je onder andere op Joomla Community terecht. In versie 3.6 is onder meer de updater verbeterd en kunnen nu de kernonderdelen geherinstalleerd worden om zo eventueel aangepaste bestanden te overschrijven. In versie 3.6.1 is een beveiligingsprobleem verholpen wat consequenties heeft voor de updateprocedure. Meer informatie daarover is in de release notes te vinden.

The Joomla! 3.6.1 Update
During the latest release of Joomla! 3.6.1 an issue emerged because of a security fix. 3.6.1 introduced a CSRF token check to the Joomla! Update component as an extra level of security to fix a Medium Level security issue. 3.6.0 down to 2.5.4 (every Joomla! release with the update component) will hit an issue with failing to pass the CSRF token check because those versions don't generate the needed token to pass the check. Therefore we have had to make some emergency decisions:

Updating from Joomla! 2.5.x
Unfortunately there was a bug when updating Joomla! 2.5.x to 3.6.0 - this was patched in the 3.6.1 release - however as this migration is no longer possible - you will need to first migrate to Joomla! 3.5.1 then upgrade to 3.6.0. Then follow the steps below for users on Joomla! 3.6.0.

Updating from Joomla! 3.0.0-3.5.1
Update to Joomla! 3.6.0 through the Joomla! Update component. Then follow the steps below for users on Joomla! 3.6.0.

Updating from Joomla! 3.6.0
Update the Joomla! Update Component through the Extension Manager. Then use the Joomla! Update component to update to the latest 3.6.x version.

For those who have updated to 3.6.1 from 3.6.0 already
For those who have already updated to Joomla! 3.6.1 don’t worry. All the new 3.6.1 files have been successfully put in place. Simply run the database fixer tool to delete the one file we have removed.

For those who have updated to 3.6.1 from a version earlier than 3.6.0 already
Your files have been updated. You must treat this upgrade as if you have updated Joomla! by unzipping the files over your existing system. We strongly advise that you run the database fixer tool to clean up outdated files and update the database structure. Note this will not fix any insert or updates by design as we cannot verify that these have happened before. Therefore you will need to manually apply these changes yourself. We apologise for the inconvenience this causes our users.

All Versions (2.5.4 to 3.6.0) - Manual Upgrade
Though we do not encourage this practice, it is possible to update Joomla! manually (similar to Joomla! 1.5 updates) and perform a proper upgrade. There is a script with detailed instructions available here.

Joomla! 3.0 dashboard screenshot (620 pix)

Versienummer:3.6.1
Releasestatus:Final
Besturingssystemen:Scripttaal
Website:Joomla!
Download:https://joomla.org/download
Bestandsgrootte:11,37MB
Licentietype:GPL
Moderatie-faq Wijzig weergave

Reacties (7)

Is er ook ergens informatie over de code wijziging? Ik kan hem niet vinden op:

https://issues.joomla.org/

Een van mijn module vertoont wat onverwacht gedrag...
Hier is een overzicht van alle wijzigingen die in 3.6.1 zitten, heb je daar wat aan?
https://github.com/joomla...tone%3A%22Joomla+3.6.1%22

[Reactie gewijzigd door Xaverius op 4 augustus 2016 20:32]

En toen had je een synology |:( tot op heden nog geen php 7 (volgens mij).
Maar je hebt ook geen PHP 7 nodig om Joomla te gebruiken. Zelf zit ik nog op 5.6 en als ik het goed herinner moet het werken vanaf 5.3.10
Voor degenen met de volgende melding "Failed to start the session: already started by PHP ($_SESSION is set)", hier de oplossing: https://github.com/joomla/joomla-cms/pull/11430/files

en een verplichte 'foei' voor het gebruik van PHP 5.3 na EOL.
Inmiddels is Joomla 3.6.2 uit:
Joomla! 3.6.2 fixes some issues found in the 3.6.1 release on Wednesday related to sessions on PHP 5.3 and some general email cloaking bugs:
PHP 5.3 users were unable to login
Cloaking emails could cause issues with placeholder and input values that were emails
Emails in links with attributes had the attributes stripped when email cloaking happens

Op dit item kan niet meer gereageerd worden.



Nintendo Switch Google Pixel Sony PlayStation VR Samsung Galaxy S8 Apple iPhone 7 Dishonored 2 Google Android 7.x Watch_Dogs 2

© 1998 - 2016 de Persgroep Online Services B.V. Tweakers vormt samen met o.a. Autotrack en Carsom.nl de Persgroep Online Services B.V. Hosting door True