Cookies op Tweakers

Tweakers maakt gebruik van cookies, onder andere om de website te analyseren, het gebruiksgemak te vergroten en advertenties te tonen. Door gebruik te maken van deze website, of door op 'Ga verder' te klikken, geef je toestemming voor het gebruik van cookies. Wil je meer informatie over cookies en hoe ze worden gebruikt, bekijk dan ons cookiebeleid.

Meer informatie

Door , , 19 reacties
Bron: Drupal, submitter: nobleone

Drupal logoVersie 8.0.2 van Drupal is uitgebracht. Drupal is een in php geschreven, gebruiksvriendelijk en krachtig contentmanagementplatform, waarmee bijvoorbeeld websites kunnen worden gemaakt. In versie 8 staan responsive templates standaard aan, waardoor een website er altijd goed uitziet, onafhankelijk van het apparaat dat wordt gebruikt om hem te bekijken. In Drupal 8 is de overstap van xhtml naar html5 gemaakt, wat onder meer web-apps mogelijk maakt. Verder is de in php geschreven broncode flink opgeschoond en gemoderniseerd en zouden door slimmere caching de prestaties zijn verbeterd. Versie 8.0.2 bevat diverse bugfixes en verbeteringen aan de documentatie en testprocedures.

Drupal 8.0.2 released
Drupal 8.0.2, a maintenance release with numerous bug fixes (no security fixes), is now available for download. See the Drupal 8.0.2 release notes for a full list of included fixes.

Change Log
Drupal 8.0.2 contains bug fixes and documentation and testing improvements only. The full list of changes between the 8.0.1 and 8.0.2 releases can be found by reading the 8.0.2 release notes. A complete list of all changes in the stable 8.0.x branch can be found in the git commit log.

Drupal 8 (620 pix)

Versienummer:8.0.2
Releasestatus:Final
Besturingssystemen:Scripttaal
Website:Drupal
Download:http://ftp.drupal.org/files/projects/drupal-8.0.2.tar.gz
Bestandsgrootte:11,18MB
Licentietype:Voorwaarden (GNU/BSD/etc.)
Moderatie-faq Wijzig weergave

Reacties (19)

Verder is de in php geschreven broncode flink opgeschoond en gemoderniseerd en zouden door slimmere caching de prestaties zijn verbeterd.
... is wel een flinke understatement als je het mij vraagt. Versie 8 van Drupal is grotendeels van de grond af aan opgebouwd met componenten van het Symfony framework. Eerst waren er plannen om het volledig op Symfony te baseren maar later hebben ze besloten alleen bepaalde componenten er van te gebruiken (wat tevens de kracht is van een framework als Symfony). Dit is een gigantisch grote stap voorwaarts ten opzichte van versie 7. Met de opkomst van een nieuwe generatie CMS systemen als Bolt en October moesten ze ook wel. Drupal 7 was stabiel maar was wel echt oud aan het worden. Wordpress gaat het zwaar krijgen de komende tijd :)
Dat valt denk ik wel mee, vooral met een versie benodigd als PHP 5.5.9 wat veel hosters nog niet hebben. Ook is het opvallend lastig om er achter te komen wat de requirements zijn. Google moest er aan te pas komen, een link op de normale pagina nog niet kunnen vinden.
Dus veel hosters gebruiken volgens jou een PHP versie die EOL is? Van versie 5.5 worden alleen nog security updates uitgegeven, dus lijkt mij vrij normale requirement.
Ja, er draait genoeg nog op een oude versie, dit zou niet echt verbazend moeten zijn aangezien er ook nog steeds mensen op windows xp en ie8-9 zitten.

Tevens de meeste security issues zitten in de PHP scripst zelf, al is dat natuurlijk geen excuus om achter te blijven.
En dit is dus de reden dat websites altijd gekraakt worden...
(...)een versie benodigd als PHP 5.5.9(...)
Ondanks PHP 5.5.29 kom ik ook niet echt ver:
Fatal error: Call to undefined function Drupal\Core\Config\fnmatch() in /share/HDA_DATA/Qweb/drupal-8.0.2/core/lib/Drupal/Core/Config/InstallStorage.php on line 233
Als ik daar op zoek dan krijg ik dit: https://www.drupal.org/node/2620576. fnmatch is een functie in PHP en is blijkbaar op jouw installatie niet beschikbaar ...
Die had ik in november ook ontdekt maar ik had gehoopt dat ze de bedachte patch (toepassen van alternatief voor fnmatch) inmiddels in de core hadden verwerkt.
Dit speelt al sinds 8.0.0, was niet opgelost in 8.0.1 en ondanks committed patches ook niet in 8.0.2 meegenomen.
Jammer.
Is het dan geen idee je hosting provider te mailen/bellen? Er moet toch een oplossing zijn voor iets wat zoveel gebruikt word. Dit zou hun ook klanten kunnen kosten. Een beetje self-initiatief is ook wel handig.

[Reactie gewijzigd door BJ_Berg op 14 januari 2016 16:56]

Met patch #17 op dit site lukt het me om verder te komen in het installatieproces...
...wat mij tot de volgende uitdaging brengt:
Drupal\Core\Database\DatabaseExceptionWrapper: SQLSTATE[HY000]: General error: 2006 MySQL server has gone away
Ben al aan het stoeien met de 'max allows packet'-instelling maar tot nu toe zonder succes.
Zonder dat ik site van Drupal ken, ben ik er toch in drie klikken achter gekomen wat de requirements zijn: https://www.drupal.org/requirements
Ik mag hopen voor hosting partijen dat ze al wel de switch gemaakt hebben naar 5.6, zo niet dan mag je wel eens op zoek naar een ander ;)
Ik denk dat dit nog tegen zal vallen.
Toevallig net ff gekeken naar mijndomijn.nl -> PHP v5.4.41 :'(
Welke versie draaien andere hostings?

[Update] Webhosting Plus PHP Upgrade
door Hendrik Jan van den Berg op 08 Dec 2015, in Nieuws
In de nacht van 9 op 10 december gaan we over naar php 5.6

[Reactie gewijzigd door cruysen op 13 januari 2016 14:19]

Hostingdiscounter -> PHP 5.3.10
Heeft helaas geen overzicht pagina
Mijn andere bekeken hosters KPN (<-slecht), correcthosting, ONE zitten respectievelijk op 5.2.5(!), 5.6.16, 5.6.16.

Ik weet dat ik kan kiezen bij Flexweb, Hostnet en Yourhosting... meestal zijn die wel up-to-date. Ik weet dat je bij SoHosted nu kunt je kiezen voor PHP7.

Heeft er iemand een USBwebserver (o.i.d. portable) op PHP7 draaien??
Ik wilde gisteren een PHP-DEVserver instaleren maar mijn virusscanners springen gevaarlijk op: http://www.easyphp.org/

[Reactie gewijzigd door Stranger__NL op 13 januari 2016 14:22]

Ik moet hier altijd even om lachen:

Drupal is een in php geschreven, gebruiksvriendelijk en krachtig contentmanagementplatform.

Gebruiksvriendelijk.... Als één cms dat niet is en een stijle leercurve kent, dan is het drupal wel. Zelfs onze contentmanagers hebben de grootste moeite gehad het cms aan te leren. Staat mijlenver van sitecore, wordpress of zelfs Joomla..
Wat is tegenwoordig eigenlijk het beste cms om te gebruiken?
Ik ben ooit, tien jaar terug of zo joomla gaan gebruiken, en gebruik dat nog steeds...
Het heeft me vooral in het begin heel veel gevloek en geklopt opgeleverd maar heb er uiteindelijk mee leren werken. Vooral het updaten van joomla was in het verleden een drama. Hele site from scratch bouwen was geen uitzondering :P
Ik gebruik nu sinds kort Wordpress en ben daar wel erg tevreden over. Ook al 2 updates uitgevoerd en er veranderd niets aan de site zelf. Andere om mij heen hebben de zelfde ervaringen.
Gebruiksvriendelijk in die zin, dat je niet direct naar PHP code hoeft te grijpen. En heel veel via de CMS interface kan bewerkstelligen. Daarbij is kennis nodig van diverse modules en de interactie er tussen.
Jaren geleden met Joomla gewerkt, daar zat je direct in PHP te rommelen. In WordPress 'The loop'. In Drupal heb ik nog maar weinig met PHP te maken gehad. En ja, het is lastig om dingen gedaan te krijgen in Drupal. Maar ik kan het documenteren en overdragen aan de eind gebruiker.
Dat is onmogelijk bij PHP-code aanpassingen.

Op dit item kan niet meer gereageerd worden.



Apple iOS 10 Google Pixel Apple iPhone 7 Sony PlayStation VR AMD Radeon RX 480 4GB Battlefield 1 Google Android Nougat Watch Dogs 2

© 1998 - 2016 de Persgroep Online Services B.V. Tweakers vormt samen met o.a. Autotrack en Carsom.nl de Persgroep Online Services B.V. Hosting door True