Cookies op Tweakers

Tweakers maakt gebruik van cookies, onder andere om de website te analyseren, het gebruiksgemak te vergroten en advertenties te tonen. Door gebruik te maken van deze website, of door op 'Ga verder' te klikken, geef je toestemming voor het gebruik van cookies. Wil je meer informatie over cookies en hoe ze worden gebruikt, bekijk dan ons cookiebeleid.

Meer informatie

Door , , 0 reacties
Bron: Drupal, submitter: axper

Drupal is een veelzijdig contentmanagementsysteem dat zijn werk doet op een groot aantal platformen. Het programma kan via modules van extra functionaliteit voorzien worden en door gebruik te maken van thema's kan een andere layout aan het cms worden gehangen. Zo is het mogelijk om met Drupal een nieuwssite, forum en/of een collaboratiesite te onderhouden. De ontwikkelaars hebben twee nieuwe versies de deur uitgedaan in de 6.x- en 5.x-branch, die een beveiligingslek dichten en een aantal kleine foutjes oplossen. De versienummers zijn aangekomen bij respectievelijk 6.3 en 5.8 en voorzien van de volgende aankondiging:

Drupal 6.3 and 5.8 released, fixing security issues

Drupal 6.3 and Drupal 5.8, maintenance releases fixing problems reported using the bug tracking system, as well as security vulnerabilities, are now available for download. Drupal 6.3 also includes some changes to the installer to prevent file ownership issues on shared hosts; upgrades jQuery to version 1.2.6; improves PostreSQL compatibility; fixes performance issues in search, menu and form API and contains a variety of other small improvements. It should also be noted that the Views for Drupal 6 release candidate requires Drupal 6.3 to run properly.

Upgrading your existing Drupal 5 and 6 sites is strongly recommended. There are no new features in these releases, but we fixed some notable performance issues too.

Changelog

The full list of changes between the 6.2 and 6.3 releases can be found by reading the 6.3 release notes. The full list of changes between the 5.7 and 5.8 releases can be found by reading the 5.8 release notes.

Security vulnerabilities

Drupal 6.3 and 5.8 were released in response to the discovery of security vulnerabilities. Details can be found in the official security advisory: SA-2008-044

To fix the security problems, you can either (1) upgrade Drupal or (2) patch Drupal. We recommend you do the full upgrade (which is also detailed in the security announcement) as the patches do not contain the additional bugfixes that went into the release. Applying the patches will leave your site in an unversioned state and confuse update status module, which will keep reminding you to upgrade to 6.3 or 5.8. Please read the announcement for details on the patches.

If you still prefer to patch Drupal, apply this file to your Drupal 6.2 code base or this file to your Drupal 5.7 codebase.

Important update notes

Although these releases contain no database changes, it is important to run update.php to refresh the menu cache and other caches on the website.
Moderatie-faq Wijzig weergave

Reacties


Er zijn nog geen reacties geplaatst

Op dit item kan niet meer gereageerd worden.



Apple iOS 10 Google Pixel Apple iPhone 7 Sony PlayStation VR AMD Radeon RX 480 4GB Battlefield 1 Google Android Nougat Watch Dogs 2

© 1998 - 2016 de Persgroep Online Services B.V. Tweakers vormt samen met o.a. Autotrack en Carsom.nl de Persgroep Online Services B.V. Hosting door True