Cookies op Tweakers

Tweakers maakt gebruik van cookies, onder andere om de website te analyseren, het gebruiksgemak te vergroten en advertenties te tonen. Door gebruik te maken van deze website, of door op 'Ga verder' te klikken, geef je toestemming voor het gebruik van cookies. Wil je meer informatie over cookies en hoe ze worden gebruikt, bekijk dan ons cookiebeleid.

Meer informatie

Door , , 24 reacties
Bron: Newsforge

CodeWeavers heeft bekend gemaakt dat ze na vier maanden testen een programma af heeft dat het mogelijk maakt om Windows-plugins te gebruiken onder Linux. Het programma, Crossover Plugin 1.0, kan ook gebruikt worden om documenten te bekijken die gemaakt zijn met Microsoft Office. Het installeren van de plugin schijnt makkelijk te gaan en het installeren van de plugins, zoals Quicktime en Flash, werkt net zoals in Windows:

Logo CodeWeaverThe first thing I installed after CrossOver was Apple's QuickTime program. The installer behaved much as it would on any Windows or Macintosh system, but I did chuckle over the QuickTime install program wanting to place its wares in C:/Program Files/QuickTime. I got an even bigger laugh when I discovered that the program would work just fine, even without changing the default destination!

[..] a few times I ran into a problems with Netscape not picking up file associations or recognizing the QuickTime plugin. Every time, entering a few bits of information in CrossOver's Association dialog frame solved the problem.

Het programma schijnt dus goed te werken. Volgens de schrijver op Newsforge draait de IPIX plugin (voor het bekijken van 360-graden afbeeldingen) zelfs beter onder Linux dan onder Windows. Het bekijken van documenten die gemaakt zijn met Microsoft Office kan gewoon gedaan worden door de officiŽle viewers van Microsoft te downloaden en te installeren. Het programma is niet gratis: De cd versie kost $29.95 en voor $19.95 mag je het downloaden.

Moderatie-faq Wijzig weergave

Reacties (24)

Uiteraard gaan ze niet in op het typische Linux/Unix probleem: met welke user-level moet je zo'n plug-in installeren?
Of is dat proggie zo snugger dat een willekeurige OCX zich vanzelf installeert in de $HOME dir? :?

Jammer alleen voor de Alpha, Sparc en PPC distributies - daarvoor zullen die plug-ins alsnog niet werken.
Goede vraag... eens even kijken...

Volgens http://crossover.codeweavers.com/html/html/userguide .html
1.2. Installing CrossOver Plugin
Installing CrossOver Plugin is a simple process.

Login as a normal user (NOT root). This version of CrossOver is intended to support a single end-user. As a consequence, the installation works best if installed by that user into a separate directory.
Wat wordt er precies verstaan onder "windows-plugins"? Programma's voor windows? plugin's voor IE?

Vaag verhaal dit, absoluut niet duidelijk....
De quote is misschien niet duidelijk maar als je even verder leest/ klikt zie je dat het met name gaat om netscape-style plugins. Niet de Acitvex-plugins die IE6 exclusief lijkt (? , ikzelf niet getest hebben) te ondersteunen.
Windows-plugins == browser-plugins die tot nog toe alleen onder Win* draaien.
Coole ontwikkeling dit, ben sterk geneigd die vijftig piek op tafel te leggen.
Jah, ik zou ook niet echt vies zijn om die 50,- te dokken hiervoor, alleen heb ik zo sterk mijn twijfels over de functionaliteit ;)

Ik vertrouw zowieso niet op commerciele software onder linux, omdat deze vaak voor specifieke libraries zijn gecompileerd, waar mijn systeem van af kan wijken. En ik heb nou net geen zin om verplicht Red Hat oid te gaan draaien.... Goed, ik zou waarschijnlijk de juiste versie van die bepaalde librarie(s) er naast kunnen installeren, maar dat kost weer zoveel schijfruimte......... bah
Met windows plugins worden vooral plugins voor internet explorer bedoelt voor flash, quicktime .... Daarnaast vallen enkele bestandsviewer plugins er ook onder. Crossover is gebasseerd op wine. Mozilla , Netscape en alle andere browsers voor linux moeten deze plugins d.m.v Crossover kunnen gebruiken. Crossover dient als een soort brug.

Er is ook een alternatief voor Crossover welke gratis is. Een aantal kde programmeurs hebben eenzelfde systeem gemaakt voor konqueror. Dit kan alleen activex plugins (.ocx) gebruiken.
Gewoon viewers. Bijvoorbeeld voor Word, Excel, Flash, QuickTime, etc... Een soort van embedded component zeg maar.
Jammer van het niet gratis zijn, maar daar gaat het toch een beetje naartoe. Bedrijven zien gewoon dat je omzet moet halen.
Verder een leuke ontwikkeling. Linux wordt daardoor steeds interressanter, niet alleen voor thuisgebruikers, maar zeker voor bedrijven met grote aantallen werkstations.
woepsie, dit was dus een reply op real[b]art

zolang men voor desktop features windows functionaliteit moet emuleren zal linux nooit doorstoten op dat gebied.

Dit programma is een stap in de goeie richting maar totdat in het mainstream nieuws verhalen verschijnen over proggies die op windows linux zaken emuleren moet je er niet op hopen.
Linux moet wel emuleren zolang de originele auteurs om diverse redenen weigeren een native oplossing te maken
Ja maar wat nou als jij een plugin voor Windows had gemaakt, en iemand maakt een emulator om datzelfde programma op Linux te draaien, dan ben jij toch blij? Weer een probleem opgelost. Waarom zou je dan nog een aparte versie voor Linux maken, als ie daar toch al op draait?
Zie het meer dat men een brug moet slaan om iedereen over te halen naar linux, zodra de mensen het commercieel gaan gebruiken en windows niet meer nodig hebben blazen ze deze brug op.
Wie weet wordt Linux nog eens een serieuze concurrent voor Micro$oft, en dan bedoel ik niet de doorsnee gebruiker, maar meer de mensen die wat hogere eisen aan hun OS stellen wat betreft o.a. stabiliteit en toch ook wat functionaliteit willen hebben :)
Als je een plugin voor Windoos onder Linux installeert, wordt dan je linuxbak niet instabieler door de Windoos-factor?
Ik geloof niet dat die software invloed heeft op de kernel op zich. Als WINE crasht, ja jammer dan, killen en niet meer naar omkijken. Maar de rest draait gewoon gezellig verder :)
Waarom de bovenstaande posting als Troll bestempeld word weet ik niet, het is een legitieme vragen van een onwetend persoon ;)

De 'instabiliteit' van een operating systeem zou niet mogen beinvloed worden door een applicatie. Als een applicatie zich misdraagt, dan is het aan het operating systeem om de des betreffende applicatie op zijn vingers te tikken, dan wel af te schieten.

Dat dit onder Linux vaak wat beter gebeurt dan onder Windows 98, tja.. ;) (NT/2K doen het al stukken beter)
De software is geenszins verbonden met het Windows OS, maakt gebruik van eigen algoritmen en constructies en zal dus nooit op dezelfde manier crashen als de Windows-plugin (die inderdaad wel Windows met zich meetrekt, maar bij Linux is dit onmogelijk).

Het ergste wat kan gebeuren is dat de applicatie die gebruikmaakt van de plugin crasht, maar daar houdt het dan verder mee op.
Tja, omdat de plugin-maker nu eenmaal voor win32 programma's schrijven (flash/realplayer/pdf) e.d werken btw gewoon), heeft dus niet met zelf schrijven te maken...tis namelijk nog steeds verboden commerciele software te reverse engineren en naar een ander platform te porten zonder de toestemming van de eigenaar (hoewel jouw opemerking suggereert dat jij daar anders over denkt)

Apple maakt bijvoorbeeld geen quicktime spul voor linux en dat kun je ook niet zo ff schrijven
Als de plugin makers als Quicktime dat niet doen, zullen ze daar wel een reden voor hebben.
Ik heb het ook niet over reverse engineering.

En ik kan me niet aan de indruk ontrekken dat de linux community niet vies is van wat reverse engineering om windows appz te porten naar linux
Je kunt programma's helemaal niet reverse engineren. Met bestanden kan dat wel. Kijk word is een gesloten formaat. Alleen Microsoft spullen geven de handel correct weer. Als die specificaties niet open zijn houdt het op. Dan kun je wel blaten dat ze zelf iets moeten schrijven, maar dat KUNNEN ze niet. Of dacht je soms dat ze daar te lui voor waren? Ze kunnen wel filters maken enzo, maar die gaan nooit zo goed werken. Zelfde geldt voor Flash, is ook een gesloten formaat, zelfde geldt voor QuickTime en noem het allemaal maar op. Daarom ben ik zo voor open standaarden, zodat je ook echt kunt kiezen wat je het beste vind en niet wordt gedwongen door bepaalde softwarebakkers om bepaalde software te gebruiken.
Als je deze software wilt draaien, heb je Windows wel nodig.
Voor mensen met hogere eisen is het denk ik al een serieuze concurent. Ik draai zelf alles onder linux (behalve games, maar die speel ik zelden).
Enige nadeel is dat je wat moet weten van linux, maar dat is eigenlijk net zo makkelijk als leren omgaan met dos en windows.
Als het aan mij ligt draai ik niets anders meer.
Linux is voor mij ideaal, maar oke, niet voor idereen.
Hangt gewoon er van af waar je je pc voor gebruikt.
Zo'n plugin heb je weinig aan, ik kan flash al zien, de rest neem ik voor lief dat ik dat niet kan zien.
Heb toch al een hekel aan al die websites die zogenaamd modern zijn met de nieuwe techniekjes.
Geef mij maar gewoon een plain html of php site, werkt tenminste altijd.

* 786562 pOZOR
[mod me down], reactie op verkeerde plek in thread.

Op dit item kan niet meer gereageerd worden.



Apple iOS 10 Google Pixel Apple iPhone 7 Sony PlayStation VR AMD Radeon RX 480 4GB Battlefield 1 Google Android Nougat Watch Dogs 2

© 1998 - 2016 de Persgroep Online Services B.V. Tweakers vormt samen met o.a. Autotrack en Carsom.nl de Persgroep Online Services B.V. Hosting door True