Cookies op Tweakers

Tweakers maakt gebruik van cookies, onder andere om de website te analyseren, het gebruiksgemak te vergroten en advertenties te tonen. Door gebruik te maken van deze website, of door op 'Ga verder' te klikken, geef je toestemming voor het gebruik van cookies. Wil je meer informatie over cookies en hoe ze worden gebruikt, bekijk dan ons cookiebeleid.

Meer informatie

Door , , 54 reacties

Amazon waarschuwt gebruikers van oudere Kindle-e-readers dat ze hun apparaat voor 22 maart moeten bijwerken naar een nieuwe softwareversie. Voeren ze de kritieke software-update niet door dan verliezen de e-readers hun internetverbinding.

Amazon Kindle 3GDe kritieke softwareupdate, waarvan Amazon de details niet bekendmaakt, geldt voor alle Kindle-readers van voor 2013. In de praktijk betekent dit dat alle Kindle-readers tot en met de vijfde generatie bijgewerkt moet worden naar de laatste softwareversie, evenals de Kindle Touch van de vierde generatie en de Kindle Paperwhite van de vijfde generatie. Alle Kindle-varianten van de zevende generatie en de Paperwhite van de zesde generatie hebben geen update nodig.

Wie zijn e-reader niet bijwerkt voor 22 maart krijgt de melding te zien dat het apparaat niet meer met internet verbonden kan worden. Ze kunnen vervolgens alleen nog handmatig de update doorvoeren. Amazon meldt op zijn site welke softwareversies de Kindles minimaal moeten draaien om de verbinding niet te verliezen en ook verduidelijkt het bedrijf de stappen die gebruikers moeten doorlopen om hun apparaten bij te werken.

Moderatie-faq Wijzig weergave

Reacties (54)

Wow what?

Dus een update niet installeren zorgt ervoor dat je geen verbinding meer kunt maken met het internet? Hoe zit dat dan in elkaar? Is er bij een vorige update een timer ingesteld ofzo?
Of een proxy aan de kant van Amazon...
Dat zou me niet eens verbazen. Was altijd verbaast hoe de oude kindles redelijk netjes een pagina konden weergeven, maar er zal waarschijnlijk een soort van opera mini-achtige constructie zitten waarbij de pagina's kleiner worden gemaakt.

Als het adres van Amazon zelf was geweest zouden het kunnen aanpassen en een andere server aan koppelen, maar misschien werd het door een externe partij uitgevoerd.

Ondanks de botte boodschap lijkt me dat het verhaal er achter te complex is voor de gemiddelde gebruiker.
Je kan het eigelijk vergelijken met wat ik nu doe op mijn telefoon.
Ik gebruik een VPN die naar huis gaat. Thuis wordt de pagina opgehaald, reclame eruit gesloopt, en dan teruggestuurd naar mijn telefoon, zonder reclame. Niet persé om de reclame, maar ook om de bandbreedte.
Dit doet Amazon ook. Jouw apparaat maakt helemaal niet direct verbinding met een website ofzo, maar gaat naar Amazon toe (als DNS), die haalt de pagina op, en stuurt deze (aangepast) door naar je Kindle.

Dus als Amazon zegt: “Vanaf nu worden alleen website aanvragen behandeld komend vanaf een Kindle tenminste veiligheid patch XYZ.” dan wordt jouw aanvraag gewoon niet behandeld als jij die patch niet hebt.
Puur uit intresse, wat gebruik je thuis op je server om dit mogelijk te maken?
Wil al een tijdje een VPN naar huis maken maar wist niet dat dit ook mogelijk was.

Tutorials kan ik zelf wel vinden moet alleen even de namen hebben van de software :)
Als je een Linux bak hebt, of zelfs een Raspberry Pi zijn hier veel tutorials voor te vinden I.c.m openvpn of zoek bijvoorbeeld eens op pi-hole (voor een complete handleiding voor de Raspberry pi incl. server-side adblocker.)

Via de VPN benader ik dan ook de lokale ip-adressen omdat ik vanuit de router alles van buiten af heb dicht getimmert.
Bedankt! Hier zou me ik wel mee moeten redden :)
dus een perfect onderwerp om op tweakers juist wel op in te gaan. :Y)
Die hadden ze wel een paar werken langer live kunnen houden. Dit lijkt meer op een "oh f+ck" reactie omdat ze er net achter komen dat er, inderdaad, een certificaat gaat verlopen.
Dit vroeg ik mij dus ook af. Kan het begrijpen dat je wilt dat je gebruikers op de laatste versie zitten, maar dit is wel erg kort dag.
Idd, als ik dit bericht niet had gelezen had ik geen internet meer gehad op mijn Kindle3. Slecht.

Edit: Huh, ik zit al op 3.4.2 op mijn Kindle keyboard. Ik zet hem net voor het eerst aan in weken... Vreemd, dit gaat dus helemaal niet op een nieuwe update.

[Reactie gewijzigd door teek2 op 21 maart 2016 09:20]

Niet helemaal... ik heb zo'n oude Kindle en ik heb tenminste twee keer een reminder e-mail gehad dat ik moest updaten. Ik heb dat zelf niet gedaan omdat het 1) altijd weer gepruts is en 2) ik me (toen) niet kon voorstellen wat op dat moment prima werkt dan ineens niet meer zou werken.

Overigens, als het wegvallen van de internet verbinding het enige echte probleem is dan laat ik die upgrade wel zitten. Internet toegang op je Kindle (is een heel oude) was toch al geen feest... ;)
Mja, internet is wel handig voor de Amazon store, de updates gingen bij mij altijd vlekkeloos, en 1 keer kreeg je zelfs een veel beter leesbaar font.
ik snap je reactie niet zo. Amazon stuur zeeer tijdig mails uit.
Nee, Amazon stuurt hierover helemaal geen mails uit (naar mij)
lijkt me sterk.
Ik kreeg bericht op 9maart EN op 19februari
Nou, ik dus niet...
"Wie zijn e-reader niet bijwerkt voor 22 maart krijgt de melding te zien dat het apparaat niet meer met internet verbonden kan worden. Ze kunnen vervolgens alleen nog handmatig de update doorvoeren. "
Dus zo paniekerig moeten we er allemaal niet over doen. Als we de deadline missen, dan kunnen we gewoon via de kabel de update uitvoeren.
Alleen snappen veel gebruikers waarschijnlijk niet hoe dat werkt. Mijn gok is dan ook dat er vanaf morgen héél veel gebruikers opeens zonder internet op hun Kindle zitten en dat ze geen flauw idee hebben hoe het komt en hoe ze op kunnen lossen.
Ja, vooral ook omdat ik nog géén mail gekregen heb van Amazon, en dit bericht het eerste is dat ik ervan hoor. Maar als er een probleem is met een toestel, is het eerste wat je doet toch info gaan opzoeken?
Dan neemt men als eerste contact op met Amazon, die heeft vast wel een vooraf opgezet e-mail template klaar liggen die je dan vrij vlot terug krijgt met een beknopte stappenplan met download link etc. voor op de computer.
Klein gokje...

verlopen van het certificaat ?
Zoiets idd. Of de TLS library moet geupdate worden omdat er een probleem in een oudere versie zit en ze voeren een strengere eis voor verbinden met de server in. Aangezien ze het zo gehaast en serieus aanpakken lijkt het me in ieder geval een beveiligingskwestie.
Dat was ook mijn gevoel. Ik ben oprecht wel geïnteresseerd wat er in die update zit.

Voor alle mensen die denken dat het een CA update is: ja, dat kan wel zo zijn, maar waarom zou dat invloed hebben op het opzetten van je internetverbinding? Op zich maakt de datum niet zo veel uit daarvoor.

--update--

Een verlopen certificaat suggereert dat de kindle bij het verbinden meteen contact via HTTPS maakt ergens mee en dat dat cert is verlopen. Allemaal geen dingen die ik vind dat een kindle zouden moeten doen als onderdeel van "het opzetten van een internetaansluiting". Linksom of rechtsom, dat lijkt wel het geval te zijn:
Amazon is upgrading their security certificates, which changes the way the Kindle communicates with the Amazon server. You will have to connect to the internet and automatically download the latest patch by March 22, or you will be cut off.
Bron: http://webcache.googleuse...lse&num=1&strip=1&vwsrc=0

[Reactie gewijzigd door atlaste op 21 maart 2016 09:38]

Ik denk dat al het internetverkeer van de Kindle via de Amazon servers verloopt. Een soort proxy dus. Die verbinding kan prima standaard over TLS looen.
Gelukkig kan je als gebruiker nog een handmatige update doen. Neemt niet weg dat Amazon wel erg laat is met het informeren van de gebruikers...
Ik ben hier al eerder via de email door Amazon op gewezen. Het is dus niet zo dat ze pas vandaag hun klanten zijn gaan informeren.
Gelukkig maar, het nieuwsbericht geeft een iets ander beeld dan wat dus de werkelijkheid is :)
achja, media...........
Ik ben privé gebruiker van een van die Kindles. Amazon heeft mij niets laten weten. Omdat mijn Kindle elke verbinding met een pc weigert (gelukkig laadt hij nog op), ben ik blij met dit bericht. Zonder internet had ik geen nieuwe boeken meer kunnen lezen.

Het is dus zo dat Amazon in elk geval niet elke gebruiker heeft ingelicht. Nu kun je zuur lopen doen over 'media', maar dit bericht zal sommigen zoals ik echt helpen. Dat is toch ook wat waard :)
Idem dito.

Geen melding per mail of op mijn Kindle gezien.
Nu moet ik toch snel eens even gaan kijken want ik weet niet precies meer van welke generatie mijn kindle is.
Yep, klopt hier ook een gevalletje van toevallig dit bericht lezen en dadelijk maar eens afstoffen.
Valt op zich mee hoor - ik had die notificatie vorige maand al ergens gehad, net als de update en wat nieuwe features. Het nieuwsbericht hier voelt voor mij ook een beetje als mosterd na de maaltijd :p
Ik heb zelf op 9 maart een mail gehad.
dat vind ik dus laat. Erg laat. Zo'n ding kan een maand ofzo zonder opladen. Neem je hem mee op een grote reis, kom je terug, is je internet weg want je had moeten updaten. WTF?
Ik heb die mail 2 weken geleden gekregen (9 maart)
Het is niet zo dramatisch want updaten gaat nog steeds vlotter met je usb kabel.
Bij mij kwam de update OTA niet deftig binnen. Firmware downloaden, usb kabel derop en 10 minuuten later was alles ok met mijn paperwhite.

Het probleem dat ze hebben is dat veel mensen met de 3G verrsie hun Wifi nooit aanzetten om batterij te besparen en dat de meeste mensen nooit in hun settings menu komen en er geen update notificatie zit in de kindle software.
Dat is wel een vreemde redenering.
Mijn ervaring met de meeste telefoons die ik gehad heb is dat WiFi een pak zuiniger is dan 3G.
Het standby-verbruik van wifi is laag genoeg zodat het altijd laten aanstaan netto een stuk meer oplevert. (Een paar minuten vergeten om manueel wifi aan te zetten als het beschikbaar is, of het scherm laten aan staan om de wifi aan te gaan zetten verbruikt vermoed ik meer dan wifi gewoon aan laten staan en automatisch laten verbinden indien beschikbaar)
Nee bij mij staat alles af en aangezien de 3G gratis is en ik meestal "on the roaad" ben als ik een boek wil kopen, zet ik gouw mijn 3G even aan. aangezen typen niet zo een leuke ervaring is op de kindle's.
Mensen die 95% van de tijd wifi access hebben investeren niet in de 3G versie.

Mijn collega hier zegt hetzelfde. wifii komt bijjna nooit aan want authen op corporate of landing page wifi's lukt vaak niet.
Hangt ook van je gebruikspatroon af lijkt me. Als je veel heen en weer reist op een dag en je telefoon dan wanhopig met iedere ziggo, NS, arriva en qbuzz hotspot die ie tegenkomt probeert te verbinden kost dat toch al gauw meer stroom dan de (redelijk stabiele) 3g verbinding, lijkt mij.
Als ik het goed heb wordt er een aankondiging/brief in je kindle gezet over nieuwe updates/features. Weet alleen niet of dat alleen is voor al geïnstalleerde.
Nog nooit gezien op mijn first gen paperwhite
Ik had dit dus met mijn Paperwhite van 2013 of 2014...
Ik probeerde direct mijn Kindle 3 up te daten. Helaas kan ik geen verbinding met het Wifi netwerk meer maken. Ik heb drie wifi netwerken geprobeerd. Helaas krijg ik de melding dat er geen verbinding gemaakt kan worden na het invoeren van het wachtwoord. Iemand anders dezelfde problemen?
Mijn vrouw heeft dezelfde en ik heb gisteren dus ook proberen te updaten. Ik had precies het probleem wat jij hier ook beschrijft. Uiteindelijk na 2x "rescan" en een ander netwerk selecteren (heb er diverse tot mijn beschikking hier) lukte het wel.
Updaten is echter niet gelukt, helaas. Ik doe het wel een keer handmatig, zo vaak zit ze ook weer niet in de Kindle Store. Meeste doen we via Calibre.
Ik heb dezelfde melding gehad inderdaad. Ik heb mijn 2e generatie Kindle opgezocht en de update installeerde na een tijdje vanzelf. Mijn versie heeft een sim kaart erin trouwens en haalt via 3G zijn data binnen. Ideaal, omdat dit ook in het buitenland werkt. Boek bestellen kan je overl ter wereld doen en binnen een minuut staat hij op je kindle. tegenwoordig niet heel bijzonder, ik weet het, maar toen ik hem kocht was dit nog best speciaal.
Hierover heb ik 2 e-mails ontvangen, één in febuari en één in maart.

Fri 19-Feb-16 17:05
Your Kindle (5th Generation) requires an important software update to continue downloading e-books and using Kindle services.
Ik raad bezitters van een Kindle aan even op Amazon te kijken welke versie ze moeten hebben en welke ze al hebben. Ik keek n.a.v. dit bericht of er een update binnen kwam, maar er gebeurde niets. Wat bleek? Ik had de laatste softwareversie al en ik denk dat ik die al 1-2 jaar geleden had geïnstalleerd (ik heb een Kindle 3). Dat verklaart waarschijnlijk ook waarom ik geen e-mail heb ontvangen.

[Reactie gewijzigd door pimjoosten op 21 maart 2016 09:34]

Geen mail gehad, wel 3 Kindles in huis, niet zo netjes van Amazon.
Ik vind het erg jammer dat Amazon dit doet. De oudere firmware was naar mijn mening beter, onder andere omdat je er een eigen lettertype op kon laden (zonder al te veel moeite). Dat kan in de nieuwe firmware helemaal niet meer.

Ook werkten de woordenboeken eerder met fallthrough, waardoor je een speciaal woordenboek kon laden met bijvoorbeeld uitleg over personages en als het woord dat je selecteerde daar niet in werd gevonden ging ie pas naar het Engelse woordenboek. Nu wordt de wikipedia tab geladen, ook als je de wifi uit hebt staan.

Maar ja het snel kunnen laden van boeken uit de amazon store is wel fijn dus ik heb maar geüpdatet...
Ik gebruik sowieso Duokan en niet de standaard Amazon software dus ik weet niet hoe druk ik me moet maken hierover. Heb trouwens ook geen email gehad van Amazon.

Edit: Blijkbaar draai ik al de laatste versie op mijn Kindle 3. Dat scheelt weer.

[Reactie gewijzigd door Mitch377 op 21 maart 2016 10:29]

Op dit item kan niet meer gereageerd worden.



Apple iOS 10 Google Pixel Apple iPhone 7 Sony PlayStation VR AMD Radeon RX 480 4GB Battlefield 1 Google Android Nougat Watch Dogs 2

© 1998 - 2016 de Persgroep Online Services B.V. Tweakers vormt samen met o.a. Autotrack en Carsom.nl de Persgroep Online Services B.V. Hosting door True