Cookies op Tweakers

Tweakers maakt gebruik van cookies, onder andere om de website te analyseren, het gebruiksgemak te vergroten en advertenties te tonen. Door gebruik te maken van deze website, of door op 'Ga verder' te klikken, geef je toestemming voor het gebruik van cookies. Wil je meer informatie over cookies en hoe ze worden gebruikt, bekijk dan ons cookiebeleid.

Meer informatie

Door , , 5 reacties
Bron: PostgreSQL

PostgreSQL is een open source relational database management system dat op diverse besturingssystemen gedraaid kan worden. De ontwikkelaars hebben weer een reeks nieuwe versies uitgebracht met 8.3.6, 8.2.12, 8.1.16, 8.0.20 en 7.4.24 als versienummers. Hiermee worden verschillende fouten opgelost en aangezien één daarvan dataverlies zouden kunnen veroorzaken, wordt iedereen aangeraden om te updaten. De aankondiging van deze versies ziet er als volgt uit:

PostgreSQL 2009-02-06 Update Releases Available Now

The PostgreSQL Project today released updates to all active branches of the PostgreSQL object-relational database system, including versions 8.3.6, 8.2.12, 8.1.16, 8.0.20 and 7.4.24. These updates include two serious fixes, for autovacuum crashes in version 8.1 and GiST indexing data loss in 8.3, and those two versions should be updated as soon as possible.

These update releases also include patches for several low-risk security holes, as well as up to 17 other minor fixes, depending on your major version of PostgreSQL. Included as well are Daylight Savings Time changes for Nepal, Switzerland and Cuba. See the release notes for full details.

The first serious issue affects users who are using version 8.1 with Autovacuum, which will fail when XID rollover is required. The second serious issue can cause data loss when CLUSTER is used with GiST indexes (such as full text indexes) on version 8.3. Both issues are fixed in these releases.

As with other minor releases, users are not required to dump and reload their database in order to apply this update release; you can simply shut down PostgreSQL and update its binaries. Users skipping more than one update should check the release notes for extra, post-update steps. As previously announced, only versions 8.2.12 and 8.3.6 of the Windows binaries are being released, as we no longer support 8.0 and 8.1 on Windows. Please note: if you downloaded a copy of the 8.3.6 source code, or Windows build 8.3.6-1, from www.postgresql.org before February 4th, you may have received a copy which contains a bug. Please replace it with today's download.
Moderatie-faq Wijzig weergave

Reacties (5)

Waarom onderhouden ze 5 branches (tegelijkertijd)?
Omdat dit een best ernstige bug fixt. Want als je kijkt naar de vorige updates in de meuktracker, zie je dat alleen 8.2 en / of 8.3 bijgewerkt werd.
Omdat database software stabiel moet zijn en je als beheerder niet zomaar naar een nieuwe versie wilt. Wie weet wat je dan op je hals haalt. Met een bugfix release is de zekerheid vrij groot dat je niet tegen andere problemen aan gaat lopen.
Waarom onderhield PHP zowel php4 als php5?
Waarom onderhoud Microsoft zowel XP als Vista
Dat is omdat er verschil zit tussen de versies en het niet altijd handig is om meteen te migreren/updaten. Maar sommige wijzigingen moeten eigenlijk overal toegepast worden.

Was een reactie op CyberSnoop

[Reactie gewijzigd door TJVB op 7 februari 2009 17:37]

Op dit item kan niet meer gereageerd worden.



Apple iOS 10 Google Pixel Apple iPhone 7 Sony PlayStation VR AMD Radeon RX 480 4GB Battlefield 1 Google Android Nougat Watch Dogs 2

© 1998 - 2016 de Persgroep Online Services B.V. Tweakers vormt samen met o.a. Autotrack en Carsom.nl de Persgroep Online Services B.V. Hosting door True