Cookies op Tweakers

Tweakers maakt gebruik van cookies, onder andere om de website te analyseren, het gebruiksgemak te vergroten en advertenties te tonen. Door gebruik te maken van deze website, of door op 'Ga verder' te klikken, geef je toestemming voor het gebruik van cookies. Wil je meer informatie over cookies en hoe ze worden gebruikt, bekijk dan ons cookiebeleid.

Meer informatie

Door , , 35 reacties
Bron: VideoLAN, submitter: begintmeta

VLC Media Player is een opensource- en crossplatformmediaspeler die diverse audio-, video- en streamingformaten kan afspelen zonder dat hiervoor de betreffende codec hoeft te worden geïnstalleerd. Versie 0.9.5 is sinds kort voor Linux en Mac OS X beschikbaar, maar voorlopig nog niet voor Windows vanwege het ontbreken van een ontwikkelaar voor dit platform. Deze versie verhelpt een aantal bugs uit de vorige versie en is voorzien van de volgende aankondiging en lijst met veranderingen:

VLC media player 0.9.5

The VideoLAN team is pleased to announce the release of VLC media player 0.9.5. This is a bugfix release. VLC media player 0.9.4 and earlier versions suffer from security vulnerability in TiVo demuxer. More technical details are available in our advisory (CVE-2008-4654, CVE-2008-4686). Also, libpng was updated in Windows and MacOS builds to fix its security issue (CVE-2008-3964).

This release also improves media keys support under Windows, file access under all OSes, Qt interface usability as well as fixing few more other bugs. Full list of changes can be found here. We strongly recommend all users to update to this new version. Binary packages for Mac OS X and source code tarballs are available for download. Windows binaries might arrive at a later time.

Help is available, as usual, in many places:We'd like to thank all our contributors, testers and users around the world for their support and help making this release possible.

Changes between 0.9.4 and 0.9.5:

Security updates:
  • Fixed buffer overflow in TiVo demuxer (SA-0809, CVE-2008-4686, CVE-2008-4654)
  • Fixed libpng CVE-2008-3964 in Win32 and MacOS builds
Features:
  • Closed Caption EIA 608/708 parsing enabled for libmpeg2
Various bugfixes:
  • Fixed various potential crashes and memleaks
  • Fixed issues with reading from files (especially non-local)
Windows port:
  • Fix bug where interface was "eating" some media keys
  • Fix some crashes in DirectShow access
Qt Interface:
  • Fix bug when the resetting of preferences didn't reset the dialog states
  • Right-click menu to select playlist columns reenabled
  • Various fixed in playlist
Access:
  • MMAP module is now deactivated by default
Translations:
  • Update of Brazillian, Swedish translation
End of support for VLC 0.8.6 series

The VideoLAN team ceases all form of support for VLC media player the 0.8.6-bugfix tree. Due to lack of interest from the developpers community, source code maintenance efforts for the VLC media player 0.8.6-bugfix branch will be stopped. This is effective immediately; there will be no more security and critical fixes for VLC 0.8.6. Binary releases of the 0.8.6-bugfix branch had already stopped as of July 2008. The VideoLAN team will continue to provide major or security-related bug fixes for the VLC media player 0.9-bugfix branch. If you have not already upgraded to VLC version 0.9.5, please do so now.
Moderatie-faq Wijzig weergave

Reacties (35)

Nu nog hopen dat er ooit een VLC uit komt met een GTK+ interface, dan kunnen ze bijna alle grote desktop omgevingen (Xfce, Gnome, KDE) native ondersteunen...

Tot die tijd voor mij ff geen VLC meer...
Volgens mij draait VLC op Linux nu met wxWidgets, wat volgens mij een GTK2 interface heeft.

Ook snap ik niet helemaal wat je bedoeld met "dan kunnen bijna alle grote desktop omgevingen native ondersteunen". Of het nou wxWidgets, GTK+, GTK2, Qt, KDE, Tk, Motif, X11 of Gnome is, het draait toch ook wel met andere desktop omgevingen?

Edit: verwoording aangepast

Edit: @Lapino887:
Ah ik liep dus een versie achter met mijn aanname van wxWidgets. Persoonlijk maakt het mij nooit een zak uit welke UI toolkit er gebruikt wordt, zelfs op Windows (waar je 'Win32' hebt) lopen de UI's van applicaties ver uit elkaar, zelfs bij apps van Microsoft zelf (zie de hele Office reeks). Ik denk dat het gewenning is voor mij. :-P Maar ik kan me ook voorstellen dat anderen dat lastig vinden ja.

[Reactie gewijzigd door 84969 op 28 oktober 2008 11:21]

De 0.8.x branch was inderdaad gebaseerd op wxWidgets, maar vanaf de 0.9.x release is men overgeschakeld op Qt 4. Dit draait inderdaad perfect onder bv. Gnome, maar de applicatie kan een beetje "out of place" lijken wegens de "andere" interface. Voor Qt 4 applicaties (zoals vlc) kan dit echter opgelost worden door QGtkStyle te installeren, dat qt applicaties er bijna perfect hetzelfde laat uitzien als de Gtk-apps.
Dat is handig voor de integratie met je desktop.

Verder denk ik niet dat er snel een GTK interface zal komen omdat net naar Qt zijn gestapt.

Maar ik was wel even nieuwsgierig, dus even gegoogled en kwam ik op dit uit: http://wiki.videolan.org/Qt_and_GTK
Dus QGtkStyle gebruiken of de oude interface compilen.
Als je windows gewend bent maakt het je misschien niks uit, aangezien ze er op windows inderdaad een potje van maken (onder leiding van MS). Als je echter al jaren linux gebruikt en een consistente desktop gewend bent is het erg vervelend als er ineens een applicatie tussen zit die niet bij de rest aan sluit. Denk dat we op linux wat meer verwend zijn met beter UI design :+

Verder ben ik nu door het hele VLC verhaal er alleen maar op vooruit gegaan, want omdat ik de wxWidgets interface niet meer kon vinden was ik gaan googlen en heb nu QGtkStyle geinstalleerd. Nu zien die paar Qt applicaties die ik had er ook GTK-achtig uit :) Als ze nou ook nog GTK icons gaan forceren in die Qt engine hoor je mij niet meer klagen.
De enige vreemde eend in de bijt is Skype, die zich om een of andere reden geen ruk van mijn Qt style aan trekt. |:(
Wat mij betreft de beste mediaplayer.
Ondersteunt veel bestandsformaten/codecs en gebruik weinig CPU.

Eerder was ik altijd groot WMP-fan, maar sinds een halfjaartje is VLC écht mijn favoriet :D
WMP of Window Media Player Classic? Anders ben jij de eerste WMP fan die ik ben tegengekomen.
Window Media Player Classic bestaat volgens mij niet

Windows Media Player of Media Player Classic zal je waarschijnlijk bedoelen
WMP of Window Media Player Classic? Anders ben jij de eerste WMP fan die ik ben tegengekomen.
Het heet media player classic, niet window media player classic.
Afgekort ook wel MPC genoemd.
Dus ja, ik denk dat hij WMP fan was. Overigens zijn dat er wel meerdere. Met name jan met de pet kent niks anders dan windows media player.
Wel apart dat alle bugfix releases nu een hoger versienummer krijgen terwijl eerst het halve alfabet aan het bestaande versienummer werd toegevoegd.
Njah mijn versienummering verandert ook telkens weer met nieuw project, wordt steeds logischer. En VLC is zo'n lang project dat je tijdens het ontwikkelen nog wel van stijl kan veranderen, bovendien zitten ze nog niet op 1 ;)
Laatst geprobeerd, maar voorlopig blijf ik nog bij 0.8.6.

Skippen door WMV files ging niet, dan crashte hij.
Onhandige overlay die elke keer opspringt in full screen.
Langzamere display van HD materiaal.

0.8.6 doet het hier nog prima :)

[Reactie gewijzigd door dxta op 28 oktober 2008 00:33]

De 0.8.6 tree gaf bij mij problemen met Quicktime MJPEG. Mijn Panasonic TZ1 schiet filmpjes in dit formaat, dus voor mij geen 0.8.x meer.
VLC blijft bij mij frames droppen met HD-content, terwijl MPC wel vloeiend afspeelt. Ben er nog altijd niet achter waar dit door komt... :|
MPC + codecpack gebruikt andere codec die gebruik kan maken van hardwarematige decoding bij het afspelen van HD content. Dit is echter een betaalde codec, dus deze kan VLC natuurlijk niet meeleveren. Het is wachten tot FFMPEG gebruik kan maken van hardwarematige decoding.
Hoe kom je erbij dat het een betaalde codec is??? In MPC-HC zit gewoon DXVA ondersteuning voor h264. Niks betaald aan. Codec packs gebruiken soms wel codecs die eigenlijk betaald moeten worden, maar die heb je niet per sé nodig.

Hardware ondersteuning in ffmpeg zal nog wel even duren, zolang dit op *nix nog niet tot nauwelijks mogelijk is.
Mwah, hij verwart het waarschijnlijk met CoreAVC die ook ooit hardware support krijgt xD.

[Reactie gewijzigd door SoundWave729 op 30 oktober 2008 20:27]

Misschien eens meuk: The Kmplayer 2.9.4.1433 gebruiken, als je daar de reactie's leest en ook die van vorige uitgaven dan kom je al snel tot de conclusie dat The KMplayer net dat ietsje meer heeft dan VLC, ook wat betreft CPU gebruik etc :)

[Reactie gewijzigd door KimG op 28 oktober 2008 07:39]

MPC heeft geen betaalde codec nodig voor het afspelen met hardware support hoor.
True, maar die is niet zo heel goed. De betaalde versie kan met dezelfde hardware veel beter beeld leveren. Ik probeerde Appleseed 2 1080p versie op mijn AMD X2 4800 af te spelen. Dat ging toch niet zo heel lekker met alleen MPC, totdat ik een betaalde decoder erop heb gezet. Toen ging alles als een zonnetje draaien.
Volgens de site van VideoLan, is de laatste versie 0.9.4.
Downloaden van 0.9.5 kan dus nog niet. Tenzij je een andere locatie hebt dan de standaard downloadsite van vlc. :?
Als je even leest in het begin van de meukpost:
Versie 0.9.5 is sinds kort voor Linux en Mac OS X beschikbaar, maar voorlopig nog niet voor Windows vanwege het ontbreken van een ontwikkelaar voor dit platform.
Best jammer gezien de securityfix in de changelog
Fixed libpng CVE-2008-3964 in Win32 and MacOS builds
:o over het hoofd gezien.

Dan nog maar even wachten op de Windows build.
Hopelijk wordt hij dan snel ge compiled, want anders moeten we nog langer wachten.

Wel raar trouwens dat niemand voor de windows versie wil gaan werken, dit is toch de meest gebruikte versie! En als ik zelf goed in was was ik zeker voor een programma als vlc gaan wezen werekn. 1 van de meeste bekende Progs en je staat ook nog eens goed op je CV
Ik vind VLC erg traag met hd materiaal, hierin doen zoomplayer en met name gomplayer het veel beter.
Ik vind de 0.9.x serie nog helemaal niets. In veel anime mkv-tjes laat hij gewoon geen subtitles zien en skippen in de stream (vooruit of achteruit) gebeurt met waanzinnig veel artifacts tot het punt dat het gruwlijk irritant wordt.

Totdat ze de engine weer op het niveau van 0.8.6 hebben blijft deze jongen mooi bij de oude versie...
Grote punt met heel de 0.9.x is eveneens ook de stabiliteit op Windows. Die is om te huilen. Ik snap eigenlijk ook niet dat 0.9.2 destijds op Windows gereleased is als final.
Ik vind dat onder windows wel meevallen. Enige is soms als ik een film pauzeer met 'spatie' dat de film dan ineens heel langzaam/vertraagd gaat afspelen :S
En wat ik irritant vind is dat het OSD bij een dualscreen-opstelling precies in het midden verspreid over de 2 schermen getoond wordt.
Misschien verschilt het per OS/CPU/etc, maar mijn grootste probleem is dat VLC vastloopt en crashed. Als ik een download preview (nog niet klaar met downloaden dus) loopt ie geheid vast. Alleen Taskmanager verlost hem dan uit zijn lijden. Eveneens crashed ie redelijk vaak als ik een .avi heb bekeken en VLC afsluit.
Met 0.8.x nooit problemen mee gehad.
Hèhèh, eindelijk: Fix some crashes in DirectShow access.
Hier had ik meerdere keren last van...., verder is ie wel goed, vind ik! ;)

Op dit item kan niet meer gereageerd worden.



Apple iOS 10 Google Pixel Apple iPhone 7 Sony PlayStation VR AMD Radeon RX 480 4GB Battlefield 1 Google Android Nougat Watch Dogs 2

© 1998 - 2016 de Persgroep Online Services B.V. Tweakers vormt samen met o.a. Autotrack en Carsom.nl de Persgroep Online Services B.V. Hosting door True