Cookies op Tweakers

Tweakers maakt gebruik van cookies, onder andere om de website te analyseren, het gebruiksgemak te vergroten en advertenties te tonen. Door gebruik te maken van deze website, of door op 'Ga verder' te klikken, geef je toestemming voor het gebruik van cookies. Wil je meer informatie over cookies en hoe ze worden gebruikt, bekijk dan ons cookiebeleid.

Meer informatie

Door , , 32 reacties
Bron: InfoWorld

Red Hat zal volgende maand tijdens een presentatie, die samen zal vallen met de Linuxworld Conference & Expo in Boston, versie 4 van Red Hat Enterprise Linux (RHEL) introduceren. Versie 3 van dit enterprisebesturingssysteem is door Red Hat in oktober 2003 geïntroduceerd. Red Hat Enterprise Linux 4 zal nieuwe versies bevatten van het overgrote deel van de meegeleverde software. De meest opmerkelijke software-update is echter de nieuwe kernelversie, namelijk 2.6. Verder is het I/O-subsysteem herschreven, wat als gevolg heeft dat RHEL4-servers aanmerkelijk sneller grote hoeveelheden data zullen kunnen verwerken; dit is voordelig voor bijvoorbeeld databases. Verder is de Logical Volume Manager naar versie 2 getild. Een van de verbeteringen aan LVM 2 is de betere integratie met het besturingssysteem. Verder is de limiet van 1TB op een bestandssysteem verwijderd en kan er nu enkele petabytes aan data in een bestandssysteem worden opgeslagen.

Red Hat logo (rood)Verder is er aan deze release van RHEL een groot aantal features uit SELinux toegevoegd. Ook is het apparaat- en energiebeheer verbeterd. De afgelopen maanden had Red Hat al features van de 2.6-kernel aan zijn producten toegevoegd. Desalniettemin is Red Hat Enterprise Linux 4 een belangrijke mijlpaal, voornamelijk vanwege het psychologische effect dat de volledige ondersteuning van de 2.6-kernel kan hebben op IT-managers en systeembeheerders. Red Hats grootste Linux-concurrent op enterprisegebied is Novell. Suse Enterprise Linux 9 is in augustus 2004 op de markt gekomen en had toen ook al ondersteuning voor de 2.6-kernel. Red Hat Enterprise Linux 4 zal op 14 februari gelanceerd worden, aldus een woordvoerder van Red Hats PR-bureau. Het bedrijf zelf wilde geen commentaar geven op de eventuele release, maar gaf wel toe dat er op de 14e een event gepland was.

Moderatie-faq Wijzig weergave

Reacties (32)

Voor onze mission critical servers gebruiken we nog steeds een 2.4 kernel. Inmiddels zijn we, juist door dit soort berichten, wel over een testopstelling na aan het denken met een 2.6 kernel.

Red Hat is toch een groot en redelijk toonaangevend bedrijf in de Linux-wereld. Dit soort acties van het bedrijf kunnen veel sysops, server bouwers, etc. ervan overtuigen om toch eens de overstap te maken naar een nieuwere kernel.
2.6 is veilig voor productie als Debian het als standaard kernel in stable zet :+
Sarge is nog niet gereleased hoor. :(
En de standaard kernel van Sarge is volgens mij nog steeds 2.4. :(
"nog steeds" ? :) de standaard voor woody is 2.2 :) je kunt 't wel installeren met 2.4 (bf2.4 flavor), maar default is 't 2.2 (op de multi-flavor install cd)
Vorige week de snapshot van Sarge geinstalleerd en ik kreeg standaard inderdaad kernel 2.4. Tijdens de installatie kreeg ik geen keus voor een andere versie.
Daarna kon ik uiteraard wel met apt-get de 2.6 er op zetten, maar standaard is dus 2.4 geinstalleerd.
@M_v_A (sorry als dat niet duidelijk was olaf :D)
heb je alle bootopties wel nagekeken?
Volgens mij is er echt wel een optie zodat je een 2.6 kernel bij sarge wel kan laden en installeren ;)
even alt-f?-en (met in plaats van ? het juiste getal :))
heb je alle bootopties wel nagekeken?
Ik had het over de default/standaard kernel, niet over alternatieve kernels.
Ja, Sarge kan met 2.6 geinstalleerd worden, nee, 2.6 is niet de default/standaard kernel.

> mxcreep

Ik had het over de default/standaard kernel, niet over alternatieve kernels.

Waarom dit niet 'netjes' met een menu kan snap ik ook niet.
rtfm, bij de bootprompt van de cd linux26 inkloppen en je installed een 2.6 kernel bij de sarge installer...
Sarge kun je ook gewoon installeren met een 2.6 kernel.
"nog steeds" ?
Ja, aangezien de 2.6 kernel zelf al een jaar geleden als stable is gereleased.
Roses are FF0000, Violets are 0000FF,
All of my base are belong to you!
And I'll love you even more,
if you use this gift: Red Hat 4!

Leuk rijmpje voor valentijnsdag :) (Dat is toch de 14e?)
(dank aan bash voor de 1e 2 regels.)
Maar dan wel over een maand pas ;)
De 2.6 kernel begint nu eindelijk een beetje stabiel te worden....
De 2.6.9 kernel bevat een hele belangrijke NFS-fix die in alle voorgaande 2.6 kernels aanwezig is.
Onder extreme omstandigheden kan de machine dan met een kernel panic de geest geven....
Bij ons draaide de testserver gemiddeld 1-2 weken voordat ie weer vastliep.
Overigens heeft SuSe de patch ge-backport naar hun 2.6.5-111 kernel...

Nu maar hopen dat alle grote problemen een beetje zijn opgelost...
Na bijna met alle distro's te hebben gewerkt, blijven er maar 2 over, SLES en RHEL. Echt gemaakt voor mission crticial gebruik.
Allebei gecertifieerd voor Oracle enz. enz.
Deze kun je ook commercieel inzetten.
Er zijn wel meer distributies commercieel te gebruiken. Als je echter eist dat de ondersteuning goed is en je een 24/7 servicecontract wilt zijn SLES en RLES misschien een betere keuze dan anderen.

Of dat zo is hangt af van de eisen die jij aan de server stelt, je ervaring en de tijd die je erin kunt stoppen. Meestal is dat laatste een reden een servicecontract te willen. Daarnaast speelt het budget natuurlijk ook een rol :)

Belangrijk bij deze distro is waarschijnlijk zoals hierboven al genoemd de ondersteuning van nieuwe features van de kernel. Ik ben benieuwd hoe toegankelijk zij ACL's gaan maken voor beheerders zonder ervaring met SElinux. ACL's zal een belangrijk deel kunnen uitmaken van de extra beveiliging van RLES.

Ik vraag me even af of RLES uitgaat van standaard kernels of zwaar gepatchte kernels met name op het gebied van security. SElinux (en LSM) is volgens sommige ontwikkelaars niet het meest complete pakket:
http://www.rsbac.org/documentation/lsm.php
Leveren ze net als met FC3 nog steeds MySQL 3 mee?
Ja waarschijnlijk wel. In Fedora Core 4 zit overigens Mysql 4 wél. Wil je dus Mysql 4 in RHEL 4 dan kan je (makkelijk) de rpm uit de FC4 tree halen.

Deze is momenteel te vinden in:
http://download.fedora.redhat.com/pub/fedora/linux/core/development/
Licentie problemen.
Hoe hebben andere distro\\\\\\\'s dat opgelost dan?
Niet. Red Hat/Fedora interpreteerde alles net iets strikter dan de andere distributies.

Hoewel MySQL 3 nog onder de LGPL viel, was MySQL 4 volledig GPL, en dat terwijl PHP een niet-GPL-compatibele licentie gebruikte. PHP kon dus theoretisch niet legaal gelinkt worden met MySQL. Nu is het probleem opgelost omdat er een uitzonderingsclausule voor php is opgenomen in de GPL-licentie van MySQL4.

http://news.com.com/2100-7344_3-5173014.html?part=rss&tag=feed&subj=ne ws
Uh, dit lijkt me GEEN goed idee! Unsupported software installeren op RHEL gaat gegarandeerd problemen opleveren!

Je krijgt namelijk allerlei problemen met PHP's MySQL support, je zal dan ook PHP moeten upgraden met alle problemen van dien! Begin er dus niet aan tenzij je *echt* weet waar je mee bezig bent!
PHP kon dus theoretisch niet legaal gelinkt worden met MySQL.
Dat kon prima, alleen wel met de MySQL 3 client library. Deze client library werkt echter goed samen met MySQL 4 server. Dus dat was geen reden om versie 4 van de server niet mee te leveren.
En is FC3 niet na maart uitgebracht?
Ja waarschijnlijk wel.
Waarom leveren ze bijna twee jaar nadat MySQL 4 zelf als stable is gereleased, nog 3 mee?
Reactie op Olaf:

Licentie problemen.
Licentie problemen.
Hoe hebben andere distro's dat opgelost dan?
Waarom levert Debian stable nog steeds GNOME-1.4 mee?
Bedoel je Woody? Woody wordt niet volgende maand gereleased, RHEL 4 wel.
O: Er was nog geen release van mysql met de nieuwe licentie om op tijd in FC3 opgenomen te worden. En het is ook een beetje wazig om op het allerlaatst nog een major versie upgrade te doen ;) FC4 gaat zowel PHP5 als MySQL4 bevatten.
Waarom levert Debian stable nog steeds GNOME-1.4 mee? :).

Omdat QA nou eenmaal tijd kost...
Ik snap sowieso niet wat systeembeheerders ervan weerhoudt up te graden naar 2.6.
Als het niet werkt kun je toch zo de 2.4 weer booten?

Nu moet ik wel zeggen dat de unixbeheerders bij ons nooit kernels patchen, er draaien bakken nog op Redhat9 bijv. met een megaoude kernel.

Laat staan dat ze er eentje van source zelf gaan compilen.

Edit: typo
nee dat kan niet, onder andere omdat (iig de 2.6 kernel die RHEL 4 gebruikt) de meeste 2.6 kernels gebruik maken van udev, dus je server start dan niet meer met een 2.4 kernel (tenzij je al je init scripts aan gaat passen etc.)

Ik run nu een paar dagen de CentOS 4.0Beta (RHEL kloon die wel gratis is) en ik moet zeggen dat het best goed bevalt, upgraden was even lastig maar dat is altijd met major upgrades.
nee dat kan niet, onder andere omdat (iig de 2.6 kernel die RHEL 4 gebruikt) de meeste 2.6 kernels gebruik maken van udev, dus je server start dan niet meer met een 2.4 kernel (tenzij je al je init scripts aan gaat passen etc.)
udev staat daar los van hoor, je kunt dus ook zonder problemen 2.4 en 2.6 kernels naast elkaar op hetzelfde systeem draaien..
Het kan idd wel, maar het is niet eenvoudig en zeker niet altijd even stabiel (denk eraan dat RHEL voor productie servers wordt gebruikt)
Om een lang verhaal kort te houden: Omdat een verandering altijd problemen kan geven.
Over de 1 TB grens: de laatste diskbox bevat 14 disks van 72 GB dat maakt 14 * 72 == 1008 GB (in raid 0) of voor raid5+1 zo'n 12 * 72 == 864 GB. Er kunnen ook 144GB of 288GB disks in die raidbox Dan heb je het dus al over 2 of 4 TB. En dan de opvolger voor die box, die kan zo'n 50 disks bevatten.

(al moet ik niet over backuppen denken...)
Verder is de limiet van 1TB op een bestandssysteem verwijderd en kan er nu enkele petabytes aan data in een bestandssysteem worden opgeslagen

Effe een vraagje zijn er al systeembeheerders die hindering aan de 1TB hebben? Kan mij eigenlijk niet voorstellen. Anders reageer maar...

Verder ziet het er wel stabiel uit. :9

Op dit item kan niet meer gereageerd worden.



Apple iOS 10 Google Pixel Apple iPhone 7 Sony PlayStation VR AMD Radeon RX 480 4GB Battlefield 1 Google Android Nougat Watch Dogs 2

© 1998 - 2016 de Persgroep Online Services B.V. Tweakers vormt samen met o.a. Autotrack en Carsom.nl de Persgroep Online Services B.V. Hosting door True