Cookies op Tweakers

Tweakers maakt gebruik van cookies, onder andere om de website te analyseren, het gebruiksgemak te vergroten en advertenties te tonen. Door gebruik te maken van deze website, of door op 'Ga verder' te klikken, geef je toestemming voor het gebruik van cookies. Wil je meer informatie over cookies en hoe ze worden gebruikt, bekijk dan ons cookiebeleid.

Meer informatie

Door , , 4 reacties
Bron: Bolt , submitter: evertalbers

Bolt logo (75 pix) Versie 3.1 van Bolt is uitgekomen. Bolt is een opensource-contentmanagementsysteem en is daarmee in bepaalde opzichten vergelijkbaar met programma's als Wordpress en Drupal. Bolt is eenvoudig in gebruik, voor zowel installatie als beheer, heeft diverse goed uitziende templates die met Twig zijn aan te passen, en is geoptimaliseerd voor zowel desktop- als mobiele omgevingen. Sinds kort is er ook een website waarop Bolt themes live uit te proberen zijn en ook een site met een overzicht van alle beschikbare extensies. De release notes voor deze uitgave kunnen hieronder worden gevonden,

Bolt 3.1.0 released

Today we've released Bolt 3.1.0. This release further solidifies our Bolt 3.0 branch. As such, it contains a modest amount of new features, but also a lot of fixes and 'under the hood'-improvements. Besides that, we've been working on the documentation and the code for extensions. We've also updated our Roadmap with the features we're working on at the moment.

Notable changes:
  • Fix: Allow taxonomies in contentlinks again. #5698
  • Fix: Case-insensitive username lookup at login. #5696
  • Fix: Change slug to singular_slug in Edit Record screen. #5688
  • Fix: Exclude 'bower_components', 'node_modules' in .gitignore. #5689
  • Fix: Fix for uploading to themes/ folder in backend. #5679
  • Fix: Fix slash in taxonomies #5675
  • Fix: Handle Upload exceptions better #5683
  • Fix: Improve Hydration Process in Repeaters #5670, #5684
  • Fix: More session save_path bugfixes. #5691
  • Fix: Show correct error message on incorrect login attempt. #5697

Bolt dashboard screenshot (620 pix)

Versienummer:3.1.0
Releasestatus:Final
Besturingssystemen:Scripttaal
Website:Bolt
Download:https://bolt.cm/download
Licentietype:GPL
Moderatie-faq Wijzig weergave

Reacties (4)

Mooi CMS, toch een beetje de lightweight variant van Drupal 8, en dat mis ik toch vaak in andere CMS-en: Views. Maar toch; mooi pakket.
Hoe zit het met beveiliging? Heb zelf een aantal keer Wordpress gehad, maar binnen de kortste keren kreeg ik via Chrome dat mijn website geinfecteerd zou zijn.

Daarna Drupal 8 geprobeerd, lijkt een stuk veiliger, maar de core updaten is echt een rampenplan (lees: backuppen, verwijderen, uploaden, configureren)...
Ik ben geen expert op security-gebied, en bij dit soort posts moet je altijd op ongeverfd hout kloppen - maar beveiliging krijgt in Bolt en ook in het onderliggende Silex-framework zeker de aandacht die het verdient.

Om wat te noemen:
Bolt gaat tegenwoordig uit van default installatie buiten de webroot,
de admin-url is makkelijk aan te passen zodat deze niet meer is te raden,
door de flexibele opzet heb je minder plugins nodig,
de plugins die ik tot nu toe heb gebruikt waren van goede kwaliteit,
mail wordt verzonden via een SMTP account met login/wachtwoord etc.,
en als er een potentieel security issue was werd een update heel snel uitgerold.
Ik heb nu een twintigtal sites online staan en heb qua security nooit problemen gehad. (klopt nogmaals)

Updaten via Composer is een fluitje van een cent, zie https://docs.bolt.cm/3.1/upgrading/updating
Bij updaten van 2.X naar 3.X is wat handwerk nodig, maar dat was voor mij (designer) goed te doen.
De plugins kunnen via de admin-interface automatisch checken op de laatste versie en worden geupdate.

Ik hoop dat je hier wat aan hebt, anders ben je welkom op het forum en het Slack channel voor andere vragen.

[Reactie gewijzigd door evertalbers op 30 augustus 2016 12:54]

Je moet niet teveel naar een product wijzen omdat je slechte ervaringen hebt. Ik draai al 6 jaar met diverse sites op wordpress zonder beveiligings problemen.

Bij wordpress zit het probleem 90% van de tijd in de plug-ins die je hebt gebruikt. Of in de themes (welke weer plug-ins gebruiken die weer niet worden ge-update).

Kort door de bocht, ook met andere software moet je security bewust werken en updaten (met zo min mogelijk plug-ins).

[Reactie gewijzigd door dycell op 30 augustus 2016 17:01]

Op dit item kan niet meer gereageerd worden.



Nintendo Switch Google Pixel Sony PlayStation VR Samsung Galaxy S8 Apple iPhone 7 Dishonored 2 Google Android 7.x Watch_Dogs 2

© 1998 - 2016 de Persgroep Online Services B.V. Tweakers vormt samen met o.a. Autotrack en Carsom.nl de Persgroep Online Services B.V. Hosting door True