Cookies op Tweakers

Tweakers maakt gebruik van cookies, onder andere om de website te analyseren, het gebruiksgemak te vergroten en advertenties te tonen. Door gebruik te maken van deze website, of door op 'Ga verder' te klikken, geef je toestemming voor het gebruik van cookies. Wil je meer informatie over cookies en hoe ze worden gebruikt, bekijk dan ons cookiebeleid.

Meer informatie

Door , , 32 reacties
Bron: VideoLAN

VideoLAN / VLC Media Player logo (60 pix)

De ontwikkelaars van VideoLAN hebben versie 1.0.2 van VLC Media Player uitgebracht. Deze opensource- en crossplatform-mediaspeler kan diverse audio-, video- en streamingformaten afspelen, zonder dat hiervoor de betreffende codec hoeft te worden geïnstalleerd. VLC Media Player is beschikbaar voor Windows 2000 en hoger, Linux, Mac OS X en BSD; oudere versies zijn ook beschikbaar voor onder andere Windows 9x, BeOS, Morphos, en Windows CE. Hieronder zijn alle veranderingen te vinden die sinds versie 1.01 zijn aangebracht:

Decoders:
  • Native support for WMA Professional, without the use of the Win32 dlls
  • Fix issues in subtitles, especially SSA ones
  • Various fixes on theora and ogg
Demuxers:
  • Various fixes for EPG support in MPEG-TS demuxer
  • Fixes for potential stack overflow in .avi, .mp4 and .asf demuxers
Access:
  • Fixes for v4l2 devices
  • Fixes for dvb-c channels-scanning
Qt Interface:
  • Fix some playlist sorting issues
Mac OS X Interface:
  • Fixed a crash when updating VLC
  • Fixed a crash related to QTKit when opening video files (10.6 only)
  • Added the ability to play 2nd media in sync to the primary item (input-slave)
  • Added the "Quit after Playback" feature
Mac OS X Port:
  • The "Delete Preferences" script is now delivered as a Universal Binary with native code for PowerPC, Intel and Intel 64bit
  • Full 64bit runtime compatibility on both Mac OS X 10.5 and 10.6
    • no support for Goom and SDL
    • limited text rendering support
    • This port is still considered as EXPERIMENTAL despite its binary release.
Encoders:
  • MPEG2 transrate stream output removed
  • x264 default-values closer to x264.exe defaults.
  • x264 rc-behaviour fixes:
    • if user defines qp-value, CQP-mode is used
    • otherwise if user defines vb=0, CRF-mode is used
    • otherwise ABR-mode is used
  • x264 set vbv-bufsize/vbv-maxsize better if user hasn't defined these:
    • ABR mode set vbv-max-bitrate=bitrate
    • vbv-bufsize is bitrate
    • seconds between keyframes (keyint/fps)
Playlist:
  • Lua scripts for Mpora and Vimeo playback
Unix builds:
  • Various fixes to enable 1.0 to build on Solaris and OpenBSD
Translations:
  • New Kazakh and Croatian translations
  • Lithunanian translation is available on Windows
  • Galician, Korean, Nepali, Vietnamese, Ukrainian, Brazilian, Arabic and French translation updates
VLC media player 0.9.2 screenshot (481 pix)
Versienummer:1.0.2
Releasestatus:Final
Besturingssystemen:Windows 7, Windows 2000, Linux, BSD, Windows XP, macOS, Solaris, Windows Server 2003, Windows Vista, Windows Server 2008
Website:VideoLAN
Download:http://www.videolan.org/vlc/index2.html
Bestandsgrootte:17,60MB
Licentietype:GPL
Moderatie-faq Wijzig weergave

Reacties (32)

Wat ik nog wel zou waarderen is of hardware decoding voor mkv (maar volgens mij zit dit er niet zo snel in) of SMP support... Op mijn unibody mac heeft VLC soms moeite met stukken 1080p, waardoor de cpu op max 100 zit, terwijl plex dan rustig doorschiet naar 150, en het daarmee makkelijk haalt. (Ter vergelijking, een quicktime 1080p komt nooit boven de 15!!)
Mkv kun je niet door hardware laten "decoden". Het is namelijk geen codec maar een container. Ik denk dat je H264 acceleratie bedoelt, wat volgens mij de meestgebruikte codec is in mkv bestanden.
Ik zag vorig jaar al wel berichten langskomen over VDPAU support op linux, maar volgens mij is dat niets meer dan wat patches die je er zelf in moet bakken...
Er is nu VDPAU ondersteuning in linux in VLC en Xine, volgensmij ook mplayer maar dat weet ik niet zeker. Opzich heb je er weinig aan als je een "oude" 8 serie kaart (geen G92) of oudere kaarten hebt omdat VDPAU die niet ondersteunt, natuurlijk kun je altijd nog wel Xvmc gebruiken.
Prima initiatief ook, om compatibiliteit te bewaren met Windows 2000 en W9x, dat zouden meer programma's moeten doen.
Misschien moet je je oude pentium 2 eens wegpleuren als je nog steeds win9x gebruikt? Waarom zou een developer ooit win9x nog willen ondersteunen? Voor die 2 mensen op aarde die behoefte hebben om moderne dingen op zwaar verouderde apparatuur/software te doen? Ga jij ook je programma nog voor windows 3.11 compileren? Die hele win9x reeks valt onder dezelfde legacy categorie als win 3.x...
Wat een toon zeg... Dat de ontwikkelaar geen rekening meer houdt met oudere besturingssystemen en hardware is op zich natuurlijk wel terecht maar misschien gaat het hier wel om een Pentium II systeempje van iemand die verder niets meer nodig heeft en daar ook het geld niet voor (over) heeft. Genoeg mensen met een bijstandsuitkering die gebruik maken van zo'n verouderd systeempje. De opmerking van "Mjzelf"is dus voor die doelgroep best informatief.
Misschien moet je je oude pentium 2 eens wegpleuren als je nog steeds win9x gebruikt? Waarom zou een developer ooit win9x nog willen ondersteunen? Voor die 2 mensen op aarde die behoefte hebben om moderne dingen op zwaar verouderde apparatuur/software te doen? Ga jij ook je programma nog voor windows 3.11 compileren? Die hele win9x reeks valt onder dezelfde legacy categorie als win 3.x...
Lieve help, wat is er met jou aan de hand? Ben je vanmorgen van de trap gedonderd of zo? Ik zei alleen dat ik ondersteuning voor oudere besturingssystemen een prima idee vind, meer niet. Bovendien heb ik geen Pentium 2 maar een lekker supersnel systeem waar ik meerdere OS'en op draai - van Linux via XP en Vista tot en met Windows 7.
Helaas werkt dit niet onder W9x. Daarvoor moet je versie 0.8.6 hebben.
wat ik nou nooit voor elkaar krijg (zonder een playlist te maken) is het afspelen van een dvd.. je moet op een vob file klikken en dan speelt die die af maar gaat niet verder naar de volgende.
Je kunt toch ook gewoon Open Disk i.p.v Open File kiezen? Dan hoef je alleen maar aan te geven welke DVD speler je als bron wil en de rest gaat vanzelf.
Beter voor een video_ts map is open directory/map... ;)
Als je je dvd in een map heb zitten kun je gewoon die map openen in VLC, dan werkt het wel. :)
Wat ik met Mac build nog mis is een optie om het als default player in te stellen voor video bestanden, Quicktime wordt ik niet goed van:9
Dit kan toch zonder problemen? Anders "get-info (cmb+i) op videobestand -> open with VLC natuurlijk -> change all.

Must have update verder voor Snow Leopard gebruikers. De 0.99 geeft glitches bij het gebruik van ondertiteling. Na de update niets meer gezien en alles weer zoals ik inmiddels verwacht van VLC.

Waar ik me nog steeds over verbaas is de default skin van de Windows variant. What the effff?
Ik vind die van OSX niet veel beter. Voelt nog erg 10.3. Gelukkig zijn er wel allerlei UI hacks te vinden op bv macthemes2 forum.
Ik zweer echt bij VLC!
wel jammer dat het geen codec voor wmv onder Linux heeft
win32codec pack installeren; problem solved
Inderdaad, dan kun je prima wmv bestanden afspelen met VLC.

Voor Debian, Ubuntu en Linux Mint: sudo apt-get install w32codecs, sudo weglaten voor Debian!
Ik vind dit 1.0 reeks echt een stuk minder werken dan de 0.8.6-reeks.

Ondersteuning voor dvd(-menu)'s lijkt een stuk minder te zijn. Menu reageert niet tot heel slecht op de muis bijvoorbeeld. Het afspelen van corrupte avi-files werkt een stuk minder, je kon eerst nog spoelen hier werkt dat helemaal niet.

Al met al lijkt het veel instabieler te werken. Het kan overigens komen dat ik Windows 7 draai maar ik dacht dit ook al te merken met XP. Voor videobestanden ben ik nu overgegaan op MPCH.
Ik draai nog steeds lekker op 0.8.6, dan kun je zonder mankeren VIDEO_TS en AUDIO_TS files in de watchlist zetten en het wordt goed afgespeeld, terwijl de 1.0 versies dat schijnbaar niet aankunnen? Ik peins er dan ook niet over om up te graden.

Verder is VLC wat mij betreft onmisbaar bij films kijken :)
Werkt tegenwoordig de update functie in vlc al?
Ik weet niet welk OS jij gebruikt, maar in Mac OS X werkt het prima.
Niet altijd onmiddelijk, maar het werkt wel.
Hoewel ik versie 1.0.1 heb, beweert het programma dat dit de laatste versie is.
Onder Windows Vista werkt het (bij mij iig) niet dus.
Dit is een perfect programma, het is simpel, en het werkt perfect.
Wat ook goed is, is dat dit programma ondertitels van srt goed kan afspelen.
Hiermee kijk ik altijd films.
Nu is het alleen nog wachten op een vlekkeloze RTMP ondersteuning. Als dit daadwerkelijk werkt zal het een van de eerste programma's zijn waarmee dan ook via RTMP gestreamd kan worden zonder gebruik te maken van Adobe software :)

[Reactie gewijzigd door Intheweb op 23 september 2009 12:12]

http://mirror01.x264.nl/x264/changelog.txt

commit d5429261cc2a2205d225b0f0c0802d3b565eb7bd r1268
Author: Jason Garrett-Glaser <darkshikari@gmail.com>
Date: Tue Sep 22 17:30:19 2009 -0700

Attempt to detect miscompilation due to bug in gcc 4.2
I don't know if this bug still affects latest x264, but it can't hurt to try to detect it.
Accordingly refuse to open the encoder if detected.
Apparently VLC (on Windows) has been distributed for some time with a completely
broken x264 due to the use of a completely broken compiler (gcc 4.2). In
particular, the MV costs seem to be calculated incorrectly on win32 when linking
from an application compiled without -ffast-math to an application with
-ffast-math.
I am not entirely certain why this occurs, but the result is, unsurprisingly,
encoding quality that makes MPEG-2 look good, due to the motion search being
completely broken.

Op dit item kan niet meer gereageerd worden.



Apple iOS 10 Google Pixel Apple iPhone 7 Sony PlayStation VR AMD Radeon RX 480 4GB Battlefield 1 Google Android Nougat Watch Dogs 2

© 1998 - 2016 de Persgroep Online Services B.V. Tweakers vormt samen met o.a. Autotrack en Carsom.nl de Persgroep Online Services B.V. Hosting door True