Cookies op Tweakers

Tweakers maakt gebruik van cookies, onder andere om de website te analyseren, het gebruiksgemak te vergroten en advertenties te tonen. Door gebruik te maken van deze website, of door op 'Ga verder' te klikken, geef je toestemming voor het gebruik van cookies. Wil je meer informatie over cookies en hoe ze worden gebruikt, bekijk dan ons cookiebeleid.

Meer informatie

Door , , 62 reacties
Submitter: Stoepie1

De nieuwste versie van Android heeft problemen met Exchange-accounts. Bestaande profielen lijken te blijven werken, maar wie onder 4.4 KitKat een nieuw Exchange-account instelt, ondervindt problemen met het ophalen van e-mail.

Android logoHet is niet duidelijk hoeveel mensen last hebben van de Exchange-bug, maar volgens Android Police gaat het om een significant aantal. Een groot deel van de gebruikers zou al problemen hebben met het configureren van een account; in sommige gevallen zou dat kunnen worden verholpen door in plaats van het e-mailadres de 'domein\gebruikersnaam'-syntax van Exchange te gebruiken.

Zelfs als de configuratie van een Exchange-account lukt, kunnen echter problemen optreden: zo treden er problemen op bij het ophalen van e-mail. In sommige gevallen treden die problemen pas op na uren of dagen. Terwijl de e-mail niet meer wordt binnengehaald, gaat de accu van het toestel wel opeens veel sneller leeg. Het veranderen van de instellingen, zoals het opnieuw instellen van certificaten of het kortstondig in- en uitschakelen van synchronisatie, lijkt de problemen op te lossen, maar dat blijkt slechts tijdelijk te werken. Wat beter zou werken is het uitschakelen van pushmail en polling in te stellen, waarbij om de zoveel tijd wordt gecontroleerd of er nog nieuwe e-mail is.

Opvallend is dat bestaande, geconfigureerde Exchange-accounts onder Android 4.4 wel lijken te werken, maar dat het fout gaat bij nieuwe accounts. Mogelijk hebben de problemen te maken met de manier waarop Exchange certificaten en logingegevens opslaat, maar ook het inschakelen van encryptie op het toestel, zoals Exchange-servers van sommige bedrijven verplichten, lijkt bij te dragen aan het probleem.

Ondertussen lijken de Android-ontwikkelaars te hebben toegegeven dat er een probleem is: een bugmelding op de Android-website is aangemerkt als 'op te lossen in een toekomstige versie'. Eerder had iOS 6.1 problemen met Exchange-accounts.

Heb jij problemen met Exchange onder Android 4.4?

Nee, ik heb geen Android 4.4/Exchange-account
78,9%
Nee, ik heb geen problemen
12,2%
Ja, en oplossen lukt niet
7,2%
Ik had problemen, maar heb het gefixt
1,7%

Aantal stemmen: 4.415. Deelname gesloten op 16-12-2013 08:43. Stemmen is niet meer mogelijk.

Moderatie-faq Wijzig weergave

Reacties (62)

Vreemd, ik heb op mijn Nexus 5 een nieuwe exchange account ingesteld en ik heb nog geen problemen gehad hiermee, vraag me af of dit nog gaat komen dan. Gaat ondertussen toch al een week of 3 goed
Volgens mij gaat het over nieuwe accounts op de Exchange server die problemen geven als je ze configureert op 4.4.
Het zal ook wel uitmaken of de Exchange server bepaalde policies verlangt. Dat triggert namelijk afhankelijk van welke policies het zijn bepaalde features op de telefoon.
ik gebruik maildroid ... die gebruikt z'n eigen api's ipv die van android...
in mijn geval weliswaar voor imap/smtp dus ik had er sowieso geen last van

wel bizar dat google dit niet beter getest heeft; of zou het weer zo'n onder-de-gordel stomp zijn naar microsoft om gebruikers te doen oveschakelen naar hun eigen diensten?
Het ligt aan de exchange servers, bedoel je ??? hoe kan een nieuw account op een exchange server problemen geven op een android. in het bericht wordt duidelijk vermeld als iemand een nieuw exchange account insteld die hij niet eerder had ingesteld op zijn telefoon.
Het account op de exchange server hoeft daar bij niet nieuw te zijn.
En sinds wanneer heb je Android 4.4 want de laatste nieuwsberichten op Tweakers leren mij dat pas sinds 14 november er een uitrol is begonnen van 4.4 naar de Nexus-familie. Als het bij jou dan al snel een week of 3 goed gaat, is niet goed te begrijpen op welk OS je nou zat :)
De Nexus 5 is al sinds begin november verkrijgbaar in Nederland.
En daarbij wordt de Nexus 5 met 4.4 geleverd.
Er zijn andere manieren om aan een update te komen dan OTA. Ik gebruik al tijden de android toolkits van Mark Skippen (http://www.skipsoft.net/?page_id=703) en als je dan weet waar Google de images voor jouw hardware 'parkeert' ben je vrij snel bij. :)
Je weet toch dat de Nexus 5 met standaard met 4.4 komt? Ik heb zelf 4.4 op mijn Galaxy S2 en gelukkig heb ik geen problemen met exchange. Alle mail en afspraken komen netjes op tijd binnen en versturen gaat ook prima.
Stomme vraag, maar hoe heb je 4.4 op je S2 gekregen? Is er al een mod dan?
Uhm even verder gekeken dan mijn neus lang is. Gevonden;)

[Reactie gewijzigd door Heintjepek op 25 november 2013 14:18]

Ze waren er vrij snel bij op XDA, ik las ergens dat Chainfire zijn S2 weer gaat gebruiken als dedicated test apparaat :D
4.4 op mn Nexus 7(2012) sinds mid november
je weet toch hopelijk wel dat de Nexus 5 al 4.4 had toen hij uitkwam? 14 november heeft google ook de update uitgebracht voor de andere Nexus toestellen.
Hier ook een Nexus 5 en absoluut geen problemen. Misschien dat de exacte build afwijkt die op de Nexus 5 voor ge´nstalleerd staat ten opzichte van de updates voor andere toestellen, of zou dat niet kunnen?
Ik had ook dat idee. Ken niemand met een Nexus 5 die het probleem heeft. Maar wel mensen die de update hebben gehad op de nexus 4
Heb ook een Nexus 4 met KitKat 4.4, maar ook geen problemen met het configureren van een nieuw Exchange account?
De poll blijkt ook te bevestigen dat er echt weinig mensen zijn met deze problemen. Best vreemd....
Er zijn ook nog maar weinig mensen met 4.4... het percentage zou hier op Tweakers wel wat hoger liggen dan gemiddeld, maar als het al 10% is van de regelmatige bezoeker dan vind ik het al veel.
Als we naar de stemmen kijken die problemen hebben of geen problemen (dus niet de bovenste optie) zijn er toch 180 mensen zonder problemen en een 90 tal met (snel geteld)

Op zich niet veel, maar wel opvallend dat er dubbel zoveel mensen zijn zonder problemen dan dat er zijn met ...
Nexus5 gebruiker meldt zich. Ik heb vorige week een een gloednieuw Exchange 2013 account toegevoegd. Ik heb geen (merkbare) problemen ondervonden.
Hier wel problemen. Aanvankelijk dat de accuduur erg tegenviel. Pas later zag ik dat het sync symbool continu draait op mijn exchange (2003) account. heb de push naar uitgeschakeld, maar lees nu gelukkig dat het niet aan mij lag :-)
Ik heb dat exacte probleem al sinds Android 4.1
Het vervelende is dat het niet te voorspellen is. soms gaat het maanden goed en dan is opeens je accu in twee uur leeg omdat de Exchange sync blijft hangen. Op Android 4.3 heb ik het btw nog niet gehad. Hopelijk wordt het snel opgelost.
Precies. Niet alleen bij 4.4 gebeurd dit. Ik heb het probleem al zo vaak gehad, op verschillende android versies, dat ik gewoon geen exchange meer instel op mijn mobiel.
ZIjn er gebruikers die nitrodesk touchdown o.i.d. gebruiken i.c.m. android 4.4? Ik mag aannemen dat het probleem dan niet bestaat en alleen beperkt is tot de ingebouwde active-sync client.
Ik gebruik Touchdown op mijn Nexus, zonder problemen nu. Maar ik moest de backup die ik met Titanium had teruggezet van een ouder toestel wel opnieuw configureren (maar dat was ook wel te verwachten, gebeurt met meer apps bij een OS-sprong). Aan de andere kant op mijn werk staat een echte exchange server.

Thuis draait Zarafa, waar ik met de ingebouwde Android cliŰnt mee synchroniseer. Gaat zonder problemen.
Wat zo vervelend aan het worden is aan Android is dat de app developers niet early-access hebben tot Android, waardoor er teveel mensen zijn met Nexus devices die aan de frontlinie staan wanneer de software updates uitgerold worden, met tot gevolg dat deze Android-promoters geconfronteerd worden met een negatieve ervaring omdat ze ongewild als beta-tester worden ingezet.

Google moet komen met een oplossing waarbij je als developer kunt aangeven dat je device eerdere release cycles van nieuwe major- en minor-version updates kan binnenharken (kan vast wel ergens in een van de developer options).. nu lopen ze iedere keer achter de boze app-klanten aan te rennen die weer eens lopen te brullen dat hun favoriete apps niet meer werken in versie+1.
Mja, al sinds de eerste Nexus ben je gewoon een betatester voor Google niet meer niet minder. Goed daarvoor mag je wel tegen een zeer scherpe prijs een smartphone kopen en de laatste versie van Android gebruiken.
Wil je een stabiele Android versie dan zul je een non-Nexus toestel moeten kopen. De meeste fabrikanten voegen naast de Google code nog extra's toe waardoor e.e.a. wel of zelfs beter werkt. Samsung en HTC voeren bijvoorbeeld eigen aanpassing in hun exchange stacks. Net zoals met Linux distro's is bleeding edge niet altijd verstandig :)
Een groot deel van de gebruikers zou al problemen hebben met het configureren van een account; in sommige gevallen zou dat kunnen worden verholpen door in plaats van het e-mailadres de 'domein\gebruikersnaam'-syntax van Exchange te gebruiken.
Dat is geen bug, dat is een NTLM-versie verschil:
NTLM-DOMAIN\%USERNAME% = een al oudere manier van aanmelden buiten een Windows Domein.
%USERNAME%@DOMAIN-FQDN is de nieuwe tegenwoordige manier die wordt als standaard gehanteerd i.p.v. de NTLM wijze, bij iPhone moet je geloof ik standaard de FQDN gebruiken.
Ik vind het dus persoonlijk niet echt een Bug, meer onwetendheid van een groot aantal gebruikers... ;-)


Edit: Typo.

[Reactie gewijzigd door HoeZoWie op 25 november 2013 10:06]

Het is een bug. Als username@domain-fqdn of username@principal-domain-name.tld niet werkt (wat zou moeten werken voor activesync) dan kun je als workaround de oude inlogmethode via NTLM proberen. Heeft dus niets te maken met gebruikers opvoeden.
Mogelijk hebben de problemen te maken met de manier waarop Exchange certificaten en logingegevens opslaat
Exchange slaat toch weinig op behalve mail? Heb nog niet gezien dat (onderdelen/servers van) Exchange aktief nieuwe/andere certificaten van clients accepteert en ergens op een server opslaat.

Het enige wat ik me kan voorstellen is dat sommige bedrijven mogelijk verschillende typen certificaten gebruiken voor communicatie tussen "server & client" en tussen "server en server". Zo kan je wel simpel een self-signed certificate gebruiken tussen CAS & MAILBOX maar zal je als bedrijf liever wel een trusted certificate aan de buitenkant configureren als je gebruik wil maken van externe clients.
Ik denk ook dat er bedoeld wordt het opslaan van de exchange certificaten op de mobiel.
De server slaat geen cretificaten op van client.
Sinds de update naar 4.4. werkt mijn exchange mail niet meer... ik kan synchroniseren maar er komt geen nieuwe mail binnen...
Ook het account verwijderen en opnieuw aanmaken helpt niet, komt geen mail binnen.
Dat probleem is er ook op de Note3 en Android v4.3. De build-in mail client kan niet gebruiktworden en Touchdown is het alternatief met ale gebreken van dien, zoals syncen met een decent calendar.
Ik had een on-official 4.4 op mijn Galaxy3 draaien maar die zuigt de batterij leeg alsof het bier is.
Maar outlook werkt wel gewoon goed, met al aangemaakte accounts.

[Reactie gewijzigd door db_seven op 25 november 2013 09:10]

Hier ook problemen.. Instellen ging prima op mijn Nexus 5 en toen leek het ook prima te werken.. Maar na een paar dagen kwam er geen mail meer binnen.. Enige oplossing was om het handmatig op te halen.. Tijdelijk maar even "Cloudmagic" erop gezet, deze werkt wel gewoon nog gelukkig met push mail.

Op dit item kan niet meer gereageerd worden.



Apple iOS 10 Google Pixel Apple iPhone 7 Sony PlayStation VR AMD Radeon RX 480 4GB Battlefield 1 Google Android Nougat Watch Dogs 2

© 1998 - 2016 de Persgroep Online Services B.V. Tweakers vormt samen met o.a. Autotrack en Carsom.nl de Persgroep Online Services B.V. Hosting door True