Cookies op Tweakers

Tweakers maakt gebruik van cookies, onder andere om de website te analyseren, het gebruiksgemak te vergroten en advertenties te tonen. Door gebruik te maken van deze website, of door op 'Ga verder' te klikken, geef je toestemming voor het gebruik van cookies. Wil je meer informatie over cookies en hoe ze worden gebruikt, bekijk dan ons cookiebeleid.

Meer informatie

Door , , 13 reacties
Bron: PHP, submitter: AtleX

De ontwikkelaars van PHP hebben donderdag versie 4.4.9 van hun populaire programmeer- en scriptingtaal vrijgegeven. Deze versie is de laatste uit de PHP 4-serie, wat inhoudt dat er voor deze versie geen beveiligingsupdates meer zullen verschijnen. PHP adviseert, zoor zover dit nog niet is gedaan, over te stappen naar PHP 5. Het changelog van PHP 4.4.9 laat de volgende wijzingen zien:

* Updated PCRE to version 7.7.
* Fixed overflow in memnstr().
* Fixed crash in imageloadfont when an invalid font is given.
* Fixed open_basedir handling issue in the curl extension.
* Fixed bug #37421 (mbstring.func_overload set in .htaccess becomes global).
Versienummer:4.4.9
Releasestatus:Stable
Besturingssystemen:Linux, BSD, Linux x86, Solaris, UNIX, Linux AMD64, Linux IA-64
Website:PHP
Download:http://nl2.php.net/get/php-4.4.9.tar.bz2/from/this/mirror
Bestandsgrootte:4,44MB
Licentietype:Voorwaarden (GNU/BSD/etc.)
Moderatie-faq Wijzig weergave

Reacties (13)

Tot ziens, PHP 4! Je hebt goede diensten verricht, maar het is tijd om plaats te maken voor versie 5 :)
Hoe dan ook, het is mooi om te zien dat ze de bugs in PHP4 nog aanpakken.
Dit is dus de laatste keer dat ze dat doen. Vanaf nu wordt PHP4 niet meer onderhouden:
This release wraps up all the outstanding patches for the PHP 4.4 series, and is therefore the last PHP 4.4 release.
bron
Als je het letterlijk leest, kan het toch zijn dat er nog een PHP 4.5 komt? :P
Zolang ze het tenminste maar niet te lang blijven doen, anders blijven mensen zelfs nadat PHP4 eol is nog steeds plakken. Uiteindelijk moet je toch een keer door :)
* LuCarD pinkt een traantje weg, ondanks de haat liefde verhouding hebben we toch leuke dingen samen gedaan.... ;)
Doei, PHP4.
Hallo PHP5.

Nu nog wachten tot het gros van de serverparken updaten ;)
Wij hebben er niet mee gewacht, en draaien sinds maart ook al PHP6 naast de installatie van PHP5. Het wordt echt tijd dat men updates van MySQL/PHP net zo gaat behandelen als een update van je browser. (Direct na uitgave, testen, en uitrollen).
Probleem is dat niet alle scripts direct werkt op nieuwe versie... Kijk naar 4> 5...
Probleem is dus dat PHP het niet aandurft om backwards compatibility te garanderen, ook al zou dat er misschien wel zijn.

[Reactie gewijzigd door _Thanatos_ op 8 augustus 2008 19:59]

Probleem is dus dat PHP het niet aandurft om backwards compatibility te garanderen, ook al zou dat er misschien wel zijn.
Ik zie dat eigenlijk niet als een probleem, maar als een logisch gevolg. Anders blijf je houden dat mensen kwalitatief gezien (qua code) slechte code blijven schrijven. Natuurlijk kan dat in PHP5 ook, maar met PHP5 is het allemaal beter beveilgt dan met PHP4. Er zitten dus alleen maar voordelen aan om over te stappen op PHP5 en dan komt er nog is bij dat PHP5 meer OOP geörienteerd is dan PHP4, met de komende PHP6 word dat geloof ik nog leuker!
Draait PHP4 niet op windows het valt me op dat die niet in het lijstje van OSen staat terwijl het volgens mij wel mogelijk is
Dit is inderdaad mogelijk.
All Windows binaries can be used on Windows 98/Me and on Windows NT/2000/XP/2003.

Op dit item kan niet meer gereageerd worden.



Apple iOS 10 Google Pixel Apple iPhone 7 Sony PlayStation VR AMD Radeon RX 480 4GB Battlefield 1 Google Android Nougat Watch Dogs 2

© 1998 - 2016 de Persgroep Online Services B.V. Tweakers vormt samen met o.a. Autotrack en Carsom.nl de Persgroep Online Services B.V. Hosting door True