Cookies op Tweakers

Tweakers maakt gebruik van cookies, onder andere om de website te analyseren, het gebruiksgemak te vergroten en advertenties te tonen. Door gebruik te maken van deze website, of door op 'Ga verder' te klikken, geef je toestemming voor het gebruik van cookies. Wil je meer informatie over cookies en hoe ze worden gebruikt, bekijk dan ons cookiebeleid.

Meer informatie

Door , , 61 reacties

Er komen binnenkort roms op basis van Android 4.4 met bijgewerkte gpu-drivers van Texas Instruments. Dat blijkt op het forum van XDA-Developers. De support van Google is gestopt, maar TI stelde desondanks nieuwe drivers beschikbaar.

Er zijn nu al Android 4.4-roms voor de Galaxy Nexus uit 2011, maar die bevatten allemaal grafische issues bij bijvoorbeeld het roteren van het scherm, waardoor de gebruikservaring verre van optimaal is. Makers van custom roms beloven daarom snel met updates te komen die de issues oplossen, zoals Carlos_Manuel van de Dreams-custom rom.

Die fix is mogelijk, omdat een ontwikkelaar met medeweten van Texas Instruments en gpu-maker Imagination een update voor de gpu-drivers online heeft gezet. Deze update is nog niet gebruikt door Google in de Android 4.3-rom voor de Galaxy Nexus en fixt de issues op Android 4.4.

Google liet vorige week weten Android 4.4 ondanks de focus op toestellen met minder krachtige processors en minder geheugen niet voor de Galaxy Nexus uit te brengen. Google zegt anderhalf jaar support te leveren op toestellen. Veel mensen kopen juist Nexus-toestellen vanwege de support van Google en de snelle updates, maar Google heeft van tevoren niet gezegd tot wanneer de Galaxy Nexus updates zou ontvangen.

De Galaxy Nexus kwam uit in november 2011 en was een van de eerste telefoons met 720p-scherm en de eerste met Android 4.0. De smartphone heeft een Omap4460-soc van Texas Instruments aan boord, met een PowerVR SGX540-gpu van Imagination.

Galaxy Nexus

Moderatie-faq Wijzig weergave

Reacties (61)

Ik denk dat dit ook nog wel interessant is:
Q: THESE PVR BINARIES LOOK AMAZING! WON'T THEY HELP WITH 4.4 DEVELOPMENT?

A: Maybe.. Maybe not. In reality these binaries posted by @aosp are a bit "odd" when it comes to the build. The newest OMAP4 PVR binaries from TI are DDK 1.9 @ 2291151. They were found on the review website and never actually posted into the proprietary git. The actual "standard" JellyBean TI PVR binaries are around DDK 1.9 @ 2166536. You can see from the image that the binaries posted above are DDK 1.8(?).

In the end, the main goal is to be compatible w/ the current surfaceflinger/hwcomposer implementations so that no major hacks are needed to get the GPU functioning. EGL support for GL_OES_EGL_image was key for ICS when it first came out. In JellyBean you needed hwcomposer API 1.0 with a 3.0.31+ omap kernel. For hwcomposer 1.1 API (as implemented by TI) you would need a 3.4 kernel complete with android platform framebuffer patches / extended hwcomposer API.

GNex *could* use the newer TI PVR binaries. But might need to have it's 3.0 kernel's dss/dsscomp/gralloc files edited to be closer to the end of the p-android-omap-3.0-dev kernel's sources. And of course the pvr kernel modules need to match as well.
Bron: http://forum.xda-develope...?p=47160722&postcount=309
Ik vind het toch wel jammer dat ze zo snel support droppen. Betekend dat dat de Nexus 4 ook nog maar een halfjaar support heeft ondanks dat hij pas 3/4 jaar in nederland beschikbaar is?
Dat is inderdaad wel raar, er zijn een hoop andere fabrikanten die langer support leveren..Zat juist een Nexus te overwegen omdat ik dacht dat je hier langer support op kreeg..En custom roms zijn ook niet alles.

En Google zou juist het goede voorbeeld hierin moeten geven. En als ik Google was zou ik juist ook nieuwe Android versies testen op meerde Nexus modellen. Hoewel de Nexus lijn meestal qua hardware voorop ligt natuulijk, dus al je op een low end toestel wil testen kan je beter een andere pakken.
Jup daar kun je vanuit gaan. Nexus One had 18 maanden support, Nexus S idem dito. Maw: de update die rond juni/juli waarschijnlijk uit gaat komen krijg je nog mee, die van eind 2014 niet meer.
Petitie "Google: Update the Galaxy Nexus with Android 4.4 "Kitkat""
Since we reached over 10.000 supporters in really short time it was finally time to send in the signatures. Today I have printed out all of the 13.024 Signatures and over 3.000 comments, written a short letter and send the whole package to Mr. Sundar Pichai in Mountain View, California.
Picture

[Reactie gewijzigd door noakes op 8 november 2013 11:46]

Daarom heb ik die dus, Custom ROMs are the way to go :D

Vind het wel echt perfect dat bijna 2 jaar na de release hij toch nog ondersteund word en de ROM community zo goed loopt.
Daarentegen is het wel minder perfect dat Google zelf de Galaxy Nexus niet meer ondersteunt. Dit terwijl ze juist deze versie van Android op toestellen met mindere processors (en dus ook oudere) gericht hebben.

Ze hadden hierin zelf wel het goede voorbeeld moeten geven vind ik.
Argument van Google om dit toestel niet meer te ondersteuning was nou juist dat TI gestopt was met SoC's te maken voor mobieltjes en dus niet meer goede ondersteuning kon bieden. Beetje tegenstrijdig dat ze nu dan juist wel nieuwere drivers uitgeven (en het blijkbaar dus wel kunnen ondersteunen). Misschien toch meer een ingeving van financiele aard? Dat TI te veel geld vroeg voor verlengde ondersteuning voor Android 4.4?
Volgens mij waren dat geruchten (dat het lag aan gebrek aan nieuwe drivers). Google heeft dat naar mijn weten nooit zelf gezegd. Heb je een bron?
Blijkt inderdaad alleen een gerucht. Kan alleen dit vinden:
https://support.google.com/nexus/answer/3468085?hl=en

Maar voor een toestel dat 12 maanden lang over de toonbank ging, vind ik dat ze de eindtijd van verkoop zouden moeten pakken en DAARNA 18 maanden ondersteuning zouden moeten geven. De mensen die het toestel kochten later in zijn verkoopcyclus zouden ook gewoon ondersteuning moeten krijgen. Niet iedereen wil een Cyanogenmod gaan installeren!
Zoals ik heb had begrepen staat in alle aankondigingen expres "low-end" hardware, en niet "older" hardware. Dat is waarschijnlijk toch wel wat anders. Ik kan me voorstellen dat de nieuwere low-end SoC's toch wel nieuwere features hebben die je nodig kan hebben, ondanks dat ze in MHz en MB RAM niet mee kunnen doen met de high-end.
Daar ben ik het mee eens. Heb zelf de Nexus, en was wel verbaasd dat hier de update niet voor uitgebracht wordt.
Nou ja op zich was ik niet verbaast zelfs de levensduur bij een Nexus houd een keer op, en ik vind dat die toch al aardig wat updates gehad heeft een mooie levensduur.

Maar goed toen google idd ook zij dat 4.4 voor oudere toestellen beter zou zijn is wel vreemd, ik snap dat een telefoon een keer ophoud met updates maar kondig dan niet aan 4.4 werkt beter met oudere hardware en o ja onze oudere toestel krijgt de update niet.
Ze zouden er op ze minst dan nog een reden bij kunnen geven waarom.
Ze geven een reden aan:
Google zegt anderhalf jaar support te leveren op toestellen.
En dan te bedenken dat veel telefoons met een tweejarig contract zijn afgesloten. Voordat je contract is afgelopen ben je al unsupported.
Nope. Je krijgt tot en met 18 maanden support. Dus 'precies' op't einde van je 2 jarige contract krijg je de nieuwste versie niet meer. :)
Mijn kalender heeft 12 maanden per jaar.
Inderdaad, plus dat je de telefoon zeer vaak niet op de releasedatum koopt...
Toch... Ik heb een SGS2 uit 2011 die nog redelijk mee kan komen.
Dat gaat nu wel snel ophouden denk ik, maar dan zit je toch wel op 30 maanden.
Dus wat dat betreft denk ik dat ondersteuning best had gekund. Google heeft maar drie toestellen immers. Voor samsung kan ik me dat nog voorstellen met een 87 verschillende telefoons...
Samsung S2 houd idd op samsung zelf heeft al aangegeven geen nieuwe updates meer te maken, maar goed dan hangt die op 4.2 dacht ik toch best netjes nog van ze.

@aToMac

Ja oke 18 maanden maar goed dit hadden ze met andere fabrikanten afgesproken(Niet dat ze zich daar aan houden meestal), maar ja snap zelf ook wel dat ze dit gaan doen.
Ik vind alleen jammer je hoort dat die goed moet draaien op oudere toestellen en dan krijgt het oude toestel hem niet, het zou mooi voorbeeld zijn geweest van google om hem deze dan nog wel te geven.
de S2 i9100 is hier in NL niet verder gekomen dan 4.1.2 ;)
Dat klopt. Gelukkig hebben we cyanogenmod nog :)
Ik heb toch geen klachten over samsung wat dat betreft, maar voor Google had dat toch mogelijk moeten zijn.
Inderdaad.
Ik heb zelf een Galaxy Nexus en was een beetje verrast dat 4.4 niet kwam. Ik hem daarom ook maar meteen een Nexus 5 gekocht. Maar nu merk ik wel dat de Galaxy Nexus toch echt erg gedateerd is. Wat een verschil. veel groter dan ik had gedacht. :)
Je wilt een reden weten? Geld! Google is gewoon een commercieel bedrijf hoor, met aandeelhouders die het tevreden moet houden.
Die petitie heb ik al ondertekend hahaha!
Ben benieuwd wat het oplevert :)
Ik denk persoonlijk dat de cyclus van de meeste mensen 2 jaar is, gezien het grotendeel een telefoon met 2 jarig abonnement koopt. Je zou daardoor een half jaar zonder eventuele updates/ondersteuning zitten.

Gezien ze 4.4 mede introduceren onder de noemer dat hij minder eisend is, is het wel vreemd dat ze hun eigen Nexus niet meer ondersteunen.

Toch neem ik het graag voor lief, liever 18 maanden vooraan in de pikorde dan totaal afhankelijk zijn van de grillen van de fabrikant, kom maar op met die KitKat, ik krijg trek! }>
Je neemt dan wel aan dat mensen de Gnex alleen kopen op het moment dat hij uitkomt. Ik heb hem een jaar later gekocht, dus dan zou ik tot ergens halverwege 2014 moeten als ik die bij een tweejarig abonnement had gekregen. Dat zou meer dan een jaar zonder updates zijn.
Inderdaad, helemaal mee eens.

Ik roep al tijden dat mijn volgende telefoon een Nexus gaat worden maar als Google net als de andere grote fabrikanten (samsung, HTC, ect) gaat worden qua updates....tja. Dan word de belangrijkste factor om een toestel te kiezen straks echt de (XDA)community om het toestel.
Die lagere requirements hebben waarschijnlijk ook niet met oude hardware te maken, maar juist met nieuwe hardware. Hier kun je denken aan nieuwe toepassingen zoals smart watches, apparaten als Google Glass, et cetera. Apparaten welke vaak niet de ruimte hebben voor dezelfde hardware als moderne smartphones.

Marques Brownlee geeft in dit filmpje ook enkele voorbeelden waar Google Now voor gebruikt kan gaan worden en hoe de lagere requirements hier mee te maken kunnen hebben.
Inderdaad. Apple ondersteunt toch ook modellen van 3 jaar oud in iOS updates?
verwijderd wel bepaalde functies uit de updates voor oudere toestellen
Nu niet meteen weer de discussie zuur maken door onzin te verkondigen, wat ze niet altijd doen is alle nieuwe functies toevoegen omdat het oude toestel bijvoorbeeld geen Bluetooth LE ondersteund. (AirDrop, 3GS) of geen of amper mogelijkheden heeft om achtergrond geluid te onderdrukken (3GS, Siri).

Weghalen van functionaliteit heb ik nog niet gezien.
Volgens mij hadden ze Siri eruitgehaald voor bepaalde modellen Iphone? Terwijl dat geen speciale hardware vereist.
weghalen van functionaliteit die nieuwere toestellen wel krijgen.

zo bedoelde ik het.

ik bedoelde dus zeker niet dat ze opeens de functies die het toestel al had verwijderen.

mijn excuses voor de onduidelijkheid.
Lijkt me ook een peuleschil voor een bedrijf als Google om de ondersteuning wel te leveren. Maar geen ondersteuning betekent ook dat mensen eerdere een nieuwe telefoon kopen.
Is het niet zo dat de Galaxy Nexus een AMOLED scherm heeft en de Nexus 4 en 5 een IPS scherm? Het lijkt me dat KitKat, met al die witte schermpjes, negatief uit zou pakken voor de batterijduur op de Galaxy Nexus.

Tegelijkertijd zal 4.3 via de Google Play framework update wel alle 4.4 apps kunnen draaien en is een update dus minder dringend dan bij voorgaande versies waar het framework minder relevant was. Dit was, zover ik begreep, een van de speerpunten van Android 4.3.
dan installeer je toch een donker thema? Het lijkt mij dat android kitkat juist minder veel van je processor vraagt of in ieder geval het geheugen omdat er zoveel fixes zijn doorgevoerd, performance op oudere toedstellen was met 4.4 wel het richtpunt. Dat zou zelfs positief moeten uitpakken voor de batterijduur.
We praten hier over een commit van een jaar geleden (5 Nov 2012) dus die driver is helemaal niet nieuw. Ik vraag me dan ook af of
A: Deze driver daadwerkelijk 4.4 compatible is.
B: Google niet wist van het bestaan van deze driver?
in het GN topic heb ik het al een paar keer gezegd, niet de laatste versie krijgen betekend niet dat je toestel niet meer bruikbaar is. Met 4.3 doe je mee in de top van de android updates, er zijn slechts enkele high end toestellen die nu een 4.3 update hebben gekregen (of uitkomen met 4.3), dat je die al een paar maanden had draaien op je oude GN is beter dan dat je bij andere fabrikanten ooit gaat krijgen.

Ik vind het ook jammer, maar om nou te roepen dat het schande is...
Zelf heb ik geen Galaxy Nexus, maar het zo snel stoppen van officiŽle Google support voor dit toestel maakt me pislink. Naast geen verschrikkelijke vertragende en accuslurpende My Little Pony-achtige fabrieksschil over Android is goede update-support de belangrijkste reden voor Nexus. Dit nu wetende had ik niet alleen naar Nexus uitgegeken en mogelijk zelfs geen Nexus 7 2013 gekocht. Nexus 5 wilde ik gaan aanschaffen, maar deze toestand en de belachelijke kleine batterij vergeleken de G2 (2300 vs 3000 mAh) zijn dealbreaker.

Stock Android valt me Łberhaupt erg tegen ook al is het wel erg zuinig, stabiel en vlot. Het is te kaal, want supergoede opties uit mainstream custom roms zijn als je die gewend bent een te groot gemis. Stock is voor mij alleen acceptabel met modules via Xposed, die een beetje het custom rom gevoel terug geven.

Nexus is voor mij geen must meer. De belangrijkste reden om tot aankoop van Android apparaten over te gaan is de kwaliteit van support op xda vooral aangaande openlijke beschikbaarheid van hardware binaries voor dat apparaat.

[Reactie gewijzigd door Juliatan op 8 november 2013 14:16]

Google wilde simpelweg de licentiekosten niet betalen, en nu heeft "de community"er is overleg met TI voor gezorgd dat de drivers uit beta gehaald zijn!
Naja balen voor de Galaxy nexus gebruikers dat ze vanuit google geen updates meer krijgen. Maar mooi dat het via XDA kan.


Zat er trouwens in de Galaxy Nexus geen Omap4460? ipv 4430
Het was voor mij een reden om geen Galaxy Nexus 2e hands te gaan kopen. Wel mooi dat TI zelf gewoon alles beschikbaar stelt voor 4.4, kan Qualcomm nog wat van leren! (Zie: Desire, Desire HD, etc)
Geen 4460, deze draait stock op 1,5 GHz.
De Galaxy Nexus draait een teruggeclockte (80% van de clockspeed) Omap 4460
Daar heb je gelijk in. Daarom kan je hem vaak ook overclocken naar 1,5/1,6 GHz :p

Op dit item kan niet meer gereageerd worden.



Apple iOS 10 Google Pixel Apple iPhone 7 Sony PlayStation VR AMD Radeon RX 480 4GB Battlefield 1 Google Android Nougat Watch Dogs 2

© 1998 - 2016 de Persgroep Online Services B.V. Tweakers vormt samen met o.a. Autotrack en Carsom.nl de Persgroep Online Services B.V. Hosting door True