Cookies op Tweakers

Tweakers maakt gebruik van cookies, onder andere om de website te analyseren, het gebruiksgemak te vergroten en advertenties te tonen. Door gebruik te maken van deze website, of door op 'Ga verder' te klikken, geef je toestemming voor het gebruik van cookies. Wil je meer informatie over cookies en hoe ze worden gebruikt, bekijk dan ons cookiebeleid.

Meer informatie

Mozilla stopt volgend jaar met ondersteuning Firefox voor Windows XP

Door , 73 reacties

Browserbouwer Mozilla heeft aangekondigd dat het gaat stoppen met de ondersteuning van Windows XP en Windows Vista. De organisatie raadt gebruikers van de besturingssystemen aan te upgraden naar een moderner OS.

De ondersteuning duurt nog tot juni 2018, zegt Mozilla. Tot die tijd geeft de browserbouwer nog beveiligingsupdates uit voor de oude versies, hoewel Mozilla al enige tijd geleden stopte met het toevoegen van functies aan de browser voor XP en Vista.

Mozilla heeft de ondersteuning langer volgehouden dan Microsoft zelf. Het Redmondse bedrijf stopte een paar jaar geleden met de support voor XP en dat gebeurde eerder dit jaar voor Vista. Firefox was de laatste bekende browser die nog beveiligingsupdates kreeg op XP.

Door Arnoud Wokke

Redacteur mobile

05-10-2017 • 07:24

73 Linkedin Google+

Reacties (73)

Wijzig sortering
Goede zaak, als je nu nog een XP machine gebruikt om op het internet rond te hangen doe je gewoon iets verkeerd. Nu kan Mozilla zich in ieder geval 100% gaan focussen op het optimaliseren voor moderne besturingssystemen zonder de compatibiliteit met een fossiel als XP in gedachten te hoeven houden :)
Je zou eens moeten weten hoeveel HP Thin Clients er nog Windows XP Embedded draaien die geen updates krijgen en niet te upgraden zijn naar een nieuwer Windows :N
En hoe communiceren die dingen dan?

In ieder geval tentijde van het Diginotar-drama, bedachten Microsoft, Google en anderen dat er CA's vervangen moesten worden. Elke centralr omgeving (RDS / Citrix) kreeg de nieuwe certificaten. Gevolg was dat de thinclients niet meer konden aanloggen of een sessie opzetten. De enige omweg was om (lokaal) geen check te doen op SSL/TLS.

En aangezien thinclients amper/niet thuis gebruikt moeten worden, ben ik van mening dat bedrijven met XP Embedded sowieso al achterlopen en semi-bewust security en compliancy negeren.
Thin clients kan je gewoon beheren, en dat moet je ook doen. Het fabeltje dat je aan Thin Clients helemaal geen werk hebt gaat in mijn ogen nooit op. Lastiger is het wel.
heeft een thin client geen usb poorten die je met een omweg bootable kan maken?
want dan kan je er een usb 2.0 hdd op hangen en gewoon linux installeren (of met een snelle thumbdrive)

je kan zelfs een live-versie gebruiken van (u/x/k/l/edu/...)-buntu en alles wat je doet 'ook apps installen/upgraden) bewaren in een imagefile op de usb-drive/disk zodoende dat je niet echt een ubuntu hoeft te installeren.
Dat heeft niks meer met een managed omgeving te maken, JUIST daar zet je thin clients in. Natuurlijk kan je zo'n ding booten van USB het is immers een normale pc met een traag SATA ssdtje van 16 of 32GB oid. Je kan daar sowieso al gewoon op installeren wat je wil.
Het punt is dat je dat soort clients juist in beheerde omgevingen hebt, en daar wil je niet dat mensen gaat klooien met de hardware. USB boot staat dus uit, en BIOS staat een wachtwoord oid op. Je zou ze ook via PXE kunnen booten naar een 'beter' OS. Maar wederom, dat is niet de zin en onzin van Thin Clients. Die moet je gewoon beheren, en in bovengenoemd geval kan je er gewoon een patch of zelfs nieuw OS op uitrollen. Als een modern OS niet meer draait wordt het maar eens tijd nieuwe te bestellen, want dan zijn ze ook al lang en breed afgeschreven.
Je kan er een Linux-based thin-client van maken die je wel gewoon oneindig kan bijwerken. Die maken op hun beurt gewoon verbinding met je Citrix/RDP verhaal.

De enige reden om die hardware te vervangen is als het stuk is of niet meer de I/O doet die je nodig hebt. Dat de fabrikant de firmware niet meer bijwerkt is toch geen goede reden om alles maar weg te gooien.
'thuis' niet, maar zakelijk het heeft ook iets met kosten / baten te maken. Als ik 100 thin clients moet voorzien van Linux en ik moet daarvoor printerdrivers installeren ivm local client printing, ben ik uren bezig want ik heb veel te weinig kennis van Linux om dat centraal uit te rollen. Maar zelfs als ik dat wel centraal doe, zit ik met bv Linux die voor zover ik weet bijvoorbeeld nog steeds geen goeie support heeft voor RDGateway. En wat doe ik met lokale USB scanners, waar geen drivers voor zijn? Ja ze zijn er nog, specifieke bv paspoort scanners op USB die doorgemapt worden naar de RDS.
Windows 7 embedded of hoger past niet. Moet ik dan al die clients handmatig voorien van een aftermarkter grotere sata disk oid en dan opnieuw imagen? Dat schiet zn doel een beetje voorbij.

Bovendien zien we vaak dat die oudere thin clients (maar ook nieuwere) vaak ZO'N dramatisch slechte performance hebben, zeker gezien wat ze kosten, dat ze in de steeds grafischer wordende omgevingen gewoon niet meer voldoen.

Dus nee, Linux is echt niet overal de oplossing voor.

[Reactie gewijzigd door Rataplan_ op 5 oktober 2017 15:42]

Dus nee, Linux is echt niet overal de oplossing voor.
Zonder kennis gaat het niks worden inderdaad. Maar dat geldt overal wel voor he ;-)

ThinStation kost niks, heeft geen 'grote schijf' nodig (is een paar MB kan kan prima op bestaande SPI flash of DOM werken), geen speciale custom installatie en kan je gewoon centraal beheren met standaard configuratie management tooling. Je kan ook een image gewoon op je bestaande PXE bootserver (die heb je vast wel) pleuren en gewoon alle clients rebooten en dan ben je er al.

[Reactie gewijzigd door johnkeates op 5 oktober 2017 15:43]

Ok. Even ongeremd door kennis van ThinStation van de laatste 3 jaar: Onze eisen (of eigen die van MS):
- RD Gateway support
- Doormappen van lokale printers (dus fatsoenlijke support voor printers nodig)
- Doormappen van lokale scanners
- Fatsoenlijke multimedia perfomance (zal meer in de hardware van de client zitten, maar gedeeltelijk ook in software ondersteuning daarvoor)

Met name de eerste, RD Gateway support heeft ons al vaak problemen gegeven omdat in veel Linux distributies gewoon niet goed of helemaal niet uit de verf komt.
Ja, dat zit gewoon allemaal ingebouwd. Alleen scanners die op GDI+ vastzitten gaan niet werken. Het is ook niet 'een Linux distributie met een RDP client', het is meer een Thin Client firmware. Wij hebben ze voornamelijk als Horizon clients, maar er zitten ook nog wel wat klassieke MS setups bij.

[Reactie gewijzigd door johnkeates op 5 oktober 2017 16:31]

Natuurlijk kun je een Linux omgeving wel supporten, daar zijn zelfs speciale distributies voor:
https://thinstation.github.io/thinstation/
Natuurlijk, dat weet ik ook wel. Maar mijn punt is dat wanneer je zoals veel toko's Microsoft georiŽnteerd bent, met weinig kennis van Linux, het kosten technisch niet interessant is zoiets uit te rollen.
Waarom niet gewoon de laatste ISO van de fabrikant erop gooien, al onze TC's zijn destijds gewoon geupdate en anders nieuwe (root) certificaten installeren op je TC's, met een centraal management tool als HP Device manager of de tool van een andere TC fabrikant is dat een fluitje van een cent.

Daarnaast wordt de laatste versie van XP embedded (Embedded Standaard 2009) tot 2019 nog gesupport. Zie https://support.microsoft...ycle-faq-windows-products
Beetje kort door de bocht, als je nog achterliggende systemen hebt die werken met het NetBEUI netwerkprotocol, dan kan het vervangen van zo'n controller (pc met XP) nog een hele klus zijn. Want opvolgende windows versies ondersteunen dat niet meer. Zo zal een RWS, wat daarmee bepaalde sluizencomplexen deels aanstuurt, een miljoenen kostende uprade niet even een paar jaar naar voren halen. Of een lokaal machinebedrijf een verder prima werkende CNC frees even vervangen.
Je weet al 16 jaar wanneer de EOL van XP zou plaatsvinden, je weet al 11 jaar dat de daaropvolgende Windows versie het niet meer ondersteunen, dus je heb ruim de tijd gehad om er wat aan te doen...

Nu zou je prima nog Windows XP embeded kunnen draaien mits je het aan de andere kant helemaal dicht timmert. Geen mogelijkheid voor storage devices aan te sluiten, alleen kiosk modus, netwerk kabels vastzetten aan de netwerkpoorten en PCs, afgesloten netwerk zonder internet toegang, etc. Maar dat vertikken dergelijke bedrijven ook nog eens. En dan maar klagen dat er miljoenen aan schade is na een hack opdat toch iemand een infected laptop in het netwerk heeft gehangen en die niet geeft om XP security...
Je vergeet wel dat dit in de regel gaat om zeer dure industriŽle machines met een levensduur van 20-30 jaar tot soms nog langer. Uiteraard moet je daar je security op orde hebben (niet op internet, afgesloten netwerken e.d.), maar zomaar even een machine van een paar ton tot miljoenen afschrijven omdat de laatste XP Embedded versie in 2019 uit support gaat zal niet direct gebeuren.
Ik herken die verhalen over industriŽle machines/installaties die op verouderde hardware moeten draaien omdat ze niet te upgraden zijn eigenlijk nauwelijks. Sowieso stel je jezelf als productiebedrijf erg kwetsbaar op als je met dergelijke oude systemen blijft draaien, er is doorgaans ook geen kennis meer aanwezig en er zijn geen vervangende componenten meer te krijgen. Doorgaans zijn er redelijk betaalbare upgrade mogelijkheden door een deel of de gehele besturing te vervangen. Er zullen best bedrijven zijn met een beperkt budget en een of andere machine waarvan de leverancier niet meer bestaat, maar dat zijn echt uitzonderingen en niet de standaard in industriŽle omgevingen.
Ik kom ze ook niet dagelijks tegen hoor, maar ik zie toch echt nog geregeld Windows XP (Embedded) gebaseerde CNC machines e.d. vooral bij de kleine MBK klanten waar wij de IT doen, nu doen wij in principe niets met die machines (wij zorgen er alleen voor dat ze netwerk technisch afgeschermd zijn van de rest van het netwerk), de rest regelt de leverancier van de machines. Maar klanten hebben ook wel eens gevraagd of een upgrade naar meer recente aansturing mogelijk is en het antwoord is dan vaak "Op deze range machines is dat niet mogelijk" of "vervanging van de besturing is zo duur dat je beter een nieuwe machine kan kopen" en de paar keer dat ik een offerte gezien heb was dat ook niet mals inderdaad, Windows XP embedded vervangen door een Windows 7 Embedded oplossing kwam als snel op duizenden euro's.

Eigenlijk zouden ze leveranciers van dit soort apparatuur gewoon moeten verplichting dat wanneer je machines levert die gemaakt zijn om makkelijk 15-20 jaar in productie te draaien, dat je dan ook ervoor moet zorgen dat de software 15-20 jaar up-to-date te houden is zonder enorme investeringen.
Op Windows XP zul je een verouderde versie van SSL/TLS hebben, en ook een verouderde versie TCP/IP stack, of verouderde WiFi firmware. Dat zijn bouwstenen van een thin client. Heb je die bouwstenen op orde, kun je bijvoorbeeld in theorie Chrome met Chrome Remote Desktop of PuTTy gebruiken en doet de verdere beveiliging van je Windows XP er niet toe (mits je de rest hebt dichtgetimmert).

(Ik zeg: "in theorie", want Chrome ondersteunt Windows XP blijkbaar niet meer.)

[Reactie gewijzigd door Jerie op 5 oktober 2017 11:45]

Klopt, hier draaien ook alle thin clients op Windows XP Embedded.
Maar... XP Embedded krijgt blijkbaar nog wel updates, tot 2019 (https://www.comsysco.nl/1...indows-xp-embedded-update)

En daarbij is het enige bij ons wat op deze clients draait, een remote desktop applicatie. Dus zelfs al zou er een verouderd besturingssysteem opstaan, dan lijkt het risico mij beperkt.
Dit is wat anders dan dat wat MS zelf aangeeft voor Windows XP Embeded SP3:
https://support.microsoft...dded%20Service%20Pack%203
Einddatum uitgebreide ondersteuning: 12-1-2016
Dat gaat om de originele release, de 2009 versies van XP embedded krijgen nog wel support tot 2019..
En met een simpele registry hack kun je XP wijsmaken dat het XP embedded is. :)
Het risico ontstaat niet (alleen) door de gebruikte software.
Op zijn minst zouden dergelijke apparaten in een apart en afgescheiden netwerk (segment) moeten draaien en beschermd moeten worden tegen het mounten van storage en het gebruiken van onbekende hardware. Als het niet meer ondersteund wordt, moet je ervan uitgaan dat het zo lek als een zeef is.

Ik zou ook enkel en alleen de ondersteuningsinformatie van de fabrikant en Microsoft vertrouwen.
Dan moeten die volledige systemen vervangen worden. En volgende keer beter nadenken welk systeem wordt aangeschaft, zodat het wel te upgraden is.

Typisch gevalletje goedkoop=duurkoop...
Typisch gevalletje goedkoop=duurkoop...
Jij wist dus al ver van te voren, dat na W7 Microsoft redelijk snel alweer met eerst W8 en daarna W10 zou komen?
Jij wist dus misschien ook al, dat Intel geen W10 drivers voor jouw CPU wil maken, waardoor er niet kan worden geupdate. |:(

Knap van jou. _/-\o_
Informatie mbt de ondersteuning is zowel in het geval van Microsoft als intel beschikbaar bij lancering.
Wat niet specifiek (toekomstig) ondersteund wordt, moet je ook als niet ondersteund beschouwen. Je kan er nooit vanuitgaan dat soft-of hardware leveranciers zomaar ondersteuning zullen toevoegen voor nieuwe soft- of hardware combinaties.
Dus kort gesteld: je kon het niet weten, maar je mocht er ook niet van uit gaan ;)
Ben ik met je eens, maar Intel heeft wel een hoop mensen laten barsten door de Atom N2600 chip niet te ondersteunen met W10 drivers
Deze chip werd in heel veel systemen ingebouwd.

W7 is het laatste wat er ondersteund werd.
Launch date Q4'11
Windows 8 ergens mid'12
Intel kon ook niet voorzien wat de minimum reqs waren voor Windows 8 en volgende... zoals ik zei: ga er niet van uit....
Dan moet Microsoft eens de upgrade van XP naar W7 mogelijk maken.

Microsoft is wat mij betreft de hoofdschuldige dat er nog zoveel mensen met XP werken. Als die mensen een W7 licentie hadden/zouden kunnen kopen en dan hun systeem, met behoud van alle geÔnstalleerde software, zouden kunnen upgraden naar W7 en van daaruit evt. verder hadden/zouden kunnen doorgroeien dan had 99% dat allang gedaan.

Maar dat kan niet. Nu moet je eerst naar Vista upgraden en van daaruit naar W7, wat stukken lastiger en meer gedoe is.

Microsoft zou nog steeds een dergelijke upgrade mogelijk kunnen maken. Gewoon een installer maken die je kunt opstarten en die de upgrade-installatie kan uitvoeren met de installatiebestanden evt. van een ander medium. Als Microsoft zijn verantwoordelijkheid eens zou nemen zouden ze dit nu alsnog eindelijk eens moeten doen.
Het is dus wel degelijk mogelijk ťn ondersteund. Je moet alleen de aangeboden procedurss volgen.
Je moet ook geen >10 jaar wachten om een upgradeplan uit te dokteren.
Als je nu nog XP moet gaan migreren ben je imho schromelijk en nalatig te laat.
Dat kun je niet echt bij MS op het bordje gooien, de hardware en 3rd party software moet allemaal ondersteund worden door Windows 7 (of hoger) in zo'n geval (nu nog upgraden naar Windows 7 heeft ook niet heel veel zin) anders kan je zo'n upgrade helemaal niet faciliteren als MS zijnde.

Daarnaast is upgraden nooit de aanbevolen werkwijze geweest tot aan Windows 10 (waar het upgrade proces volledig veranderd is). Herinstallatie is altijd best practise geweest en ook gewoon altijd mogelijk geweest (mits de hardware gesupport is door de nieuwe versie).
ik weet niet wat een gangbare levensduur van die thin clients zijn... maar er zou inmiddels toch wel budget voor moeten zijn om deze te vervangen..
Precies wat proxx zegt. Na zoveel jaar xp heb je toch hopelijk een fatsoenlijk budget om die dingen te vervangen? Vandaag de dag nog xp... Of de zaken gaan heel slecht of er zijn andere redenen..
Tim cliŽnt draaien zelf een remote desktop app? Dan maakt het een stuk minder uit.
Windows XP Embedded heeft nog gewoon Support en ontvangt daarom nog steeds updates:

- Windows Embedded Standard 2009.
- This product is an updated release of the toolkit and componentized version of Windows XP. It was originally released in 2008, and Extended Support will end on January 8, 2019.

- Windows Embedded POSReady 2009.
- This product for point of sale devices reflects the updates available in Windows Embedded Standard 2009. It was originally released on 2009, and extended support will end on April 9, 2019.

Source: https://support.microsoft...ycle-faq-windows-products
en moet op een thin client een browser draaien?
Da's wel wat kort door de bocht. XP is het laatste windows OS wat het NetBUI netwerkprotocol gebruikt. Als jij zeg een sluizencomplex daarmee aanstuurt, of een MRI scanner waar een ziekenhuisvleugel omheen gebouwd is, dan is daarmee blijven werken, bijvoorbeeld door wat extra te betalen aan support van Microsoft of extra veiligheidsmaatregelen, met afstand de meest efficiŽnte keus.
Ik snap dat oude systemen niet zomaar overgezet kunnen worden, maar of het een goed idee is om "www" functionaliteit te behouden op deze systemen is een andere discussie.

Bij mijn ouders heb ik er specifiek er voor gekozen om een Win XP machine los te koppelen van het internet, zodat de bedrijfs belangrijke software die alleen daar op functioneerde niet meer in gevaar kwam. Daarnaast heb ik een Win10 systeem neer gezet, welke voor internet en testverwerking word gebruikt.

Dit is in grotere systemen lastiger. Vooral als systemen verder van elkaar af staan. Dan is internet al snel de beste optie. Maar hier kan in sommige oplossingen ook gedacht worden aan dark-fibers (een verbinding die specifiek voor een toepassing aangelegd en gebruikt word), dit is duur, maar wel veiliger.
Virtualisatie 😉, hyper-v in win10 pro of bijv. Vmware player (gratis) of virtualbox (gratis)
De actie bij mijn ouders hing ook op poorten, op de 1-of-andere manier wou het kastje dat er aanhing niet met USB-COM adapters werken. Vage ding in ieder geval. Dus bedacht ik de 2 PC oplossing. Daarnaast is een aparte pc aan slingeren en uit te leggen aan niet technische mensen makkelijker.
Een virtuele Win xp machine is niet veiliger dan een fysieke..
Uiteraard, maar wel qua kans dat het defect raakt.
Klopt, zo werk ik op mijn werk ook. Daar maak ik met het host OS pdf bestanden aan die op de VB WinXP worden afgedrukt. Verder heb ik op de VB WinXP alle internettoegang afgesloten door een onbekende proxy, zeg maar een 127.0.0.1 te sluizen.
En mocht het toch mis gaan, dan eenvoudig een kopie van de VB WinXP terugzetten.
Virtualisatie is lang niet altijd een oplossing bij Embedded software versie's, zeker omdat de (custom) interfaces die de MRI scanner / CNC machine of wat voor apparaat dan ook aansturen lang niet altijd gesupport worden in een virtuele omgeving.
Zal aan de omgeving liggen, bijv. proxmox ondersteund het doorsturen van lokale poorten naar de VM, dan heb je dat iig niet.
Dat het ondersteund wordt in de virtualisatie software betekend helaas niet altijd dat het ook daadwerkelijk werkt, zeker niet met niet standaard interfaces. Maar zelfs bijv. iets simpels als USB-Passtrough werkt niet in alle gevallen. Zo heeft vSphere gewoon USB-Passtrough support, maar sommige dongels voor licentie activatie weigeren te werken via USB-Passtrough. Met zaken als speciale seriele of parallelle interfaces is het vaak nog spannender of het werkt, ook al is de support er in de basis om de interface door te geven.

[Reactie gewijzigd door Dennism op 5 oktober 2017 13:15]

@Neko Koneko zegt dan ook "om op het internet rond te hangen". Ik begrijp dat een sluizencomplex moet kunnen communiceren over een netwerk maar hopelijk gaat dat over een zwaar afgeschermd VPN. Een MRI scanner communiceert hopelijk al helemaal niet met het open internet, maar slechts met de computer die in het kamertje er naast staat waarop de beelden worden bekeken.
xp machines horen al lang niet meer aan het internet te hangen daar zijn geen excuses voor als je een betrouwbaar systeem wilt hebben. Hangen ze niet aan het internet dan hoeven ze ook geen updates te hebben zeker niet van de browser...
tevens netbui werkte onder vista en onder 7+ is het NetBT
Maar ik denk dat je 7 kunt aan passen door de vista versie te installeren... Misschien zal je wel even de installer moeten hacken/ tweaken...en Windows 7 toe voegen. Maar eigenlijk is de vervanger NetBT geworden...
Op mijn werk gebruiken we bijvoorbeeld hyperterminal voor ontzettend veel verbinding.
Om te praten met oude apparatuur of verbindingen op te zetten met terminals. Maar toch zijn alle computers Windows 7 of Windows 10. Windows Xp was ook het laatste os waar hyperterminal standaard in zat. Maar wij zijn ook met de tijd mee gegaan hebben. Hebben alternatieve programma's gevonden zo als powerterm en putty die prima draaien onder Windows 7 of 10. Veel oude computers zijn ook vervangen door remote IO 4 com porten met een netwerk verbinding verbonden met een pc op afstand. In onze slagbomen zaten vroeger industriŽle pcs met Xp standalone machines geen netwerk verbinding. Gelukkig allemaal verleden tijd

We hebben wel wat 4 oude laptops met Xp liggen voor legacy support hele oude apparatuur die heel af en toe gebruikt wordt uitlezen en in stellen van touch screens, lazers ect ect totaal niet interessant om een upgraden naar Windows 7. deze worden ook langzaam uit gefaseerd
Ook die hebben geen updates nodig

[Reactie gewijzigd door j1b2c3 op 5 oktober 2017 09:59]

Precies dat kan anno 2017 niet echt meer , zie het heel af en toe voorkomen in bedrijven maar dan heeft het meer een intranet functie dan echt internet.

Maar petje af voor Firefox dat ze XP nog zo lang hebben ondersteunt.
Precies, een besturingssysteem ondersteunen die geen updates meer krijgt is onnodig en kan mensen zelfs een verkeerde indruk geven over de veiligheid van internetten op Windows XP. Het is nogsteeds jammer dat het uitfaseren van XP zo traag gaat.
naja, ik heb xp nog draaiende in vmware voor bepaalde stokoude software / games
Je zult je windows xp machine maar in leven moeten houden anno 2017. Het laatste apparaat wat bij ons nog op win xp draaide was een oude pc uit 2008. Dit jaar overleden vanwege defecte harde schijf en dat moederbord is behoorlijk gammel.
Mwah, valt wel mee. Hier draait nog een oude thin laptop op XP probleemloos als dedicated jukebox aangezien de 855GM mobo chip juist geen support heeft voor Win10. Wel offline gehaald natuurlijk.
Kan toch ook Linux op? ;)

Ik zeg het met een knipoog, want steeds minder distributies ondersteunen officieel de x86 architectuur. AMD64/x64 natuurlijk wel. Voor een offline jukebox is het risico natuurlijk klein, als hij maar offline blijft. Niets mis met een beetje recyclen. :)

[Reactie gewijzigd door The Zep Man op 5 oktober 2017 08:55]

Niet altijd. Sommige oude Atoms (met GMA 3600 GPU) worden slecht ondersteunt door Linux. Dan kan je overigens wel naar Windows 7 upgraden.
Zolang het draait, draait het. Als er echter iets kapot gaat succes met het zoeken van een onderdeel dat past ;) Met wat geluk kun je op de tweedehands markt iets vinden maar dan is het ook maar de vraag hoe lang dat betrouwbaar blijft werken.
Zolang het draait, draait het. Als er echter iets kapot gaat succes met het zoeken van een onderdeel dat past ;)
Het zal je verbazen hoe lang sommige oude hardware nog meegaat. Bij oude laptops trek je de accu eruit (toch niet nodig op een vaste plek), je vervangt de HDD met een SSD/CompactFlash kaart m.b.v. een adapter, je zorgt ervoor dat de fan niet onnodig hoeft te draaien (koel = uit, blijft koel = blijft uit) en de kans is groot dat het nog jarenlang mee gaat.
Dan kun je hem toch naar windows 7 upgraden?
Is het niet al een tijdje bekend dat Firefox dan zou stoppen? Dit is toch oud nieuws?

Having said that; good riddance. Ik veronderstel dat er nu wel weer een hoop legacy code gedropt kan worden van Firefox nu er geen rekening meer moet worden gehouden met XP en Vista. In 1 klap is het oudste OS dat ze ondersteunen plots 8 jaar jonger (hoewel 7 ook alweer 8 jaar oud is).
https://support.mozilla.o...port-windows-xp-and-vista

Firefox 52 dus is de laatste versie voor XP en Vista. Ik neem aan dat ze dus toen al zijn begonnen met het eruit slopen van de legacy code.
Ik vind het terecht. Als het OS zelf niet eens meer ondersteund word (door Microsoft) waarom zouden browsers de laatste versie dan nog wel moeten ondersteunen. Iedereen blijft in mijn ogen te lang de oude zooi (kijk webdevlopers websites bouwen voor een ancient IE versie). Het is meer dan 10 jaar geleden.
XP is de langst operationele besturingssysteem, die met beveiligingsupdates werd ondersteund, tot dusver.

Bron: Wikipedia
De ondersteuning voor Windows XP werd beŽindigd op 8 april 2014. Dit betekent niet dat Windows XP niet meer bruikbaar is. Er is wel een verhoogd risico op virussen en spyware, omdat Windows XP niet langer van beveiligingsupdates wordt voorzien door Microsoft. Op 12 mei 2017 bracht Microsoft echter uitzonderlijk een beveiligingsupdate uit om gebruikers te beschermen tegen een wereldwijde cyberaanval met ransomware.

On October 25, 2001, Microsoft released Windows XP (codenamed "Whistler"). The merging of the Windows NT/2000 and Windows 95/98/Me lines was finally achieved with Windows XP. Windows XP uses the Windows NT 5.1 kernel, marking the entrance of the Windows NT core to the consumer market, to replace the aging 16/32-bit branch. The initial release met with considerable criticism, particularly in the area of security, leading to the release of three major Service Packs. Windows XP SP1 was released in September 2002, SP2 came out in August 2004 and SP3 came out in April 2008. Service Pack 2 provided significant improvements and encouraged widespread adoption of XP among both home and business users. Windows XP lasted longer as Microsoft's flagship operating system than any other version of Windows, from October 25, 2001 to January 30, 2007 when it was succeeded by Windows Vista.

Windows XP Embedded Service Pack 3 14-11-2008 11-1-2011 12-1-2016 Ondersteuning eindigt of 24 maanden na verschijning van het eerstvolgende service pack ofa aan het einde de ondersteunings-lifecycle van het product, afhankelijk van welke als eerste komt. Bezoek voor meer informatie over Service Pack ondersteuningsbeleid https://support.microsoft.com/help/17138.

Nu stopt Firefox met het ondersteunen van updates om veiliger te kunnen surfen op het internet met Windows XP. Geweldig dat het 16 jaar voorzien was van updates.

[Reactie gewijzigd door DefaultError op 5 oktober 2017 10:01]

Als je het beveiligingsgedeelte niet interesseert, wat is dan het probleem?

Vader draait gewoon XP x64, op een Skylake i7, met 16gb ram....
Draait vele malen sneller dan de bloatware in Windows 10... Geen caching, maar superfetch is niet altijd heel efficient. Verder is er qua performance vrij weinig verandert.

Waarom: Want exporteren uit Outlook express lukt niet (error melding, maar gegevensbeastanden overzetten naar andere Outlook Express lukt wel) en XP is veel flexibeler met overzetten naar andere moederbordjes, hij hangt zijn HDD elke 2-3 dagen wel aan een ander systeempje, van de nieuwste generatie tot aan lga775 systemen, gewoon dat wat voorhanden is.

[Reactie gewijzigd door SnoVVdog op 5 oktober 2017 10:04]

Ik denk dat de code die specifiek voor XP/Vista geschreven is minimaal is. Op zich was de overstap van XP naar Vista groot (registry redirection, 32/64-bit, UAC etc), maar tussen Vista en opvolgers een stuk kleiner. Weliswaar is in Windows 2008R2 en later wat zaken gekomen voor multi-socket/NUMA zaken, maar daar heeft volgens mij een browser niet mee te maken. De tendens die ik zelf zie (als C/C++ ontwikkelaar) dat steeds minder Windows-versie specifieke code geschreven hoeft te worden.

Ik verwacht dat dan de support voor Windows Server 2003 en 2008 ook vervalt. Dat zijn de 'server' tegenhangers van genoemde OS versies.
Naar mijn weten is Opera ook een bekend browser en die ondersteunen windows XP ook voorlopig nog wel even. Dus de laatste regel van dit artikel is niet helemaal correct. O-)
Maarja, nieuwe applicaties installeren die gebruik maken van TLS1.2 etc geeft je problemen aangezien deze niet meer voor Windows XP en Vista beschikbaar zijn. Om maar een voorbeeldje te noemen. Ik denk dat als je nog op XP draait dat je dan maar een paar (oudere) vaste applicaties draait.
Lukt mij niet eens meer om fatsoenlijk een XP virtual machine te installeren zonder dat die in een loop gaat voor verificatie (was sowieso hier op de zaak al moeilijk om nog een werkende key te kunnen vinden, bijna ale oude keys zaten op computers die inmiddels gerecycled zijn).
Valt niemand iets op aan het getoonde plaatje?... Daarop zou Firefox 53 draaien op XP SP3; een combinatie die "officieel" niet zou moeten werken!?... Interessant! :)
Domme zet van Mozilla.

Marktaandeel van Firefox zit in een dalende spiraal, nu schoppen ze een aantal van hun trouwste gebruikers voor de schenen. Indien XP gebruikers overstappen naar een ander OS is er geen enkele reden om opnieuw firefox te gaan gebruiken want binnenkort werken de meest firefox extensions niet meer op nieuwere versies van firefox. Steeds minder redenen om firefox te gebruiken ipv chrome.
Het gros van de XP-gebruikers had al 3 jaar geleden op een nieuwer OS moeten zitten en zit dat ook. Die paar gebruikers die nog stug op XP blijven zitten zijn voor Mozilla waarschijnlijk de moeite niet waard.

Op dit item kan niet meer gereageerd worden.


Apple iPhone X Google Pixel 2 XL LG W7 Samsung Galaxy S9 Google Pixel 2 Far Cry 5 Microsoft Xbox One X Apple iPhone 8

© 1998 - 2017 de Persgroep Online Services B.V. Tweakers vormt samen met o.a. Autotrack en Hardware.Info de Persgroep Online Services B.V. Hosting door True

*