Cookies op Tweakers

Tweakers maakt gebruik van cookies, onder andere om de website te analyseren, het gebruiksgemak te vergroten en advertenties te tonen. Door gebruik te maken van deze website, of door op 'Ga verder' te klikken, geef je toestemming voor het gebruik van cookies. Wil je meer informatie over cookies en hoe ze worden gebruikt, bekijk dan ons cookiebeleid.

Meer informatie

Door , , 15 reacties
Submitter: contrast

Een versie van het Xposed-framework voor Android 6.0 is uitgekomen. De ontwikkelaar kondigde vorige week al aan dat de release eraan zat te komen en op zondag heeft hij versie 78 van zijn framework om geavanceerde tweaks mogelijk te maken online gezet.

Xposed 78 is uitgekomen in meerdere varianten, waaronder versies voor Android 6.0, 5.1 en 5.0, die de ontwikkelaar aanduidt met de versienummers van de sdk: 23, 22 en 21. Daarnaast moeten gebruikers de juiste versie voor de processor in hun telefoons hebben: ARM, ARM64 of x86. De ARM-versie is voor toestellen op basis van ARMv7-architectuur, zoals de Nexus 5, Nexus 6 en OnePlus One. De ARM64-versie is voor processors op ARMv8-architectuur, die 64bits ondersteunt, zoals de Nexus 5x en 6p en vrijwel alle andere high-end en midrange-telefoons uit 2015.

Ontwikkelaar rovo89 meldt een bug in stock roms op Samsung-telefoons. Er zijn niet-officiële versies die dit oplossen. Er zijn ook problemen met bepaalde firmwares op Sony-telefoons, maar de ontwikkelaar noemt die niet specifiek.

Xposed is een plug-in-framework voor modules die geavanceerde tweaks op Android-telefoons mogelijk maken. Zo zijn er bijvoorbeeld modules om de taal per applicatie in te stellen, om thema's in te stellen in WhatsApp en om te verbergen dat een gebruiker root-toegang heeft om apps te draaien die weigeren te functioneren met root. In totaal bevat de repository 735 modules.

Moderatie-faq Wijzig weergave

Reacties (15)

Wel jammer dat het niet werkt met stock android roms voor Samsung. Moet binnenkort maar even kijken wat het meest in de buurt komt voor mijn Samsung Galaxy S6.
Je zou XtreStoLite kunnen proberen, die is compleet stock (odexed versie de-odexed zijn wel wat system files aangepast) maar haalt, op de echte stock apps na, alles weg (wat je wel kan installeren via een andere pakket)

En xposed werkt er perfect op.

Ps: geen 6.0 momenteel
Die rom heb ik idd ook, maar xposed werkte volgens mij niet toen ik het probeerde.
Klopt, Samsung support is pas sinds 1 of 2 versies volgends mij. Ik gebruik zelf een unofficial en versie van wanam.
Welke heb jij dan? Ik had de sdk 22 ARM64 gepakt, maar daarmee kwam ik in een bootloop terecht.

Heb nu de Wanam geprobeerd. Kijken of ik in bootloop terecht kom. Fingers crossed, rebooting.

Geen bootloop, is de apps aan het optimaliseren nu. Tnx!

[Reactie gewijzigd door Miglow op 16 november 2015 14:44]

Anders heb je nog Omega rom, debloated stock rom die dicht bij TouchWiz blijft.
Anderzijds, ik ben kortgeleden overgestapt naar Cynagenmod (vanwege onder andere de privacy adviseur en omdat het op sommige punten veel handiger is) en ik zou eigenlijk niet zo snel meer terug willen
Iemand ervaring met het installeren van dit Framework op een Oneplus One? Wat mij met name interesseert is of het mogelijk is om op een device zonder root-toegang dit pakket te installeren.

Omdat mijn werktelefoon een OPO is, wil ik hem niet rooten
Niet mogelijk om Xposed te installeren zonder root. Wel kan je met Xposed je root verbergen met een module. Dus dan heb je wel root, maar het wordt niet gedetecteerd. Op een werktelefoon lijkt me dit tricky als root is verboden vanuit het bedrijf. Er is ook een module voor de GOOD app voor rooted devices.
Bedankt voor je reactie.

Het is niet zo zeer verboden, maar het is meer dat als het fout zou gaan ik ook verantwoordelijk ben om een vervangend exemplaar te regelen. Op eigen kosten uiteraard :).

Nu weet ik uit het verleden dat er weinig fout kan gaan, maar heb wel eens een telefoon gehad die op willekeurige momenten ging herstarten uit zichzelf.
Als je Xposed voor MM gaat flashen, let er goed op of je modules MM compatibele zijn! Anders krijg je weer bootloops.

Hier is een lijst met tot nu toe bekende compatibele modules.
Zoiezo is het altijd aan te raden om een nandroid backup te maken voordat je aanpassingen doet aan je /system directory.
Eigenlijk was het alleen maar voor de App rechten dat ik xposed gebruikte. Maar nu dat het standaard in Android 6 zit heb ik het eigenlijk niet meer nodig.
NIet alle roms werken goed met deze Xposed. Ikzelf draai de laatste Xtrasmooth op mn NExus 5, maar geeft ie aan dat framework niet geactiveerd is.
Jammer, werkt niet op Nexus5 met marshmallow.
Hoppa!
Hopelijk kan ik gewoon me rom upgraden van 5.1.1 naar 6 en dan xposed upgraden.. en dan maar hopen dat alles compatible is.
Wat ik uiteraard wel verwacht van xposed.

+1 Aanrader!

[Reactie gewijzigd door robbinwehl op 16 november 2015 08:28]

Op dit item kan niet meer gereageerd worden.



Apple iOS 10 Google Pixel Apple iPhone 7 Sony PlayStation VR AMD Radeon RX 480 4GB Battlefield 1 Google Android Nougat Watch Dogs 2

© 1998 - 2016 de Persgroep Online Services B.V. Tweakers vormt samen met o.a. Autotrack en Carsom.nl de Persgroep Online Services B.V. Hosting door True