Cookies op Tweakers

Tweakers maakt gebruik van cookies, onder andere om de website te analyseren, het gebruiksgemak te vergroten en advertenties te tonen. Door gebruik te maken van deze website, of door op 'Ga verder' te klikken, geef je toestemming voor het gebruik van cookies. Wil je meer informatie over cookies en hoe ze worden gebruikt, bekijk dan ons cookiebeleid.

Meer informatie

Door , , 76 reacties
Bron: GTA Forums

Spelontwikkelaar Rockstar heeft de eerste patch voor de pc-versie van Grand Theft Auto IV vrijgegeven. De update kan via Windows Live toegepast worden of vanaf deze server als losse update worden gedownload. De ontwikkelaars van GTAIV hebben onder meer de video-editor onder handen genomen en het geheugengebruik verbeterd. Verder zijn er verbeteringen aangebracht in de ondersteuning van de ATI Radeon X1900 en is er een crashbug uit het spel gehaald. De volledige lijst met veranderingen die de patch met zich meebrengt ziet er als volgt uit:

Changelog
  • A fix to the crash after legal screen that some German customers were reporting.
  • Numerous improvements to the video editor: Smarter naming of videos, improved rendering quality, better fx during replays.
  • Fix to bowling while using certain sensitive mice.
  • Fix for ATI 1900 shadows.
  • Overall savings to memory.
  • Graphic improvements to particle systems and mirrors.
  • Multiplayer character settings are preserved.
  • Support for DirectInput controllers.
[break]
Grand Theft Auto IV
Versienummer:patch 1
Releasestatus:Final
Besturingssystemen:Windows XP, Windows Vista
Website:GTA Forums
Download:http://msxb-d1.vo.llnw.net:3074/content/5454083b/5454083B1000008310000183.cab
Bestandsgrootte:32,65MB
Licentietype:Freeware
Moderatie-faq Wijzig weergave

Reacties (76)

Hmm heel even goede hoop gehad maar na installatie van de patch en starten van GTA4 blijft de camera (het beeld) rondjes draaien en heb ik XBox controls in mijn menu.
Waardoor esc opeens veranderd in de (rode) b ingedrukt te houden en vervolgens esc in te drukken....... huh???
Zoals ik net al zei, ontkoppel je guitar hero controller of andere controller, gta iv kan hier niet meer omgaan.
Ze mogen SLI wel eens werkend krijgen, eerlijk gezegd. Dat kost vast behoorlijk wat werk, maar ik hoop wel dat het bovenaan hun prioriteitenlijst staat.
SLI werkt als je de nieuwe Nvidia 180.84 drivers gebruikt.
Ik heb 180.84 al een tijdje, en vandaag die update ge´nstalleerd. Ik heb toch echt nog steeds slechts 489MB gfx memory tot mijn beschikking in de options. (Geforce 9800GX2)
Oplossing is eenvouding:

- Maak een commandline.txt file aan en zet deze in je GTA IV folder
- Zet in deze txt file de volgende opties, achterelkaar:

-nomemrestrict -norestrictions -novblank -availablevidmem 2
Waarbij de kanttekening gemaakt moet worden dat het spel dan langzamer werkgeheugen gebruikt.
Dit komt omdat je een dual GPU kaart hebt. Hierbij heeft elke GPU een eigen stuk geheugen en moeten ze beide dezelfde data hebben in lokaal geheugen. Effectief kun je dus ook maar 512MB gebruiken. Zelfde geld voor alle Crossfire en SLI opstellingen/kaarten.
Ik heb gehoord dat dat nu werkt, ookal staat het niet in de changelog.

De starter/club zijn trouwens compleet buiten deze update gelaten, daar is niets aan veranderd :)
De starter/club zijn trouwens compleet buiten deze update gelaten, daar is niets aan veranderd
Ah dat was zeer nuttige info, thanx. }>

Anyways, ook met de patch zit er nog kleine graphics bug voor me in (NVidia, geen SLI). De game wil af en toe het stuk ondergrond (stuk weg of brug) die direct onder je wielen zit opeens beschouwen als iets wat 'ver weg' is en daarom de details wehalen. Dit is maar voor 1 seconde ofzo maar toch een beetje storend.
E8400 op 3,6ghz
4GB ddr800
2x9800gtx
Nforce 750i moederbord
1680x1050
Vista 64 (XP is in deze tijd voor zuurpruimen die Vista niet snappen)

View distance: 32
Detail distance: 40
Vehicle density: 40
Texture resolution: medium
Rendering quality: highest

Ik heb ook die blur filter aan. Druk op P tijdens het spelen om hem aan te zetten. Echt een aanrader!

Na de nieuwe patch en Nvidia driver werkt SLI, maar ik merk weinig verschil. Al met al ben ik heel tevreden hoe het eruit ziet en hoe het draait. Ik zit constant rond de 40 frames, zonder storende dalingen. Tuurlijk, 60 zou mooi zijn, maar het is prima speelbaar.

Ik denk dat een hoop mensen de instellingen te hoog willen zetten. Op medium is het al een prachtig spel. Kijk eens goed hoe het er als geheel uitziet. Je bent voor het eerst in een spel in een echte, levende stad. Auto's, voetgangers, het weer etc... het gebeurt allemaal tegelijk. De physics zijn ook opvallend knap gedaan (rij maar eens zachtjes tegen iemand aan. De manier waarop mensen je auto van zich af duwen klopt ook precies), dat moet ook een hoop power kosten. Vergeet ook niet dat met alle instellingen op low het er nog steeds mooier uitziet dan op de xbox of ps3.

Het enige probleem dat ik soms heb, is dat ik geen verbinding krijg met Rockstar Social Club. Maakt op zich niet heel erg uit, omdat ik nog volop met de single player aan de gang ben. Waarschijnlijk overbelaste servers.

Crashes enzo heb ik nooit last van gehad. Ik heb de Steam versie trouwens.

Ik kan niet wachten op het volgende deel.
Patch ge´nstalleerd, nieuwste ati drivers 8.12 ge´nstalleerd. Heeft helemaal niks opgelost. Moet nog steeds resolutie terugbrengen naar 1024x786 wil het spel Řberhaupt opstarten. Vervolgens is dat in het spel ook de maximale resolutie die ik kan instellen. Erg slecht dit.

Heb vista x64 icm ATI HD4870

[Reactie gewijzigd door Whats85 op 14 december 2008 13:24]

De 8.12 drivers schijnen nogal wat problemen op te leveren. Zie het Ati Driver Forum
Vaag, ook ik heb vista x64 en draai GTA IV op mijn HD4870x2 op zijn hoogste instellingen. Ik krijg alleen de bekende RESC:10 error (ofzoiets). En mijn crossfire werkt nog niet. Maar hier zal ATI wel met een patch komen neem ik aan.

Edit: ik heb de patch nog niet geinstalleerd, ik hoop dat die error nu dus ook weg zal zijn.

[Reactie gewijzigd door Cyw00d op 14 december 2008 13:36]

Ik krijg zowel voor als na de patch nog steeds de RESC10 error, gemiddeld zo eens per half uur spelen. OK, Da's dan wel met een GeForce GTX 280 systeem, maar toch.
Ik kreeg eerst ook regelmatig RESC10 errors met een HD4870X2, maar sinds ik de Catalyst 8.12 heb en ik de graphics instellingen iets hebt teruggeschroefd naar de veilige zone qua videogeheugen loopt ie prima stabiel.
Ja ik stel hem in op gemid. helft van mijn zichtbare-geheugen voor GTA. dus rond de 512. Ik heb 8.12 en krijg nog steeds die error. Zal nu eens proberen met de patch. Ben erg benieuwd, want dit soort praktijken maken dit spel zwaar irritant.
@Frankknopers

Dat is juist het probleem, ik heb ook een HD4870X2 en ik moet mijn graphics terug schroeven. Lees: Graphics terug schroeven, op (momenteel) de snelste kaart van de wereld. 8)7
Een quadcore q9950 @ 2,84Hgz, en geheugen van 4 GB, en ze willen dat ik de graphics terug schroef, volgens mij hebben ze daar een cursus efficient programmeren nodig.

Op (zwaar verouderde) hardware zoals Xbox360 loopt het zelfs nog beter, ben ik nu gek?
Vergeet niet dat de render distance op de xbox / ps3 ongeveer is wat je krijgt als je op de PC setting 5 / 100 gebruikt... ;)
Je heb helemaal gelijk. Ik bedoel: Er zitten nog (programmeer)fouten in dit spel. Nog na de update. Ik kreeg zojuist een foutmelding dat ik onvoldoende video-geheugen heb. En dat terwijl hij toch nog vrij laag staat ingesteld. Ik hoop dat ATI of Rockstar alsnog met een volgende patch komt. Ik denk dat ATI met een hotfix moet komen om dit probleem op te lossen. Vrij irritant, zat zojuist midden in een missie.

4870x2, 4GB DDR2-800, E8400 op 4GHz.

[Reactie gewijzigd door Cyw00d op 14 december 2008 15:31]

Als jij de setting net zo zet als de xbox 360 (dus geen 1 setting boven de 20 en medium geloof ik loopt het vast wel goed hoor ;)
Oh op hoogste he?

Kun jij dan de viewing distance op 100 zetten? Ikke niet hoor (4870x2 hiero)

Rest kan allemaal max ja, maar die toch niet, dan krijg ik de melding dat het geheugen op de videokaart vol is.

Patch 1.1 installed...
Ik heb ook een HD4870 en ik kan redelijk goed draaien op 1680x1050 (gemiddeld 28 fps). Ik denk dat je processor het probleem is.

[Reactie gewijzigd door Ywa op 14 december 2008 15:21]

Dat mag je toch ook wel verwachten.....heb de patch nog niet ge´nstalleerd...wacht het eerst wel ff af. Catalyst 8.12 draait ook prima :)

Heb zelf een 4850 en draai het prima op Very High @ 1680 x 1050.
Daarom snap ik ook niet dat men er zoveel problemen mee heeft....

wel verrot als je zo'n dur kaartje heb.
Hier is mijn processor (AMD Athlon64 X2 6400+) het probleem waardoor ik niet op very high kan spelen (ik speel op high). Me videokaart kan wel beter denk ik. Tijdens het spelen is me CPU verbruik op 100% en af en toe 90%.
Ik had veel problemen, maar door een biosupdate van mn sapphire 4870 isdat allemaal gefixt. welke fabrikant is jou radeon? miss ook update voor jou beschikbaar. ik gebruik vista business x64, met catalyst 8.12, game loopt zeer stabiel. ik heb sinds mijn biosupdate geen enkele game crash meer gehad, en zie ook weinig verandering met deze game patch. Het aantal lege grijze texture vakken is trouwens wel afgenomen.

hebben jullie trouwens ook dat de schaduwen erg 'korrelig' zijn, alsof ze met MS paint aan de randen met de verfbus pray zijn gedaan ofzo?
Is ook een bekend probleem met ATI kaarten. Zelfde geldt hier voor m'n 3870CF setup, erg vreemde schaduwen. Niet echt heel storend, maar mooi is anders...

Ik heb hier XP64, 4gb geheugen en 2x 3870 in CF. Had eerst problemen met blacked out textures, maar toen moest ik m'n mipmap settings op highest quality zetten in CCC. Toen deed alles het goed, op de schaduwen na...
Wat ben ik blij dat ik het spel zonder problemen mijn xbox kan spelen.
tja, eerste waar ik aan dacht. Blijft toch voor mij de grootste reden dat ik een PS3 heb, geen kosten voor om het jaar een PC uit te breiden en dit soort problemen die je toch vaak alleen bij de PC hebt, omdat het nou eenmaal moeilijker is spellen goed te laten lopen op alle mogelijke systemen.
Vergeten dat kort na de release van GTA IV op PS3 een patch werd uitgebracht, voor ongeveer dezelfde problemen als nu aanwezig zijn bij de PC versie.

GTA draaide hier perfect gedurende een lange tijd. Plots na het doen van een bepaalde missie crashed het spel elke 10min. Lijkt me sterk dat dit de oorzaak is van PC's, wel van een belabberde coding.
en ik ben blij dat ik het zonder problemen op me pc kan spelen met lekkere graphics

Het is echt pech hebben wil het niet op je pc draaien (of geluk dat het wel draait)
want er zijn genoeg mensen die geen problemen hebben!
nou idd, ik zou er bijna een xbox voor halen!
heb je voor de Xbox ook geen flinke patch nodig? ik kan me alle verhalen nog wel herinneren.
Er zijn wel weer diverse problemen gecreŰerd als ik de diverse fora afga...
Sinds de nieuwe ATI drivers worden mijn grafische instellingen niet bewaard. Moet ze telkens opnieuw instellen als ik het spel opstart. Eens kijken of de performance verbeterd is (ik heb een ATI X1950XT).
dat was ook al zo voor 8.12. dat is een fout van het spel.
hier draaide het spel acceptabel op high/high op een e6600, 8800GTS640 en 6gb ram. tot de patch, deze heeft bijna 2/3 van mijn FPS afgehaald, en alle (grafische) bugs lijken er nog gewoon in te zitten. wat een aanfluiting dit zeg, hadden ze in die 2 weken testen niet ff de moeite kunnen doen om hem op een 8800GTS te draaien?

[Reactie gewijzigd door ph4ge op 14 december 2008 15:28]

Of ze hebben het wel getest op een 8800GTS, maar niet in combinatie met een E6600, of niet in combinatie met een E6600 en 6GB ram...

Da's het probleem van pc's, elke config is anders in zowel hardware als software, en het is onmogelijk om alle situaties te testen.
en toch lukt het andere spellenbakkers wel om een goed product af te leveren.
Ik noem dit gewoon Epic Fail.
Aan alle klachten te zien, hebben ze de game veel te vroeg te deur uitgedaan zonder het uitvoerig te hebben getest. Patchen is dan een redelijke oplossing, maar dan moet de patch wel de oplossing zijn. En niet wat halfbakken fixes uitbrengen, waarvoor er tig bugs terugkomen.
Stoemme 'newfags' met hun 'Epic Fail lol so randum XD' achtige praktijken :(
Dit heeft niets te maken met een Epic Fail...

Epic Fails zijn voor mensen die iets uitvreten en het ECHT verknallen...

Het zou pas Epic zijn als ze met dit spel Windows zouden vernaggelen :P

[Reactie gewijzigd door Greyh0und op 15 december 2008 08:25]

Let op je woorden he, straks sta je in je onderbroek op dumpert!
Momenteel heb ik het spel wel redelijk in de houdgreep. Met een Q6600, 2GB geheugen en een 8800 GTS 512 (25% overclock) loop het met ca. 25 - 30 fps op 1920x1200 met alles op de hoogste instellingen (behalve de eerste setting, die staat op medium).

Processorkracht en geheugen heb ik genoeg, omdat beiden niet naar 100% reiken tijdens het spelen. Volgens mij is het alleen cruciaal om niet alleen een snelle videokaart, maar ook veel videogeheugen (1GB of meer) te hebben. Ik hoop daarom ook dat de memory savings gebaseerd zijn op het videogeheugen.

De video-editor interesseert me niets. Sinds ik het spel als een van de eersten gekocht heb, heb ik het nog niet eens bekeken en ik word er nu pas weer aan herinnerd dat het er in zit.

Ik hoop dat de schaduwen wat verbeterd zijn, want die zagen er (zeker zonder AA) belabberd uit.

Zodra ik weer thuis ben, zal ik de patch eens proberen.
ik heb een E6850 (20% overgeklokt), 2GB geheugen en ook een 8800GTS 512 (overgeklokt) en toch loopt bij mij mn geheugen wel degelijk vol, dus ik snap niet waarom dit bij jou niet gebeurt
Ik heb een E6750 (ook 20% overklok), 4GB geheugen (sinds een aantal dagen) en een gtx260. Maar had dus ook het probleem dat het geheugen vol liep ofzo, nu ik er 2 gb bij heb gezet, dus nu 4gb in totaal heb ik er helemaal geen last meer van.
Nou, ik heb een GF 280 GTX, die heeft 1GB geheugen, en ik kan je zeggen dat ik op 1920*1200 texture en render quality mag op medium zetten. Ik ga niet boven de gieg als ze beiden op high staan, maar toch stottert het spel. Bij mij is het eerder de CPU die de bottleneck vormt in mijn systeem (een Core 2 Duo van een jaar en half oud).
Ik denk dus dat het eigenlijk niet echt uitmaakt, als er ÚÚn onderdeel niet splinternieuw is en high-end is, mag je het vergeten...
Dit spel heeft nog een hoop performancetweaking nodig vrees ik...
De patch doet niks. Ik heb nog steeds random crashes / blue screens. Zelfs met een volledig niet overclocked systeem werkt het niet op een clean install. Er is duidelijk nog heel wat werk aan de winkel, waarbij ik trouwens kan vermelden dat dit vast niet " de grote patch" is :)
Dit is ook precies hetzelfde wat ik ervaar. Terwijl je toch wel wat anders verwacht van zo'n spel. Ik kan het ook niet fatsoenlijk spelen op hoger dan: low/low 1280x960. Met een opteron 185 @2.9Ghz /8800GT/2GB ram verwacht ik er toch wel wat meer van.

[Reactie gewijzigd door Barres B. op 14 december 2008 18:04]

met alles op high en de view distance balkjes etc in het midden ongeveer haal ik een 35-40 fps met een E8500 & GTX280 - 4GB ram..

ik verwachte ook best wat meer...
Met die processor hoef je niet veel te verwachten hoor..
spel loopt pas echt goed op een quad core of een erg hoog geclockte dual core
Ja maar hij zit toch wel boven de minimum vereisten. Ook heb ik een raid0 setje voor eventueel snellere laadtijden. Ik heb het ook wel een keer op hogere reso gehad met ander instellingen(1680x1050 high/medium). Opzich trekt hij dat wel, niet heel erg geweldig. De resolutie moet hij wel aan kunnen, alleen dan andere instellingen wat lager zetten.

Alleen bij die reso kapt het spel er zelf gewoon mee met foutmeldingen of uit het niks vastlopers. Of zomaar trage reacties, die niet komen doordat de pc het niet aan kan. Want hetzelfde kan ik na een restart wel gewoon doen. Ik kan het verschil daar tussen wel zien. Maar vastlopers en dergelijke heb ik minder als ik hem lager speel :S ...

ik ben er net achter gekomen dat de patch het alleen nog maar erger heeft gemaakt, kon ik normaal ongeveer een halfuurtje ongestoord spelen. Nu is het nog niet langer dan 5 minuten gelukt van de 7 keer....

[Reactie gewijzigd door Barres B. op 14 december 2008 19:25]

Excuseer? Erg hoog geclockt zeg je.. Is 4,32 ghz hoog genoeg? was dat even vergeten te melden.

En niet veel verwachten.. Volgens dat ik zie is 35-40fps een goed gemiddelde...
Ik denk dat hij het tegen mij had, kan me niet voorstellen dan een core2duo erg slecht qua performance is voor dit spel.
ik had het idd tegen jouw ja ;)

maar bekijk het GTAIV performance topic maar is.
daar zie je genoeg mensen met een relatief laag geclockte C2D + bijv 8800GT die ook maar erg weinig FPS halen

terwijl ik bijvoorbeeld met een maar op 2.5 geclockte quad core + 8800GT bijna tegen de 50fps aan zit (in benchmark)

me processor word btw zo'n 80% belast

[Reactie gewijzigd door Sinester op 14 december 2008 22:18]

die benchmark is geen echte benchmark. De camerastandpunten en aantal objecten is amper 50% van wat je gemiddeld in de game ziet. Mijn E8500 @ 4.3 ghz & GTX280 halen ook slechts tegen de 50 fps op high - highest | 50-75-50-10 op 1680x1050.

De game is gewoonweg CPU-limited. Want hoe zwaar ik de game ook zet, mijn fps blijft hetzelfde... Idem als ik mijn grafische kaart overclock. Zelfs op maximale overclock gaat m'n fps amper de hoogte in, waar bij andere games ik minstens 7 - 10 fps winst haal..

[Reactie gewijzigd door C-Gate op 14 december 2008 23:15]

De ingame benchmark is inderdaad waardeloos. Verschillende instellingen (o.a. car density) hebben geen enkel effect op de benchmark. Je kan beter benchmarken door gewoon een paar minuten te spelen met Fraps aan.

Op dit item kan niet meer gereageerd worden.



Apple iOS 10 Google Pixel Apple iPhone 7 Sony PlayStation VR AMD Radeon RX 480 4GB Battlefield 1 Google Android Nougat Watch Dogs 2

© 1998 - 2016 de Persgroep Online Services B.V. Tweakers vormt samen met o.a. Autotrack en Carsom.nl de Persgroep Online Services B.V. Hosting door True