Cookies op Tweakers

Tweakers maakt gebruik van cookies, onder andere om de website te analyseren, het gebruiksgemak te vergroten en advertenties te tonen. Door gebruik te maken van deze website, of door op 'Ga verder' te klikken, geef je toestemming voor het gebruik van cookies. Wil je meer informatie over cookies en hoe ze worden gebruikt, bekijk dan ons cookiebeleid.

Meer informatie

Door , , 31 reacties
Bron: Sun

mbravenboer stuurde ons de volgende bijdrage: "Enkele maanden voor de release van Windows XP maakte Microsoft bekend dat er standaard geen Java Virtual Machine meegeleverd zou worden met het besturingssysteem. Dit leidde tot nogal wat commotie, maar uiteindelijk was vrijwel niemand er echt rouwig om; hij zou als optie te downloaden zijn en Sun Microsystems maakte bovendien al snel bekend dat het haar eigen Java 2 Runtime Environment zou aanpassen zodat deze ook feilloos zou werken in Internet Explorer 6.x. Deze browser maakt namelijk gebruik van een nieuwe plugin-architectuur, waar ook Quicktime last van had.

JAVA Aanvankelijk was het de bedoeling om deze Java plug-in nog voor de release van Windows XP klaar te hebben. De verschillende grote OEM's zouden de software dan kunnen installeren op de computers van hun klanten. Helaas heeft het allemaal een stuk langer geduurd dan verwacht, waardoor de meeste bedrijven besloten om alsnog de Virtual Machine van Microsoft mee te leveren. Uiteindelijk is de nieuwe plug-in van Sun nu toch klaar. Door hem te downloaden en te installeren wordt het mogelijk om alle Java applets perfect weer te geven in Internet Explorer 4.x, 5.x en 6.x. Officieel gaat het nog om een publieke early-access versie, maar omdat er al een developer-connection early-access is geweest, kan deze release al wel als betrouwbaar worden gezien. De downloadsite zelf is overigens ook nieuw, omdat de software voorheen niet goed te vinden was:"

Java Plug-in makes it possible for your computer (including Windows XP, NT, 2000, 98, or 95) to run applets, small applications that add tremendous power to the convenience of the Web. Applets run on just about any computer because most come with Java software already installed. But some do not, and older computers may have an out-of-date version.
Moderatie-faq Wijzig weergave

Reacties (31)

Kleine vraag/tip voor Mozilla 0.95 (en misschien ook andere) gebruikers: als je bij de licence agreement op [Accept] of [Decline] klikt maakt niet uit. Hij gaat namelijk gewoon weer terug naar dezelfde pagina |:( :P

Als iemand me een tip kan geven over hoe ik hem binnen haal met Mozilla: graag (mirror mag ook, denk ik :? ).

EDIT:
Ik heb ondertussen een oplossing, als je dit probleem hebt: gewoon even op [Accept] klikken, en vervolgens op [Reload page]. Dit zelfde kun je herhalen voor het kiezen van de FTP/HTML sites. Suc6 !
het is een plugin voor IE.. dus zo gek is dat niet.. :)
Niet helemaal, de Plug-in werkt ook in Netscape 4.x, Mozilla/Netscape 6.x en Opera :) .

Het kan zijn dat er ik nog wat vergeet ;) .
Ik heb dus de plugin voor Sun SPARC gedownload, uitgepakt, plugin in de mozilla plugin dir gezet (ik draai dus moz. 0.9.4), en ook nog $NPX_PLUGIN_PATH laten wijzen naar de plugindir.
Toen dus mozilla opgestart, plugin is zichtbaar, geen foutboodschappen tijdens opstarten, maar als je op een pagina komt waar een applet staat knalt'ie er uit met de volgende boodschap:
./plugins/libjavaplugin_oji.so: symbol XtOpenApplication: referenced symbol not found
Hebben meer mensen dit probleem? :?
Hier in Mozilla 0.9.5 op Linux werkt het gewoon. Het duurt wel heel eventjes nadat je op accept hebt geklikt.

Probeer het eens via deze directe link (voor MS Windows)
Vergeet die link boven gewoon, en ga naar deze pagina. Helaas moet je ff 100000000 keer agree klikken, maar daarna krijg je gewoon de Java 2 Runtime Environment 1.4 beta3 binnen. Die heb ik nu al een tijdje, en die werkt prima. Zelfs in Internet Explorer doet ie het! (Al gebruik ik die browser voor het MSInternet niet echt meer).
Java 2 Standard Edition 1.4 beta 3 is inderdaad prachtig (ik gebruik het al sinds de eerste beta), maar het is de vraag of een normale gebruikers daar erg mee geholpen is.

Het fraaie van deze aktie is dat er nu een duidelijke site is waar je de meest recente productie release van Java 2 Standard Edition kunt downloaden als normale internet gebruiker. Beta's (hoe goed ze ook mogen zijn) zijn helaas ongeschikt voor die doelgroep. Zodra 1.4 production release is geworden, zal de getjava site direct worden aangepast zodat iedereen voortaan deze release gebruikt.

1.4.0 wordt voor een ontwikkelaar fantastisch (JAXP, JCE, Swing verbeteringen, nio, etc) maar een thuisgebruiker heeft daar nog maar weinig aan. Java Web Start (wat in 1.4.0 standaard wordt geinstalleerd) werkt zelfs niet voor beta's. Alleen production releases worden daarvoor gebruikt (tenzij expliciet de beta vermeld is).
Ik weet zo net nog niet of Java 2 Runtime Environment 1.4, zelfs in bčta versie, niet voor eindgebruikers interessant kan zijn. Dit is namelijk de eerst jdk waar JSA (Java Security Architecture) wordt meegeleverd, m.a.w. voor het eerst worden de deftige encryptie-algoritmes en deftige beveiligingssystemen met java meegeleverd. In alle andere jdk's zaten alleen heel zwakke systemen. Gezien de huidige situatie i.v.m met terrorisme en zo, zou het wel eens de LAATSTE jdk kunnen zijn die dit ondersteunt :'(
Punt is dat er wel applicaties of applets moet zijn die ook daadwerkelijk van 1.4 functionaliteit gebruik maken.

Soms is dat wel het geval bij software die in bedrijven zelf wordt gebruikt, maar voor publieke software is dat in ieder geval niet het geval. Dus is een beta van 1.4.0 vrij zinloos.

Die toevoeging van zware cryptografische algoritmen aan de JRE heet trouwens Java Cryptography Extension (JCE) (zie mijn vorige post). Deze was al een tijdje los te downloaden na de versoepeling van de uitvoer-wetgeving voor cryptografische producten uit de USA. Ook nieuw is de Java Authentication and Authorization Service (JAAS).

Een security architectuur kent het Java Platform gelukkig al een stuk langer ;) .
Ok, ik zat er hier en daar naast :?.

Mijn punt blijft echter : de 'versoepeling' waardoor de extra cryptografische algoritmes in java nu wel uit de vs geëxporteerd mogen worden (sinds januari 2000), dreigt van korte duur te gaan worden. Als je dit dus in uw standaard runtime environment wilt gebruiken ( of apart wil afhalen, wat dan ZEKER niet voor de gewone gebruiker zal weggelegd zijn, ... ), dan is het nu toch wel de moment ...
Zit zeker wel wat in, maar er zijn vrijwel geen applicaties die ook daadwerkelijk JCE gebruiken. Als dit wel het geval is gaat het vaak om in-house software die draait op een intranet oid. Die kunnen altijd nog de optionele download van JCE gebruiken.

Om nu maar voor altijd met een beta van 1.4.0 te gaan werken omdat daar wat cryptografische algoritmen in zitten, is denk ik niet echt een oplossing. Mocht het al een oplossing zijn, dan is het een oplossing voor een probleem waarmee de normale gebruiker niet echt zit ;) .

Overigens is het natuurlijk prachtig als er zoveel mogelijk gebruik wordt gemaakt van recente VMs en 1.4.0 beta 3 is van een behoorlijke kwaliteit. Hij zou zelfs behoorlijk uit de verf komen als een production release. Maar voor de 'massa' is het misschien toch verstandiger om gewoon even te wachten op een production release (die waarschijnlijk nog wel even op zich laat wachten trouwens).
Good for Sun. Nadat ze Microsoft geen licentie hadden gegeven (had Microsoft het best wel na gemaakt door Java te ver-microsoften) voor Java moest Sun het wel zelf doen. Zie hier het resultaat.
Nadat ze Microsoft geen licentie hadden gegeven
Da's niet correct. MS heeft wel een licentie, alleen moeten ze zich er nu aan houden. (Dus M$-only uitbreidingen zijn verboden) En dat wilde MS niet, dus heeft men besloten om Java helemaal niet meer mee te leveren. Althans niet standaard.

Maar goed, ondertussen moet je zo (associeel) vel plugins installeren. Als het nu alleen Java zou zijn. Maar ook Flash/QuickTime/RelaAudio weet ik niet wat allemaal. En als het nu nog standaarden zouden zijn. Maar alleen Java kan een beetje aan die eis voldoen ;(
Uhm, niemand verplicht je om die plugins te installeren hoor.. als iemand mij een quicktime of realvideo filmpje wil laten zien, zeg ik gewoon dat ie het eerst maar moet converteren naar mpeg ofzo. (of mp3 in geval van realaudio)

Maar ff ontopic: als je in IE/XP een java-applet tegenkomt, wordt dan de plugin wel automagisch gedownload, zoals bij Shockwave enzo?
Java 1.0 ondersteunen ze wel in iedergeval de 1e versie, de basis versie, maar de nieuwere versie niet en die moet je tegenwoordig wel hebben wil je zo'n beetje de nieuwste websites bekijken....
// offtopic
Ook Flash is onderhand vrij standaart hoor... Je komt het op steeds meer pagina's tegen. Mits er niet overdreven wordt is Flash een perfecte manier om een mooie pagina te krijgen, lange laadtijden zijn niet noodzakelijk.

// offtopic
Ik had een tijd geleden inderdaad een plugin nodig in WindowsXP om een java-applet voor het Tentamen Aanmeld Systeem (TAS) van de TU Delft te kunnen draaien. Even installeren en het werkt perfect :)
Ach, eff een nutteloze opmerking ertussendoor:
Maar, www.opentas.org werkt ook heel erg goed hoor :) Geen java voor nodig en nog sneller ook.
Zo zo, Microsoft die Java ondersteund... het moet ook wel, je kunt er moeilijk omheen. Vooral omdat veel users van IIS ook met JSP werken (ik ook :) ) en natuurlijk ook applets.
De downloadsite zelf is overigens ook nieuw, omdat de software voorheen niet goed te vinden was
En dat is maar al te waar! Man, ik heb samen met 2 collega`s wel 2 uur moeten zoeken om JDK te vinden |:( al moet ik zeggen dat de search van java.sun.com nog niet helemaal naar wens is...

Misschien moet ik ze een keer bellen :+
Die plugin heb je alleen nodig voor client-side applets hoor. Al het andere draait op de server en dus op een JVM. En denk ook niet dat je als site al snel je clients met een client-side applet wilt laten stoeien. Of het moet iets zijn wat lijkt op flash of zo.

Trouwens is die nieuwe JRE redelijk vlot qua applets moet ik zeggen. Ze zijn al een tijdje met 1.4 bezig maar die beta's zijn eerder alpha's want die zijn nog lang niet af. Maar als plugin voor je brouwser zijn die nog interessanter omdat die library hiervan nog uitgebreider is.

Enne, JDK's moeilijk te vinden? Lijkt me nogal onhandig als je daar twee uur voor nodig had. Maarja nu weet je het en vind je het de volgende keer beter.
[info]
Sun heeft de originele eigenschap om alpha's vaak beta's te noemen en wat de rest van de wereld met beta aanduid release candidate te noemen. Na de allerlaatste beta komt er dus eerst nog minstens een RC voordat de versie werkelijk vrijgegeven wordt voor productie omgevingen.
[/info]

* 786562 rephlex
tiens,

het menu aan de linkerkant van www.uptomovie.com kan ik niet meer gebruiken, het werkt niet na installeren van java sun plug-in op IE 6.0 op windows ME
Dat komt door het volgende:
java.lang.ClassFormatError: inm (Invalid start_pc/length in local var table)
Er zijn meer applets die daar last van hebben met nieuwe JVM's, ik denk dat ze gebakken zijn met een niet helemaal compatible Java compiler.. het probleem is simpel te fixen overigens, recompile zo'n applet met een recente javac. (en als je de source niet hebt eerst even jad gebruiken)

Maar dat moet wel door de site-beheerder gebeuren. Dus stuur eens een mailtje als je wilt dat 't werkt. :)
Als ik met IE 6.o op de link nieuwe plug-in druk sluit mijn explorer :?
Ik zie niet direct een reden waarom dit zou moeten gebeuren (het is een gewone html pagina) , maar je zou het via de startpagina van de site kunnen proberen:

http://java.sun.com/getjava/
De Java-goeroe (hate the word ;)) mbravenboer heeft gespot!! thanxxx 8-)
Ik herinner mij vagelijk een soort conflict met een dergelijk genaamd persoon.... :+
Helaas loopt er inderdaad iemand op deze aardbol rond met dezelfde naam als ik (vreemd he?). Ik heb echter niets met klein-informatica te maken...

Zoals je merkt ben ik al vaker op de treffende gelijkenis gewezen ;) .
Dit is een goede stap voor SUN. Ze hebben daar bij de top schijnbaar toch de grijze massa gebruikt. Het is alleen jammer dat ze te laat hiermee zijn uitgekomen. Maar dat mag de pret niet drukken, wel lekker dat ze hun JAVA 2 RE aanpassen voor IE 6.0. Hoewel ik me afvraag hoeveel mensen er IE 6.0 gebruiken, aangezien dat er al zoveel verschillende nieuwe browsers uit zijn (zoals Netscape Nevigator's nieuwe versie).


"Applets run on just about any computer because most come with Java software already installed. But some do not, and older computers may have an out-of-date version."

hmm, verwacht SUN dat niet veel mensen Windows XP hebben ofzo? ik bedoel, eerder in het artikel werd gezegd dat JAVA niet standaard in Windows XP zat. Aangezien dat de meste normale kopers Windows XP bijna direct zullen kopen. Lijkt me niet dat er dan weinig mensen geen JAVA hebben maar bij de normale consument een heleboel (dus allemaal die wat Windows XP). Beetje vreemd :?.

Op dit item kan niet meer gereageerd worden.



Apple iOS 10 Google Pixel Apple iPhone 7 Sony PlayStation VR AMD Radeon RX 480 4GB Battlefield 1 Google Android Nougat Watch Dogs 2

© 1998 - 2016 de Persgroep Online Services B.V. Tweakers vormt samen met o.a. Autotrack en Carsom.nl de Persgroep Online Services B.V. Hosting door True