Cookies op Tweakers

Tweakers maakt gebruik van cookies, onder andere om de website te analyseren, het gebruiksgemak te vergroten en advertenties te tonen. Door gebruik te maken van deze website, of door op 'Ga verder' te klikken, geef je toestemming voor het gebruik van cookies. Wil je meer informatie over cookies en hoe ze worden gebruikt, bekijk dan ons cookiebeleid.

Meer informatie

Niantic stopt Pokémon Go-ondersteuning voor toestellen met iOS 10 en lager

Niantic stopt de ondersteuning voor Apple-apparaten die geen update krijgen naar iOS 11. Het gaat daarbij onder meer om de iPhone 5 uit 2012 en de 5c uit 2013. Vanaf 28 februari kunnen spelers Pokémon Go niet meer spelen op die apparaten, meldt Niantic.

Niantic voert veranderingen door die alleen kunnen op iOS 11, meldt de ontwikkelaar. Een update van de game maakt Pokémon Go niet langer speelbaar op onder meer de iPhone 5c, iPhone 5, iPad 4 en iPad Mini. Apple besloot die apparaten geen upgrade te geven naar iOS 11. Niantic heeft een lijst online gezet van niet langer ondersteunde apparaten.

Het is onbekend welke functie iOS 11 vereist. Daarbij kan het niet gaan om ARKit. Pokémon Go ondersteunt ARKit al en de ar-functies werken bovendien niet op de iPhone 5s en 6, die Niantic wel zal blijven ondersteunen.

Pokémon Go kwam medio 2015 uit. Niantic vermeldt niet hoeveel gebruikers de apparaten gebruiken waarvoor de ondersteuning zal vervallen.

Door

Redacteur mobile

67 Linkedin Google+

Submitter: Zeror

Reacties (67)

Wijzig sortering
Aangezien mensen geld uitgeven voor het spel is het wel sneu voor de mensen die veel geld hebben betaald voor het spel maar geen nieuwe iPhone hebben


Edit:typo

[Reactie gewijzigd door puntje013 op 10 januari 2018 19:44]

Je kan ook niet verwachten dat je een smartphone 10 jaar kan gebruiken.Daar gaan de veranderingen qua kracht toch wel hard voor vooruit. Ik snap dat sommige mensen ervoor kiezen om in 2018 een iphone te kopen van 2016 bv. Maar waar je bij android dan allang geen updates meer krijgt, zit je bij apple nog 3 jaar goed. Ik vind het best netjes dat ze nog toestellen van 2013 ondersteunen (iphone 5s) dat is ondertussen al 5 jaar!

[Reactie gewijzigd door magnat505 op 10 januari 2018 17:42]

De doelgroep van pokemon go omvat ook kinderen van 8-12 jaar. En die hebben vaak een oudere telefoon gekregen van pap of mam. Nogal zuur dat juist die groep geen pokemon go kunnen spelen.
Tja, maar in het begin van het spel draaide het gewoon op iPod 5e generatie. Bij de tweede update was die al bij de compatibility weg, paar weken verder draaide het gewoon niet meer. Het spel is slecht geoptimaliseerd, waardoor laadtijden, netwerkbelasting en batterijgebruik gewoon buitensporig zijn. (Zelfs de providers zeggen dat, in stadions bij wedstrijden blijft alles werken, zelfde hoeveelheid mensen op een veld met PoGo en extra masten en het gaat alsnog mis).

Nu met nieuwe AR+ snap ik dat ze moeten schipperen, maar dit is gewoon idioot. Een iPhone 5/5c/5s moet dit spel zonder moeite kunnen draaien. Eventueel met mindere graphics.

Edit: Ik zie dat de 5C daar ook bij hoort. Gisteren heeft m'n zoontje daar nog gewoon Pokemon Go op gespeeld, moet nu dus voor hem een nieuw toestel regelen? Wat een waanzin.

[Reactie gewijzigd door Jo0Lz op 10 januari 2018 21:42]

Ja en aan die groep verdiend Pokemon Go dus geen donder ;)

ze zullen echt wel statistieken hebben per os hoeveel geld het in het laadje brengt en te bekijken of je dit kan afzetten tegen de kosten van de ondersteuning.
Dat geld toch net zo goed voor Android dat veel korter updates krijgt? :?
Dat is de doelgroep waar Niantic geen bal om geeft want die kopen toch niks uit hun shop. Pokémon Go schreeuwt al sinds de release aan alle kanten dat Niantic eigenlijk alleen geeft om mensen die hun een hoop geld geven en eigenlijk vrijwel niet om de game zelf of de kleinere demografiën, bijvoorbeeld mensen in dorpjes.
Nee,de veranderingen gaan de laatste tijd juist langzamer. Net als bij PC's begint de snelheid uit de ontwikkelingen te raken en kan een toestel van een paar jaar oud vaak nog prima mee. PC's worden nu ookj al in 5 jaar ipv 3 jaar afgeschreven en bij bedrijven zie ik vaak genoeg nog veel oudere machines staan.
Als ik heel even kijk:

- Iphone 5: 1200 geekbench
- Iphone 5s: 2200 geekbench
- iphone 6: 2800 geekbench
- iphone 6s: 4400 geekbench
- iphone 7: 5600 geekbench
- iphone 8: 10500 geekbench

Over de afgelopen 6 jaar is dat dus bijna 10x zo snel, en als ik kijk naar afgelopen jaar is de verandering juist enorm.
Maar topscore zegt niets over gewoon gebruik. En dát is wat Morgan4321 bedoeld: “oudere” hardware is prima in staat gewone, dagelijkse taken uit te voeren. De top hardware van een aantal jaren geleden is vergelijkbaar met de low entry hardware van nu. En die wordt ook goed verkocht. En de low entry hardware van nu is prima voor dagelijks gebruik, dat is niet meer (zoals vroeger) onbruikbare rommel.

Edit: wat natuurlijk niets afdoet aan de grote stappen die er bij Apple zijn gemaakt. Intel kan hier slleen van dromen op ‘t moment.

[Reactie gewijzigd door chinco op 10 januari 2018 20:34]

Ik zou Pokémon Go niet definiëren als “gewoon gebruik”.
Voor veel mensen boeit maximale snelheid echt totaal niet. Ja een iphone 8 is stukken sneller maar met een iphone 5 kan je ook nog prima uit de voeten, tenzij ze dit soort beslissingen gaan nemen zoals stoppen met beveiligingsupdates etc.
de discussie ging echter over of de rek eruit was of niet, en dat pokemon go niet eeuwig oude toestellen kan blijven ondersteunen. Uiteindelijk zal de minimale snelheid vooral uitmaken voor games.
De rek is er nog niet uit maar net als bij computers hoef je niet meer elk half jaar iets nieuws te kopen om de software bij te benen zoals in de jaren '90 van de vorige eeuw. Mijn huidige laptop is van eind 2013 en die doet de meeste dingen nog snel zat (al is Android Studio wel erg traag, een ssd zou daar zeker helpen).
ligt er ook aan in wat voor soort bedrijf ^^
Consumptiemaatschappij denken noem ik dat, ¤1000 voor de nieuwste Iphone maar ik mag niet verwachten daar 10 jaar mee te doen ? Omdat het een telefoon is ?
En anders moet ik maar een goedkopere kopen ? zoiets ?

Dat je sommige spellen dan niet kan spelen okee, maar waarom mag ik geen lange levensduur verwachten van een meer dan ¤1000 kostend toestel verwachten ?
Ik draai hier nog een dolby pro logic versterker uit '98 en die blaast nog prima, nee geen hdmi, usb poort etc etc en die kostte destijds 500 gulden...

Milieu en duurzaamheid ?????
Consumptiemaatschappij denken noem ik dat, ¤1000 voor de nieuwste Iphone maar ik mag niet verwachten daar 10 jaar mee te doen ? Omdat het een telefoon is ?
Ja. Misschien daarom maar geen telefoon van 1000 euro kopen? ;)

Zonder gekheid, je kunt niet verwachten dat hardware en software tien jaar meegaat. Uiteindelijk komt er iets nieuws en kun je niet verwachten dat elke developer bij ieder nieuw product voor jaren aan apparaten en software gaat ondersteunen (om nog maar te zwijgen over afwijkende 'standaarden'). Sommige nieuwe apps zijn uberhaupt niet mogelijk op oudere apparaten omdat er bijvoorbeeld geen sensoren voor aanwezig zijn. Als developer ben ik het in elk geval zat om steeds maar 'iedereen' te moeten ondersteunen. Het zal namelijk altijd ten koste gaan van mensen die wel een wat nieuwer apparaat hebben (minder tijd voor nieuwe features, meer ondersteuning op andere vlakken). Daarnaast zul je geen gebruik kunnen maken van de nieuwere technieken die beschikbaar zijn, wat vaak erg zonde is als de performance daardoor minder is. Persoonlijk richt ik voor ondersteuning op ongeveer 96% van alle apparaten voor alle basisfeatures. Overige features met minder ondersteuning mogen dan geen impact hebben op de andere gebruikers. Als je een tien jaar oude telefoon hebt val je waarschijnlijk bij de overige 4%, waar ik een perfecte ondersteuning niet kan garanderen. Wellicht dat er verandering in komt als ook de hardwareboeren hun systemen blijven updaten, maar het neemt niet weg dat je op een gegeven moment hardware moet gaan vervangen omdat je anders alsnog vastloopt.
Je vergeet het punt duurzaam en milieu.
Wanneer mijn zeer dure telefoon het 10 jaar later nog doet maar niet met de nieuwste functies, hoeft dat toch geen probleem te zijn voor de nieuwe toestellen ?
Ik kan nu toch ook gewoon met mijn digitale thuis toestel naar een oude analoog toestel bellen ?

Waar het mij om ging is dat wanneer iedereen iedere 10 jaar een telefoon/mobiel zou "moeten" kopen ipv 4 jaar dit veel beter is voor het milieu, duurzaamheid en ik vind dat je van een duur product toch zeker wel een lange levensduur mag verwachten.

Eigenlijk gaat het alleen om geld en niet in eerste plaats om de techniek, je koopt toch ook geen mooi leren bankstel van ¤5000 iedere 4 jaar ?
Slechte vergelijking ik weet het, maar nogmaals duurzaamheid en milieu is waar het mij om gaat.
2016 is de 6S. Een prima telefoon als je de batterij netjes houd. Gaat nog mee met de grote jongens wat mij betreft en zal zeker nog drie jaar goed te gebruiken blijven. Met een nieuwe batterij ben ik ook echt nog niet van plan te upgraden met ondertussen twee jaar op de teller.
"Maar waar je bij android dan allang geen updates meer krijgt, zit je bij apple nog 3 jaar goed."

Mijn Nexus 6 heeft anders toch echt de 1 na laatste versie. En die komt uit 2014. En je hoeft dan ook niet per se de laatste android te hebben om pokemon go fatsoenlijk te spelen.
Je praat nu over DE uitzondering bij Android, een toestel van Google.

Terwijl 99% van de Android toestellen dus gewoon niet meer dan 2 jaar ondersteund wordt.

En met die 4 jaar van je Nexus kom je dus nog steeds niet bij de 5 jaar ondersteuning die Apple bied, zelfs al evenaart de Nexus het dan nog overtreft die het niet als uitzonderingstoestel.
Persoonlijk vind ik dat nu toch ook geen prestatie om over naar huis te schrijven. De nexus 6 is uitgekomen met android 5, en heeft slechts 2 (!) major upgrades naar 6 en 7 gehad. Die 2 major upgrades gelden overigens voor heel veel nexus telefoons. De iPhone 5 daarentegen is uitgekomen met iOS 6, en heeft de upgrades 7 tem 10 gehad.

Maar ik snap niet dat ze de iPhone 5 weren van pokemon go, ik begrijp dat AR+ hier op draait, maar dat is op android ook niet het geval en niet echt een breekpunt in mijn mening. Ik hoop dat ze in de nabije toekomst met sterke verbeteringen komen die deze beslissing kunnen verantwoorden.
Maar je mag verwachten dat je gebruik kunt blijven maken van betaalde producten.
En dat zou in dit geval niet meer kunnen.

Dan zou Niantec het geld moeten retourneren in mijn ogen.
Pokémon Go draait volgens mij ook onder Android Kitkat. Even checken: ja 4.4 en dat is dus 2013.
Waarom niet? Het spel draait gewoon normaal op die telefoons maar ineens is het zogenaamd niet meer speelbaar, magically?

Een telefoon gaat mee totdat hij fysiek kapot gaat. Dat iedereen en zijn moeder tegenwoordig om de twee jaar een nieuwe telefoon eist wil niet zeggen dat telefoons niet meer lang meegaan.
Ik snap dat sommige mensen ervoor kiezen om in 2018 een iphone te kopen van 2016 bv. Maar waar je bij android dan allang geen updates meer krijgt, zit je bij apple nog 3 jaar goed.
De S4 uit 2013 heeft dit jaar (of in 2017, weet ik het) nog een update gehad volgens Samsung. Maar inderdaad de meeste Android toestellen krijgen na 2 jaar geen updates meer.
Ik vermoed dat hetzelfde zal gelden voor Ingress Prime dat ook in Q1 of Q2 uit zal komen. Zal wel gebruik maken van wat nieuwe API’s. Kan me sowieso voorstellen dat de 32 bit chips hun beste tijd gehad hebben (alles 64 bit heeft iOS 11).
De Unity engine kan prima exporteren naar 32bit en 64bit. Als de 32bit processors nog een substantieel marktdeel hebben lijkt het mij niet dat ze deze zullen uitsluiten.

[Reactie gewijzigd door hejkompas op 10 januari 2018 21:21]

Mijn vermoeden: ze gaan 32-bits ondersteuning stoppen.

Dan vallen alle genoemde modellen af, omdat hun processors geen 64-bits ondersteund. Dat is de reden waarom precies deze modellen eerder geen update kregen naar ios11.
Geen onredelijke connectie maar wat zouden ze daar uit winnen?
Kosten. Dat is een platform minder om op te moeten testen.
Ik heb 3 maanden geleden mijn 3e hands iPhone 4 vervangen met een refurbished iPhone 5, ik ben er heel blij mee. Volgens mij is die markt in NL vrij groot maar misschien heb ik het mis en geeft de meerderheid van de mensen elke 2 jaar 600 euro uit aan een nieuwe telefoon.
Waarom heb je dan geen se gekocht, de iPhone 5 krijgt juist al geen software updates meer.
Ook apps zullen steeds sneller nu ios11 gaan verplichten, hierdoor kan je straks ook geen apps gebruiken meer.

Of doe jij niks anders dan bellen en smsen aangezien je nog op een iPhone 4 zat ?.
Je hoeft echt niet elke 2 jaar een nieuw toestel, maar een telefoon kopen die nog ondersteund word met updates lijkt mij toch wel fijn.

[Reactie gewijzigd door Carlos0_0 op 10 januari 2018 18:46]

De iPhone 5 wordt dus uberhaupt al niet meer ondersteunt. Je kan wel niet elke 2 jaar ¤600 euro uit willen geven, maar het is niet zo slim om een inmiddels ruim 5 jaar oude telefoon te kopen.

Als je niet veel geld over hebt voor een smartphone moet je geen duur merk als Apple kiezen. Tegenwoordig kan je voor ¤150 al een behoorlijke smartphone kopen, zelfs nieuw.
Je kan al een iPhone SE kopen voor 320 euro die nog minimaal 3 jaar ondersteund word.

Daarnaast behoud een iPhone veel beter zijn waarde en ben je dus nog goedkoper uit dan die 320 euro als je het na 3 jaar nog verkoopt.

Daarnaast bied een Android toestel niet hetzelfde als een iPhone in de ogen van de iPhone gebruiker en is die meerprijs volledig te rechtvaardigen als het al meer kost netto gezien.
Tuurlijk, dat ontken ik ook niet. Maar ¤320 is dus nog steeds ver boven zijn budget(refurbished iPhone 5's zitten iets boven de ¤100). En zal ik persoonlijk geen goedkope telefoon noemen.

Dit is niet als haat op Apple bedoelt, maar het is geen goede keuze als je op zo'n strak budget zit.
Maar wat is dan een goede keuze?

Als je een nieuwe Android toestel koopt die 2 jaar ondersteund word als je geluk hebt moet je na 2 jaar weer een nieuwe Android toestel kopen.
een android toestel wat 2 jaar ondersteunt wordt is toch al een stuk beter dan een iPhone die uberhaupt al niet meer ondersteunt wordt? dan begin ik nog niet eens over het gebruik van custom roms, omdat ik weet dat veel mensen dat niet aan zullen durven.
Waar heb je het over?

Ik heb het over een iPhone SE die nog 3 jaar updates ontvangt.

En je zegt het goed, meeste mensen weten niet eens van het bestaan van custom roms af laat staan dat ze er wat mee willen doe zelfs al zouden ze weten wat het is.
Zoals ik al zei. Die SE is veel te duur voor de originele commenter. Voor *zijn* budget is een Android telefoon een veel betere keuze. De iPhone 5 die hij nu gekocht heeft wordt niet meer ondersteunt.
Nee want het gaat om de updates, die Android toestel krijgt die updates niet meer na 2 jaar en moet hij dus een nieuwe telefoon kopen waardoor die op dezelfde prijs uitkomt of zelfs duurder.
okay. laat ik het nog een keer op een rijtje zetten;
de man heeft ¤150 te besteden aan zijn nieuwe telefoon.

hij koopt een refurbished iPhone 5 voor ¤150. welke al niet meer ondersteunt wordt.

of

hij koopt een recent goedkoop Android toestel voor ¤150. welke nog 1 tot 2 jaar ondersteunt wordt.
Koop iedere 2/2.5 jaar een China phone van ¤450.

Die Apple (en Samsung) prijzen zijn gewoon belachelijk. Doet me denken aan mijn jeugd toen iedereen dure trainingspakken moest hebben.
Grappig, die belachelijke prijs denk ik juist van die telefoon van ¤450. Dat vinden we blijkbaar tegenwoordig een budget-toestel, nou mij niet gezien. Zit nu op een tweedehands Galaxy S5 van 120 euro. Batterijtje er in van een tientje, en voila na 2 of 3 jaar weer weg doen voor 60-80. Dan kost het je luttele euro's op jaarbasis. ¤ 450 is me veel te veel. Meestal kan men nog prima door met een bestaande telefoon, maar voelt men aldoor een drang om iets nieuws te hebben.
De reden voor iOS 11 is de AR kit die in Unity gebruikt word. Niantic heeft de AR kit dus geimplementeerd wat dus betekend dat iOS 11 of hoger als build target version gezet moet worden.
Ja, maar dat zit nu al in de game. Het werkt nu nog op de iPhone 5C, zonder problemen overigens.
Zal met de volgende update dan wel gedaan zijn.
Wat @maskedmous bedoeld is dat Unity een andere AR gebruikt dan dat ze nu gaan implementeren in de volgende update. Apple heeft sinds iOS 11 een nieuwe AR kit waar ze nu gebruik van maken. De onderliggende technologie is dus aangepast.

[Reactie gewijzigd door zwik op 11 januari 2018 11:05]

Ja, die nieuwe AR werkt al (op mijn iPhone 8) en niet op de 5C. Snap sowieso niet dat dat een reden is om toestellen te laten vallen. Harstikke geinig voor een keertje of 2, maar daarna zet iedereen het toch weer uit.

Het is te idioot voor woorden dat een telefoon die het prima kan draaien niet langer ondersteuning heeft. Ook niet logisch dat dat aan AR+ zou liggen, want volgens mij werkt AR+ pas vanaf 6S en nieuwer. iOS 11 is dan de enige "belemmering".

Maar goed, ze doen maar, mijn zoontje is de interesse al lang geleden kwijtgeraakt toen ze de raids en de beloning aan het team van de gym koppelden. Switchen van teams zou ook komen, "Soon". Hahaha.
het korte verhaal: AR+ (oftewel het gebruik van de AR Kit plugin) heeft minimaal iOS 11 nodig om te kunnen werken. een iPhone 5C ondersteunt geen iOS 11 en dus ook geen AR Kit en het is niet backwards compatible. AR kit is niet weg te laten bij devices die het niet ondersteunen.

Het lange technischer verhaal: Om vanuit het programma Unity3D (de game engine) een build te maken (dus de applicatie) die gebruik maakt van de AR kit, moet iOS 11 als minimale systeem vereiste opgegeven worden. Je kunt hierdoor dus ook geen backwards compatibility geven door bijvoorbeeld AR kit niet te activeren op devices die het niet ondersteunen. Hierdoor valt de support voor alle devices dus weg die iOS 11 niet ondersteunen.

[Reactie gewijzigd door maskedmous op 16 januari 2018 00:27]

Maar op dit moment is er al AR+, dat wel werkt op de iPhone 8, en niet op de 5C. Exact dat wat je beschrijft is nu het geval. Daarbij laten ze ondersteuning voor de 5S actief, dat wel iOS 11 heeft, maar geen AR+ :D Dat werkt pas vanaf de 6S, of 6.
En hiermee schieten ze zichzelf in de voet, zeer jammer weer.
Ik ben toch wel zeer benieuwd wat voor features niantic toe gaat voegen die niet meer op een iPhone gaan draaien maar kennelijk wel op een Android toestel. Als het om 64 bits ondersteuning gaat dan zou Niantic wel erg veel klanten gaan verliezen op het Android platform.
De Persgroep zal een goede bos analytics draaien en als een onderwerp waar makkelijk over te schrijven veel verkeer genereerd zou je wel stom zijn dit niet te publiceren.
Pokémon GO én Apple. Dat is wel de 'perfect storm' van website verkeer.
Dan moet je dat nieuws inzenden. Misschien dat er dan wat mee gebeurt. Maar dan krijg je ook weer mensen die bij dat nieuws zeggen: waarom krijgt deze game aandacht? Iedereen is het wel altijd ergens niet mee eens ;)
[iOS/Android] Pokémon GO - Deel 5
Zelf op GOT forum nog een actief draadje over.
Titel geeft iOS 10 aan
Dit klopt toch ook gewoon. "iOS 10 EN lager" is hetzelfde als "alles onder iOS 11".
Klopt, maar iOS 10 is toch niet extreem oud?
Dit heeft vermoedelijk te maken met 64bit-ondersteuning. De keuze om te stoppen met de 32 bit app maakt Niantic en niet Apple.
Dat zeker niet nee. Het zal inderdaad te maken hebben met de 64bit-ondersteuning zoals @Steven.w al zegt.
iOS 10 en lager
= 10, 9, 8, 7, ...

Zou 10 wel werken, dan was het "lager dan 10" geweest, of "9 en lager".

Al was een betere titel geweest eentje waaruit duidelijk werd dat alleen 11 nog ondersteunt wordt, bijvoorbeeld "Niantic ondersteunt voortaan alleen iOS 11 voor Pokémon Go".

[Reactie gewijzigd door TheTinusNL op 10 januari 2018 18:01]

Al was een betere titel geweest eentje waaruit duidelijk werd dat alleen 11 nog ondersteunt wordt, bijvoorbeeld "Niantic ondersteunt voortaan alleen iOS 11 voor Pokémon Go".
De titel klopt niet en het volgende gedeelte van het artikel ook niet.
Niantic voert veranderingen door die alleen kunnen op iOS 11, meldt de ontwikkelaar
De ontwikkelaar geeft aan dat ze de ondersteuning stopt voor toestellen die niet geüpgrade kunnen worden naar iOS 11. Dit zijn de toestellen die geen 64 bit ondersteunen.

Er wordt nergens gezegd door de ontwikkelaar dat de software op iOS 10 of lager niet meer werkt. iOS 10 heeft ook gewoon 64 bot-ondersteuning.

Een 5S op iOS 10 wordt dus gewoon ondersteund.

[Reactie gewijzigd door White Feather op 10 januari 2018 18:38]

Op dit item kan niet meer gereageerd worden.


Call of Duty: Black Ops 4 HTC U12+ dual sim LG W7 Google Pixel 3 XL OnePlus 6 Battlefield V Samsung Galaxy S9 Dual Sim Google Pixel 3

Tweakers vormt samen met Tweakers Elect, Hardware.Info, Autotrack, Nationale Vacaturebank en Intermediair de Persgroep Online Services B.V. © 1998 - 2018 Hosting door True

*