Firmware-update: OpenWrt 18.06.8

OpenWRT logo (45 pix) De achtste Service Release van OpenWrt versie 18.06 is uitgekomen. OpenWrt is alternatieve opensourcefirmware voor een groot aantal verschillende routers en embedded devices. Door middel van het opkg-package management system is er de mogelijkheid om zelf te bepalen wat de router allemaal wel en niet kan. Ook op GoT zijn er diverse mensen actief mee bezig, zie daarvoor dit topic. Versie 18.06 is de eerste stabiele uitgave na het samengaan van de projecten OpenWrt en Linux Embedded Development Environment. Deze update brengt verder een de volgende verzameling verbeteringen:

Highlights In OpenWrt 18.06.8

The OpenWrt Community is proud to announce the eighth service release of the stable OpenWrt 18.06 series. OpenWrt 18.06.8 brings security fixes, as well as the usual device support fixes and core components update. The main highlights of this service release are:

For more details, please see the detailed Changelog.

Versienummer 18.06.8
Releasestatus Final
Website OpenWrt
Download https://openwrt.org/releases/18.06/notes-18.06.8
Licentietype GPL

Door Bart van Klaveren

Downloads en Best Buy Guide

03-03-2020 • 10:54

22 Linkedin

Submitter: WRT54G

Bron: OpenWrt

Update-historie

Reacties (22)

Wijzig sortering
Yeey weer een nieuwe versie!
Echt mega wat je allemaal kan met deze router sofware. Bedenk een bepaalde service en het is geschreven voor Openwrt.
Al loop ik vaak tegen het punt aan dat mn routertje geen vrije ruimte meer heeft en dus een bepaald software pakket niet kan draaien.


Ik draai 19.07 branch maar merk dat deze niet heel stabiel is, Luci (webinterface) kan zo nu en dan geen gegevens laden.
Edit: Verder netwerk wel gewoon stabiel

Tijd om maar es te down/upgraden naar 18.06.8

[Reactie gewijzigd door robbinwehl op 3 maart 2020 11:21]

is er ook zo iets als dns-sinkhole / pihole?
Zelf gebruik ik het pakket Adblock op mijn OpenWRT-router, zie: https://openwrt.org/docs/guide-user/services/ad-blocking Ben erg tevreden.
Misschien is dit wat je zoekt? https://github.com/mrkno/pi-hole-lede-openwrt
Ja dat is er zeker.
Standaard functie is al om al het dns verkeer te forceren over je openwrt router of een specifieke dns server.
Zo heeft het voor clients geen nut als zij handmatig een dns instellen, requests blijven dan via de openwrt lopen.
Via de software package manager kan je zoeken op bijv. pi hole , je krijgt dan alle beschikbare packages te zien, deze kan je met 1 klik installeren.
Zoals Visje! hieronder aangeeft heb je lede pi hole.
Ik lees idd nog te veel problemen met 19.07 dus ik blijf voorlopig nog op de 18.06 met mijn TP-Link Archer C7's. Ze draaien al geruime tijd op OpenWRT (Lede hiervoor) en dik tevreden!
Ik lees idd nog te veel problemen met 19.07 dus ik blijf voorlopig nog op de 18.06 met mijn TP-Link Archer C7's. Ze draaien al geruime tijd op OpenWRT (Lede hiervoor) en dik tevreden!
Ik draai al geruime tijd de voorgaande development builds op Archer C7 routers en nu ook de final 19.07. Bijzonder stabiel, en snel dankzij hardwarematige NAT.

Verder maak ik best wel intensief gebruik van de managed switch, extra packages (HAProxy, VPN's, etc.). Af fabriek is het apparaat niet veel, maar met OpenWRT is het een veelzijdig en robuust apparaat.

[Reactie gewijzigd door The Zep Man op 3 maart 2020 11:28]

Sounds good! Heb je de C7 v2?
Mijn C7's werken overigens alleen als domme AP.
Voor de C7's staat nog een pfSense firewall die de rest regelt.
Sounds good! Heb je de C7 v2?
Yup. In verschillende varianten (originele van TP-Link, "Wifi Booster" van Ziggo...).

Overweeg ook de nieuwere ath79 target build in plaats van de oudere ar71xx. Die is geoptimaliseerd naar de beschikbare hardware.

[Reactie gewijzigd door The Zep Man op 3 maart 2020 11:26]

Recent heb ik 19.07 geprobeerd op mijn Archer C5 v1.2 (hardware vrijwel identiek aan C7 v2) en daar kreeg ik de 5 GHz wifi met de ath79 target build niet werkend. Dus daarom maar weer terug gegaan naar v18 met ar71xx. Voorlopig geloof ik het wel even met v19....
Recent heb ik 19.07 geprobeerd op mijn Archer C5 v1.2 (hardware vrijwel identiek aan C7 v2) en daar kreeg ik de 5 GHz wifi met de ath79 target build niet werkend.
Had je wel de package mod-ath10k geïnstalleerd? Was voor mij niet nodig (alles werkt out-of-the-box), maar wellicht ontbrak het in jouw image.

Verder is door DFS voor 5 GHz soms wat geduld nodig voordat de eerste verbinding toegestaan is.
Nee, ik heb niet gecheckt of die package geinstalleerd was. Aangezien ik een upgrade vanaf v18 deed, ging ik ervanuit dat het "gewoon" zou moeten werken zonder gehannis. Overigens denk ik dat dat eerder mijn probleem zou kunnen zijn dan een probleem met DFS want ik kan mij herinneren dat mijn 5 GHz adapter helemaal niet herkend werd.

[Reactie gewijzigd door arnova op 3 maart 2020 15:24]

Aangezien ik een upgrade vanaf v18 deed, ging ik ervanuit dat het "gewoon" zou moeten werken zonder gehannis.
Bij een upgrade worden extra geïnstalleerde packages niet opnieuw geïnstalleerd. Ook packages die onderdeel waren van een ouder image die niet in een nieuwer image zitten worden niet automatisch geïnstalleerd.
Overigens denk ik dat dat eerder mijn probleem zou kunnen zijn dan een probleem met DFS want ik kan mij herinneren dat mijn 5 GHz adapter helemaal niet herkend werd.
Dat lijkt toch echt meer op een driverprobleem. Zelfs tijdens de initiële periode waarin DFS geen verbindingen toelaat moet de adapter herkend worden.
Je kan je c5 v1.20 flashen naar een c7 (hardware is het zelfde in beide modellen)

Dan kun je de firmware builds voor de c7 pakken.

Op mijn routes draai ik overigens gargoyle.
Is de hardware matige nat in openwrt de moeite waard? Ik haal nu ook de volle 1000 mbit in eigen netwerk, en op de wanpoort heb ik toch geen gbit internet.
Thx! Binnenkort maar eens proberen. :*)
De Ziggo 'Wifi booster' kan je vaak voor een prikkie kopen op marktplaats. Werkt top met OpenWRT :D
Eerst naar LEDE flashen voordat je OpenWRT er op kan zetten, toch?

Overigens heb ik mijn N750 en C5 bijgewerkt; kan vandaag dus nog een keer ;)
Eerst naar LEDE flashen voordat je OpenWRT er op kan zetten, toch?
De makkelijkste weg is inderdaad eerst het LEDE image dat je hier kan vinden. Daarna een sysupgrade naar de nieuwste OpenWRT versie.

Een upgrade van ar71xx (LEDE of oudere OpenWRT versies) naar ath79 moet via de command-line interface en geforceerd.
Geen last van, 19.07.1 werkt prima op mijn WRT1900ACS.
Betekent dit ook dat je dan freemesh kunt updaten?
Freemesh is opensource software om voordelig mesh netwerk aan te leggen. Zou heel voed werken
freemesh
Ben benieuwd. Moet nog steeds mijn router updaten. Hij draait nu erg instabiel en moet hem bijna dagelijks herstarten.
Ik heb OpenWrt als virtual machine op mijn Unraid server draaien. Werkt perfect met een 4 ports NIC en een USB WiFi module.

Voordeel is ook dat je een nieuwe versie redelijk pijnloos kunt uitproberen.
Weet iemand hoe lang de v18x range nog van updates wordt voorzien?

Ik heb tweedehands een Netgear Nighthawk X4S R7800 op de kop getikt wat de hoofd router moet gaan worden. Ik twijfel nog welke versie daarop moet gaan komen...

Gisteren mijn huidige router (Netgear WNDR3700v4) en AP/switch (TP-Link WDR3600) geüpdatet en dat is vooralsnog probleemloos gegaan. Dat is nog wel ar71xx...

Op dit item kan niet meer gereageerd worden.


Nintendo Switch (OLED model) Apple iPhone SE (2022) LG G1 Google Pixel 6 Call of Duty: Vanguard Samsung Galaxy S22 Garmin fēnix 7 Nintendo Switch Lite

Tweakers vormt samen met Hardware Info, AutoTrack, Gaspedaal.nl, Nationale Vacaturebank, Intermediair en Independer DPG Online Services B.V.
Alle rechten voorbehouden © 1998 - 2022 Hosting door True

Tweakers maakt gebruik van cookies

Tweakers plaatst functionele en analytische cookies voor het functioneren van de website en het verbeteren van de website-ervaring. Deze cookies zijn noodzakelijk. Om op Tweakers relevantere advertenties te tonen en om ingesloten content van derden te tonen (bijvoorbeeld video's), vragen we je toestemming. Via ingesloten content kunnen derde partijen diensten leveren en verbeteren, bezoekersstatistieken bijhouden, gepersonaliseerde content tonen, gerichte advertenties tonen en gebruikersprofielen opbouwen. Hiervoor worden apparaatgegevens, IP-adres, geolocatie en surfgedrag vastgelegd.

Meer informatie vind je in ons cookiebeleid.

Sluiten

Toestemming beheren

Hieronder kun je per doeleinde of partij toestemming geven of intrekken. Meer informatie vind je in ons cookiebeleid.

Functioneel en analytisch

Deze cookies zijn noodzakelijk voor het functioneren van de website en het verbeteren van de website-ervaring. Klik op het informatie-icoon voor meer informatie. Meer details

janee

    Relevantere advertenties

    Dit beperkt het aantal keer dat dezelfde advertentie getoond wordt (frequency capping) en maakt het mogelijk om binnen Tweakers contextuele advertenties te tonen op basis van pagina's die je hebt bezocht. Meer details

    Tweakers genereert een willekeurige unieke code als identifier. Deze data wordt niet gedeeld met adverteerders of andere derde partijen en je kunt niet buiten Tweakers gevolgd worden. Indien je bent ingelogd, wordt deze identifier gekoppeld aan je account. Indien je niet bent ingelogd, wordt deze identifier gekoppeld aan je sessie die maximaal 4 maanden actief blijft. Je kunt deze toestemming te allen tijde intrekken.

    Ingesloten content van derden

    Deze cookies kunnen door derde partijen geplaatst worden via ingesloten content. Klik op het informatie-icoon voor meer informatie over de verwerkingsdoeleinden. Meer details

    janee