Cookies op Tweakers

Tweakers maakt gebruik van cookies, onder andere om de website te analyseren, het gebruiksgemak te vergroten en advertenties te tonen. Door gebruik te maken van deze website, of door op 'Ga verder' te klikken, geef je toestemming voor het gebruik van cookies. Wil je meer informatie over cookies en hoe ze worden gebruikt, bekijk dan ons cookiebeleid.

Meer informatie

Door , , 15 reacties
Bron: Mozilla Developer News

Mozilla Firefox logo (75 pix) De ontwikkelaars van Mozilla hebben niet alleen de 3-serie van Firefox een update gegeven, maar ook de 2-tak van de browser voorzien van een update. Om precies te zijn gaat het om versie 2.0.0.19, die vanaf deze pagina te downloaden is. Firefox is een opensource webbrowser die standaard voorzien is van tabbed browsing, een pop-up blocker en een rss-reader. Daarnaast is het mogelijk extra functionaliteit toe te voegen door middel van add-ons. Verder kan ook het uiterlijk van Firefox via themes gewijzigd worden.

Volgens Mozilla is Firefox 2.0.0.19 de allerlaatste Firefox van de 2-serie. Deze tak krijgt geen beveiligings- en stabiliteitupdates meer. Verder zal ook de Phishing Protection niet meer ondersteund worden en raden de ontwikkelaars sterk aan om naar de 3-serie van Firefox over te stappen:

Mozilla is not planning any further security & stability updates for Firefox 2, and recommends that you upgrade to Firefox 3 as soon as possible. It’s free, and your settings and bookmarks will be preserved.

Also, the Phishing Protection service will no longer be available for Firefox 2 users. Firefox 3 offers a free Phishing and Malware Protection service, which will continue to protect you from online scams and attacks.

If you already have Firefox 3 or Firefox 2, you will receive an automated update notification within 24 to 48 hours. This update can also be applied manually by selecting “Check for Updates…” from the Help menu.

Fixed in Firefox 2.0.0.19
  • MFSA 2008-69 XSS vulnerabilities in SessionStore
  • MFSA 2008-68 XSS and JavaScript privilege escalation
  • MFSA 2008-67 Escaped null characters ignored by CSS parser
  • MFSA 2008-66 Errors parsing URLs with leading whitespace and control characters
  • MFSA 2008-65 Cross-domain data theft via script redirect error message
  • MFSA 2008-64 XMLHttpRequest 302 response disclosure
  • MFSA 2008-62 Additional XSS attack vectors in feed preview
  • MFSA 2008-61 Information stealing via loadBindingDocument
  • MFSA 2008-60 Crashes with evidence of memory corruption (rv:1.9.0.5/1.8.1.19)
Versienummer:2.0.0.19
Releasestatus:Final
Besturingssystemen:Windows 9x, Windows 2000, Linux, Windows XP, macOS, Windows Server 2003, Windows Vista, Windows Server 2008
Website:Mozilla Developer News
Download:http://www.mozilla.com/en-US/firefox/all-older.html
Licentietype:Freeware
Moderatie-faq Wijzig weergave

Reacties (15)

Waarom zijn er nog mensen die versie 2.xx gebruiken als 3 al uit is..? Compatibiliteit??
Compatibiliteit??

Ja, hier op het werk draaien we nog een oude RHEL3 wegens compatibiliteit met andere software. Bijgevolg moeten we ook FF2 blijven gebruiken. FF3 vereist extra libraries die zonder root wachtwoord niet te installeren zijn. En aan IT moet je het hier ook niet vragen. In principe moeten we Mozilla 1.5 gebruiken...
Gemakzucht?

Voor het upgraden naar versie 3 moet je zelf extra werk verrichten, het automatisch bijwerken van Fx 2.0 niet.

Overigens zal Fx 2.0.0.19 ook een automatische update aanbieden naar Fx 3.0.5 - zodat iedereen de mogelijkheid heeft om automatisch naar Fx 3.0 over te gaan.

Zoals in het artikel al te lezen is, wordt Fx 2.x niet langer meer geupdate en is 2.0.0.19 de laatste update...
Omdat nummertje drie hier onherroepelijk crasht en me pc naar de vaantjes helpt. Vraag niet hoe het kan maar miseri krijg ik op deze pc na installatie van FF3. FF2 geeft geen problemen dus ik blijf bij 2 :)
Versie 3 draait enkel op de meest recente versie van Linux. Dus bedrijven met oudere versies van Linux zijn op 2 aangewezen. Zoals wij hier..
Maar kan jouw bedrijf dan niet de Linux opwaarderen naar een nieuwere versie? Of zijn nieuwere versies (gedeeltelijk) incompitabel met de programma's die jouw bedrijf gebruikt? ;)
Hoezo dat dan? Mozilla compileert semi-statische builds die over het algemeen op elke distributie die is uitgeleverd tussen 2 jaar geleden en nu zou moeten werken. Dat er voor jouw oude distributie geen pakketje met firefox3 beschikbaar is wil niet zeggen dat Firefox3 niet werkt.
Compatibiliteit??
Google Browser Sync...
Wat dat betreft wel jammer dat Weave niet zo opschiet. Vind ik echt een mooi project, zeker als ze straks extensions kunnen syncen! _/-\o_
Omdat ik zeer tevreden ben met mijn huidige perfect werkende v2 + plugins. :)
Windows 98 en ME kunnen niet met FF3 overweg en ja er draaien nog aardig wat van die bakken. Gisteren nog een '98se bak vervangen.
De softwarearchitectuur van firefox 3.x is volgens mij een stuk anders dan firefox 2.x.
Dus het lijk me best logisch dat er nog veel mensen zijn die nog de vorige versie door compatibiliteit reden (OS ondersteuning en gevoelige plugins die alleen op ff2 werken) gebruiken.
Een groot deel van de plug-ins werken nog steeds niet op FF3
Vandaar dat ik ook nog op FF2 blijf.
Vanuit veiligheidsoverwegingen wordt het stilaan weer wel tijd om over te stappen, ongeacht de handige plug-ins
(nieuws: Mozilla verwijdert phishingfilter uit Firefox 2.0 op verzoek Google)
Hoe komt het dat als je de NL of UK versie download, je gewoon in de download pagina blijft terwijl je bij de US versie doorgelinkt wordt naar een installatie handleiding? Zijn ze daar aan de overkant van de plas echt niet slimmer?
Uhmm ligt het aan mij of is er pas geleden versie 20020 uitgebracht?
In ieder geval op de site kan ik versie .20 downloaden

Op dit item kan niet meer gereageerd worden.



Apple iOS 10 Google Pixel Apple iPhone 7 Sony PlayStation VR AMD Radeon RX 480 4GB Battlefield 1 Google Android Nougat Watch Dogs 2

© 1998 - 2016 de Persgroep Online Services B.V. Tweakers vormt samen met o.a. Autotrack en Carsom.nl de Persgroep Online Services B.V. Hosting door True