Cookies op Tweakers

Tweakers maakt gebruik van cookies, onder andere om de website te analyseren, het gebruiksgemak te vergroten en advertenties te tonen. Door gebruik te maken van deze website, of door op 'Ga verder' te klikken, geef je toestemming voor het gebruik van cookies. Wil je meer informatie over cookies en hoe ze worden gebruikt, bekijk dan ons cookiebeleid.

Meer informatie

Door , , 6 reacties
Bron: VMware

VMware heeft versie 6.0.3 build 80004 van zijn virtualisatiesoftware Workstation uitgebracht. Dit pakket doet zijn werk onder Linux of Windows en is in staat om via een virtuele machine diverse besturingssystemen op de hostcomputer te laten draaien. Voor de gastcomputer kan je gebruikmaken van verschillende BSD-varianten, diverse Linux-distributies, Solaris en Windows. Voor meer informatie verwijzen we jullie door naar deze pagina en deze handleiding in pdf-formaat. De lijst met aanpassingen voor versie 6.0.3 build 80004 ziet er als volgt uit:

New in Version 6.0.3:

Workstation 6.0.3 adds full support for the following operating systems:
  • 32-bit and 64-bit Ubuntu Linux 7.10 as host and guest operating systems
  • 32-bit and 64-bit Red Hat Enterprise Linux 4.6 as host and guest operating systems
  • 32-bit and 64-bit Asianux Server 3 as a guest operating system
  • 32-bit and 64-bit Turbolinux 10 Server as a guest operating system
Note: The Eclipse Integrated Virtual Debugger is not yet supported on Ubuntu Linux 7.10 and Red Hat Enterprise Linux 4.6 hosts.

Workstation 6.0.3 addresses the following security issues:
  • On Windows hosts, if you have configured and enabled a shared folder, it is possible for an attacker to write arbitrary content from a guest system to arbitrary locations on the host system (CORE-2007-0930). (bug 200360)
  • An internal security audit determined that a malicious user could attain and exploit LocalSystem privileges by causing the authd process to connect to a named pipe that is opened and controlled by the malicious user. (Foundstone CODE-BUG-H-001) In this situation, the malicious user could successfully impersonate authd and attain privileges under which Authd is executing. (bug 193049)
  • This release updates the libpng library to version 1.2.22 to remove various security vulnerabilities. (bug 224453)
  • This release updates the OpenSSL library to address various vulnerabilities to denial-of-service attacks and buffer overflows. The Common Vulnerabilities and Exposures project (cve.mitre.org) assigned the following names to these issues: CVE-2006-2940, CVE-2006-2937, CVE-2006-4343. (bug 216493)
  • Workstation 6.0.2 allowed anonymous console access to the guest by means of the VIX API. This release, Workstation 6.0.3, disables this feature. This means that the Eclipse Integrated Virtual Debugger and the Visual Studio Integrated Virtual Debugger will now prompt for user account credentials to access a guest. (bug 187785)
Known Issues Fixed in Workstation 6.0.3:
  • On openSUSE Linux 10.3 hosts, USB devices cannot be used in a virtual machine unless you plug the USB device in to the host before powering on the virtual machine. (bug 177615)
  • With Workstation 6.0.2 the iPhone could be seen as a camera device by a Windows guest but iTunes did not list the device in its device list. In this release, Workstation 6.0.3, the iPhone is usable and visible in iTunes for Windows guests. (bug 191214)
  • On 64-bit Windows Vista hosts, if the guest has a USB controller and you attempt to connect or disconnect a USB device, occasionally the guest crashes to blue screen with a "USBPROT.SYS" error. (bug 219224)
  • For Windows guests, if a filename inside a shared folder includes any extended ASCII characters (that is, characters whose ASCII code is above 128), then you cannot view any of the files in the shared folder. The folder looks empty when you access it from the guest operating system. The value of such characters could not be converted to UTF-8. (bug 222397)
  • For Windows guests, if you configured the virtual machine to connect to a specific physical floppy drive instead of using auto-detect, and if you then start the virtual machine without having a floppy disk in the drive, you might see a "Windows - No Disk" error message. (bug 217782)
  • On Windows guests, you cannot access files that are cached for offline access. This means that if you have set up the system to mount a network drive and enable the option to cache files for offline access, you still will not be able to access the files unless the remote server is available. (bug 201758)
  • On Linux guests that use X.Org Server 1.3, which includes Fedora Core 7 guests, you receive the following error message when installing VMware Tools: "Detected X.org 1.3. No drivers for X.org version 1.3." (bug 185281)
  • On some 64-bit Windows hosts, the host sometimes crashes when starting up a Linux virtual machine that has paravirtual kernel support enabled. (bug 192011)
  • If you install Workstation on a Linux host that uses kernel version 2.6.23 or newer, the necessary kernel modules do not build. Therefore, Workstation is installed but cannot start. (bug 200828)
  • On Windows Vista hosts and Windows guests, if you swap the left and right mouse button functions, as many left-handed people do, dragging and dropping files does not work correctly. (bug 188997)
  • Occasionally on Windows guests, the guest crashes when you use the multiple-monitor feature and view streaming video. This issue might arise if you have two monitors arranged one on top of another and you launch a media player from the secondary monitor. (bug 189779).
  • In some newer Linux guest operating systems, the mouse pointer becomes unusable after you install VMware Tools. (bug 156988)
  • Hardware breakpoints set in applications that run inside guest operating systems are lost occasionally. (bug 199267)
Moderatie-faq Wijzig weergave

Reacties (6)

Zit in deze versie ook een update van VMware Tools? Zo ja, dan blijf ik bij v6.0.2.59824
Heb namelijk nog geen zin alle virtuele machientjes min of meer verplicht bij te werken.
In (bijna) elke nieuwe versie zit een nieuwe versie van VMware Tools. Logisch ook omdat er steeds bugs worden gefixed en nieuwe functionaliteit toegevoegd.

Maar je kan ook gewoon de oude VM's draaien met oude VMware Tools hoor, je krijgt alleen een melding dat ze outdated zijn, maar het zal gewoon werken (tenzij je misschien een prehistorische versie hebt, maar zo te zien is dat niet het geval).

En waarom zou je die tools niet upgraden? het is niet dat je er uren mee bezig bent ofzo, het kost je nog geen minuut per VM...
Bij Preferences -> Tools staat:
"Upgrade automatically at next power on when a new version of VMWare tools is available."
Ben alleen bang dat het niet zo automatisch zal gaan als dat je zou willen bij hedendaagse OS'n.
Ja, nieuwe versie Vmware tools
Die bug met 2.6.23 die geen modules kon bouwen was al officieus gepatched. Er was een functie in het netwerk gedeelte van naam veranderd.

Wel mooi dat dat nu in de officiele distributie zit, dan hoef je niem meer zelf de vmnet tree te patchen.
If it an't broke, don't fix it.

Als je dus geen reden hebt om te updaten, dan hoef je dat natuurlijk niet te doen. WS 6.2 is goed genoeg voor 'normaal' gebruik. Maar als je de nieuwe features of fixes wilt gebruiken, dan zou ik WS zelf wel bijwerken.

Dan hoef je inderdaad nog niet meteen de gasten bij te werken, dat kan je rustig doen op het moment dat je die bijwerkt, des noods over een jaar of 4...

Op dit item kan niet meer gereageerd worden.



Apple iOS 10 Google Pixel Apple iPhone 7 Sony PlayStation VR AMD Radeon RX 480 4GB Battlefield 1 Google Android Nougat Watch Dogs 2

© 1998 - 2016 de Persgroep Online Services B.V. Tweakers vormt samen met o.a. Autotrack en Carsom.nl de Persgroep Online Services B.V. Hosting door True