Cookies op Tweakers

Tweakers maakt gebruik van cookies, onder andere om de website te analyseren, het gebruiksgemak te vergroten en advertenties te tonen. Door gebruik te maken van deze website, of door op 'Ga verder' te klikken, geef je toestemming voor het gebruik van cookies. Wil je meer informatie over cookies en hoe ze worden gebruikt, bekijk dan ons cookiebeleid.

Meer informatie

Door , , 24 reacties
Bron: nVidia, submitter: accel

De ontwikkelaars van nVidia hebben weer een nieuwe nVidia Display Driver uitgebracht met 1.0-9629 als het versienummer. Deze drivers zijn in vier verschillende smaken binnen te halen, namelijk voor Linux x86, Linux x64, FreeBSD x86 en Solaris x86/x64. Met deze nieuwe versie is het onder andere mogelijk om een Quad SLI opstelling aan de praat te krijgen en wordt OpenGL 2.1 ondersteund. De lijst met aanpassingen toont ons het volgende:

Release Highlights:
  • Added initial support for GLX_EXT_texture_from_pixmap.
  • Added new "Display Configuration" page in nvidia-settings.
  • Improved workstation OpenGL performance in Xinerama.
  • Added support for NVIDIA Quadro Plex.
  • Added support for Quad SLI.
  • Improved X driver error recovery.
  • Improved workstation overlay performance.
  • Added SMBus functionality to the Linux/i2c interface.
  • Fixed DFP scaling support.
  • Added support for OpenGL 2.1.
  • Added new "TwinViewXineramaInfoOrder" X configuration option to control the order of display devices when in TwinView.
  • Fixed some problems related to TV Out.
  • Added new NVIDIA logo artwork to nvidia-settings and X driver splashscreen; the X driver splashscreen can now be configured with the new "LogoPath" X configuration option.
[break]De volgende vier bestanden zijn binnen te halen:
* nVidia Linux x86 Display Driver 1.0-9629
* nVidia Linux x64 Display Driver 1.0-9629
* nVidia FreeBSD x86 Display Driver 1.0-9629
* nVidia Solaris x86/x64 Display Driver 1.0-9629

Lees meer over

Versienummer:1.0-9629
Besturingssystemen:Linux, BSD, Linux x86, Solaris, Linux AMD64
Website:nVidia
Download:http://www.nvidia.com/object/unix.html
Licentietype:Voorwaarden (GNU/BSD/etc.)
Moderatie-faq Wijzig weergave

Reacties (24)

Helpt deze driver nu ook om AIGLX onder Fedora aan de praat te krijgen?
Ja, de nvidia beta 9xxx drivers ondersteunen AIGLX. Dit kan dankzij de support voor GLX_EXT_texture_from_pixmap. Kijk bijvoorbeeld op http://gentoo-wiki.com/HOWTO_nVidia_GL_Desktop_Effects voor een howto.
Nu zal ik dit niet in een flame war veranderen maar...

AIGLX geeft werkelijkwaar niets maar dan ook niets te maken met de nvidia-close source drivers. Om het niet te technisch te laten worden.
AIGLX is simpel weg een andere aanpak als de XGL manier om Beryl / Compiz te voorzien van mooie eye-candy...

oh en je link naar de Gentoo-wiki site. Ik copy paste de eerste regel

"This short guide will describe how to use nVidia's drivers to create an OpenGL accelerated desktop environment similar to AIGLX. Currently, driver revision 9625 BETA or higher is required."

Hmmm, read before you act... Arian San.... ;)

Maar verder.... hopelijk zijn de vervelende i2c bug eruit gehaald en hebben ze het geheel wederom Xen compatible gemaakt. Ik wordt gek van al die patches die ik over hun toch vrij vaak uitkomende releases moet gooien om het geheel draaiend te krijgen..

Grz
Sorry, dat is mijn standaard reactie op de AIGLX vraag... Ik weet dat het niet hetzelfde is, maar vrijwel iedereen die om AIGLX vraagt bedoelt gewoon "Beryl/Compiz draaien zonder XGL", en dat is natuurlijk wel mogelijk met deze beta drivers.
Naar mijn weten heeft dit er wel zeker iets mee te maken. Het systeem AIGLX heeft gewoon de GLX_EXT_texture_from_pixmap nodig, wat in de driver ge´mplementeerd moet zijn. Dat bij de hierboven geposte link niet helemaal duidelijk wordt dat gebruik wordt gemaakt van AIGLX komt volgens mij gewoon omdat het standaard al in X.org is ge´ntegreerd (vanaf 7.1).

"Currently, driver revision 9625 BETA or higher is required." Dit komt omdat vanaf deze driver de GLX_EXT_texture_from_pixmap extensie is ge´mplementeerd. De 9629 waar we het nu over hebben is echter de eerste stabiele driver met deze extensie wat het geheel toch wel een stuk prettiger maakt.
aiglx + compiz en fedora 6 werkte al prima met de beta driver van livna...

ik heb hier deze howto voor gevolgd:
http://www.fedoraforum.or...?t=121119&highlight=aiglx

echter, er is zo te zien sindsdien alweer een en ander verandert en werkt AIGLX nu out of the box met de "1.0-9625 driver or better" en ook AIGLX + beryl behoort nu tot de mogelijkheden!

vanavond maar eens fijn even uitproberen :)
Ik vrees van niet. NVIDIA doet niet aan AIGLX.
Just pondering 'Added support for OpenGL 2.1.'.. En waarom heeft de laatste Nvidia windows driver maar support voor OpenGL 2.0? Tussen deze twee zit misschien net een week of 2?
Tsja, als zelfs Microsoft nu (Suse) Linux gaat verkopen, kan ik me voorstellen dat nVidia ook niet zo veel meer ziet in Windows ;)
gewoon omdat windows zelf geen OpenGL2.1 heeft.. het kan daar alleen met sommige programmas waar je tog "custom drivers" nodig voor hebt.
Nvidia is goed bezig voor Linux.

Beryl is nu bijvoorbeeld zˇ gemakkelijk aan de praat te krijgen als je deze hebt ge´nstalleerd, echt een verademing.
Beryl is nu bijvoorbeeld zˇ gemakkelijk aan de praat te krijgen als je deze hebt ge´nstalleerd, echt een verademing.
Misschien handig aan te geven hoe dit zˇ gemakkelijk aan de praat te krijgen is aan de hand van een klein stappenplan oid?
Verschilt natuurlijk per distro. Sommige distro's zullen wel een package ofzo hebben die na installatie er voor zorgt dat alles autometotisch werkt.

Onder gentoo is het als volgt (en voor mensen aankomen met 'zie je wel dat linux te moeilijk is' -- Gentoo gebruikers kiezen voor veel handwerk, dat is hoe de distro opgebouwd is. Bovendien is Beryl nog prille software).

* xorg.conf aanpassen (nVidia only, ATi weet ik niet):
Section "Device"
[wat er al stond]
Option "RenderAccel" "on"
Option "AddARGBGLXVisuals" "true"
EndSection

Section "Extensions"
Option "Composite" "Enable"
EndSection
* emerge beryl
* Voor KDE, /etc/env.d/99kde-env aanpassen:
KDEWM=beryl-manager
* Voor Gnome, ~/.config/autostart/beryl-manager.desktop maken:
[Desktop Entry]
Name=No name
Encoding=UTF-8
Version=1.0
Exec=beryl-manager
X-GNOME-Autostart-enabled=true
Met behulp van deze guide is het makkelijk aan de praat te krijgen als je in het bezit bent van een NVidia grafische kaart. Onthoud wel dat deze guide is geschreven voor versie 1.0-9625 van de driver (beta versie die ik ook op het moment draai). Dus dat moet je nog veranderen naar deze recentere versie.
* Added initial support for GLX_EXT_texture_from_pixmap
Alle linux fanaten kunnen een vreugdedansje doen :). Voor mij misschien toch wel een reden om toch eens linux te gaan installeren. Laten we hopen dat ATi snel volgt.
OpenGL vendor string: ATI Technologies Inc.
OpenGL renderer string: ATI Mobility Radeon X1400 Generic
OpenGL version string: 2.0.6011 (8.28.8)

server glx extensions:
GLX_ARB_multisample, GLX_EXT_visual_info, GLX_EXT_visual_rating,
GLX_EXT_import_context, GLX_EXT_texture_from_pixmap, GLX_OML_swap_method,
GLX_SGI_make_current_read, GLX_SGIS_multisample, GLX_SGIX_hyperpipe,
GLX_SGIX_swap_barrier, GLX_SGIX_fbconfig


En dat met de ati driver van dik 2 maanden terug.
De ati implementatie schijnt bijzonder buggy te zijn (maar dat weet ik niet uit ervaring)
op zich zat al deze functionaliteit al in de 9625 beta driver, maar daar zaten ook een paar bugjes in.

Ik had zelf last van een bug waarbij grotere/rare resoluties niet mogelijk waren via DVI. Ik moest mijn 1440x900 TFT op VGA aansluiten, en kon mijn beamer dus niet aansluiten. Hopelijk is dit nu opgelost.
Op het Nvidia forum is al lang uitgekeken naar deze driver. Het is ook niet zomaar een upgrade, maar de eerste in een totaal nieuwe serie. Volgens de mensen van Nvidia is de interne architectuur grondig onder handen genomen.

Goede zaak dit!

NVidia had al de lead onder Linux, en dat breiden ze nu alleen nog maar uit.
Heel veel lof alleen....
de standaard skin van xmms player is nu een beetje vernageld bij mij :'( .
Is dit bij meerdere mensen ook zo?
(BTW: ik heb de ubuntu distro)

EDIT:
Oorzaak gevonden:
Na installatie van de NVidia driver is de Section "Files" met daarin de paden naar de fonts verdwenen van het xorg.conf bestand.

Na het aanpassen hiervan werkt het weer!
(detail:
Section "Files"
FontPath "/usr/share/X11/fonts/misc"
FontPath "/usr/share/X11/fonts/cyrillic"
FontPath "/usr/share/X11/fonts/100dpi/:unscaled"
FontPath "/usr/share/X11/fonts/75dpi/:unscaled"
FontPath "/usr/share/X11/fonts/Type1"
FontPath "/usr/share/X11/fonts/CID"
FontPath "/usr/share/X11/fonts/100dpi"
FontPath "/usr/share/X11/fonts/75dpi"
# paths to defoma fonts
FontPath "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
FontPath "/var/lib/defoma/x-ttcidfont-conf.d/dirs/CID"
EndSection
)
Daarom koop ik altijd zo graag Nvidia producten, hun support is altijd vele malen beter dan die van ATi. ATi kan veel leren van de driversupport, maar ook van usability van de controlpaneeltjes en simpliciteit dat Nvidia in zijn software stopt.
Ati was eerder met Xorg 7 support
Ati was eerder met GLX_EXT_texture_from_pixmap

Ati is lang zo slecht niet meer als dat ze een jaar terug waren. Credit where Credit is due.
Ati heeft helemaal geen texture_from_pixmap! ook niet in de nieuwste driver, van vorige week.

De r200 en r300 kunnen het wel, maar dat is eerder ondanks Ati, de open source drivers voor die kaarten zijn namelijk met veel bloed, zweet en tranen reverse engineerd, waarbij Ati alleen maar tegengewerkt heeft.
Leg mij de output van glxinfo dan eens uit?

Op dit item kan niet meer gereageerd worden.



Apple iOS 10 Google Pixel Apple iPhone 7 Sony PlayStation VR AMD Radeon RX 480 4GB Battlefield 1 Google Android Nougat Watch Dogs 2

© 1998 - 2016 de Persgroep Online Services B.V. Tweakers vormt samen met o.a. Autotrack en Carsom.nl de Persgroep Online Services B.V. Hosting door True