Cookies op Tweakers

Tweakers maakt gebruik van cookies, onder andere om de website te analyseren, het gebruiksgemak te vergroten en advertenties te tonen. Door gebruik te maken van deze website, of door op 'Ga verder' te klikken, geef je toestemming voor het gebruik van cookies. Wil je meer informatie over cookies en hoe ze worden gebruikt, bekijk dan ons cookiebeleid.

Meer informatie

Door , , 34 reacties
Bron: ATi, submitter: nhimf

ATi logo (kleiner) ATi heeft nieuwe display drivers voor Linux uitgebracht en deze versienummer 8.27.10 meegegeven. Ze kunnen hun werk doen op alle kaarten vanaf de Radeon 8500 en zijn beschikbaar voor een 32-bits en 64-bits omgeving als closedsource-driver. Naast enkele bugfixes zijn de meest noemenswaardige veranderingen ondersteuning voor X.org 7.1 en de Linux-distributie van Fedora Core. Het volledige changelog ziet er als volgt uit:

New Features
  • X.org 7.1 Support
  • Fedora Core Package Support
Resolved Issues
  • TV Out is currently not supported on the ATI Radeon X1x00 products.
  • Resolution of a number of rendering issues affecting the OpenGL-based Java2D pipeline. Java users are highly encouraged to upgrade their ATI Proprietary Linux drivers to version 8.27.10 or higher.
  • Resolution of an XGL startup issue that prevented users from starting XGL on display :0.
Known Issues
  • Attempting to install the ATI Proprietary Linux driver on distributions that have updated certain 3D components outside of the stock XOrg 6.8.2 may result in the driver not initializing 3D applications properly.
  • TV display is corrupt after switching resolutions.
  • A system hang may occur when attempting to resume from hibernation mode.
  • Attempting to use 3D applications on Radeon 9000/9100/9200/9250 and FireGL 8x00 products fails to start and reports back something similar to "[fglrx] API ERROR: could not register entrypoint for SelectTextureSGIS".
  • Loading the XVideo Extension on 64-bit Xorg 6.9+ systems causes the X Server to segfault on launch with ATI Radeon X1K products.
  • Users with X Server X.org 7.1 can not play any video using XV. The ATI AVIVO Video adaptor is not present.
[break]De volgende downloads zijn beschikbaar:
*ATi Driver Installer version 8.27.10 voor 32-bits versie van Linux
*ATi Driver Installer version 8.27.10 voor 64-bits versie van Linux[break]
ATi Linux Driver logo

Lees meer over

Alle 25 producten

Versienummer:8.27.10
Besturingssystemen:Linux
Website:ATi
Download:https://support.ati.com/ics/support/default.asp?deptID=894&task=knowledge&folderID=300
Bestandsgrootte:23,90MB
Licentietype:Voorwaarden (GNU/BSD/etc.)
Moderatie-faq Wijzig weergave

Reacties (34)

Grr, support voor de 7500 blijkt m'n meest naieve wens ooit...
volgens mij gaat dat nooit meer komen...

voor windows wordt ie iig niet meer supported, dus dnk dat ze het zelfde doen bij de linux drivers....
Het verschil is dan wel dat er in windows ooit degelijke drivers zijn uitgebracht voor de 7500, in linux niet bij mijn weten. :(
Hoop op support voor oude hardware is zowiezo naief. :P
Wordt die niet gewoon door de open source radeon driver ondersteund?
De 7500 wordt uitstekend ondersteund door de Open Source radeon Driver, een van de best onderhouden video drivers onder Linux / Xorg.

Niet zeuren dus. :-)
Misschien kan je het aan ATI vragen? Misschien zullen ze je uit medelijden een echte videokaart sturen. :+
Wordt de ATI Mobility Radeon 1400 ook ondersteund? Ik heb een Dell Inspiron 6400 laptop met een X1400, maar die kaart staat niet in het lijstje.
Naar mijn weten wordt die ondersteund.
... • Gerelateerde producten: (eerste 30 op totaal van 348): ...
die kaart is van de R5xx familie die ondersteunt is
toch wel mooi van Ati dat ze nu Xorg 7.1 ondersteunen.
nVidia heeft nog geen driver uit gebracht die het ondersteund helaas :(

Verder zijn er eigenlijk nie veel bugs gefixed...
Euh, best wel rare statement, aangezien ik toch wel Xorg 7.1 draai op Debian Unstable, in combinatie met de nieuwste nvidia drivers?
Het enige wat ik moest doen om het te laten werken is 2 nieuwe symlinks aanmaken. :Z
heb jij zelf xorg 7.1 gecompileerd? :?
In de Debian reps zit ie nog op 7.0
Alleen xbase-clients en xutils zijn naar 7.1

Dat het kan door links te veranderen wist ik maar mijn punt is dat het niet standaard werd ondersteund, en dat is bij Ati
wel het geval. :)
Euh, best wel rare statement, aangezien ik toch wel Xorg 7.1 draai op Debian Unstable, in combinatie met de nieuwste nvidia drivers?
Valt wel mee hoor, het gaat hier namelijk om de ATI drivers :)
deze ati drivers werken van gene kanten op 64 bits linux distributies (ubuntu in dit geval) voor simpele ati rage xl
vanaf nu is AIGLX dus mogelijk met deze drivers dacht ik! goed nieuws!
Nope, de pixmap extentie doet het nog niet. Volgens bronnen zal Ati de eerstvolgende versie het voor elkaar hebben, dus nog heel even wachten.
Die functie komt uit je MesaGL kakken, en de enige MesaGL met die functie zit naar mijn weten nog enkel in CVS.
Die mesa zit al wel in de FC6 test releases, en misschien zelfs in FC5, aangezien ze daar al een groot deel van de support in hebben zitten.
FC5-aiglx repo heeft inderdaad Mesa uit cvs
check hier eens: Gentoo Forums

een Gentoo user heeft de driver geïnstalleerd en heeft de GLX_EXT_texture_from_pixmap
'k heb deze driver zojuist geinstalleerd en twee zaken vallen op:

- bij glxgears gaat het aantal fps terug van 8400+ naar 3200+ t.o.v. driver versie 8.26.18
- XGL start een heel stuk sneller op; van +/- 1 minuut naar ongeveer 10 seconden

ik draai overigens de 64bit versie op een X800XL met Fedora Core 5
GLX gears is alleen een programmaatje om te zien hoe snel je processor door de main loop heen is.
tja...ik weet ook wel dat glxgears niet een de-facto benchmark programma is, maar een fps drop van 5200 fps is wel op z'n minst opvallend, aangezien bij alle voorgaande drivers het aantal fps ongeveer gelijk bleef...
Wanneer de drivers open source zouden zijn dan bleef de oude hardware ook ondersteund. Dan evolueert de code voor de oude hardware mee met de rest.
Helaas willen niet alle fabrikanten dat.
Zie voor een mooi verhaal:
http://www.kroah.com/log/linux/stable_api_nonsense.html
http://www.kroah.com/log/2005/11/03/
Probleem met oude kaarten is dat mensen die dingen uitendelijk vervangen door nieuwe kaarten. Laatst praatte ik met een X.Org driver ontwikkelaar (unichrome project), die had het er al over dat er allemaal oude PCI meuk al niet meer te krijgen is, waardoor ze nieuwe releases niet kunnen testen.
overlay op tv-out werkt nog steeds niet (het beeld is vertikaal opgeblazen tot 200%). Heeft wel gewerkt in versie 8.20, maar Ati wil het niet meer corrigeren:
"The Linux drivers available from ATI are provide are "as is"."
Hierdoor moet ik blijven werken met de 2.6.11.12 kernel, terwijl we onderhand al bij 2.6.17 zijn.
geweldig dit :) kan ik eindelijk eens aiglx gaan proberen op fc6 :)
Wat is het verschil van deze drivers en die ik van livna af haal?!? (Ik gebruik FC4...)
maar het minste dat ze dan toch kunne doen is de specs open gooien dat de gemeenschap er iets kan voor schijven.
Maar dat is weer te veel gevraagt zeker? (het is dat ze zo veel inkomste zullen mislopeen hé :? )
Ik snap dat dan weer niet, als ze in de licence verplicht stellen dat het dan expliciet niet om ATI-mde maar om HOME-made drivers gaat, dan zou je toch al iig een argument kunnen wegnemen van Ati dat men in de war kan raken.

Ik vind het zelf betreurenswaardig hoe weinig mogelijkheden ik heb voor mijn videokaart onder Linux. Ik had graag nog wel een bijdrage willen leveren om hier iets aan te verbeteren.

Op dit item kan niet meer gereageerd worden.



Apple iOS 10 Google Pixel Apple iPhone 7 Sony PlayStation VR AMD Radeon RX 480 4GB Battlefield 1 Google Android Nougat Watch Dogs 2

© 1998 - 2016 de Persgroep Online Services B.V. Tweakers vormt samen met o.a. Autotrack en Carsom.nl de Persgroep Online Services B.V. Hosting door True