Cookies op Tweakers

Tweakers maakt gebruik van cookies, onder andere om de website te analyseren, het gebruiksgemak te vergroten en advertenties te tonen. Door gebruik te maken van deze website, of door op 'Ga verder' te klikken, geef je toestemming voor het gebruik van cookies. Wil je meer informatie over cookies en hoe ze worden gebruikt, bekijk dan ons cookiebeleid.

Meer informatie

Door , , 46 reacties
Bron: PSP-Updates, submitter: iyanic

Het heeft even geduurd, maar ook de beveiliging van de 2.50-versie van de firmware van Sony's PlayStation Portable heeft het begeven. Twee hackers die als 'Fanjita' en 'Ditlew' door het leven gaan, hebben de Super Nintendo-emulator uo_Snes9x aan het werk gekregen op PSP's met firmwarerevisie 2.01 en hoger. Door middel van een speciale Grand Theft Auto: Liberty City Stories-savegame kunnen programma's die niet uit Sony's catalogus komen, toch gestart worden. Overigens zouden de hackers niet alleen geïnteresseerd zijn in het spelen van extra spelletjes, maar ook in de uitgebreide WiFi-functionaliteit waar de 2.50-versie van Sony's mobiele spelcomputer over beschikt. De 2.50-firmware was als onkraakbaar gepresenteerd, maar, zoals Engadget opmerkt, men moet nooit onderschatten wat fans met genoeg tijd en blikjes Red Bull voor elkaar kunnen krijgen. Voor de gezondheid van de 2.60-versie van de firmware, die nog dapper verzet biedt, moet dan ook gevreesd worden.

Gehackte PSP v2.50 met eerbetoon aan Fanjita
De hack werd her en der met veel enthousiasme begroet
Moderatie-faq Wijzig weergave

Reacties (46)

De firmware is helemaal niet gekraakt.

Vooralsnog heeft nog niemand het voor elkaar gekregen om een ".exe" (of hoe dat heet) te starten, of dusdanig te signen zodat die gestart werd.

GTA heeft een lek, waardoor wel onofficial code gedraaid kan worden. Dus GTA is gekraakt, en niet firmware 2.01 of 2.5
Het was voorheen niet mogelijk om homebrew te draaien met firmware 2.01+ dus in die zin is 2.5 gekraakt.
Ook dat is niet waar, dat was wel mogelijk. Alleen waren dat simpele tetris-spelletjes enzo. Pas nu is er een launcher applicatie gemaakt waarmee gemakkelijk bestaande homebrew code aangeroepen kan worden.

Eigenlijk vind ik dit wel een mooie 'kraak': je kunt geen illegale kopieen van psp-games draaien, maar wel veel zelfgemaakte spelletjes.
Iso loader zit er voorlopig niet in ;(
En ondertussen zijn er 100en gebruikers die hun firmware niet willen/kunnen upgraden en die daardoor hun spelletjes niet kunnen spelen
Iedereen kan z'n firmware upgraden alleen zijn er wel velen (onder wie ikzelf) die dat niet willen vanwege de 100% homebrew ondersteuning (1.5)
Probleem is vooral dat niet iedereen zn psp kan downgraden naar bijv 1.5 (welke versie volledig gekraakt is)
Ik wacht nog steeds op de (in het geruchtcircuit) beloofde Flash Player voor de PSP.

Niet zozeer om Flash games te kunnen spelen, maar wel om Flash websites voor de PSP te kunnen maken.
Ik denk dat jullie het allemaal een beetje verkeerd zien. Via de GTA hack is het mogelijk om code te starten die niet "gesigned" is door Sony. Er zitten echter veel restricties hieraan, welke ze zo goed mogelijk proberen te omzeilen.

De zogenoemde "backup" iso's kan je niet draaien op firmware 2.0 en hoger, omdat het in die firmware's niet mogelijk is om toegang te krijgen tot kernel modes. In 2.0 was het nog mogelijk om gedeeltelijke toegang te krijgen waardoor uit eindelijk de downgrade mogelijk was.

Iso Backups van je orginele spelletjes die een firmware hoger nodig hebben als 1.50 kunnen soms gestart worden omdat ze geen gebruik maken van de "extra functies" in 2.0 en hoger, of omdat de spelmakelaar de beveiliging hiertegen niet goed genoeg heeft afgehandeld.
Om andere backups weer aan de praat te krijgen worden er weer de orginele prx bestanden van een 1.5 spel verwisseld met die van een 2.0+ spel, in de hoop dat het dan wel werkt. Er zijn vele hacks etc. om dit alles te laten werken, maar tot nu toe is er niet een oplossing gevonden die voor alle backups werkt. Flashmod 2.0 werkt bijvoorbeeld niet voor alle games.

De GTA hack geeft de mogelijkheid tot homebrew die geen kernel mode nodig hebben. Als je kijkt naar www.fanjita.org dan zie je daar een lijst met welke homebrew werkt en welke niet. Homebrew is gewoon geweldig en ik wil daarom niet updaten (ik heb 1.50). Daarom zijn deze hacks geweldig, dan kan ik toch nog spelletjes kopen en tegelijkertijd homebrew gebruiken.
Er is blijkbaar een behoefte aan extra features waaraan fabrikanten van spelcomputers niet kunnen of willen voldoen (ik denk eerder dat laatste).

Om maar een voorbeeld te noemen: Waarom geen emulators met een berg ROM's onder licentie aanbieden voor een paar ¤?
Ze verdienen sowieso niks meer met al die oude games...
Waarom geen emulators met een berg ROM's onder licentie aanbieden voor een paar ¤?
Omdat ze dan geen spellen verkopen waar ze wél winst op maken
Dat betwijfel ik. Wie geeft er honderden euro's uit voor een krachtige console als je er alleen maar oude games mee gaat spelen?

Maar als je toch al van plan bent om bijvoorbeeld een PSP te kopen (vanwege de games die ervoor ontworpen zijn), dan is het toch een mooi extra'tje als je voor iets meer geld officiele ROMS hebt?

Dan hoef je iig geen apart apparaat te gebruiken of je console om te laten bouwen (met alle mogelijke problemen tot gevolg).

edit: Maar stel nou dat je gelijk hebt: wat zegt dat dan over die games waar ze wél winst op maken? ;)
Dat betwijfel ik. Wie geeft er honderden euro's uit voor een krachtige console als je er alleen maar oude games mee gaat spelen?
Ehh... ik?!
Zo hou ik 1.50 om 480x272 video te kunnen afspelen in sublieme kwaliteit.
Dat is onmogelijk met een hogere firmware. Dan zit je vast aan het mp4/avc formaat, beperkt tot 320x240.
Welk formaat en welke encoder gebruik jij dan voor 480x272? Bij MP4 wordt het zoals je zegt inderdaad niet ondersteund. Ik had dat al geprobeerd door de configfile van PSP Video 9 handmatig te forceren naar 480x272 maar dan knalt hij eruit bij het begin van 't coderen.
nintendo revo?
Sja, wat is ook het nut van zo'n beveiliging? Dat je alleen maar games kan spelen die aan Sony een stukje van hun omzet betalen? Klinkt als antitrust-praktijken...

En freeware games dan?
onzin... Sony verkoopt dat ding, dus mag zelf bepalen wat er aan beveiliging op komt.. Wil jij ontwikkelen voor de psp dan moet je maar een licentie aanschaffen...

Wil jij als gebruiker eigen spelletjes en software draaien, dan moet je naar een andere handheld gaan kijken..
onzin... Sony verkoopt dat ding, dus mag zelf bepalen wat er aan beveiliging op komt.. Wil jij ontwikkelen voor de psp dan moet je maar een licentie aanschaffen...
Ook onzin in zekere zin. als je een duur ding als een PSP aanschaft wil je van het volle potentieel van dat ding kunnen genieten, en niet alleen van de zaken die een of ander groot bedrijf vind dat je die wilt.... en blijkbaar is een groot deel van de PSP beziters het daarmee eens, want het gekraak gaat door als een op hol geslagen kudde eekhoorns op een walnoten fabriek.
Wil jij als gebruiker eigen spelletjes en software draaien, dan moet je naar een andere handheld gaan kijken..
Waarom? Er is niets illegaals aan je eigen software willen draaien op een handheld. Als mensen het leuk vinden om een frogger-kloon te maken voor de PSP lijkt het me dat je dat wilt stimuleren.

Sony wil dat natuurlijk niet, want daar verdienen ze niets aan... maar voor de acceptatie is het eigelijk beter.
Ik bedoel maar, op een PC kun je ook draaien wat je wilt. Ook al heb je een PC die speciaal gemaakt is ok mee te gamen. Dan snap ik niet wat er zo op tegen is om eigen games te maken, das toch juist alleen maar goed? Ik kan me herinneren dat MS hobby-programmeren juist wil stimuleren, vandaar dat ze Express Editions van VS 2005 hebben gemaakt. Hobby-programmeren voor een xbox360, PS3 of PSP zou daar dan ook onder moeten vallen...

btw, walnoten komen niet uit een fabriek :+
Ondanks sommige reacties hier, vind ik wel dat het in dit geval een soort firmware hack betreft, vooral omdat het GTA lek niet van toepassing blijkt voor 2.6 firmwares.
de GTA lek is niet van toepassing in 2.6 omdat sony die erg snel doorhad en meteen heeft gedicht
Heel leuk dat ze 2.5 hebben gehacked. Maar 2.6 is al uit en deze wordt nu ook met de spelletjes geleverd.
Als ze nu een hack vonden dat je een '2.5' psp op een '2.6' game kan spelen, dat zouw mooi zijn.
Edit: Verkeerd om :9
Dat kan al. Je kan zelfs 1.5 spellen spelen met een 2.6 firmware zonder hack ;)
http://pspupdates.qj.net/...20-now-for-10-and-20.html

en vergeet dat ook niet.
Daarmee is het mogelijk om spellen die 2.00+ nodig hebben af te spelen op 1.50.
Overigens worden de voordelen van 1.50 t.o.v. 2.50/2.60 alsmaar kleiner. Het enige grote voordat dat 1.50 nu nog heeft is het afspelen van ISO's, maar dat is binnenkort ook helemaal onmogelijk vanwege het beveiligen van de spellen:(
Daarmee is het mogelijk om spellen die 2.00+ nodig hebben af te spelen op 1.50.
Ja dat kan, maar dan alleen voor UMD's en geen ISO's die 2.00 of hoger vereisen.
Mja nog steeds geen kernel mode

Op dit item kan niet meer gereageerd worden.



Apple iOS 10 Google Pixel Apple iPhone 7 Sony PlayStation VR AMD Radeon RX 480 4GB Battlefield 1 Google Android Nougat Watch Dogs 2

© 1998 - 2016 de Persgroep Online Services B.V. Tweakers vormt samen met o.a. Autotrack en Carsom.nl de Persgroep Online Services B.V. Hosting door True