Cookies op Tweakers

Tweakers maakt gebruik van cookies, onder andere om de website te analyseren, het gebruiksgemak te vergroten en advertenties te tonen. Door gebruik te maken van deze website, of door op 'Ga verder' te klikken, geef je toestemming voor het gebruik van cookies. Wil je meer informatie over cookies en hoe ze worden gebruikt, bekijk dan ons cookiebeleid.

Meer informatie

Door , , 2 reacties
Bron: Sun, submitter: Left

Java logoSun heeft na een eerdere release candidate nu de final uitgebracht van zijn Java 2 Platform Standard Edition 5.0. J2SE 5.0 is een belangrijke release voor Sun met veel updates en nieuwe mogelijkheden, maar blijft desondanks compatibel met oudere versies. De documentatie is uitstekend maar erg lang, dus verwijzen we slechts naar de pagina's waarop de New Features and Enhancements, de J2SE 5.0 in a Nutshell en de volledige JDK 5.0 release notes te vinden zijn.

The development of J2SE 5.0 was led by Sun and progressed following the Java Community Process (JCP) to include input from a variety of constituents. Some highlights of J2SE 5.0:
  • New language updates: Metadata, Generics, Enumerated types, Autoboxing of primitive types
  • New JVM Monitoring and Management API
  • Improved out-of-box performance
  • New (but compatible) default Java look and feel
Versienummer:5.0
Besturingssystemen:Windows 9x, Windows NT, Windows 2000, Linux, Windows XP, Solaris
Website:Sun
Download:http://java.sun.com/j2se/1.5.0/download.jsp
Licentietype:Freeware
Moderatie-faq Wijzig weergave

Reacties (2)

Even inhakend op de download van de site, die zowel de SDK als de NetBeans IDE bevat:

Ik vind de look van de nieuwe NetBeans maar niks. Het ziet er best wel anders uit en ik vind 'm iets minder strak en professioneel. Hij heeft meer de XP look gekregen. Ook stonden er enkele andere dingen die mij niet logisch leken.

Nou ben ik sindskort weer met java begonnen (ben nog groentje) maar het lijkt me ondanks het bovenstaande wel handig over te stappen. Zeker omdat ik net begin is het handiger om gelijk maar de nieuwste versie aan te leren, aangezien je daar in de toekomst waarschijnlijk ook mee moet werken. Of zit ik hier nou dramatisch mis. Overigens lonkte de verbeterde performance me ook wel.
Het lijkt me wel verstandig om de nieuwe versie te gaan gebruiken inderdaad. En dan niet zozeer omdat je over moet (want de nieuwe versie is backwards compatible), maar omdat er een aantal nieuwe / verbeterde dingen in zitten die je jezelf zeker wilt aanleren om te gebruiken. Ik noem bijvoorbeeld de for-each loop, enumerations, variabel aantal argumenten in een functie, etc.

Op dit item kan niet meer gereageerd worden.



Apple iOS 10 Google Pixel Apple iPhone 7 Sony PlayStation VR AMD Radeon RX 480 4GB Battlefield 1 Google Android Nougat Watch Dogs 2

© 1998 - 2016 de Persgroep Online Services B.V. Tweakers vormt samen met o.a. Autotrack en Carsom.nl de Persgroep Online Services B.V. Hosting door True