Cookies op Tweakers

Tweakers maakt gebruik van cookies, onder andere om de website te analyseren, het gebruiksgemak te vergroten en advertenties te tonen. Door gebruik te maken van deze website, of door op 'Ga verder' te klikken, geef je toestemming voor het gebruik van cookies. Wil je meer informatie over cookies en hoe ze worden gebruikt, bekijk dan ons cookiebeleid.

Meer informatie

Door , , 12 reacties
Bron: XviD, submitter: Fairy

De organisatie achter de ontwikkeling van de XviD-codec heeft een nieuwe versie uitgebracht. Het versienummer is opgehoogd naar 1.0.2 en zoals gebruikelijk is alleen de broncode beschikbaar gesteld. Versie 1.01 lost alleen enkele kleine problemen op die in de 1.0 release zijn gevonden. In deze release worden slechts enkele kleine bugs verholpen en zowel de broncode als binary zijn compatible met de vorige versie. Het changelog ziet er als volgt uit:

xvidcore
  • Fixed non compliant bvop decoding (was using rounding=0 instead of rounding=1)
  • Added better mv bound clipping for broken streams.
  • Better behavior with content claiming not containing bvops but eventually having bvops.
  • Force fincr and fbase to be < 16bit.
  • Fixed thread safety problem in C language iDCT implementation.
VFW frontend
  • Memory leak
Debian dir
Versienummer:1.0.2
Besturingssystemen:Windows 9x, Windows 2000, Linux, Windows XP
Website:XviD
Download:http://files.xvid.org/downloads/xvidcore-1.0.2.zip
Bestandsgrootte:730,00KB
Licentietype:GPL
Moderatie-faq Wijzig weergave

Reacties (12)

Uiteraard de link voor de installer:
http://www.koepi.org/

Deze is nog niet up2date maar dit zal vanmiddag wel het geval zijn denk ik.
@ _Thanatos_
Workaround: installeer DivX 3.11 alpha en gebruik deze voor DivX 3.x (8>
Of gebruik ffdshow, deze speelt DivX 3.x ook.
Het gaat hier toch over XviD, toch niet over DivX ?
Of begrijp ik het niet ?
XviD kan ook andere codecs afspelen, netzoals DivX 5 naast DivX 3, 4 en 5, ook XviD kan afspelen.

máár iig is het zo dat als je XviD via DivX laat afpspelen je CPU-gebruik ongeveer 2x zo hoog ligt. (zie ook dit topic) Het beste is ffdshow + ac3filter. Óf, als je ook wil encoden; DivX + XviD + ac3filter en dan "Support Generic mpeg4" uitzetten in beide codecs.

géén codec-packs, werkt iets toch niet gebruik dan G-Spot om te kijken welke codec je nog meer nodig hebt
géén codec-packs, werkt iets toch niet gebruik dan G-Spot om te kijken welke codec je nog meer nodig hebt
De meeste zitten idd vol met zooi die je niet nodig hebt, maar DefilerPak kan ik toch aan iedereen aanbevelen. Zit alleen het hoogst noodzakelijke in, en je hoeft het niet meer allemaal apart te installeren :)
jow je fourcc zegt welke codec voor afspelen gebruikt moet worden. Alleen hele ouwe rotzooi heeft misschien geen fourcc maar koepie geeft een fourcc changer mee, dan kan je dat zelf doen. Je hoeft dus geen generic support uit te zetten en je kan altijd zowel xvid als divx installeren...
Het gaat nog wel falikant mis als ik met Xvid een filmpje afspeel dat encoded is met DivX 3.x. Maar de met DivX 4 en 5 encoded films gaan wel goed. Is hier een fix/workaround voor?
als je xvid 1.01 installeert wordt ook meteen ondersteuning voor divx5 werd geïnstalleerd. Dus ik dacht dat ik dat niet meer hoefde te doen......... Het blijkt toch dat het mis gaat / kan gaan. Ik weet niet of het altijd misgaat want ik heb meteen divx5 erbij geïnstalleerd. Ben benieuwd of het met deze versie ook nog het geval is.......
Ik gebruik daarvoor ffdshow. Hier zit een divx, xvid, dx3, dx4 en mpeg4 codec en nog veel meer in en heeft 1 optiemenu voor alle ingebouwde codecs en is ook nog eens erg snel en kwalitatief subliem.

Ik raad je aan deze een keer te proberen.
Ik heb weer athlon en thunderbird optimized builds gebouwd.
CFLAGS="-march=athlon-xp -Wall -fstrength-reduce -finline-functions -freduce-all-givs -m3dnow -msse -mfpmath=sse -mmmx -O3 -pipe -fforce-addr -fomit-frame-pointer -funroll-loops -frerun-cse-after-loop -frerun-loop-opt -falign-functions=4 -maccumulate-outgoing-args -ffast-math -fprefetch-loop-arrays";
redundant testflags jaja ik weet het.

hiero
Koepi heeft inmiddels de 1.0.2 build op zijn website gezet (www.koepi.org). De vertraging is wegens een verhuizing, meldt ie op z'n site :). Het valt allemaal nog best wel mee als je bedenkt dat ie een deadline van halverwege september had gesteld.

Op dit item kan niet meer gereageerd worden.



Apple iOS 10 Google Pixel Apple iPhone 7 Sony PlayStation VR AMD Radeon RX 480 4GB Battlefield 1 Google Android Nougat Watch Dogs 2

© 1998 - 2016 de Persgroep Online Services B.V. Tweakers vormt samen met o.a. Autotrack en Carsom.nl de Persgroep Online Services B.V. Hosting door True