Cookies op Tweakers

Tweakers maakt gebruik van cookies, onder andere om de website te analyseren, het gebruiksgemak te vergroten en advertenties te tonen. Door gebruik te maken van deze website, of door op 'Ga verder' te klikken, geef je toestemming voor het gebruik van cookies. Wil je meer informatie over cookies en hoe ze worden gebruikt, bekijk dan ons cookiebeleid.

Meer informatie

Door , , 16 reacties
Bron: Kernel.org, submitter: Arno

Marcelo Tosatti heeft een nieuwe versie van de 2.4 Linux Kernel uitgebracht met 2.4.27 als het versienummer. Hoewel de 2.4.x-serie eigenlijk is opgevolgd door de 2.6.x-kernels en ook geen nieuwe features meer kan verwelkomen, draait het overgrote gedeelte van de Linux-systemen nog steeds een 2.4-variant. Het complete changelog vanaf versie 2.4.27-pre1 tot en met versie 2.4.27-rc6 is helaas te groot om hier te plaatsen. Onder andere zijn de volgende beveiligingslekken aangepakt:

Here is a list of the most important security issues fixed by this release:
  • CAN-2004-0495 (Al Viro sparse fixes)
  • CAN-2004-0497 (users could modify group ID of arbitrary files on the system)
  • CAN-2004-0535 (e1000 minor info leak)
  • CAN-2004-0685 (backported Conectiva usb sparse fixes)
  • CAN-2004-0415 (file offset pointer handling race)
  • CAN-2004-0565 (information leak ia64)
Moderatie-faq Wijzig weergave

Reacties (16)

2.4 Kernel is eigenlijk alleen maar goed voor oudere bakken en oudere servers. 2.6 is met ondersteuning voor hyperthreading gewoon een must voor nieuwere computers :)

Toch leuk dat als nog bugjes worden gefixt :)
Totaal niet mee eens. Hier op mijn laptop draait Linux 2.6.{6,7,8rc} als een ramp: random freezes, DMA time-outs en dergelijke. 2.6.5 draait gelukkig wel goed.

Bij een klant, draait er een 2.6.3 op een nieuwe server. Die draait daar ook slecht, geeft freezes onder langdurige hoge load en dergelijke. Voor servers is 2.4 dus nog altijd een must, ik vrees dat 2.6 nog minstens een paar maand nodig is eer die echt de nodige maturiteit bereikt heeft voor servers. Voor desktops raad ik wel 2.6 aan. De verbeterede performantie zijn daar wel erg interessant. Voor een server maakt die performantieverbetring toch niet veel uit, en wil je 100% stabiliteit.

Recente 2.4 kernels ondersteunen ook HyperThreading trouwens.
Dat heeft toch echt eerder een andere oorzaak. kernel.org draait ook op 2.6 en mijn server met via chipset draait al sinds 2.6.0 stabiel en deze is mee gegaan met de nieuwe releases. Nooit problemen mee gehad.

Mijn werkdoos was een totaal ander verhaal. Die was niet stabiel te krijgen met 2.6. Sindsdat de nForce workaround is geimplementeerd werkt dat nu als een trein :)
Nee, het heeft zeker geen andere oorzaak, 2.6.5 werkt zeer stabiel, terwijl alle recentere versies dat niet doen. Ik weet het, het is allicht te wijten aan de combinatie van bepaalde hardware, en iemand met andere hardware zal er allicht geen last van hebben, maar dit soort dingen kom je dus toch vaker tegen met een 2.6 dan met een 2.4...
Freezes bij langdurige hoge load had ik juist bij kernel 2.4. Ik heb kernel 2.6 nu op een aantal gameserver systemen draaien, zonder enkele crashes. Binnen enkele dagen ga ik ook de eerste webserver omgooien naar kernel 2.6.

Verder heb ik het voor webservers meer op FreeBSD, maar daar kan Linux ook niks aan doen :P

Edit: hoogste uptime van een kernel 2.6 server is 150 dagen hier
performantie? wat een woord man :P lol
De 2.6 kernel heeft zich nog lang niet bewezen om in de zware productie omgevingen zomaar los te laten. Desondanks het feit dat de 2.6 serie al vrij stabiel is vergeleken met de 2.4 kernel wachten de meeste mensen best nog wat af tot de 2.6 kernel compleet klaar is voor productie. Op dit moment ondergaat 2.6 nog redelijk wat wijzingen en zo'n zaken wil je niet zomaar hebben in productie omgevingen, dus kies je beter nog steeds voor de oude, vertrouwde, superstabiele en bewezen 2.4 kernel.
kernelkeuze is ondergeschikt aan distributiekeuze...

debian stable zit nog (!) gewoon op 2.4, dus daar blijf ik het ook bij houden... 2.6 is mij nog te nieuw anyway.

je gaat hier echt veel te kort door de bocht door te zeggen "oudere bakken en oudere servers"... gloedje nieuwe servers zou ik vandaag ook zonder problemen uitrusten met 2.4
debian stable is natuurlijk geen referentiepunt. het is bekend dat debian her en der wel eens wat conservatief omgaat met bepaalde zaken. prima hoor, daar niet van.

zelf heb ik ene rommeldoos (deze) waar 2.6.x op draait, 2 GB en een dual XEON. niks mis mee. de instabiliteit merk hje op als je ATI drivers gebruikt. dat is wel een aardig recept voor een crash.

rechts staat de computer van vriendinlief. 2.6.5-7-104 (SuSE) en is rock solid. Collega idem, andere collega met 2.6.7, niks aan de hand. uptimes van weken... maanden afhankeijk van de versie die gebruikt is.

als ikzelf naar 2.4 terug ga, dan merk ik dat SMP toch wat minder vloeiend werkt; de 2.6 kernel series werkt wat dat betreft als de brandweer hier.

soms moet je wat spelen met boot-opties als er wat mis gaat.
ik zeg natuurlijk niet dat debian-stable Het uitgangspunt is ... tuurlijk niet

maar voor mij persoonlijk wel :)

en 2.6 is vast ontzettend stabiel en natuurlijk sneller, maar het is mijns insziens toch nog niet volwassen genoeg om zomaar overal op te donderen.
Ik draai op al mijn machines gewoon een 2.4.x kernel. In de 2.6.x kernel serie is gewoon teveel anders geregeld en er veranderd mij teveel. Ik heb ook nog diverse kernel builds 2.2.x gedraaid voordat ik ben overgegaan naar 2.4.x en dat zal nog wel even zo blijven, zowel thuis op mijn router als op al mijn productie machines.
Ik heb hem nog draaien op mijn server. Op mijn normale machines draait 2.6.
Als je moderne spellen als UT2K4 wilt draaien met de nieuwste videodrivers is 2.6 eigenlijk een must. En last but not least de 2.4 is voor AMD64 systemen officieel deprecated verklaard.
Hrmm.. I could be wrong maar de 2.4 kernel die met Fedora Core 1 kwam deed het volgens mij ook met HT ...
redhat stopt z'n kernels helemaal vol met custom patches. je kunt een redhat kernel zeker niet vergelijken met degene die je van kernel.org afhaalt.

ikzelf heb alleen nog maar 2.6 bakken (workstation, web/irc-server en gameserver) en doen het allemaal prima, met uitzondering van een rare hardware reset die ik krijg als er in me cdbrander geen disc zit. als voorlopige workaround laat ik er gewoon altijd een cd in zitten, anders kan ik iedere keer weer me dma aan gaan zitten zetten :S het zal vast binnenkort wel gefixed worden, want ik zag op google een heleboel mensen die er last van hadden, maar niemand die een oplossing wist...
Voor desktop systemen zou ik zeker de 2.6 aanbevelen.

Op dit item kan niet meer gereageerd worden.



Apple iOS 10 Google Pixel Apple iPhone 7 Sony PlayStation VR AMD Radeon RX 480 4GB Battlefield 1 Google Android Nougat Watch Dogs 2

© 1998 - 2016 de Persgroep Online Services B.V. Tweakers vormt samen met o.a. Autotrack en Carsom.nl de Persgroep Online Services B.V. Hosting door True