×

Help Tweakers weer winnen!

Tweakers is dit jaar weer genomineerd voor beste nieuwssite, beste prijsvergelijker en beste community! Laten we ervoor zorgen dat heel Nederland weet dat Tweakers de beste website is. Stem op Tweakers en maak kans op mooie prijzen!

Cookies op Tweakers

Tweakers maakt gebruik van cookies, onder andere om de website te analyseren, het gebruiksgemak te vergroten en advertenties te tonen. Door gebruik te maken van deze website, of door op 'Ga verder' te klikken, geef je toestemming voor het gebruik van cookies. Wil je meer informatie over cookies en hoe ze worden gebruikt, bekijk dan ons cookiebeleid.

Meer informatie

Software-update: MySQL 3.23.54c

Door , 10 reacties, submitter: Robin, bron: MySQL

19-12-2002 • 10:37

10 Linkedin Google+

Submitter: Robin

Bron: MySQL

Kort na het verschijnen van MySQL 3.23.54 zijn er versie 54a en 54b verschenen, deze bevatten echter allemaal een select aantal bugs/compileer fouten waardoor nu dan toch MySQL 3.23.54c is uitgebracht. De volgende woorden wisseling komt met deze release:

> Ok, here you go:
> # ldd /usr/local/mysql-max-3.23.54a-pc-linux-i686/bin/mysqld
> libdl.so.2 => /lib/libdl.so.2 (0x40020000)
> libpthread.so.0 => /lib/libpthread.so.0 (0x40024000)
> libz.so.1 => /usr/lib/libz.so.1 (0x4003a000)
> libcrypt.so.1 => /lib/libcrypt.so.1 (0x40049000)
> libnsl.so.1 => /lib/libnsl.so.1 (0x40077000)
> libm.so.6 => /lib/libm.so.6 (0x4008c000)
> libc.so.6 => /lib/libc.so.6 (0x400ae000)
> libnss_files.so.2 => /lib/libnss_files.so.2 (0x401c1000)
> libnss_dns.so.2 => /lib/libnss_dns.so.2 (0x401cb000)
> libresolv.so.2 => /lib/libresolv.so.2 (0x401cf000)
> /lib/ld-linux.so.2 => /lib/ld-linux.so.2 (0x40000000)
>
> While:
> # ldd /usr/local/mysql-max-3.23.53a-pc-linux-gnu-i686/bin/mysqld
> not a dynamic executable
> (doh, that one worked )

OK, as I already assumed, the Max binary was not linked statically. Doh!
Interesting, that this also causes the load to spike, even though it's not statically linked against an unpatched glibc.

> > What version of Linux are you using?
> Running Slackware 8.1 GNU/Linux, kernel 2.4.17, GNU libc 2.2.3
>
> Have fun recompiling

Thanks. Could you please give this one a try? If this one solves the problem, I will publish it on our download pages ASAP.

Sorry about that - it seems like getting out that security update as fast as possible caused too many glitches here...

Bye,
LenZ
Versienummer 3.23.54c
Besturingssystemen Linux, Linux x86
Website MySQL
Download http://files.tweakers.net/mysql/mysql-max-3.23.54c-pc-linux-i686.tar.gz
Licentietype GPL

Update-historie

Meer historie

Reacties (10)

Wijzig sortering
Maar ik snap het toch niet, ik heb hem volledig goed gecompiled gekregen, maar nu moet ik hem toch updaten?
Nee, dit is nml de binary release. Als je hem zelf gecompiled hebt is er niks aan de hand.
interessant, bij het artikel gisteren ( http://www.tweakers.net/nieuws/24810?&Lastpage=true&NextID=667680&Prev ID=667660&niv=-1&mode=nested&order=&t= )
over de fix reageerde Trackz met :
Nope.. als er iets is wat je niet moet doen op een goed draaiend systeem is elke willekeurige patch / update toepassen
wat gelijk een 'overbodig' als moderatie gaf.
Met een software update als deze geeft het je toch te denken :D
Ik weet niet. Als een update een aantal veiligheidsgaten dicht, lijkt het mij vrij nuttig :) En hiermee lossen ze gelijk het compileerprobleem op ..
Definieer een goed draaiend Systeem?

Ik ben absoluut met je eens dat je niet al te rap met patches moet zijn, maar laten we wel wezen: In deze internet wereld waarbij je arbitraire code kan uitvoeren op een systeem via een draaiend proces is absoluut uit den boze.

Is een systeem dat zo lek is als een vergiet wel een "goed draaiend systeem" ??
is er ook een source versie van beschikbaar... ik heb gisteren PicServer geupdate, en nu is er weer een update :(

Nou ja, als iemand weet waar de source staat... hoor ik het graag
Volgens mij hadden de fouten in 54a en 54b alleen betrekking op de (fout gecompileerde) binary.
Fijn dat er nu eindelijk een volledig werkende 3.23.54 versie is :)
Trouvens over de update tracker je ziet de tracks van zowel v3 als v4 van MySQL. Maar volgens mij zijn dit toch echt 2 verschillende pakketten .. tenminste je gaat toch ook niet RedHat 7 en 8 updates in de zelfde update tracker zetten of wel soms?
nog een reden om geen binaries te gebruiken maar ze zelf te compilen :S
Ik volg het nu niet echt helemaal meer met al die versies.Ik heb dus gekeken voor MySQL 3.23.54c (source) maar zie het nergens. :?

Op dit item kan niet meer gereageerd worden.


Apple iPhone X Google Pixel 2 XL LG W7 Samsung Galaxy S8 Google Pixel 2 Sony Bravia A1 OLED Microsoft Xbox One X Apple iPhone 8

© 1998 - 2017 de Persgroep Online Services B.V. Tweakers vormt samen met o.a. Autotrack en Hardware.Info de Persgroep Online Services B.V. Hosting door True

*