Cookies op Tweakers

Tweakers maakt gebruik van cookies, onder andere om de website te analyseren, het gebruiksgemak te vergroten en advertenties te tonen. Door gebruik te maken van deze website, of door op 'Ga verder' te klikken, geef je toestemming voor het gebruik van cookies. Wil je meer informatie over cookies en hoe ze worden gebruikt, bekijk dan ons cookiebeleid.

Meer informatie

Door , , 15 reacties
Bron: Nvidia, submitter: roeleboel

nVidia logo (60 pix) Dinsdag zijn door Nvidia met versienummer 180.44 nieuwe *nix display drivers uitgebracht. Ze zijn beschikbaar voor Linux (32-bits), Linux (AMD64/EM64T), Solaris (x64/x86) en FreeBSD. Specifieke installatie-instructies kunnen op de afzonderlijke pagina's worden gevonden. In deze release treffen we onder andere ondersteuning aan voor diverse nieuwe videokaarten, ondersteuning van OpenGL 3.0 die in de vorige release geïntroduceerd is, verder verbeterd en zijn er natuurlijk weer verschillende problemen verholpen. Hieronder is het volledige changelog van versie 180.44 te vinden:

Release Highlights:
  • Added support for the following GPUs:
    • Quadro FX 3800
    • Quadro FX 3700M
    • Quadro FX 1800
    • Quadro FX 580
    • Quadro FX 380
    • Quadro NVS 295
    • GeForce GT 120
    • GeForce G100
  • Fixed a problem that could cause Xid errors and display corruption in certain cases when OpenGL is used to render to redirected windows, for example when Java2D is used with the -Dsun.java2d.opengl=true option.
  • Updated glGetStringi(GL_EXTENSIONS, i) to no longer return NULL in OpenGL 3.0 preview contexts.
  • Fixed OpenGL crashes when using a large number of texture objects.
  • Fixed the timestamp reporting in the GL_NV_present_video extension on SDI II with Quadro FX 4800 and 5800.
  • Fixed a problem that caused the screen to flicker momentarily when OpenGL applications exit unexpectedly on GeForce 6 and 7 series GPUs.
  • Fixed an X server crash when an X client attempts to draw trapezoids and RenderAccel is disabled.
  • Improved recovery from certain types of errors.
  • Added support for RG renderbuffers in OpenGL 3.0.
  • Added support for OpenGL 3.0 floating-point depth buffers.
  • Updated VDPAU to support VC-1/WMV acceleration on all GPUs supported by VDPAU; see the README for details.
  • Fixed VDPAU corruption on some H.264 clips.
  • Updated VDPAU documentation in the README and in vdpau.h, in particular regarding how to use the deinterlacing algorithms in the VdpVideoMixer object. Explicitly documented "half rate" deinterlacing, which should allow the advanced algorithms to run on more low-end systems.
  • Implemented a "skip chroma deinterlace" option in VDPAU, which should allow the advanced deinterlacing algorithms to run on more low-end systems. See vdpau.h.
  • Fixed VDPAU VC-1 decoding on 64-bit platforms.
  • Updated the VDPAU wrapper library to print dlerror() messages when driver loading problems occur.
  • Improved VDPAU's handling of some corrupt H.264 streams, and some corrupt/invalid MPEG streams on some GPUs.
  • Fixed VDPAU to correctly handle WMV "range reduction" on some GPUs. A minor backwards-compatible API change was made for this; see vdpau.h's documentation for structure field VdpPictureInfoVC1.rangered.
  • Fixed a problem that caused surfaces to be marked as visible too early when the blit presentation queue is in use.
  • Fixed VDPAU to prevent some cases of "display preemption" in the face of missing H.264 reference frames on some GPUs.

De volgende downloads zijn beschikbaar:
*Linux Display Driver - x86
*Linux x64 (AMD64/EM64T) Display Driver
*Solaris Display Driver – x64/x86
*FreeBSD Display Driver – x86

Nvidia Linux Display Driver (481 pix)
Moderatie-faq Wijzig weergave

Reacties (15)

Deze versie is al een tijdje geleden uit.
Ik heb 'm 2 weken geleden onder Ubuntu geïnstalleerd.
Werkt goed. Ik merk geen hinderlijke veranderingen voor mijn 7600 GS kaart
Kun je nu ook eindelijk goed resoluties instellen? Dat werkte niet bij mijn 7600 GS kaart. Moest handmatig de X org file aanpassen, anders kreeg ik de 1680*1050 resolutie net werkend.
(heb nu gelukkig een 8600 GTS maar mijn 7600 GS systeem moet niet ongebruikt blijven)
Ik draai sinds een poosje mee met packages van iemand op nvnews om de veranderingen en verbeteringen in VDPAU bij te houden en heb met de pakketjes van diegene (die nu ook op .44 zitten) een groot probleem:

Als firefox het "do you want to quit" dialog weergeeft met de keuze om af te sluiten of om de tabs op te slaan en dan af te sluiten, raakt de X sessie corrupt en bevriest het hele systeem :|. Dit is wanneer compiz aan staat.

Heb het op nvnews nog niet aangekaart, zal eerst de 'officiele' NVIDIA driver eens proberen :).
Ik heb deze net geïnstalleerd op m'n Ubuntu 8.10. Ervoor gebruikte ik 177.80.
Compiz draait veel soepeler nu en nergens zijn nog artefacten te zien als ik een nieuw venster open.
Dikke aanrader deze driver!

GPU: geforce 8600m GT

[Reactie gewijzigd door K_VL op 1 april 2009 14:34]

Da's een grote stap hoor, van 177.80 naar 180.44. Het zou zomaar kunnen dat je performance issues al zijn verholpen in 180.0.
Nja, versie 180.22 draaide bij mij om de één of andere reden niet stabiel... daarom ben ik terug naar 177.80 gestapt :)
180.06 heb ik overgeslagen.

[Reactie gewijzigd door K_VL op 1 april 2009 19:27]

Nvidia heeft ook al beta OpenGL 3.1 drivers voor Linux, Solaris, FreeBSD en Windows uitgegeven:
http://developer.nvidia.com/object/opengl_3_driver.html

Gebaseerd op de 180.37 driver. Binnenkort zal er wel een final gebaseerd op de 180.44 driver uitkomen.
Is deze ook geschikt voor de nieuwste Ubuntu 9.04 beta? Of werkt deze nog niet met de nieuwe Xserver?
Ik las dat deze waarschijnlijk gepackaged gaat worden.
Hij kwam vandaag mee met de standaard updates :)
Hebben we hier een KDE-hater als poster? De changelog is namelijk aangepast. Punt 4 is in het origineel: Fixed OpenGL crashes while running KDE4's Plasma.

[Reactie gewijzigd door BartOtten op 1 april 2009 12:31]

Ik denk eerder dat we met een FreeBSD-aanhanger te maken hebben, want in die changelog staat het inderdaad niet vermeld...
Eigenlijk vind ik de omschrijving hier nuttiger. Dat was namelijk hét punt waar ik deze driver update voor zou willen hebben toen ik de changelog las. Ik heb op het moment last van crashes in world of warcraft als ik in dalaran ben of ben geweest. Gezien het grote aantal texture objects wat ik in die area verwacht, hoopte ik dat deze driver die crashes op zou kunnen lossen. Als er specifiek iets over KDE4 stond zou ik er over heen hebben gelezen, want ik gebruik gnome.
Gelijk weer conclusies trekken he, triest. :o Waarom dat punt niet in de FreeBSD changelog staat is me niet helemaal duidelijk, zal daar wel niet van toepassing geweest zijn.

Op dit item kan niet meer gereageerd worden.



Apple iOS 10 Google Pixel Apple iPhone 7 Sony PlayStation VR AMD Radeon RX 480 4GB Battlefield 1 Google Android Nougat Watch Dogs 2

© 1998 - 2016 de Persgroep Online Services B.V. Tweakers vormt samen met o.a. Autotrack en Carsom.nl de Persgroep Online Services B.V. Hosting door True