Cookies op Tweakers

Tweakers maakt gebruik van cookies, onder andere om de website te analyseren, het gebruiksgemak te vergroten en advertenties te tonen. Door gebruik te maken van deze website, of door op 'Ga verder' te klikken, geef je toestemming voor het gebruik van cookies. Wil je meer informatie over cookies en hoe ze worden gebruikt, bekijk dan ons cookiebeleid.

Meer informatie

Door , , 5 reacties
Bron: phpMyAdmin, submitter: Olaf van der Spek

phpMyAdmin logo (klein) De ontwikkelaars achter phpMyAdmin hebben zojuist versie 2.6.4 uitgebracht en deze bevat weer de nodige nieuwe features en bugfixes. Dit programma bestaat uit een verzameling van PHP-scripts waarmee een MySQL-database via een webinterface kan worden onderhouden en beheerd. De software is in verschillende smaken vanaf deze pagina te downloaden. De release notes van deze versie zien er als volgt uit:

Note:
  • phpMyAdmin 2.6.4 requires a minimum version of 2.1 for custom themes
Improvements:
  • Foreign-key dropdowns can be more customized
  • Export: configurable filename templates
  • Display column comments while editing data
  • Transformations: new hexadecimal mode
  • HTTP auth: support FastCGI
  • Themes: can now have different theme per server
  • OLD_PASSWORD in the list of functions
  • Better messages when checking numerical input
  • Allow adding DROP TABLE when copying databases
  • Better support of information_schema
  • Various interface CSS improvements
  • Tree subgroups in left panel database selector
  • Documentation: links and anchors to every FAQ item
  • Table comments move to page header
  • Export: configurable default charset
  • Removed warning about PmaAbsoluteUri not set
Fixes:
  • Database search in MySQL 5.0.x on fields without a charset
  • Invalid "normal" cursor style
  • Browsing state when deleting multiple rows
  • Support bigger queries in print view, insert row, export results
  • Unsaved changes to relations were lost when changing display field
  • Exporting under IE 6 (Windows XP SP2)
  • Better catching of parse errors in config file
  • XSS on the cookie-based login panel
  • Show all while browsing foreign values
  • Escaping of special characters in ENUM or SET
  • XSS on table creation page
  • Using mysqli extension with MySQL 4.0.x
  • "empty result set" message was sometimes not returned
  • Incorrect message "You should define a primary key"
  • Abide cfg['Lang'] settings even if using MySQL > 4.1.x
  • XSS on username (cookie-based login)
[break]De volgende downloads zijn beschikbaar:
*phpMyAdmin 2.6.4 (bzip2)
*phpMyAdmin 2.6.4 (gzip)
*phpMyAdmin 2.6.4 (zip)[break]
phpMyAdmin screenshot (resized)
Moderatie-faq Wijzig weergave

Reacties (5)

Removed warning about PmaAbsoluteUri not set
Ah, eindelijk, die was zo irritant. Nou kon je dat wel oplossen door de Blowfish Secret in te vullen, maar het bleef irritant dat iedere keer als je dan je root naam en wachtwoord had ingesteld naar phpmyadmin ging en je die irritante PmaAbsoluteUri melding kreeg en dan weer opnieuw dat script op moest openen, omdat je de blowfish secret vergeten was in te vullen.
Daar hadden we dit toch voor:
$cfg['PmaAbsoluteUri_DisableWarning'] = TRUE;
Het wordt tijd dat ze een keer van die framebased layout afstappen, als ik mijn venster refresh wil ik op dezelfde pagina uitkomen, niet op de beginpagina. Verder blijft het het beste stukje software om webbased je database te kunnen managen.
Note:

* phpMyAdmin 2.6.4 requires a minimum version of 2.1 for custom themes
??
Als je 2.6.4 hebt, is het toch logisch dat je een hogere versie dan 2.1 hebt?
Het zal wel ergens anders over gaan met 2.1, maar kan het nergens terugvinden :P
Ik denk dat ze bedoelen dat themes van versie <2.1 niet meer werken.

Op dit item kan niet meer gereageerd worden.



Apple iOS 10 Google Pixel Apple iPhone 7 Sony PlayStation VR AMD Radeon RX 480 4GB Battlefield 1 Google Android Nougat Watch Dogs 2

© 1998 - 2016 de Persgroep Online Services B.V. Tweakers vormt samen met o.a. Autotrack en Carsom.nl de Persgroep Online Services B.V. Hosting door True