Cookies op Tweakers

Tweakers maakt gebruik van cookies, onder andere om de website te analyseren, het gebruiksgemak te vergroten en advertenties te tonen. Door gebruik te maken van deze website, of door op 'Ga verder' te klikken, geef je toestemming voor het gebruik van cookies. Wil je meer informatie over cookies en hoe ze worden gebruikt, bekijk dan ons cookiebeleid.

Meer informatie

Driver-update: VIA 4-in-1 4.29 Beta

Door , 50 reacties, bron: VIA Hardware

25-02-2001 • 20:49

50 Linkedin Google+

Bron: VIA Hardware

Bo, |DH|TUFF|Rizla, Daneel en wzzrd kwamen bijna tegelijk melden dat er nieuwe VIA 4-in-1 drivers gespot zijn. Er is niet veel info over versie 4.29 beta, maar kennelijk is de IDE driver vernieuwd wat Win2k probs moeten fixen.

These drivers have not been fully tested, but appear to include a new IDE driver, that may fix the Win2k problems? Again these drivers are BETA and not fully tested.
Versienummer 4.29 Beta
Besturingssystemen Windows 9x, Windows NT, Windows 2000
Website VIA Hardware
Download http://216.151.100.249/via/4in1429BETA.zip

Reacties (50)

Wijzig sortering
I installed 1 hour ago and so far so good. No more SCSI reporting in the system manager - all my IDE devices are actually reported as such.

Also no more disk errors or corruption issues in the Win2k event viewer. And HD TACH says:

67 mbps/s - the highest I ever made with my ATA100 HD in Windows 2000.

So the Harddrive is OUT of PIO mode 4 and runs at least in ATA66 mode (or UDMA4 which you prefer).

So far I can recommend the 4.29beta version - I will let you know if I get any problems.

Good luck people.
Feel free to dare (no risk no fun!!).
Dat kopieren van RAID naar IDE langzaam is, is volgens mij een "foutje" in de Abit KT-7 RAID (ik gok dat 456 die gebruikt). Ik heb er hier ook last van, het resultaat is eigenlijk onwerkbaar. Daarom heb ik RAID er maar weer uitgegooid en al mijn 3 schijven op de ATA100 controllers gezet. Dat werkt in elk geval pijnloos...
Heel goed, 10 punten. Idd heb ik een abit kt7a mobo. Maar ik moet zeggen dat deze nieuwe drivers er al een HOOP beter aan doen!
Hulde! Ook heb ik het idee dat mijn agp kaart beter wordt ondersteund (vraag me niet waarom, is slechts een gevoel)
OK, ik heb alles nog ff bekeken. Volgens mij klopt er helemaal niks van de 4.29. In de Win2KIDE folder van de 4.28 en 4.29 drivers zitten verschillende files. Ik had het idee om 4.28 te installeren en dan handmatig buiten Windows 2000 om de files te overschrijven met die van de 4.29. Maar dat lukt dus niet omdat er andere files zijn. M'n vermoeden is dat de 4.29 drivers niet volledig zijn, of gewoon niet kloppen waardoor Windows 2000 terugvalt op de eigen Via drivers. Toch maar weer wachten op de volgende 'lek' van Via dus ;)

Fragment van inhoud VIAIDE2K.INF in 4.28:

Provider=%VIA%
DriverVer=11/16/2000,3.01.1

[SourceDisksNames]
1 = %DiskName%,,,

[SourceDisksFiles]
viadsk.sys= 1
VIAIDE2K.dll = 1

En in de 4.29:

Provider=%VIA%
CatalogFile=viamini.cat
DriverVer=01/01/2000,5.00.2195.101

Er is dus iets heel vreemds met die driverversies en data. Bovendien staat in de inf van 429:

CopyFiles = @viaide.sys
CopyFiles = @atapi.sys
CopyFiles = @pciidex.sys

Dit kopieert de ORIGINELE Microsoft drivers! De oude dus ;) Need I say more?
Misschien was dat wel de fix: geen VIA drivers maar Windows drivers gebruiken ;)
Ik heb hem nu dus geinstalleerd en ik moet zeggen dat ik er MEER tevreden over ben dan de 4.28 versie. Ik heb nog niet onder 12x gebrand, maar mijn kopien van RAID -> IDE gaat heel erg goed. Geen foutmeldingen en geen lastige her opstarts. (onder 4.28 ALTIJD nieuwe hardware dat werd ontdekt, nu niets!)

Dus ik denk dat het echt wel de moeite waard is!

edit:
Ik heb kt7raid en win2k

[edit2] Branden gaat dus nog steeds als een dikke drol door een vergiet bij 30graden celsius. NIET dus. Ik brand nu van Raid -> ide (sec.master) Houdt dit in dat er met mijn mobo NIET fatsoenlijk te fikken is???[/edit2]
Ik blijf eerlijk gezegd nog maar ff bij mijn eigen 'fix': gewoon die IDE-drivers niet installen...
totdat ze WHQL zijn ofzo, dan mag je misschien er vanuit gaan dat ie er niet meer meecrashed

edit: ff als reactie op hier beneden:
ik heb win2k (want daar ging de fix ook over...), en daar zitten gewoon goede (via-IDE) drivers in, ik heb gewoon een buffered read van 56Mbyte/s en een sequential read van 30 Mbyte/s ('t is een ATA100 op ATA66 controller, op ATA100 is buffered read hoger zijn, maar merk je toch niet, maar ik had Promise-troubles, niet betrouwbaar genoeg)
Bij mij draait ook Win2k op een AMD 1 Ghz en Abit kt7a mobo. Het verschil in performance tussen de standaard IDE drivers en die van VIA zijn op mijn systeem enorm groot. Met de standaard IDE drivers is het systeem werkelijk niet vooruit te branden. (Dit zal waarschijnlijk ook de reden zijn dat de installatie van Win2k erg lang duurde.)
Overigens werken deze nieuwe beta drivers helemaal niet. Win2k loopt zo hard vast, dat je niet eens meer aan het herstarten van de computer komt. Daarna op de resetknop gedrukt en er verscheen een blauwe STOP melding. Gelukkig had ik een Ghost image.
Bij die BSOD staat waarschijnlijk dat ie een driver niet kan laden.
Als je daarna onder een ander OS start, dan kun je de driver vanuit de dir waar je drivers staan naar de juiste dir kopieren.
(worked for me)

Het is wel het beste om eerst de drivers te un-installen (via de install) voor je de nieuwe drivers installeerd. (daar liep hij bij mij vast).
de trage install van win2k komt doordat je smartdrive niet hebt ingeladen.. doe dat maar is .. dan vliegt de install.
Jawel, Smartdrive was wel geladen. Wat er gebeurt is dat de harde schijf steeds twee seconden stil staat tijdens het kopiėren van bestanden naar de harde schijf; daarna weer een seconde supersnel kopiėren en dan weer twee seconden stil. De installatie duurt dan per saldo erg lang.
Overigens gebeurde er nog iets vreemds bij het installeren van de 4-in-1 4.28 drivers. Na een herstart leek de computer muurvast te zitten toen de desktop al op het scherm stond. Ik kon geen programma starten, zelfs het Control Panel leek onbereikbaar. Pas na 90 seconden wachten kwam de melding dat Win2k een VIA Bus Master Ultra ATA Controller had gevonden.
De IDE drivers niet installeren, betekent dat de harde schijf zeer slecht presteert. Je bent haast wel verplicht om ze te installeren, anders kan je net zo goed met een P2 350 Mhz blijven werken.
Niks nieuwe IDE driver, de normale Win2K driver wordt geinstalleerd, versie 5.1.2195.0.

Ik heb het getest door alle drivers te verwijderen en direct daarna de VIA drivers te installeren en de versienummers met elkaar te vergelijken.

Is overigens wel een bestere oplossing als in versie 4.28 waar m'n CD-Rom en brander spontaan zogenaamd SCSI devices werden en branden niet meer wil lukken.
Je hebt gelijk. Ik was tot dezelfde conlusie gekomen. Zelfs als ik eerst 4.28 installeer en dan 'update driver' doe door de 4.29, dan worden de originele Windows 2000 drivers geinstalleerd :D Vind je het gek dat alle Via bugs ineens verdwenen zijn ;) Maar goed, hopelijk is er een manier om het te fixen. Ben er mee bezig.
Bij mij wordt anders versie 5.0.2195.101 geļnstalleerd (ik neem aan dat je het over de Via controller hebt...)
Snap er helemaal niks meer van,ik heb een harde schijf waar moet die nou in op mijn moederbord(abit kt7a) om de beste snelheid voor mij harde schijf te krijgen?
Op de ATA100 controllers, maar ff niet als RAID.

Keb zelf: IBM 13GB op 1e ATA100 (IDE3)
Maxtor 15GB op 2e ATA100 (IDE4)
MP7060A op IDE1
Afreey 50x op IDE2
Allemaaal Master. :7

Tinaaaa.. Was kostet die Kabelsalat? :+
Op de ATA100 controllers, maar ff niet als RAID
Zijn beide schijven ata100? Als ik mijn Fireball KA13,6 (ata66) op ide4 zet (ik heb ook geen raid, gebruik wel de poorten als ide poorten) dan knalt mijn systeem plat als er veel data wordt getransfereerd.

Mijn IBM is geen probleem op ide3
iemand die driver al getest???

ben benieuwd wat hij doet in 2k
Volgens mij is ie iets sneller, ik merk het een beetje :)
Ik wacht nog even voor dat het wat getest is dan merk ik vanzelf wel of het sneller is en waar het op draait :7
Heeft iemand deze drivers al ge-installed en de boel goed lopen onder win2k? Nadat ik 4.28 had ge-installed op mijn win2k systeempje werden al mijn IDE apparaten (2 HD's, Cd-rom, Cd-rw) SCSI devices (???) en kon ik met geen mogelijkheid een cd fikken!! Lekker dan...ik hoop dat de problemen nu opgelost zijn.
Na opnieuw formatteren :'( werkte mijn win2k systeem weer perfect MET de 4.29 drivers!! :)
En ook heel belangrijk, ik kan de buma/stemra weer lastigvallen met mijn brander!!
Niet alleen onder Win2k maar ook onder Win98SE (wat ik dus draai) draaien ze beter dan alle vorige versies. En VIA die komt ook best wel vaak met updates de laatste tijd. A la nVidia of zo? :)
Ik heb ook Win98SE, en de Via 4in1 4.28 vervangen door deze 4.29 beta. Heb ff Quake 3 timedemo en 3dmark 2000 gedaan, maar merk geen enkel verschil. Deze update is denk ik alleen interessant als je Win2k hebt.

Op dit item kan niet meer gereageerd worden.


Apple iPhone X Google Pixel 2 XL LG W7 Samsung Galaxy S8 Google Pixel 2 Sony Bravia A1 OLED Microsoft Xbox One X Apple iPhone 8

© 1998 - 2017 de Persgroep Online Services B.V. Tweakers vormt samen met o.a. Autotrack en Hardware.Info de Persgroep Online Services B.V. Hosting door True

*