Cookies op Tweakers

Tweakers maakt gebruik van cookies, onder andere om de website te analyseren, het gebruiksgemak te vergroten en advertenties te tonen. Door gebruik te maken van deze website, of door op 'Ga verder' te klikken, geef je toestemming voor het gebruik van cookies. Wil je meer informatie over cookies en hoe ze worden gebruikt, bekijk dan ons cookiebeleid.

Meer informatie

Door , , 28 reacties
Bron: ATi, submitter: blade181

ATi heeft nieuwe Linux-drivers voor zijn videokaarten gelanceerd. Het versienummer is 3.7.0. De vorige drivers hadden het versienummer 3.2.8, wat doet vermoeden dat er een redelijk grote stap voorwaarts is gemaakt. Het changelog laat echter geen grote veranderingen zien:

Fixed in this release:
  • Fixed Crash with Savage from S2Games
  • RHEL 3.0 support
  • Improved FSAA
  • Added support for the following graphics cards:
    • MOBILITY FireGL T2 support
[break] De drivers zijn te verkrijgen in drie smaken, afhankelijk van de geÔnstalleerde XFree86-versie:
*4.1.0
*4.2.0
*4.3.0

Installatietips zijn hier te vinden
Versienummer:3.7.0
Besturingssystemen:Linux, Linux x86
Website:ATi
Download:ttp://www2.ati.com/drivers/linux/fglrx-glc22-4.3.0-3.7.0.i386.rpm
Bestandsgrootte:2,72MB
Licentietype:Freeware
Moderatie-faq Wijzig weergave

Reacties (28)

werkt deze ook voor de mobility radeon?

En als antwoord op de vraag hierboven: er staan ati 7500 bij gerelateerde producten, lijkt dus dat het wel werkt.
De vorige versie werkt bij mij in iedere geval zonder problemen op mijn laptop met de mobile 9000
natuurlijk is er al een gentoo ebuild :)

Werkt goed en zelfs een beetje performancewinst
15640 frames in 5.0 seconds = 3128.000 FPS
terwijl ik eerst 3097.200 FPS had :7
Sapphire 9600 PRO/XFree86 4.3.99.16/Linux 2.6.0-bk1

XFree86.org:
[30 December 2003]
The XFree86 core team voted to disband itself, effective 31 December 2003.
Werkt goed en zelfs een beetje performancewinst
15640 frames in 5.0 seconds = 3128.000 FPS
terwijl ik eerst 3097.200 FPS had
Sapphire 9600 PRO/XFree86 4.3.99.16/Linux 2.6.0-bk1
31 fps op de 3100 is geen performancewinst (1%)... Ik denk eerder dat dat binnen de marge van de meetonnaukeurigheid valt. Misschien dat je systeem de tweede keer net iets minder toe doen had...
Welke XFree86 gebruiken nieuwe distro's op dit moment? Zoals Suse 9.0, Debian 3.0, Mandrake 9.0....
www.distrowatch.com

hier kan je zien welke versies van welke pakketten welke distros gebruiken.
De stable branch, Xfree 4.3, met uitzondering van Debian die nog steeds op 4.2 zit, maar daar weten we onderhand ook de reden van.

Debian is (ff uitleggen aan Paul Milo) verdeelt in 3 branches,

Woody (stable)
Sarge (testing)
Sid (unstable)

In apt-get kun je deze 3 branches opnemen.

Hoewel Xfree 4.2 in Sid gebruikt wordt kun je vanaf de website van Debian al de 4.2.99 downloaden, dit is Xfree 4.3, je moet ze dan wel handmatig installeren (dpkg). Zo heb ik het athans gedaan. Je moet dan wel ff prutsen voordat je het voor elkaar hebt. Gnome deed het daarna wel op een Radeon kaartje. DRM wordt volgens mij niet ondersteunt!
Debian zit op Xfree86 4.1.0 Van het weekeinde nog alle ISO's 3.0_r1 gedowned. Krijg KDE niet aan de praat, en Gnome draait is een slechte resolutie/refresh..
edit:
blade181: zeer behulpzaam. ga wellicht nog es ff spitten in XFree.... Overigens heb ik een 9000 pro
Debian Sid heeft XFree 4.2, woody heeft 4.1
In woody heb je ook nog gnome 2.2, in Sid 2.4
In Woody zit Gnome 1.4 |:(
Zit Debian nog op 4.1 / 4.2? arg! hoewel ze het voor de stabiliteit doen, vind ik dit wel heel ver gaan. 4.1 bestaat toch al een tijdje??
in de readme staat: ATI Radeon 8500, 9100, 9200, 9500, 9600, 9700, 9800

betekend dus dat ze niet voor de 7000 serie zijn ?
Ik weet het niet zeker, dat wilt zeggen, ik heb er geen ervaring mee... maar als het goed is zou het antwoord helaas nee moeten zijn.
Nu moeten we wel onthouden dat ATi in het verleden geen officiŽle Linux drivers had voor haar Radeon kaarten maar dat men destijds gewoon de FireGL drivers kon pakken (wat ook deze driver's in de kern nog zijn) dus je hebt maar zo kans dat ook hier ongenoemde kaarten toch gesupport worden. Ik acht de kans persoonlijk echter klein.

Als je oudere kaarten toch onder Linux aan de praat wilt hebben (OpenGL/Mesa support that is) dan zou ik het eens met de onofficiele DRI drivers proberen (http://dri.sourceforge.net/cgi-bin/moin.cgi/) :).
Helaas, het antwoord op je vraag is nee, de support van de drivers is vanaf de radeon 8500, als je nieuwe drivers voor je R100 wilt moet je wachten op XFree86 4.4.0 denk ik.
Als het goed is is er al een release canidate van Xfree 4.4.
hmmmzzz
met deze driver werkt maxpayne2 niet meer onder winex3.2.1 en soldier of fortune2 draait met nog maar 1 fps onder winex.

call of duty doet het wel nog maar die draai ik met gewone wine want die krijg ik sowieso niet aan de gang met winex

heb dus maar weer de oude driver installed die overigens prima presteerd...

mischien dat winex een update nodig heeft om met deze nieuwe drivers goed te werken?

draai fedora btw
Wat mij betreft zijn deze drivers niet beter dan de vorige.

glxgears en neverWinter nights geven bij mij een klein beetje performancewinst. Leuk, maar nauwelijks merkbaar.

Daar staat tegenover dat de performance in Unreal Tournament 2003 gehalveerd is, waardoor deze niet meer lekker speelbaar is.

Enigste lichtpuntje is dat met de nieuwe drivers het spel savage vrij goed speelbaar is geworden met ATI onder linux.

Dit is op een Radeon 8500 met 2.4 kernel en XFree 4.3.0.
Nog niets eens Kernel 2.6.0 support ? vaag
Nog niets eens Kernel 2.6.0 support ? vaag
Huh, jawel hoor, tenminste dat draai ik al lang...
tot nu toe hebben ze bij mij met een 2.6 kernel nog niet gewerkt omdat tijdens de installatie naar /proc/ksyms wordt gezocht en juist /proc/ksyms is verdwenen bij kernel 2.6
Hij (de RPM) installeert prima onder kernel 2.6.0 hoor.
De module compiled en laad ook prima .

Alleen werkt het vervolgens niet bij mij omdat de ATI Config-tool een XF86Config file maakt die niet goed is.
Zie ook draadje op GOT: http://gathering.tweakers.net/forum/list_message/19639112

UPDATE
Met de 2.4 kernel werkt het wel !
En nog wel *met* de default/auto-created config ook !!!

Met Kernel 2.6 werkt het dus niet, ondanks het feit dat alles zich goed *lijkt* te installeren.
Bij mij onder Gentoo Linux werkt het wel, alleen direct Acceleration wordt uitgeschakeld, en daarbij wordt niet gebruik gemaakt van de DRM Radeon kernel module, Verder werkt het onder de 2.6 kernel verder goed.
Hartstikke mooi. Maar waarom geen drivers voor de mobile Radeon :? Via de website wordt je steeds verwezen naar de leverancier van je laptop.
Vind ik zelf ook zeer frustrerend. Ik heb bv. de overbekende ati mobility (dit is een rage lt pro voor zover ik weet) en kan ook nergens drivers vinden om 3d hardware acceleration te krijgen.

Om een voorbeeld te noemen: ik krijg het dus niet voor elkaar om binnen mplayer een film echt fullscreen af te spelen.
misschien omdat die rage lt bijna geen 3d hardware accelleratie doet en geen radeon is dus sowieso niet met de propriety drivers van ati gaat werken.
Dus je zult hooguit aan de drm/dri kunnen gaan, check je kernel en je xfree86 configuratie

Daarbij komt dat ati sowieso niet zo happig is met driversupport voor mobilities, misschien kan je net als bij de nvidia driver het een en ander forcen in je xfree config dat het herkend wordt als een radeon9000 als je een m9 hebt (geldt dus niet voor neutron die moet aan de normale xfree ati drivers of aan fbdev)

En je voorbeeld vind ik een beetje vreemd, dat lukt mij met mijn oude cel450 met tnt2 gewoon met de svga driver en met de svga framebuffer, beiden geven wel een hoge load maar geen framedrops
Wanneer komt er nou eens iets dat ook op friet werkt? Toen nVidia FreeBSD-drivers uitbracht was ik net overgestapt naar ATi, zul je zien dat ik dadelijk een nieuwe videokaart koop en dat er dan pas een driver voor de Radeon komt.
De ATI drivers werken perfect met de MOBILITY FIRE GL 9000 DDR. Gewoon niet installeren met die RPM maar rpm2targz doen (ofzo) en dan gewoon alles in de dirs plaatsen en fftjes make_install.sh uitvoeren :)
En je hebt 't mooi draaiend.

edit: firegl is volgens mij dus gewoon 'tzelfde als de radeon?
De ATI drivers werken perfect met de MOBILITY FIRE GL 9000 DDR
Dat meende ik idd een x eerder gehoord te hebben. Ik heb echter nog nooit iemand gehoord die ze met de ouwere radeon mobilities aan de gang heeft gekregen.

Op dit item kan niet meer gereageerd worden.



Apple iOS 10 Google Pixel Apple iPhone 7 Sony PlayStation VR AMD Radeon RX 480 4GB Battlefield 1 Google Android Nougat Watch Dogs 2

© 1998 - 2016 de Persgroep Online Services B.V. Tweakers vormt samen met o.a. Autotrack en Carsom.nl de Persgroep Online Services B.V. Hosting door True