Cookies op Tweakers

Tweakers maakt gebruik van cookies, onder andere om de website te analyseren, het gebruiksgemak te vergroten en advertenties te tonen. Door gebruik te maken van deze website, of door op 'Ga verder' te klikken, geef je toestemming voor het gebruik van cookies. Wil je meer informatie over cookies en hoe ze worden gebruikt, bekijk dan ons cookiebeleid.

Meer informatie

Door , , 24 reacties
Bron: AMD, submitter: LongBowNL

AMD Radeon Graphics logo (75 pix) AMD heeft nieuwe Linux-drivers voor zijn Radeon-videokaarten uitgegeven. Er zijn downloads voor verschillende distributies en daarnaast wordt de Catalyst Control Center als losse download aangeboden. Versie 15.9 is geschikt voor de Radeon HD 5000 en hoger en voor de geïntegreerde chipsets vanaf de 6200D. Verder worden versies 7.4 en hoger van Xserver, Linux-kernel 2.6 en hoger, en glibc-versies 2.2 en 2.3 ondersteund. De release notes voor deze uitgave kunnen hieronder worden gevonden.

Distributions supported:
  • Red Hat Enterprise Linux Suite 7.1, 7.0, 6.6, 6.5
  • Ubuntu 12.04.4 LTS, 14.04.2, 15.04
  • SUSE Linux Enterprise 11 SP3, 12
  • OpenSuSE 13.1
Distribution specific packages are available for:
  • Red Hat Enterprise Linux Suite 7.1, 7.0, 6.6, 6.5
  • Ubuntu 12.04.4 LTS, 14.04.2
Resolved Issues:
  • [425910] Driver installation sometimes fails on Ubuntu 14.04.3
  • [424450] Company of Heroes 2 - Game crashes while running the performance test
  • [424794] Middle-earth: Shadow of Mordor - Corruption observed in game
  • [424882] DIRT Showdown - Corruption observed in game
  • [425234] DIRT Showdown - Game crashes after the loading screen
  • [424802] DOTA 2 – Application hang observed while exiting the game
  • [424255] AMD Catalyst Installer removing EGL links resulting in Xserver/Xorg load failure
  • [423471] Unable to switch desktop mode after installing AMD Catalyst driver
  • [423735] Renaming Counter-Strike: GO and other Steam game binary improves performance
Known Issues:
  • [419960] Vari-Bright on some configurations is not decreasing brightness as expected
  • [425912] Alien: Isolation - Blank screen or corruption observed on the main menu in game
ATi Catalyst Linux Display Driver logo (410 pix)
Moderatie-faq Wijzig weergave

Reacties (24)

Verder worden versies 7.4 en hoger van Xserver, Linux-kernel 2.6 en hoger, en glibc-versies 2.2 en 2.3 ondersteund. De release notes voor deze uitgave kunnen hieronder worden gevonden.

Klopt dit wel? Alle bovenstaande versienummers van die paketten zijn ondertussen antiek, zo zitten de meesten op Linux >= 3.0 and glibc >= 2.10 om zo maar wat te noemen. Ondersteuning voor glibc 2.2 zou zelfs LinuxThreads support betekenen..
Ik had precies dezelfde reactie, dat is software uit het Windows XP tijdperk. Ik ben op onderzoek gegaan en heb de driver gedownload. Tot mijn verbazing zag ik het volgende:
AMD Catalyst(TM) Proprietary Driver Installer/Packager
=====================================================================
List of generatable packages:

Package Maintainer(s): Aric Cyr <aric.cyr@gmail.com>
Mario Limonciello <superm1@gmail.com>
Status: *UNVERIFIED*
Debian Packages:
Debian/sid
Debian/unstable
Debian/etch
Debian/stable
Debian/lenny
Debian/testing
Debian/experimental

Package Maintainer(s): Niko Mirthes <nmirthes@gmail.com>
Michael Larabel <michael@phoronix.com>
Status: *UNVERIFIED*
Fedora Packages:
Fedora/FC3
Fedora/FC4
Fedora/FC5
Fedora/FC6
Fedora/F7
Fedora/F8
Fedora/F9
Fedora/F10
Fedora/RHEL3
Fedora/RHEL4

Package Maintainer(s): AMD
Status: Verified
RedHat Packages:
RedHat/RHEL5
RedHat/RHEL6
RedHat/RHEL7
RedHat/RHEL5_64a
RedHat/RHEL6_64a
RedHat/RHEL7_64a

Package Maintainer(s): Emanuele Tomasi <tomasi@cli.di.unipi.it>
Status: *UNVERIFIED*
Slackware Packages:
Slackware/Slackware

Package Maintainer(s): Sebastian Siebert <freespacer@gmx.de>
Status: *UNVERIFIED*
SuSE Packages:
SuSE/SLE10-IA32
SuSE/SLE10-AMD64
SuSE/SLE11-IA32
SuSE/SLE11-AMD64
SuSE/SLE12-AMD64
SuSE/SUSE121-IA32
SuSE/SUSE121-AMD64
SuSE/SUSE122-IA32
SuSE/SUSE122-AMD64
SuSE/SUSE123-IA32
SuSE/SUSE123-AMD64
SuSE/SUSE131-IA32
SuSE/SUSE131-AMD64
SuSE/SUSE132-IA32
SuSE/SUSE132-AMD64
SuSE/SUSE-autodetection

Package Maintainer(s): Alberto Milone <alberto.milone@canonical.com>
Status: *UNVERIFIED*
Ubuntu Packages:
Ubuntu/gutsy
Ubuntu/hardy
Ubuntu/intrepid
Ubuntu/jaunty
Ubuntu/karmic
Ubuntu/lucid
Ubuntu/maverick
Ubuntu/natty
Ubuntu/oneiric
Ubuntu/precise
Ubuntu/quantal
Ubuntu/raring
Ubuntu/saucy
Ubuntu/source
Ubuntu/trusty
Ubuntu/utopic
Ubuntu/vivid
Ubuntu/wily
AMD lijkt dus wel degelijk te proberen om drivers te maken die op al die oude systemen werken. Ik weet niet of dat in praktijk ook echt werkt, ik betwijfel het eerlijk gezegd. Maar met zo'n lijst er bij snap ik hoe ze aan die antieke minimum specs komen.
Ja maar zijn de AMD Linux drivers niet heel simpel over te zetten naar nieuwe kernels. Volgens mij is de driver overal hetzelfde behalve de headers...
Voor de kernel wel al is van 2.6 naar 4.0 toch wel een erg grote stap. Dat is zo iets als een Windows XP driver op Windows 10 gebruiken. Als dat werkt dan is dat meer geluk dan wijsheid.

Maar die driver moet ook nog samenwerken met verschillende libc-versies, verschillende X versies en dan ook nog 10 jaar opengl ontwikkeling dekken. Het is theoretisch mogelijk maar ik zou het ze niet na doen. Ik denk zelfs dat het niet echt werkt en dat ze al jaren niet meer testen met die oude versies en domweg zijn vergeten om de documentatie aan te passen.
linux kernel 3.x en 4.x is toch hoger dan 2.6?

De lijst van fixes blijft toch wel een pak beperkter dan bij windows, tenzij het moest zijn dat alles beter werkt onder linux, maar dat betwijfel ik toch een beetje :).

Ben ook benieuwd naar freesync onder linux.
De versie nummers zijn vanaf. En glibc 2.2x is toch heel recent? Arch zit op 2.22-3 bijvoorbeeld.

Het lijkt mij alleen maar goed dat ze backward compatible zijn, toch?
glibc is het enigste waar ik echt over viel, 2.2 is juist niet recent.

glibc 2.2 is heel oud, deze komt uit 2001, 2.3 uit 2002 en 2.4 uit 2006. Ik heb het even opgezocht op de AMD site er hier staat dat ook vermeld. Denk dat dit verkeerd in de release notes staat, de rest lijkt wel te kloppen.

Maakt verder ook niks, maar viel me op. :P
Niet dat ik je niet geloof hoor, maar ik kan 2.3 en 2.4 dus helemaal niet eens vinden. Zelfs niet in AUR van Arch, terwijl dat juist een 100% rolling distro is.
Volgens mij ben je in de war. Je hebt versie 2.22, dat is dus 20 subversies hoger dan 2.2. Zie ook het goede oude Wikipedia voor meer informatie :)
Ja, je hebt gelijk. Duh! |:(
Ik ga deze toch eens uitproberen. Met fglrx-14.501.1003 icm een R9 280X haal ik amper 8 fps in Cities Skylines. Dat valt natuurlijk een "beetje" tegen. Mogelijk ligt het aan de game zelf...
ik gok van niet; in windows haal ik aardige framerates met cities, terwijl ik niet bepaald hippe hardware heb.. dus zou me niets verbazen als het wel degelijk AMD's 'schuld' is ;)
Een paar FPS erbij. Nu ligt het rond 13-15 fps. Dat is nog niet om van achterover te vallen. Hoe doen de opensource drivers het eigenlijk met 3D games? Is er ergens een soort vergelijkende studie te vinden met hedendaagse hardware en Linux?
Goeie vraag! Ik hoorde laatst ook dat de open source drivers tegenwoordig best aardig zijn. Heb ze zelf geprobeerd te installeren laatst maar kreeg het helaas niet voor elkaar (best nog een gedoe)..

Iig, als het je wel lukt, het lijkt me een poging waard :)
Shadow of mordor op linux? wist ik niet :)

Eindelijk krijgen we updates voor Linux, AMD liep achter en ik kan me voorstellen als de Linux drivers op orde zijn, dat meerdere games gaan richten op Linux Games.

Steam OS <3
Ik zie nog niets staan over verbeteringen als je Diablo 3 speelt.

Raad iedereen aan die een wat oudere kaart heeft (heb zelf een 6870) vooral niet de laatste amd drivers te installeren. Dit geeft allemaal problemen (craches, zwarte schermen, freezes etc.)

Zelf heb ik de drivers van december 2014 geinstalleerd (omega pack 14.12) en diablo 3 draait weer zoals het hoort zonder al die vervelende problemen.

wees dus gewaarschuwd.. scheelt een hele bak irritatie :)
http://www.phoronix.com/s...em=amd-catalyst-159&num=1
bijna over een paar kleine % verbetering, maar in cs:go wel een heel stuk

Hoe zat het eigenlijk met een universele driver waar ze aan werkte ?

[Reactie gewijzigd door holhuizen op 16 september 2015 18:52]

Opvallend: Alien: Isolation is nog helemaal niet aangekondigd op Linux. Het staat ook niet meer op de AMD website. :)
Ik heb vaak problemen na het installeren van AMD drivers (ze werken nu).

Kan iemand mij de juiste werkwijze voor het updaten van de driver uit de doeken doen?

Ik gebruik nu deze OP uBUNTU 14.04 lts

http://i.imgur.com/ZuRuxCS.png
De downloadpagina bevat een link naar de Unofficial Wiki for the AMD Linux Driver. Daar kun je voor allerlei distributies, waaronder Ubuntu, vinden hoe de laatste versie te installeren. De pagina is nu nog gebaseerd op versie 15.7, maar dat zal heel snel worden bijgewerkt.
Dat is apart dat Linux versie hogere versie heeft dan van windows, meestal was dit omgekeerd eerste windows dan Linux.
Amd baseert zijn versie nummers op de maand dat het uitkomt en niet zo zeer het feature pakket dat het introduceert.
Nu nog een never settle bundel voor de 3xx kaarten graag.
Ik zit er al even op te wachten de fan van mijn 7970 is het aan het begeven en als ik dan toch een peperdure kaart moet kopen wil ik er graag een game bij voor de MP.

Op dit item kan niet meer gereageerd worden.



Apple iOS 10 Google Pixel Apple iPhone 7 Sony PlayStation VR AMD Radeon RX 480 4GB Battlefield 1 Google Android Nougat Watch Dogs 2

© 1998 - 2016 de Persgroep Online Services B.V. Tweakers vormt samen met o.a. Autotrack en Carsom.nl de Persgroep Online Services B.V. Hosting door True