Driver-update: Nvidia Linux Display Driver 285.05.09

nVidia logo (60 pix)Nvidia heeft afgelopen week nieuwe *nix-displaydrivers uitgebracht met versienummer 285.05.09. De drivers zijn beschikbaar voor Linux (32bit), Linux (AMD64/EM64T), Solaris (x64/x86), FreeBSD (x86) en FreeBSD (x64). Specifieke installatie-instructies kunnen op de afzonderlijke pagina's worden gevonden. Versie 285.05.09 voegt onder andere ondersteuning toe voor de GeForce GTX 520MX en verhelpt verder een handvol problemen. Het volledige changelog van deze release ziet er als volgt uit:

Release Highlights
  • Added support for the following GPU:
    • GeForce GT 520MX
  • Fixed a bug causing a Linux kernel BUG when retrieving CPU information on some systems.
  • Fixed a bug causing some applications to hang on exit.
  • Fixed a bug causing flickering in some GPU/display combinations.
  • Fixed a bug that could result in poor OpenGL performance after hotplugging a monitor.
  • Fixed a bug causing possible text corruption when recovering from GPU errors.
  • Fixed a bug causing corruption of images which are 2047 pixels wide.
  • Improved performance of the RENDER extension on Fermi-based GPUs.
  • Fixed a bug causing the X server to crash after a VT-switch while running an OpenGL stereo application which is a member of a swap group.

De volgende downloads zijn beschikbaar:
*Linux Display Driver - x86
*Linux x64 (AMD64/EM64T) Display Driver
*Solaris Display Driver – x64/x86
*FreeBSD Display Driver – x86
*FreeBSD Display Driver – x64

Versienummer 285.05.09
Releasestatus Final
Besturingssystemen Linux, BSD, Solaris, Linux AMD64
Website nVidia
Download http://www.nvidia.co.uk/object/linux-display-amd64-285.05.09-driver-uk.html
Bestandsgroottes 29,20MB - 54,00MB
Licentietype Voorwaarden (GNU/BSD/etc.)

Reacties (12)

Wijzig sortering
Gelukkig zit hij ook al gelijk in Debian Experimental, wat bij de changelog niet staat is dat deze driver ook deze X11 bug fixed.
Maar helaas nog niet deze bug, waardoor iig de combinatie Xorg 1.11, KDE4 en nvidia drivers niet bruikbaar is.
Zal deze ook in de nieuwe Ubuntu distro zitten volgende week?
Meestal wordt er zoveel mogelijk vrije software gebruikt, dus ook voor de videokaart!
Zoals hier bij een standard install van fedora 15 nouveau voor de videokaart gebruikt wordt!
Dus de kans dat er een niet-vrije display-driver standaard bij wordt geleverd acht ik vrij klein!
Ubuntu levert wel closed-source drivers van o.a. ATI en nVidia die niet standaard geïnstalleerd zijn, maar wel makkelijk geïnstalleerd kunnen worden. Er wordt zelfs gevraagd of je ze wil installeren wanneer je de PC voor het eerst opstart in Ubuntu.. :P
Helaas niet dus in de laatste distro.. :(
Nee, inderdaad. En erg stabiel is de nieuwe nouveau driver ook nog niet altijd voor alle kaarten. Mijn machine op het werk ging onmiddellijk op zijn bek er door.

Dan vond ik hun vorige positie ten opzichte van closed source toch een stuk pragmatischer.
Meestal niet, maar zo kan je de laatste nvidia drivers installeren op ubuntu:
sudo apt-add-repository ppa:ubuntu-x-swat/x-updates
sudo apt-get update
sudo apt-get install nvidia-current nvidia-settings

Als je nog geen ubuntu drivers had geinstalleerd even "sudo nvidia-xconfig" voor de zekerheid. (dan wordt er een Xorg.conf aangemaakt voor je)

Ik kan zeggen dat de 285.05.09 erin zit :)
Ik ben volledig leek in dit gebeuren dus je zou me zo het bos in kunnen sturen.

Draai op GeForce 8600m GT 512mb in Ubuntu 11.10.
Wat kunnen de eventuele gevolgen zijn als ik Nvidia Linux Display Driver 285.05.09 installeer ?
Dit gaat over het algemeen wel goed, Ubuntu herkent dit (dat je hem zelf hebt geinstalleerd en dat dit niet via de officieele route is gegaan), maar ja, garanties zijn niet te geven natuurlijk.
Worst-case kom je terecht in de terminal, en daar moet je je dan wel thuis voelen. Dit is tegenwoordig gelukkig wel vrij onwaarschijnlijk hoor, Ubuntu heeft het zo geconfigureerd dat als je driver niet werkt, hij automatisch terugvalt op een generieke (vesa) driver die je in een fantantische 1024x768 resolutie in crappy kwaliteit laat zoeken naar een oplossing.
Die waarschuwing gezegd hebbende, meestal is het geen probleem, gaat wel goed.
Anders gewoon handmatig installeren.
Lukte mij binnen 15 min als linux leek. (mint)

Merk alleen nog geen verschil ;)
Deze driver werkt in ieder geval goed met openSUSE 11.3 en KDE4.

Op dit item kan niet meer gereageerd worden.

Kies score Let op: Beoordeel reacties objectief. De kwaliteit van de argumentatie is leidend voor de beoordeling van een reactie, niet of een mening overeenkomt met die van jou.

Een uitgebreider overzicht van de werking van het moderatiesysteem vind je in de Moderatie FAQ.

Rapporteer misbruik van moderaties in Frontpagemoderatie.




Google Pixel 7 Sony WH-1000XM5 Apple iPhone 14 Samsung Galaxy Watch5, 44mm Sonic Frontiers Samsung Galaxy Z Fold4 Insta360 X3 Nintendo Switch Lite

Tweakers vormt samen met Hardware Info, AutoTrack, Gaspedaal.nl, Nationale Vacaturebank, Intermediair en Independer DPG Online Services B.V.
Alle rechten voorbehouden © 1998 - 2022 Hosting door True

Tweakers maakt gebruik van cookies

Tweakers plaatst functionele en analytische cookies voor het functioneren van de website en het verbeteren van de website-ervaring. Deze cookies zijn noodzakelijk. Om op Tweakers relevantere advertenties te tonen en om ingesloten content van derden te tonen (bijvoorbeeld video's), vragen we je toestemming. Via ingesloten content kunnen derde partijen diensten leveren en verbeteren, bezoekersstatistieken bijhouden, gepersonaliseerde content tonen, gerichte advertenties tonen en gebruikersprofielen opbouwen. Hiervoor worden apparaatgegevens, IP-adres, geolocatie en surfgedrag vastgelegd.

Meer informatie vind je in ons cookiebeleid.

Sluiten

Toestemming beheren

Hieronder kun je per doeleinde of partij toestemming geven of intrekken. Meer informatie vind je in ons cookiebeleid.

Functioneel en analytisch

Deze cookies zijn noodzakelijk voor het functioneren van de website en het verbeteren van de website-ervaring. Klik op het informatie-icoon voor meer informatie. Meer details

janee

    Relevantere advertenties

    Dit beperkt het aantal keer dat dezelfde advertentie getoond wordt (frequency capping) en maakt het mogelijk om binnen Tweakers contextuele advertenties te tonen op basis van pagina's die je hebt bezocht. Meer details

    Tweakers genereert een willekeurige unieke code als identifier. Deze data wordt niet gedeeld met adverteerders of andere derde partijen en je kunt niet buiten Tweakers gevolgd worden. Indien je bent ingelogd, wordt deze identifier gekoppeld aan je account. Indien je niet bent ingelogd, wordt deze identifier gekoppeld aan je sessie die maximaal 4 maanden actief blijft. Je kunt deze toestemming te allen tijde intrekken.

    Ingesloten content van derden

    Deze cookies kunnen door derde partijen geplaatst worden via ingesloten content. Klik op het informatie-icoon voor meer informatie over de verwerkingsdoeleinden. Meer details

    janee