Cookies op Tweakers

Tweakers maakt gebruik van cookies, onder andere om de website te analyseren, het gebruiksgemak te vergroten en advertenties te tonen. Door gebruik te maken van deze website, of door op 'Ga verder' te klikken, geef je toestemming voor het gebruik van cookies. Wil je meer informatie over cookies en hoe ze worden gebruikt, bekijk dan ons cookiebeleid.

Meer informatie

Door , , 41 reacties
Bron: ATi, submitter: icyx

ATi heeft in de vorm van versie 8.42.3 nieuwe stuurprogramma's uitgebracht voor het Linux-platform. De drivers zijn nog niet officieel door ATi beschikbaar gesteld, maar zijn gevonden nadat deze review op Phoronix is verschenen. icyx heeft het volgende in de submit achtergelaten over de nieuwe Linux Drivers: "Na dertien maanden is het ATi dan eindelijk gelukt: er is ondersteuning voor AIGLX toegevoegd aan de nieuwe ATi Linux Drivers. De drivers zijn vanaf deze server als versie 8.42.3 voor AMD64-systemen te downloaden. Aangezien de closedsource drivers van ATI deze feature tot dertien maanden na concurrent nVidia nog niet ondersteunde, hebben veel mensen de hoop verloren op verbetering van de drivers. Dit moet die verbetering zijn. De performance zou erg omhoog moeten gaan, evenals de opties in de grafische manager van de driver. Een snelle test levert mij inderdaad een performanceboost op, evenals probleemloze samenwerking met de nieuwste stable X.org-release. Kernel 2.6.23 werkt echter niet, geizen de issues in het artikel." ATi zal waarschijnlijk binnenkort de officiŽle aankondiging de deur uit doen.

Lees meer over

Versienummer:8.42.3
Besturingssystemen:Linux AMD64
Website:ATi
Download:http://www2.ati.com/drivers/linux/ati-driver-installer-8.42.3-x86.x86_64.run
Licentietype:Voorwaarden (GNU/BSD/etc.)
Moderatie-faq Wijzig weergave

Reacties (41)

Voor iedereen die dit op ubuntu 7.10 wil installeren
eerst de oude fglrx drivers eraf gooien (via restricted drivers manager, gewoon unchecken en restarten)
dan restart ubuntu in lage resolutie mode enzo. download de nieuwe driver en voer dit uit in die map:
$ sudo apt-get update
$ sudo apt-get install module-assistant build-essential fakeroot dh-make debhelper debconf libstdc++5 linux-headers-generic
$ sudo bash ati-driver-installer-8.42.3*.run --buildpkg Ubuntu/7.10
$ gksudo gedit /etc/default/linux-restricted-modules-common
nu komt de texteditor naar voren. Zet nu bij disabled modules DISABLED_MODULES="fglrx" neer. voer dan dit uit:
$ sudo dpkg -i xorg-driver-fglrx_8.42.3-1*.deb \
fglrx-kernel-source_8.42.3-1*.deb \
fglrx-amdcccle_8.42.3-1*.deb
dan ga je weer naar de restricted drivers manager en klik je ATI drivers weer aan. Dan herstarten en 8.42 zou moeten werken :D
om dan nog compiz te krijgen:
$ gksudo gedit /usr/bin/compiz
zet nu achter WHITELIST ook nog fglrx erbij zodat er dit komt te staan:
# Driver whitelist
WHITELIST="nvidia intel ati radeon i810 fglrx"
doe dan dit:
$ gksudo gedit /etc/X11/xorg.conf
zorg nu dat de optie Composite in de section Extensions op Enabled staat. Vaak staat het standard op 0. Dit moet er dus komen te staan:
Section "Extensions"
Option "Composite" "Enabled"
EndSection
Herstart, en nu zou compiz ook moeten werken!

[Reactie gewijzigd door MilaNL op 24 oktober 2007 20:29]

mm, goede tutorial :)
alles loopt vlotjes, tot ik mijn compiz enable, dan krijg ik een wit scherm (na een tijdje reset hij zich dan terug), zijn er nog mensen met dit probleem ?
for the record: ATI X1650
zorg er ook voor dat de optie AIGLX in /etc/X11/xorg.conf niet op disabled staat. Als er niks staat is het goed, want dan staat het standard op enabled.
Ik heb al van alles geprobeerd maar ik doe iets verkeerd of ben nog wat cruciaals vergeten waardoor geen enkele installatie tuto mij verder kan helpen. Het start allemaal wel goed op maar zo gauw ik iets installeren wil begint het gezeur al over dependencies die ik niet heb of andere libraries oid... ik weet dat die allemaal via dat synaptic package manager te installeren zijn maar dan begint het gezeur van vooraf aan en heb toch nog weer wat anders nodig om het vorige correct te kunnen installeren.... dit was de foutmelding bij de tuto van MilaNL:

$ sudo apt-get install module-assistant build-essential fakeroot dh-make debhelper debconf libstdc++5 linux-headers-generic
Pakketlijsten worden ingelezen... Klaar
Boom van vereisten wordt opgebouwd
Reading state information... Klaar
Pakket dh-make is niet beschikbaar, hoewel er naar verwezen wordt door
een ander pakket. Mogelijk betekent dit dat het pakket ontbreekt,
verouderd is, of enkel beschikbaar is van een andere bron
E: Pakket dh-make heeft geen installeerbare kandidaat


Goed en dan denk je... laat ik dat dh-make maar downloaden... en zoals verwacht weer een grote lijst met benodigde libs en ander geneuzel... welke weer een foutmelding geven....

Hoe nu verder??? :?
kijk eens naar je sources.list (/etc/apt/sources.list) en check of ze niet allemaal commented zijn.
als je niet zo bekend bent met de commandline enzo kun je ook kijken in Systeem -> Beheer -> Softwarebronnen. Daar moet voor elke softwarebron een vinkje staan (main,universe,restricted,multiverse).
Hellaas nog geen xvideo ondersteuning.. kan dus nog geen tv kijken...
Kreeg drivers er ook niet zo makkelijk meer af.. gebruik ze dus nu wel.. maar wel met xgl.. want zonder tv kan ik niet :S
het het idee dat ze iet minder presteren dan die ik hiervoor had (ubuntu repos -> 8.37.6, die gebruikte ik ook met xserver-xgl)...
hm ik kijk tv via een PVR-150 op VLC Media player. (via bestand -> Open Capture Device -> tabje PVR -> OK)
en dan moet je bij Instellingen -> Preferences -> Onder Video kies je Uitvoer Modules -> Zet geavanceerde opties aan -> kies voor Uitvoer module X11 video uitvoer. Dan zou het moeten werken (in VLC iig).
Nou... de vorige was op mijn X1600 silence een drama. Het was zeker snel. Maar veel foutjes en vastlopers. Crossover Office deed het niet meer etc.

Ik wil nou wel eens dat GoogleEarth het gaat doen ! Hoop dat dat gefixed is. Volgens de beschrijving in de aankondiging wel.

Maar wat is dat nu weer met de laatste kernel ? Zo schiet het niet op. Ik wilde net gaan upgraden en nou kan dat dus weer niet. Ik geloof dat het tijd is voor een terugkeer naar nVidia.

....enne.... die link verwijst alleen naar een 64bit editie.

[Reactie gewijzigd door Roit op 24 oktober 2007 11:10]

Hoewel ik je kan gelijkgeven dat Ati/AMD sterk achterop loopt tov nVidia wat betreft hun linux-drivers voor grafische kaarten, vind ik dit toch wel een slecht ogenblik om te gaan terugkeren naar nVidia.

Nog nooit is de release cycle van Ati/AMD zo kort geweest en zijn er zo grote stappen vooruit gezet. De wijzigingen in de kernel van 2.6.22 naar 2.6.23 zijn niet min, en dus kan ik hen geen ongelijk geven van nog niet onmiddellijk compatibility met de nieuwste kernel te gaan verkondigen.

Bovendien werd vorige maand aangekondigd dat er nauwer zou samengewerkt worden met de opensource-gemeenschap en werd er zelfs gespeculeerd over het openstellen van de code (of gedeelten ervan). Dit zal op zijn beurt weer een vooruitgang betekenen (wie weet komt er een samensmelting met de radeon-code, zodat twee afzonderlijke, high level developing teams hun krachten kunnen bundelen)

Kortom: nog even geduld. Het einde van de tunnel is in zicht.

[Reactie gewijzigd door zenlord op 24 oktober 2007 11:46]

Verder dacht ik dat elke oneven linux kernel de 'unstable' versie was en de nieuwigheden van de kernel met de oneven versie 100% stabiel en getest enzo zijn in de daaropvolgende even versie? Dus 2.6.24 is de stable van 2.6.23?
Dat was vroeger zo:

2.1.x unstable als development branch voor 2.2
2.2.x stable
2.3.x unstable als development branch voor 2.4
etc.

met 2.6 zijn ze naar een ander model gegaan waarin geen onderscheid meer wordt gemaakt tussen stable and unstable.

Zie ook http://en.wikipedia.org/wiki/Linux_kernel#Versions
Nvidia is niet veel beter qua drivers. Vastlopers op veel turbocache kaarten, ook moeten patchen voor 2.6.23, etc.
Over kernels gesproken... de release notes zijn uit:
https://a248.e.akamai.net...s/linux/linux_8.42.3.html

Opmerkelijk detail:
Caution: The ATI Catalyst™ Linux software suite 8.42.3 does not support ATI Workstation products. AMD recommends using the AMD Proprietary Linux software driver version 8.40.4.
Als ik het goed begrijp is de driver niet alleen voor AMD64-systemen, maar ook voor systemen met de x86-architectuur.
Ja package is voor x86 en x86_64. :).
Al bekend of ie goed op gutsy draait?
bij mij werkt het, hoewel ik met XGL toch het gevoel had dat alles net wat soepeler draaide (ik spreek dan over compiz fusion, geen ervaring mat games onder linux)
Ik heb compiz nu aan de praat op de x700 mobility, maar de prestatie is om te huilen. Ik heb zelfs dat ik sommige dingen niet kan lezen. Letters zijn helemaal verstoord.
Dan heb je hem dus *niet* aan de praat ;)

Bekijk de output van $ fglrxinfo eens, en check of je niet nog gebruik maakt van de Mesa libs voor OpenGL rendering.
als het goed is, is aiglx sneller mits ondersteund door de driver. xgl werd tot nu toe gebruikt voor Ati kaarten omdat aiglx support ontbrak.

(verbeter mij indien nodig)
ik baal ervan dat ati gewoon de oudere kaarten links laat liggen..

Ik heb een notebook met een ATI Mobility 9000 en ik ben daardoor aangewezen op de open source drivers. Voor Compiz Fusion is het prima maar er zitten gewoon fouten in het 3d rendering gedeelte waardoor er in m'n eigen 3d app gewoon textures veranderen naar andere kleuren / textures / etc.

Hopelijk gaat het xorg team hard aan de slag met de specificaties want kwalitatieve open source drivers zouden ATI gebruikers goed kunnen gebruiken!!
Dit is goed nieuws! Eindelijk fatsoenlijke drivers. Vanavond even proberen. Ben benieuwd naar de eerste tests van gebruikers hier.

[Reactie gewijzigd door RadioheadRules op 24 oktober 2007 10:52]

Is dit makkelijk te installeren of is het beter om te wachten tot het in Portage zit?
De vorige drivers was gewoon een binair installatiepakketje. Werkt prima op een standaard distro.
Werkt perfect hier op gutsy (ati x1300), google earth werkt ook de desktop effects ook (wel wat langzaam alleen maar het kan nu alleen nog maar beter worden)... dus eindelijk! 8-) na lang geduldig wachten.
De grafische X installer werkte bij mij niet goed (volgens mij omdat de fglrx kernel module op dat moment draaide), ik heb vanuit een console
./ati* --buildpkg Debian/unstable
dpkg -i fglrx* (driver, kernel module)
m-a prepare
m-a update
m-a install fglrx
gedaan, waardoor hij nu prima werkt. Ik krijg in Compiz echter nog
Warn: SmcOpenConnection failed: Authentication Rejected, reason : None of the authentication protocols specified are supported and host-based authentication failed
Google heeft vooralsnog weinig opgeleverd wat dat betreft :/ Heb overigens deze guide gebruikt.
(Laptop met x1400, Xorg 7.2, Compiz 0.5.2)

[Reactie gewijzigd door geez op 25 oktober 2007 11:26]

Op dit item kan niet meer gereageerd worden.



Apple iOS 10 Google Pixel Apple iPhone 7 Sony PlayStation VR AMD Radeon RX 480 4GB Battlefield 1 Google Android Nougat Watch Dogs 2

© 1998 - 2016 de Persgroep Online Services B.V. Tweakers vormt samen met o.a. Autotrack en Carsom.nl de Persgroep Online Services B.V. Hosting door True