Cookies op Tweakers

Tweakers maakt gebruik van cookies, onder andere om de website te analyseren, het gebruiksgemak te vergroten en advertenties te tonen. Door gebruik te maken van deze website, of door op 'Ga verder' te klikken, geef je toestemming voor het gebruik van cookies. Wil je meer informatie over cookies en hoe ze worden gebruikt, bekijk dan ons cookiebeleid.

Meer informatie

Door , , 23 reacties
Bron: Creative

Creative heeft een eerste versie van de Linux-drivers voor de Sound Blaster X-Fi-geluidskaarten uitgebracht. De stuurprogramma's zijn voorzien van versienummering 1.04 beta en kunnen vanaf deze server als tarball gedownload worden. Aan de release notes valt duidelijk te zien dat de nieuwe Linux-drivers nog in bŔtastadium verkeren: alleen x64-systemen kunnen gebruikmaken van de stuurprogramma's en de s/pdif-uitgang wordt beperkt ondersteund. Meer informatie over de Sound Blaster X-Fi-drivers kan gevonden worden in dit nieuwsbericht. Hieronder zijn de volledige aantekeningen van de ontwikkelaars gepost:

Take note of the following:
  • THIS IS AN UNSUPPORTED BETA DRIVER. There is no technical support for this driver.
  • We recommend that only experienced users install this driver. Do not install this driver on a system used to perform critical tasks.
  • Your feedback is a valuable part of our development process. To submit feedback on this driver, visit the Sound Blaster X-Fi Linux Beta Driver Feedback Program.
This download is intended for the following audio devices only:
  • Creative Sound Blaster X-Fi Elite Pro
  • Creative Sound Blaster X-Fi Platinum
  • Creative Sound Blaster X-Fi Fatal1ty«
  • Creative Sound Blaster X-Fi XtremeGamer
  • Creative Sound Blaster X-Fi XtremeMusic
Current release features:
  • ALSA PCM Playback
  • ALSA MIDI Playback
  • ALSA Synth
  • ALSA Record
  • ALSA Mixer
Known issues:
  • This driver source will not compile with GCC version 4 and above.
  • S/PDIF passthrough is not supported in this driver release.
  • External I/O modules are not supported in this driver release.
  • Applications from the original Sound Blaster X-Fi Installation CD will not work with this driver.
Requirements:
  • Linux x86_64 OS
  • Creative Sound Blaster X-Fi audio devices listed above.
Notes:
    To install the driver, do the following:
    1. Download the XFiDrv_Linux_US-1.04.tar.gz package onto your local hard disk.
    2. Double-click the downloaded package to unpack its contents.
    3. Read the README file and follow the instructions.
Moderatie-faq Wijzig weergave

Reacties (23)

Volgens mij zijn er wat mensen die hier modereren die geen idee hebben waarom sommige reacties misschien wat gefrustreerd over komen. Laat ik dit even wat ophelderen...

Hoe lang bestaat de X-fi serie nu? 2/3 jaar?....
Dit zijn de eerste drivers die er voor zorgen dat er met Linux gebruik gemaakt kan worden van een X-fi kaart. Er zijn dus ook geen alpha drivers oid. Op de hardware is niets aan te merken. Maar hun driver afdeling mag wel eens op de schop. Er zijn nogsteeds geen Vista drivers die kunnen wat de XP drivers kunnen. Na weet ik veel hoe veel tijd komen er eindelijk Linux drivers, maar dan wel voor 64bit wat globaal gezien veel minder wordt gebruikt dan de 32bit versies.... Moet er nu geklapt worden? Ik vind het schandalig. Dit is de laatste Creative kaart die ik heb gekocht.
Maar welke keuzes heb je vandaag de dag een beetje voor goeie geluidskaarten?
C-Media chipsets zijn leuk maar nog niet helemaal je van het, alhoewel ik de specs van de meest recente eens moet napluizen.
Ik volg je hoor. De Realtek Azalia chip die op veel moederborden zit kan naar mijn ervaring sound wise de confrontatie met de X-Fi niet aan. Ik heb hem voor mijn linux ingeschakeld en als ik onder Windows dan eens switch tussen de X-Fi en de Azalia dan hoor je toch het verschil.

Maar goed, laat ons hopen dat Creative nu snel die Linux driver doorontwikkelt.
Gelet op de snelheid waarmee voor Vista ontwikkeld wordt en de grote labels als "THIS IS AN UNSUPPORTED BETA DRIVER. There is no technical support for this driver." die door Creative aan deze driver geplakt worden lijkt het Delftse studentengezegde: "niet hopen" hier helaas eerder op zijn plaats.
Ik zit nog altijd onder XP met mijn X-fi, maar met steeds meer DirectX 10 spellen om de hoek begint het nogal te dringen. Ik bedoel, dit zijn gamer/high-end consumer audio kaarten. Dat ze afgelopen januari nog niet meteen full feature drivers hadden voor Vista is slecht, maar niet onoverkomelijk omdat er geen goede reden was voor gamers of audiofielen om direct naar Vista te willen. Met Vista service pack 1 en diverse games om de hoek wordt het wel zo'n beetje tijd, anders gaan consumenten straks echt nog bij ze weglopen.
Het lijkt me dan ook haast vreemd als er binnenkort nog veel substantieels aan de linux support wordt gedaan, want ze zullen hun tijd voor Vista harder nodig hebben en dat is een veel groter marktsegment onder de X-fi bezitters lijkt me zo. Dat deze driver nu uitkomt is wel een goed teken, maar met 64-bit GGC 3 only en beperkte hardware mogelijkheden hebben ze nog een erg lange weg te gaan. 2009 op zijn vroegst dunkt me, linux X-fi ondersteuning die echt ergens op lijkt.
Er zijn nogsteeds geen Vista drivers die kunnen wat de XP drivers kunnen.

Die zullen er ook nooit komen, aangezien Microsoft voor Vista in al zijn wijsheid besloten heeft hardware support voor Directsound in de prullenbak te gooien.

Onder Vista krijg je alleen hardware support voor geluid via OpenAL, laat Creative nou net de enige zijn die dat een beetje aan de gang heeft weten te krijgen.

Ik moet de andere makers van discrete geluidskaarten nog met een dergelijke feature zien komen. Tot nog toe is alles software processed, via de CPU dus.
Niet alleen moet je een xx86_64 systeem hebben, je moet hem ook met GCC 3.x compileren :(. Laat de meerderheid van de linux gebruikers nu net op 32 bit en gcc 4 draaien...

Maar het is al beter dan niks zeker?
Een succesverhaal voor debian/ubuntu:
http://olausson.de/x-fi/readme.txt

[Reactie gewijzigd door moulin op 28 september 2007 00:17]

en weeral niet voor de Xtreme Audio??
niet dat ik linux gebruik maar toch raar, vorige drivers ook niet voor de Audio
Dit zijn de eerste linux drivers voor de X-fi serie dus waar jij die eerdere vandaan haalt is mij een vraag.

Verder moet men er rekening mee houden dat creative wel met iets moest komen. Creative belooft al sinds de introductie van de X-fi met een driver te komen. Eerst dacht men een specificatie vrij gegeven te krijgen, maar het bleek toch dat creative zelf een driver ging schrijven.

Zoals we allemaal onderhand hebben kunnen merken aan onder andere de development cycle van de ATI drivers. Is schijnbaar het schrijven van een complexe driver niet al te makkelijk en wordt redelijk onderschat om die reden was de creative X-fi driver al uitgesteld van Q1 2007 naar Q3/Q4 van 2007. En nu moesten ze wel met iets komen om consumenten enig vertrouwen te laten houden in het kunnen van creative. Om de schade en boze cosumenten tot een minimum te verkleinen hebben ze er voor gekozen om een driver uit te brengen die maar een heel beperkt deel van de linux gebruikers kunnen proberen. Ik schat zo dat hoofdzakelijk ontwikkelaars die werken aan de kernel, distros en andere paketten het meest met dit stuk code overweg kunnen. Niet echt nuttig voor jan met de pet, maar wel een goede stap in de richting.
nee, ik bedoel, weeral een driver dat niet de X Audio ondersteunt, ik bedoel hiermee niets dat met linux te maken heeft. De laatste driver, voor XP-Vista dus, waren ook niet voor de Audio
er zijn namelijk problemen met de laatste driver die de kaart niet meer wel initialiseren, graag had ik dit opgelost gezien :(

sry voor misverstand ;)
Dat X-Fi drivers niet voor de XtremeAudio zijn is op zich best logisch. De XtremeAudio is gewoon een rebranded Audigy.

Handige marketing van Creative, maar de XtremeAudio heeft behalve de X-Fi merknaam niets gemeen met de andere X-Fi geluidskaartjes.

Dat ze hiermee mensen voor de gek houden en dat ze gewoon met fatsoenlijke drivers ervoor moeten komen is een tweede..
Ein-de-lijk.

De enige reden waarom ik nog XP draai, een niet werkende geluidskaart onder Linux (en ik vertik het een andere geluidskaart te kopen ;) )

Maar helaas
alleen x64-systemen kunnen gebruikmaken van de stuurprogramma's
XP blijft nog even.

[Reactie gewijzigd door E.r.w.i.n op 25 september 2007 09:16]

Ach je had toch wel een 15 euro geluidskaartje kunnen kopen en dan voor je "creative xfi only business" kunnen dual booten met xp?
Mij zou het niet tegen houden..

Maar goed dat ze eindelijk een driver uitbrengen :)

[Reactie gewijzigd door stijnos1991 op 25 september 2007 09:38]

Wellicht dat een titelfix duidelijk kan maken dat het om Linux beta drivers gaat? Om te voorkomen dat Windows gebruikers massaal tevergeefs aan het testen slaan?
Waarom? Staat toch een pinguin voor?
Ik neem aan dat Windows gebruikers ook de rechterkolom zien waar
Besturingssystemen Linux AMD64
staat. Verder is het natuurlijk belachelijk dat deze driver niet compiled met GCC 4.x :+ En dan laat Creative ook nog eens de grootste doelgroep in de steek (nb: ik gebruik x86_64 en heb gelukkig geen X-Fi).
2. Double-click the downloaded package to unpack its contents.
Haha, dat ze er zomaar vanuit gaan dat iemand wel een grafisch front-end voor tar heeft ge´nstalleerd getuigt er al van dat ze linux nog steeds niet begrijpen.
Overigens, hoe krijgen ze het in hemelsnaam voor elkaar om een driver te ontwikkelen op een 64bit systeem met gcc3? Wist niet eens dat dat soort distros bestonden... Te nieuw combineren met te oud...?

[Reactie gewijzigd door kozue op 25 september 2007 10:49]

amd x86-64 support is ooit in GCC3 ge´ntroduceerd:

http://gcc.gnu.org/gcc-3.1/changes.html

SuSE Labs developers Jan Hubicka, Bo Thorsen and Andreas Jaeger have contributed a port to the AMD x86-64 architecture. For more information on x86-64 see http://www.x86-64.org.

Dat is dus uit begin 2e kwartaal 2002, dus een lullige 5 jaar...
daar heb je wel degelijk gelijk in, ik denk dat veel dat liever wilde zien. ik heb een x-fi platinum en wilde de afstand bediening onder mce gebruiken. oftewel je moest een ehshell.KEY zien te vinden. eerst een mail gestuurd naar creative maar dit had geen zin. uiteindelijk heb ik zelf wat gefabriceerd wat maar half werkt.
het is blijkbaar niet echt aan de klant ter beslissing wat er veranderd moet worden.
Nu nog een fatsoenlijke vista driver.
Met deze linux-driver zit er een gekraak op mijn geluid. Dit is niet zo op xp op dezelfde pc.
Hopelijk fixen ze het met de volgende driver en laat die niet lang op zich wachten!

Op dit item kan niet meer gereageerd worden.



Apple iOS 10 Google Pixel Apple iPhone 7 Sony PlayStation VR AMD Radeon RX 480 4GB Battlefield 1 Google Android Nougat Watch Dogs 2

© 1998 - 2016 de Persgroep Online Services B.V. Tweakers vormt samen met o.a. Autotrack en Carsom.nl de Persgroep Online Services B.V. Hosting door True