Cookies op Tweakers

Tweakers maakt gebruik van cookies, onder andere om de website te analyseren, het gebruiksgemak te vergroten en advertenties te tonen. Door gebruik te maken van deze website, of door op 'Ga verder' te klikken, geef je toestemming voor het gebruik van cookies. Wil je meer informatie over cookies en hoe ze worden gebruikt, bekijk dan ons cookiebeleid.

Meer informatie

Door , , 30 reacties
Bron: Mozilla, submitter: 4AMD

Zoals gewoonlijk stroomde onze submit-queue weer over van meldingen over een nieuwe Mozilla Firefox-versie. De nieuwe versie draagt volgnummer 2.0.0.6 en biedt een oplossing voor twee beveiligingslekken. De inmiddels beruchte 'cross-browser-bug' zou hiermee tot het verleden moeten behoren. De beknopte lijst met veranderingen ziet er als volgt uit:

Fixed in Firefox 2.0.0.6:
  • MFSA 2007-27 Unescaped URIs passed to external programs
  • MFSA 2007-26 Privilege escalation through chrome-loaded about:blank windows
[break]Mozilla Firefox 2.0.0.6 is in de volgende smaken binnen te halen:
* Linux (Engels - Nederlands)
* Mac OS X (Engels - Nederlands)
* Windows (Engels - Nederlands)
Moderatie-faq Wijzig weergave

Reacties (30)

Het complete changelog is hier te vinden.
This version is not compatible with your Java Console. Firefox can check for a compatible version.

OK

Firefox is unable to find a compatible version. Java is disabled.
Inderdaad! Dat was met voorgaande versie 's ook al zo! Erg irritant. Ligt dat nou aan Java of aan FF zelf? Is er dan zoveel code veranderd dat Java niet meer werkt?
Ligt aan Java. Als je Java 6 update 2 installeert krijg je die melding niet meer. Bovendien blijft java gewoon werken ondanks die melding.
Helaas blijven oude versies van Java ook op je systeem staan, als je update. Firefox klaagt dus over Java 6 update 1, terwijl ik update 2 ook al geinstalleerd heb. Bij Add-remove programs zie je dan meerdere versies van Java staan (heb er al 6 ondertussen). Als je deze melding van Firefox kwijt wil, dan moet je denk ik alle oude Java versies verwijderen. Dit gaat niet automatisch met het updaten van Java.
Yep, je moet update 6.1 helaas even handmatig verwijderen via configuratiescherm-programma's. Ik snap ook niet waarom Java dat zelf niet even doet tijdens het updaten, maar goed....ik snap wel meer niet ;)

Java blijft ondanks de melding van Firefox gewoon werken hoor, net weer even getest met deze nieuwe update.

[Reactie gewijzigd door Storm316 op 31 juli 2007 17:57]

De oude java versies schijnen te blijven staan wegens compatibiliteitsredenen. Net zoals je bijvoorbeeld van het .NET framework ook 1.1, 2.0 en 3.0 op je computer zult hebben (indien je Windows hebt natuurlijk). Software geschreven voor v1 werkt soms niet op v2. Java heeft hetzelfde probleem, maar daar zijn inmiddels 6 versies uit die ook elk weer een lading updates krijgen (tot 11 aan toe voor v5), die stuk voor stuk heel wat schijfruimte wegsnoepen. Heeft MS het toch beter voor elkaar met .NET waar 1.1 versie 1.0 heeft vervangen :P
Is gewoon een kwestie van backwards compatiblity hoor.
Bekend probleem. By the way, Java is niet disabled, de menu optie om vanuit Firefox de Java console op te roepen is niet meer aanwezig. Je kunt -als je dat wilt- nog steeds de console via het icoontje in de system tray (of via Configuratiescherm --> Java --> Advanced --> Java Console --> Show Console) oproepen.
Toch werken sites met Java Applets niet meer....

In IE en Opera wel.

Dus hoef ik niets aan FF aan te passen, gewoon niet gebruiken als ik een site met Java tegenkom... Of nog makkelijker, helemaal niet gebruiken.
Gebruik je toch IE tab?
Het lijkt wel of FF trager is geworden na de update. Ligt dit aan mij of hebben meer mensen hier last van?
Nergens last van, geheugengebruik is echter bij mij wel toegenomen :/ ..
Op deze pagina en alleen deze tab en geen andere sessies gebruikt 2.0.0.6 bij mij minder dan 34MB. Dit is zonder enige flashbanner of Google ad.
Lol ... ik heb daarnet 2.0.0.5 met Ubuntu binnen gekregen en er is al weer een nieuwe. *zucht*
Klopt, de Ubuntu repo is over het algemeen wat laat daarmee. Ik ben een Wine-tester en ik haal altijd handmatig de debs van de site van Wine want Ubuntu laat me wachten. 2.0.0.6 komt in de loop van de week nog wel een keer aanzetten.
Klopt, de Ubuntu repo is over het algemeen wat laat daarmee.
Wat dat betreft is Debian nog erger.

Heel soms ( ;) ) heeft een Windows bak toch wel haar voordelen; zonder al te veel gedoe kun je wel altijd overal de nieuwste versies van downloaden en gebruiken. Alles in je systeem automatisch updaten is dan wel weer een heel ander verhaal natuurlijk, maar het gewone installeren van specifieke software is in Windows dikwijls toch handiger.
@flowerp. Debian is dan in de eerste instantie ook niet voor desktop gebruik bedoeld (hoewel de doelstelling de laatste jaren wel aan het verschuiven is).

Debian wordt voornamelijk op servers gebruikt. Zoals je vast wel hebt gelezen hebben enkele gebruikers nu 'problemen' met java. Enig idee wat de gevolgen zouden zij dat als Debian MySQl zou updaten naar de 5.x releases. Dan zouden ineens een heleboel websites niet meer werken.

Een Debian release moet je dan eigenlijk ook niet zien als een release maar eerder als een snapshot. Debian developers zullen gedurende enkele jaren alle binaires binary compatible houden en enkel de bugs welke de door debian gehanteerde versie treft updaten. Extra functionaliteiten die met latere releases van datprogramma beschrikbaarkomen, worden echter niet meegenomen.

Dat betekend dat een website 4 jaar gelden geschreven gewoon nog steeds zonder aanpassingen werkt op de laatse release van debian Sarge. Wil je nieuwere functionaliteit? Dan zul je moeten updaten naar Debian Etch. Maar dan neem jij zelf het risico dat jouw website niet meer werkt.

Waar Debian aan de ene kant van het specturm zit, zit Gentoo juist weer aan de andere kant. Gentoo is een echte cutting-egde distro en als je weinig kennis hebt van portage is het zeer lastig om nieuwere releases niet via emerge te laten updaten. De meeste distrozitten een beetje in het midden: De meeste distro's hebben na een kleine week wel een update voor hun distro klaar staan. Immers alle releases moeten ook doorgrondig worden getest.

Nog als laatste puntje: De vergelijking met Windows gaat toch ook niet helemaal op. Via Windows Update worden alleen de Microsoft programma's geupdate, maar niet Firefox, Winzip, Acrobat. of OpenOffice. Terwijl als een website deb packages ter beschikking stelt, deze eenvoudig meegenomen kunnen worden via apt-get.
vraag me alleen wel af waarom je als je klaar bent met updaten steeds die mogelijkheid voor het NL woordenboek krijgt, als je die allang hebt.
Controleer maar eens of je hem wel echt hebt, dan. Bij mij mislukte de update steeds tot ik hem handmatig deed.
Ook binnen te halen dmv update.

wil niet bashen, maar daarom gebruik ik Firefox. Indien er een ernstige bug is, komt er snel een oplossing ervoor! Dat kan ik niet van IE zeggen.

[Reactie gewijzigd door vr6-only op 31 juli 2007 15:38]

Dat probleem met Java is op te lossen door te updaten naar versie 1.6.0.02.
Ik had'm al gepushed gekregen; werkt mooi dat systeem :)

[Reactie gewijzigd door Swaptor op 31 juli 2007 15:41]

Geweldig systeem, ik heb al twee keer een melding gekregen en al twee keer op "restart firefox" gedrukt, maar helemaal niks. Als ik em zelf dan handmatig nog eens op start krijg ik weer een update melding.
Heerlijk systeem :r
Klinkt een beetje alsof je installatie defect is of dat je een extension geinstalleerd hebt die niet goed samen werkt met de huidige versie van Firefox.

Persoonlijk zou ik Firefox even helemaal opnieuw installeren, dus ook je profile weggooien en opnieuw aanmaken

(profile staat in c:/Documents and Settings/username/Application Data/Mozilla/Firefox/Profiles/ - in het geval van een windows installatie dan..)
idd hier (op het werk, notebook) ook geen probleem... thuis zal ie ook wel melding geven, alleen ben nog niet thuis dus.
bij de update naar 2.0.0.5 kreeg ik mijn sessie weer terug na het herstarten, deze keer niet, jammer
hmm, ik had mijn sessies wel terug, echter heel soms gebeurt dit niet (gewoon na opnieuw opstarten bedoel ik dan) dus misschien had je gewoon pech.

je kan wel altijd via het geschiedenis menu naar onlangs gesloten tabbladen gaan en ze daar weer open.

Op dit item kan niet meer gereageerd worden.



Apple iOS 10 Google Pixel Apple iPhone 7 Sony PlayStation VR AMD Radeon RX 480 4GB Battlefield 1 Google Android Nougat Watch Dogs 2

© 1998 - 2016 de Persgroep Online Services B.V. Tweakers vormt samen met o.a. Autotrack en Carsom.nl de Persgroep Online Services B.V. Hosting door True