Cookies op Tweakers

Tweakers maakt gebruik van cookies, onder andere om de website te analyseren, het gebruiksgemak te vergroten en advertenties te tonen. Door gebruik te maken van deze website, of door op 'Ga verder' te klikken, geef je toestemming voor het gebruik van cookies. Wil je meer informatie over cookies en hoe ze worden gebruikt, bekijk dan ons cookiebeleid.

Meer informatie

Door , , 12 reacties
Bron: Linux hardware, submitter: thunderbird2k

Vandaag is de tweede bta van versie 0.8 van NVClock uitgekomen, een Linuxprogramma waarmee videokaarten van nVidia onder Linux en FreeBSD getweaked en overklokt kunnen worden. Het is gebaseerd op het programma nvcs, maar is inmiddels flink verbouwd. Zo is het gebruikersvriendelijker en kan het beter overweg met de verschillende Linux-distributies. In deze nieuwe versie zijn diverse bugs gefixed en is verder ondersteuning voor de nieuwe Geforce7 kaarten toegevoegd. Het volledige changelog ziet er als volgt uit:

Changes in this release:
  • Geforce 7300/7600/7800GS/7900 support
  • Smartdimmer suppport for 7600Go laptops
  • Fanspeed adjustment support for 7600/7800GS/7900 cards
  • Support for ADT7473/W83781D sensors
  • PCI id modding support (Quadro faking)
  • Temperature reading fixes for internal sensor
  • Fanspeed adjustment fixes for NV3x/NV4x boards
  • Pipeline modding fixes
  • Bios parsing fixes
  • Improved (experimental) lowlevel overclocking / clock reading for NV4x/ G7x boards
  • Added temperature (-T) switch to nvclock cli
  • Adjusted -F / -S switch to support incremental fanspeed/smartdimmmer values
  • Added PCI-Express info reading
  • Rewritten core backend
[break]
NVClock 0.8 beta 2 screenshot (resized)
Versienummer:0.8 beta 2
Besturingssystemen:Linux, BSD
Website:Linux hardware
Download:http://www.linuxhardware.org/nvclock/nvclock0.8b2.tar.gz
Bestandsgrootte:309,00KB
Licentietype:GPL
Moderatie-faq Wijzig weergave

Reacties (12)

Dit is eigenlijk ook wel een hele leuke tool voor Windows, als je onder Windows pipelines wilt unlocken ben je gebonden aan Rivatuner, maar die heeft zoveel opties welke je vaak niet eens wilt gebruiken.
Nvclock op zich werkt ook op linux, maar standaard lever ik deze versie niet. De versie is vooral voor debug doeleinden. Pipeline unlocking moet gedaan worden voordat de video driver geladen is. Onder linux is dat geen probleem, maar op windows heb je daar een driver voor nodig. Dat is ook precies wat rivatuner doet voor pipeline unlocken.
Welke files zijn nodig om de Qt interface te compileren?

edit: wel leuk om dit weg te modden maar ik denk dat een hoop mensen dit wel willen weten, ik heb alle libqt-devel pakketten geinstalleerd maar nog steeds lukt het niet....
Standaard is de qt versie uitgeschakeld, omdat deze niet helemaal recent is. Waarschijnlijk zal ik de qt versie zelfs verwijderen. Gebruik de gtk-versie aangezien deze veel geavanceerder is dan de qt-versie.
Hoi thunderbird,
Ik heb zowel Ubuntu als Mandriva en nvclock via hun repos geinstalleerd, op beide doet de gtk versie het niet, en ook niet de vers gecompileerde (op Mandriva). Vectrox, denkt misschien een wijsneus te zijn met zij RTFM opmerking, ik kan echter niets vinden in de configure en handleiding om Qt compilatie aan te zetten....
Okay, nou is het wel gelukt en heb ik ook een qt versie en ben ik erachter dat je als root moet runnen anders geeft de GTK versie een segmentation fault (terwijl de Qt versie gewoon een error po-pup window geeft).


In de Qt versie zit trouwens een handige manier om xorg.conf voor dualview te configureren, die zit niet in de GTK versie, jammer :'(

(hopelijk word ik niet weer weggemod en kunnen zo meer mensen hier gebruik van maken, top progje verder)
Waarschijnlijk heb je niet alle gtk2 ontwikkelpakketten geinstalleerd. Ik weet niet precies hoe die op jouw distributie heten, maar dat is denk ik waarom de GTK versie niet wil compileren.

Als je de QT-versie aan wilt zetten moet je '--enable-qt' gebruiken, maar het bouwen van de QT-versie is nog veel lastiger, mdat het lastig is om QT te detecteren.
hier nog even de output wanneer de gtk versie opgestart wordt niet als root:

$ nvclock_gtk

(process:20436): GLib-GObject-CRITICAL **: gtype.c:2240: initialization assertion failed, use IA__g_type_init() prior to this function

(process:20436): GLib-GObject-CRITICAL **: gtype.c:2240: initialization assertion failed, use IA__g_type_init() prior to this function

(process:20436): GLib-GObject-CRITICAL **: gtype.c:2240: initialization assertion failed, use IA__g_type_init() prior to this function

(process:20436): GLib-GObject-CRITICAL **: gtype.c:2240: initialization assertion failed, use IA__g_type_init() prior to this function

(process:20436): GLib-GObject-CRITICAL **: g_type_add_interface_static: assertion `G_TYPE_IS_INSTANTIATABLE (instance_type)' failed

(process:20436): GLib-GObject-CRITICAL **: gtype.c:2240: initialization assertion failed, use IA__g_type_init() prior to this function

(process:20436): GLib-GObject-CRITICAL **: gtype.c:2240: initialization assertion failed, use IA__g_type_init() prior to this function

(process:20436): GLib-GObject-CRITICAL **: gtype.c:2240: initialization assertion failed, use IA__g_type_init() prior to this function

(process:20436): GLib-GObject-CRITICAL **: gtype.c:2240: initialization assertion failed, use IA__g_type_init() prior to this function

(process:20436): GLib-GObject-CRITICAL **: gtype.c:2240: initialization assertion failed, use IA__g_type_init() prior to this function

(process:20436): GLib-GObject-CRITICAL **: g_object_new: assertion `G_TYPE_IS_OBJECT (object_type)' failed
Segmentation fault
Yikes .. op wat voor een systeem is dit precies? Verder zou root niet per se vereist moeten zijn..
Mandriva 2007 (ja ik weet dat is nog beta). Ik zal het ook nog eens in Ubuntu proberen. Trouwens bij de vorige crashte zowel in Ubuntu als Mandriva de gtk versie (segmentation) fault. Ik had die versies niet eens zelf gecompileerd maar gedownload van de distro repos.
http://www.google.nl

Anders bekijk je even wat de console zegt als je hem wilt compileren.

Tsja ik weet een RTFM opmerking |:(
Wie heeft jou nou behulpzaam heeft gegeven |:(

Op dit item kan niet meer gereageerd worden.



Apple iOS 10 Google Pixel Apple iPhone 7 Sony PlayStation VR AMD Radeon RX 480 4GB Battlefield 1 Google Android Nougat Watch Dogs 2

© 1998 - 2016 de Persgroep Online Services B.V. Tweakers vormt samen met o.a. Autotrack en Carsom.nl de Persgroep Online Services B.V. Hosting door True