Cookies op Tweakers

Tweakers maakt gebruik van cookies, onder andere om de website te analyseren, het gebruiksgemak te vergroten en advertenties te tonen. Door gebruik te maken van deze website, of door op 'Ga verder' te klikken, geef je toestemming voor het gebruik van cookies. Wil je meer informatie over cookies en hoe ze worden gebruikt, bekijk dan ons cookiebeleid.

Meer informatie

Door , , 25 reacties
Bron: ATi, submitter: Jejking

ATi logo (kleiner) ATi heeft gisteren nieuwe display drivers voor Linux uitgebracht. Ze kunnen hun werk doen op alle kaarten vanaf de Radeon 8500 en zijn beschikbaar voor een 32-bits en 64-bits omgeving als closedsource-driver. Deze driver voegt naast ondersteuning voor een aantal nieuwe kaarten uit de X800- en X850-serie ook verbeteringen met betrekking tot OpenGL 2.0 toe en maakt Full Scene Anti-Aliasing mogelijk. Het volledige changelog ziet er als volgt uit:

New Features
  • New Product Support
    • ATI Radeon X850 XT Platinum Edition
    • ATI Radeon X850 XT
    • ATI Radeon X850 SE
    • ATI Radeon X850 PRO
    • ATI Radeon X800 SE
    • ATI Radeon X800 VE
    • ATI Radeon X800 GT
    • ATI Radeon X800 GTO
    • ATI Mobility Radeon X800
  • OpenGL 2.0 Enhancement
  • Full Scene Anti-Aliasing Support
Known Issues
  • Attempting to install the driver on distributions that have updated certain 3D components outside of the stock XOrg 6.8.2 may result in the driver not initializing 3D applications properly.
  • TV Display is Corrupt After Switching Resolutions.
  • Running two X servers simultaneously results in the system failing to respond.
[break]De volgende downloads zijn beschikbaar:
*ATI Driver Installer version 8.23.7 for Linux x86
*ATI Driver Installer version 8.23.7 for Linux x86_64[break]
ATi X850 XT
De ATi Radeon X850 XT wordt nu ook ondersteund.

Lees meer over

Versienummer:8.23.7
Besturingssystemen:Linux, Linux AMD64
Website:ATi
Download:https://support.ati.com/ics/support/default.asp?deptID=894&task=knowledge&folderID=300
Bestandsgrootte:32,80MB
Licentietype:Voorwaarden (GNU/BSD/etc.)
Moderatie-faq Wijzig weergave

Reacties (25)

Ik vrees ervoor dat deze driver weeral geen merkwaardige veranderingen zal brengen. Alleen maar de ondersteuning voor de nieuwe kaarten. Echt jammer dat ATI niet zo'n driver support heeft voor Linux als nVidia.
Ik vind dat ze toch aardig bezig zijn. Het is toch een aardige verbetering weer, aangezien de laatste driver maar 1 maand geleden was.

Bovendien zul je wat beter moeten lezen, aangezien er nog 2 punten bijstaan. Verbeterde support voor OpenGL 2.0 en FSAA support. Vooral het laastste is erg prettig natuurlijk.

Ik geef toe dat ze niet bepaald voorlopen, maar ze doen aardig hun best om de schade in te halen.
De 'known issues' die hier vermeld zijn, herinner ik mij al van *tig vorige versies, waar dus nog steeds geen verbetering in zit.

Heb net Arch Linux geinstalleerd, en deze komt standaard met Xorg 7.0, zodat deze driver voor mij niets kan betekenen tenzij ik Xorg downgrade naar 6.8.2...

Persoonlijk vind ik dit tijdverlies van Ati. Ofwel doe je het zelf en doe je het goed, ofwel doe je het niet en maak je (delen van) de broncode openbaar.
Archlinux levert sindskort ook de ATI drivers mee via de "Extra" repository. Deze werken redelijk, alleen vanmorgen mocht ik downgrade naar 8.22.5 omdat ik niets anders dan een zwart scherm kreeg na het upgraden naar deze versie.
Ik heb die twee punten gelezen, maar veel kan je er niet van verwachten.

Wat die FSAA betreft: Als je gaat gamen met hoge instellingen zoals FSAA dan ga je automatisch naar Windows overstappen.
waarom? ik zie de reden niet. Ik kan perfect "hoge instellingen" gamen onder linux daar heb ik windows echt niet voor nodig.
Echt jammer dat ATI niet zo'n driver support heeft voor Linux als nVidia.
je moet je wel realizeren dat Nvidia alleen goede linux driver support heeft vanwegen hun profesionele quadro serie (die dus veel in unix en linux omgevingen worden gebruikt icm openGL), en niet omdat ze zulke fanatieke linux aanhangers zijn of uit de goedheid van hun hart.

ATI heeft niet echt zoiets, en hun chips vind je wel in server waar linux op gedraaied word maar dan is het eigenlijk altijd een rage kaart/chip die er alleen inzit zodat je er eventueel een monitor aan kan hangen, en niet vanwegen de 3d prestaties.

ik vind het dus wel goed van ATI dat ze, ondanks dat er misschien niet veel geld mee valt te verdienen toch investeren in de linux drivers.

p.s. onder ubuntu installeren de drivers prima trouwens en als je ze installerd met apt-get werken ze eigenlijk meteen out of the box.
Helemaal mee eens dat ATi op de goede weg is. Een jaar terug was ATi geen serieuze keus als je Linux wilde gaan draaien, nu beginnen de drivers op niveau te komen van wat ik lees.
Feit is echter dat ik de aankoop van mijn laptop (vorig jaar) heb uitgesteld tot ik er een vond met een nVidia grafische chip erin. Puur omdat ik dan zeker wist dat het zou werken. Of ze deze drivers nou uit hun liefde voor Linux creeeeren of omdat het noodzakelijk kwaad is, ze zijn wel top. En ik vind dat nVidia daar best een puntje voor verdient.
Nu nog support voor videokaarten die al een half jaar op de markt zijn, en weer wat meer mensen zijn blij. (De X1x00 wordt helemaal nog niet ondersteund, daar zit de nieuwe r500 (en hoger) chip in).

Wel jammer dat er zo weinig notebooks met nvidia chips zijn, daar voel je je als consument een heel stuk serieuzer genomen.
Is ook een kwestie van de juiste notebook kiezen. Ik heb m'n notebook specifiek uitgekozen op een nvidia chip, ik moet echt geen ATI in m'n linux systemen...
Dan heb je dus de keuze tussen twee notebooks, en er zijn mogelijk nog andere criteria waarop je je keuze voor een 2k EUR stukje hardware baseert dan enkel de videochip die erinzit.

Je kunt wel mooi roepen "Dan kies je toch een andere!!!!!!!!!!11111111111111", maar in de praktijk ziet het er helaas anders uit.
Pardon? Alleen Asus heeft er al 3 in de business serie. Dat valt echt reuze mee hoor.
daar voel je je als consument een heel stuk serieuzer genomen.
als consument? nvidia linux support heeft weinig met consumenten te maken anders. ze ondersteunen de quadro serie van kaarten in linux, en dat dat toevallig ook redelijk goed werkt op de normale kaarten is mooi mee genomen.
Waar heeft dat niets met consumenten te maken? Als ik hun kaart koop en gebruik (= ik consumeer hun product) dan heeft dat weldegelijk met consument, en het serieus nemen daarvan te maken.

Of begrijp ik gewoon niet wat je wilde zeggen? :?
weet iemand waarom ze de drivers niet gewoon open-source maken (of in iedergeval gedeeltelijk). Dat zou meteen een heel stuk schelen
omdat volgens hun de concurrentie daar teveel handige informatie uit kan halen over de hoe de hardware in elkaar zit, of zoiets...

* 786562 kozue
zoals kozue al zei, zodat ze de concurentie geen waardevollen informatie geven.
maar ook omdat een deel van de drivers niet van hun is om vrij te mogen geven.
bijvoorbeeld delen van de drivers die delen op de chip aansturen die ze van 3d partijen hebben gekocht.
maar ook bepaalde graphice formules waar patent en/of copy right op zit en/of andere licenties op van toepassing zijn.

als ze 100% opensource drivers zouden willen maken voor hun hardware zouden van de grond af aan opnieuw moeten beginnen waarschijnlijk, en zou uiteindelijk de preformance (een stuk) lager zijn als dat nu het geval is.
als het al kan überhaupt.
In tegenstelling tot wat de neergemodde heren beweren werken huidige en zullen waarschijnlijk ook deze drivers al perfect werken met XGL, k'heb het zelf draaiende gehad en het liep enorm smooth en alle plugins werkten zonder problemen.

Ik liet gisteren XGL zien op m'n stageplaats en k'moet zeggen dat ze toch best allemaal onder de indruk waren, zelfs de vrouw van de baas :)
Nee, Xgl heeft ondersteuning nodig voor bepaalde opengl extensies, en zowel nvidia als ati hebben die nog niet geimplementeerd.
o, echt waar?
Waar haal je die wijsheid vandaan, geef eens een link, of noem er eens een paar :S
Want ik heb toch echt XGL aan het draaien, op mijn ATi Radeon 9600 Mobility (M10) :+
Ik spreek uit ervaring, heb al eens Xgl geprobeert te installeren op m'n notebook met nvidia gfx. Xgl vertikte het om te draaien, en gaf een melding dat mijn gl libraries iets niet ondersteunden.
Er zijn tutorials voor, je kan het voor elkaar krijgen door voor de Xgl server de mesa libraries te gebruiken, en voor je games de nvidia (hw accelerated) libs, maar dat vond ik teveel gekloot, en heb dat maar laten zitten...
Nou ik ken anders aardig wat mensen op droplinegnome.org die de test packages voor GNOME 2.14 draaien ... waar dus ook XGL in zit.

Zowel op een ATi als een Nvidia chipset en daarbij ... de nvidia drivers zijn veel beter hierin, de ATi drivers schijnen nog af en toe glitches te hebben.
Ik heb vandaag de Kororaa LiveCD (http://kororaa.org/index.html) gedownload. Mijn Radeon 9800pro doet het daar prima op, alhoewel ik het niet heb onderworpen aan een stresstest.

Op dit item kan niet meer gereageerd worden.



Apple iOS 10 Google Pixel Apple iPhone 7 Sony PlayStation VR AMD Radeon RX 480 4GB Battlefield 1 Google Android Nougat Watch Dogs 2

© 1998 - 2016 de Persgroep Online Services B.V. Tweakers vormt samen met o.a. Autotrack en Carsom.nl de Persgroep Online Services B.V. Hosting door True