Cookies op Tweakers

Tweakers maakt gebruik van cookies, onder andere om de website te analyseren, het gebruiksgemak te vergroten en advertenties te tonen. Door gebruik te maken van deze website, of door op 'Ga verder' te klikken, geef je toestemming voor het gebruik van cookies. Wil je meer informatie over cookies en hoe ze worden gebruikt, bekijk dan ons cookiebeleid.

Meer informatie

Door , , 17 reacties
Bron: WAMPServer, submitter: accel

Om snel en eenvoudig een PHP 5 en MySQL 5 ontwikkelomgeving op te zetten kan je gebruik maken van WAMP5 voor Windows NT, 2000, XP en Server 2003. Het installeert Apache, PHP 5.1.0, SQLitemanager, MySQL 5.0.16 en phpMyAdmin in een aparte directory waardoor conflicten met andere installaties niet voor mogen komen. Apache 1.3.31 wordt standaard ge´nstalleerd maar met behulp van addons kan er ook gebruik worden gemaakt van Apache 2.0.55. Alle services zijn na de installatie via een icoon in de systemtray te beheren. WAMP5 1.4.6 is sinds kort beschikbaar met de volgende aanpassingen:

Version 1.4.6:
  • Now using PHP 5.1.0
  • Now using MySQL 5.0.16
  • Now using phpmyadmin 2.6.4-pl4
  • Now using sqlitemanager 1.1.3
  • Modified index.php page
Version 1.4.5a:
  • desactivated eacccelerator in the php.ini file by default
Versienummer:1.4.6
Besturingssystemen:Windows NT, Windows 2000, Windows XP, Windows Server 2003
Website:WAMPServer
Download:http://prdownloads.sourceforge.net/wampserver/wamp5_1.4.6.exe?download
Bestandsgrootte:23,77MB
Licentietype:GPL
Moderatie-faq Wijzig weergave

Reacties (17)

Apache 1?
Is dit bedoeld voor de vorige eeuw?
Ja, vraag me dat ook altijd nog af. Waarom gebruiken mensen nog Apache 1 terwijl 2 allang uit is en bewezen stabiel is?

Zelfde als met PHP. Veel mensen en zelfs hosting providers gebruiken nog PHP 4.x. Snap ook niet waarom dat nog gebruikt wordt. Voor sommige sites snap ik het nog, vanwege backwards compatibility, maar niet als de site nog gebouwd moet worden.

Klopt ook niet helemaal met de andere software. Van bijna elk onderdeel wat erbij zit is een vrij nieuwe versie en van Apache is het nog steeds uit de 1 serie.
Waarom gebruiken mensen een fiets als een bromfiets sneller gaat? :Z
Omdat een bromfiets duurder is en lawaai maakt :?
De reden dat PHP 4 nog zoveel gebruikt wordt bij hosting providers, is dat er voor PHP 5 (nog) geen PHP Accelerator bestaat... Die wordt door hosting providers veel gebruikt om minder belasting op de servers te hebben.
Veel mensen en zelfs hosting providers gebruiken nog PHP 4.x.
PHP 5 is volgens mij veel jonger dan Apache 2.
Ik hoor verhalen dat de PHP ondersteuning in Apache 2.x nog niet perfect zou zijn, al heb ik er zelf totaal geen last van en vraag me ook af waarom sommige nogsteeds blijfen hakkelen op de 1.x reeks.
Sommige PHP extensies zijn niet thread-safe, een vereiste voor Apache 2, welke standaard met threads werkt ipv processes. Als je de betrokken extensies niet gebruikt is er in principe geen probleem.
Sommige PHP extensies zijn niet thread-safe
Ah, vergeten, dat zal inderdaad een reden zijn. PHP zelf is ook niet echt safe in een threaded omgeving.
En aangezien PHP standaard niet in een los proces draait (geen CGI natuurlijk maar iets als FastCGI) kan Apache dan ook niet threaded draaien.
Het gebeurt veel dat voor grote toepassingen en dergelijke oudere, maar stabielere versies, van programmas worden gebruikt.

Zo wordt ook de vorige versie van Linux-kernel nog verder geupdated terwijl er allang een nieuwe is.

Voor bedrijven ed. is een overstap soms minder vanzelfsprekend en gemakkelijk.

Ik snap wel ergens je standpunt aangezien bedrijven ook eerder zelf apache enzovoort installeren en geen samengesteld pakket gebruiken.
Voor bedrijven ed. is een overstap soms minder vanzelfsprekend en gemakkelijk.
En dan wel de nog geen maand oude PHP includen?
Apache1 draait nog steeds overal stabiel op, kan met de laatste versies van php draaien, en de laatste veiligheidspatches komen er nog voor uit. Zou niet weten wat daar dus vorige eeuw van is.
Hier is de rede heel simpel:

apache 2 heeft bij mij een enorme memory leak. Binnen een menuutje of 3 gebruikt het meer dan 600 MB geheugen (lijkt me een beetje veel voor een simpel testservertje waar niemand opkomt). Ik heb het al eens gemeld, dr lijkt alleen weinig mee gedaan...
Is dit even veilig te krijgen als een losse installatie van al deze programma's? Dus op een gewone huis, tuin en keuken server?'

Of ben je dan toch echt gebonden aan het los configureren van deze programma's.
Dit soort installs zijn meer bedoeld voor test omgevingen, dus voor bijvoorbeeld een ontwikkelaar.

Wil je productie draaien, ga je toch instellingen aanpassen om te optimaliseren voor jou site. Dit doe je dus op eigen installaties, maar dit soort pakketjes zou ik er niet voor durven te gebruiken.
super handig programma als je gewoon wilt ontwikkelen en geen zin hebt om de boel in te stellen. Werkt allemaal erg netjes.
btw met een extra add-on kan je ook gewoon PHP4 draaien/testen. Wel handig omdat veel host's nog PHP4 draaien
Heel erg handig programma maar het is helaas niet heel erg uitgebreid. Er is nog zo'n programma en dat heet Xampp. En Xampp heeft net iets meer aan boord zoals een mail server, php5 en php4, ftp server en al dat soort dingen :). Maar voor gewoon ontwikkelen van PHP scripts is Wamp wel makkelijk en het kost niet veel ruimte :)

Op dit item kan niet meer gereageerd worden.



Apple iOS 10 Google Pixel Apple iPhone 7 Sony PlayStation VR AMD Radeon RX 480 4GB Battlefield 1 Google Android Nougat Watch Dogs 2

© 1998 - 2016 de Persgroep Online Services B.V. Tweakers vormt samen met o.a. Autotrack en Carsom.nl de Persgroep Online Services B.V. Hosting door True