Cookies op Tweakers

Tweakers maakt gebruik van cookies, onder andere om de website te analyseren, het gebruiksgemak te vergroten en advertenties te tonen. Door gebruik te maken van deze website, of door op 'Ga verder' te klikken, geef je toestemming voor het gebruik van cookies. Wil je meer informatie over cookies en hoe ze worden gebruikt, bekijk dan ons cookiebeleid.

Meer informatie

Software-update: Mozilla Firefox 66.0.4

Mozilla Firefox 2017 logo (75 pix) Mozilla heeft een update voor versie 66 van zijn webbrowser Firefox uitgebracht, de tiende versie gebaseerd op Firefox Quantum. De browser heeft met Quantum niet alleen een nieuw uiterlijk en logo gekregen, ook onder de motorkap is er veel veranderd. Zo zijn de prestaties van de browser engine flink verbeterd, zijn de zoek- en adresbalk gecombineerd en is er veel aan de beveiliging gesleuteld. Als een gevolg daarvan worden zogenaamde legacy extensies niet meer ondersteund. In versie 66.0.4 zijn de problemen met de uitgeschakelde add-ons verholpen.

Fixed in Firefox 66.0.4

De volgende downloads zijn beschikbaar:
*Mozilla Firefox 66.0.4 voor Windows (32bit, Nederlands)
*Mozilla Firefox 66.0.4 voor Windows (64bit, Nederlands)
*Mozilla Firefox 66.0.4 voor Linux (32bit, Nederlands)
*Mozilla Firefox 66.0.4 voor Linux (64bit, Nederlands)
*Mozilla Firefox 66.0.4 voor macOS (Nederlands)
*Mozilla Firefox 66.0.4 voor Windows (32bit, Engels)
*Mozilla Firefox 66.0.4 voor Windows (64bit, Engels)
*Mozilla Firefox 66.0.4 voor Linux (32bit, Engels)
*Mozilla Firefox 66.0.4 voor Linux (64bit, Engels)
*Mozilla Firefox 66.0.4 voor macOS (Engels)
*Mozilla Firefox 66.0.4 voor Windows (32bit, Fries)
*Mozilla Firefox 66.0.4 voor Windows (64bit, Fries)
*Mozilla Firefox 66.0.4 voor Linux (32bit, Fries)
*Mozilla Firefox 66.0.4 voor Linux (64bit, Fries)
*Mozilla Firefox 66.0.4 voor macOS (Fries)

Versienummer 66.0.4
Releasestatus Final
Besturingssystemen Windows 7, Linux, macOS, Windows Vista, Windows Server 2008, Windows Server 2012, Windows 8, Windows 10, Windows Server 2016
Website Mozilla Foundation
Download https://www.mozilla.com/en-US/firefox/all.html#languages
Licentietype Freeware

Door Bart van Klaveren

Downloads en Best Buy Guide

06-05-2019 • 12:37

38 Linkedin Google+

Submitter: Cyb

Bron: Mozilla Foundation

Reacties (38)

Wijzig sortering
Mocht je na de softwareupdate nog steeds last hebben van het probleem dat de add-ons uitgeschakeld zijn nieuws: Mozilla komt met fix voor problemen uitgeschakelde add-ons Firefox - ... dan kan het misschien komen door een persoonlijk instelling in de user.js en is het misschien een oplossing om handmatig de prefs.js en user.js te verwijderen. Maar het kan zijn dat je dan alsnog alle settings van add-ons kwijt bent.

Krijg je bij het installeren van add-ons de onderstaande foutmelding en heb je een persoonlijke user.js:
Download failed. Please check your connection.
Dan kan het te maken hebben met een user.js instelling, namelijk:
user_pref("security.nocertdb", true);
Door deze setting uit je user.js te verwijderen, je prefs.js te verwijderen en Firefox opnieuw opsarten is het (waarschijnlijk) opgelost.
Ik had eerder een probleem met studies (het vinkje vloog vanzelf uit). Heeft iets met developer-tools te maken.

Voor mijzelf moest ik in about:config app.normandy.enabled op true (de default) zetten, voordat de study wilde aanslaan.

In principe zou 66.0.4 het probleem uberhaupt moeten oplossen.

[Reactie gewijzigd door Keypunchie op 6 mei 2019 14:27]

Blij dat deze er is, maar mag ik het raar vinden dat deze noodfix van een nieuwe versie nog zo lang op zich heeft laten wachten? Het probleem is op vrijdag ontstaan...

Of beter gezegd: waarom eerst die fix via studies en niet meteen 66.0.4?

[Reactie gewijzigd door Keypunchie op 6 mei 2019 12:41]

Omdat die fix via studies een workaround is. Blijkbaar kost het meer werk om een fatsoenlijke fix te maken en dat heeft even geduurd. Bovendien was het weekend, dus dan is waarschijnlijk niet iedereen beschikbaar.
Maar laten we eerlijk zijn. Firefox is toch een browser met bijna 10% marktaandeel over alle browser. Dan heb je het over een tiental miljoen gebruikers. Veel van die gebruikers hebben extensies die ze gebruiken. Een workaround is iets dat niet tweakers niet kennen en daar kunn je niet van verwachten dat ze er iets mee doen.
Dus ja het heeft naar mijn mening toch echt lang op zich laten wachten en voor mij heeft firefox (die ik dagelijks gebruik) toch een deuk opgelopen.
Dan heb je het over een tiental miljoen gebruikers.
Maak daar maar een paar honderd miljoen van.

Er zijn zo’n 4,5 miljard internetgebruikers. Stel dat die 10% juist is (waar ik mijn vraagtekens bij heb, het zou best de helft of het dubbele kunnen zijn) dan zou je het over 450 miljoen Firefox gebruikers hebben.
De grote vraag is of beide bronnen wel zo betrouwbaar zijn. Er zijn bij beiden grote vraagtekens te zetten omtrent de methodiek omdat ze enorm moeten extrapoleren uit een betrekkelijk kleine hoeveelheid data.

Zelfs partijen als Google of Facebook, wiens servers miljarden mensen bezoeken, zullen geen goed beeld kunnen krijgen omdat zij amper penetratie hebben in sommige delen van de wereld. Laat staan dat partijen als NetMarketshare, die maar een fractie van de data hebben, een betrouwbaar beeld kunnen ontwikkelen. Ze moeten aanname op aanname stapelen.

De enige die een enigszins betrouwbaar beeld kan hebben is Mozilla zelf. Een groot deel van de geopende Firefox browsers zal regelmatig kijken of er een update is. Dat is de enige bron van absolute data, je krijgt een exact getal als 'afgelopen maand hebben 204.542.872 unieke browsers gecheckt of er een update was'. Niet alle installaties zullen dat standaard aan hebben staan (bijvoorbeeld omdat ze met een Linux distro mee komen of omdat iemand dat uit heeft gezet) dus je zult alsnog een schatting moeten maken hoe groot dat percentage is en dat dan extrapoleren vanaf die 204.542.872.

Dit alles speelt zich dan ook nog eens af tegen een snel groeiende groep internetgebruikers. 10% marktaandeel in 2019 zijn veel meer unieke gebruikers dan 30% marktaandeel in 2001. En hoeveel internetgebruikers er in totaal zijn is dan ook weer een schatting.

[Reactie gewijzigd door Maurits van Baerle op 6 mei 2019 16:40]

Punt blijft firefox heeft veel heel veel gebruikers, een fout als deze zou met zo veel gebruikers niet hebben mogen gebeuren, laat staan dat het dan nog paar dagen duurt voordat er via auto update een fix komt.
Aan de andere kant werken er ook veel vrijwilligers aan deze browser, daarnaast heb je nog de update die je moet testen en verspreiden. Al-met-al was het denk ik toch niet eerder gelukt om het uit te rollen dan zondag.

Overigens lees ik dat Mozilla het wel aan zichzelf te danken heeft. Van wat ik heb begrepen waren verschillende ontwikkelaars niet erg blij met deze sign oplossing en hadden ze hier al voor gewaarschuwd.
De fix via "studies" was zaterdagavond al gedaan, en gistermiddag versie 66.0.4. Vind ik alles bij elkaar nog vrij snel. ;)
Het betreft een noodmiddel met name voor platformen met een tragere update cycle. Bedenk bijvoorbeeld dat verschillende Linux distributies hun eigen package maintainers hebben. Zo is de nieuwe versie nog niet uit op de Ubuntu repository, maar kunnen gebruikers van Ubuntu wel de hotfix krijgen via studies.
Nee buntu daar noem je ook wat....
hier op opensuse LEAP 15.0 al netjes geupdate en in alle repositories doorgevoerd
In dergelijke onverwachte situaties is de kans reëel dat nog bijkomende problemen opduiken, welke je niet onmiddelijk kan inschatten. De tracking bug 1548973 [first mitigation completed, working on a second one] All extensions disabled due to expiration of intermediate signing cert, heeft ook een klein aantal andere depend bugs tot gevolg gehad: Depends on: 1549106, 1549145, 1549249, 1549305. Vooraleer je daadwerkelijk een nieuwe versie uitbrengt, wil je toch wel iets meer zekerheid dat er niet nog meer onverwachte bugs uit de kast vallen.

Waarom dan wel eerst via studies? Dat was dan wel weer de snelste hotfix, gezien die optie voor de meeste gebruikers by default wel aan staat.
Wellicht is niet overal het uitgeven van een certificaat geautomatiseerd mogelijk en moet dat in sommige gevallen nog met de hand? Of wellicht een validatie van de gegevens van de organisatie voordat een Organization Validated certificaat uitgegeven kon worden?
Je krijgt wel een -1 omdat het wordt opgevat als alu-hoedje comment (daar hebben we er veel van). Maar telemetrie kan wel degelijk voor goede doeleinden gebruikt worden in deze situatie om er voor te zorgen dat de fix niet onverhoopt andere dingen stuk maakt (zoals ook is gebeurt blijkbaar).

Ze weten pas van bugs als het gemeld wordt en sommigen zijn zo specifiek dat ze niet makkelijk gereproduceerd kunnen worden. Of mensen geven veel te weinig info. Dan is het hebben van telemetrie data voor dat doeleinde enorm behulpzaam.

Niet alle telemetrie is evil ;)
Die -1 is vast van een minnaar die het direct negatief opvat, ik gaf geen oordeel.
Data verzamelen is bad mkay ?! ;)
Ik draai 56.0.2 (64bit) komt hier ook nog een update voor of ben je nu verplicht om de laatste versie te downloaden?
Voor 56 zou ik er niet op rekenen. Als je niet wilt upgraden, dan zou je kunnen kijken of downgraden een optie is; misschien komt er wel een fix voor 52 (de ESR)...?
Ik heb inmiddels de nieuwste versie geïnstalleerd, Ik was inderdaad bang dat bepaalde extensies niet zouden werken, maar gelukkig was dit er maar eentje die ik wel kon missen.... Alle problemen zijn nu iig opgelost. :)
Voor ESR 52.9.0 komt geen update meer. In about:config de sleutel xpinstall.signatures.required op false zetten werkt wel.
Normaal gesproken zou je gelijk hebben, maar dit is een uitzondering:
For users who cannot update to the latest version of Firefox or Firefox ESR, we plan to distribute an update that automatically applies the fix to versions 52 through 60. This fix will also be available as a user-installable extension. For anyone still experiencing issues in versions 61 through 65, we plan to distribute a fix through a user-installable extension.
(Die toevoeging is pas 's avonds laat op 8 mei geplaatst, dus na jouw post.)

Ik weet dat dit een nogal late reactie is (ik betwijfel of veel mensen dit nog zullen lezen), maar dan gaat in elk geval de goede informatie het archief in :+ (en alle alu-hoedje theorieën over het opzettelijk laten verlopen van dit certificaat de prullenbak in).
Wat (of welke extensie verwacht ik) is de reden dat je nog 56 gebruikt?
Waarom gebruik je een versie die 1,5 jaar oud is?
Ik neem aan dat je dit doet, omdat je een extensie hebt die nog niet verbouwd is tot webextension? (In 57 zijn ze op Firefox Quantum overgestapt)

In principe wordt 56 niet meer supported. Ik moet eerlijk zeggen, ik was ook heel kritisch, maar intussen al mijn extensies door een acceptabele web-extension kunnen vervangen.

Er zijn telkens maar 2 supported versies: Current Release (nu 66) en ESR (nu 60). Daar kun je bugs voor rapporteren en fixes voor verwachten. Alle andere versies zijn 'at your own risk'.

[Reactie gewijzigd door Keypunchie op 6 mei 2019 15:07]

Deze fix werkt bij mij op 56.0 :) https://www.reddit.com/r/...ddons_fix_for_5602_older/

edit: Ah wacht, je had alsnog geupdate.

[Reactie gewijzigd door Raven op 6 mei 2019 19:01]

Ik draai 67.0b16 (64-bits) en daar zijn alle ongevalideerde plugins (lees alle plugins) nog steeds geflagged als ongevalideerd en staan dus uit. Als de fix wel in 66.0.4 ben ik een beetje lost wat betreft versie beheer en de waarde van een Beta versie.
Ze hebben waarschijnlijk eerst een hotfix gedaan voor versie 66 aangezien daar de meeste mensen op draaien. De fix wordt daarna waarschijnlijk ook in de beta meegenomen (al is daar waarschijnlijk weer extra testen nodig aangezien er andere veranderingen zijn geweest). Je ziet vaak dat ze voor oudere versies alleen bugfixes uitbrengen (minor update; tweede/derde getal) en alleen bij nieuwe versies nieuwe functionaliteit toegevoegd wordt (major update; eerste getal).

Meer info over versies: https://semver.org
Dit is toch wel een major f#ckup van Mozilla als ik het zo mag uitdrukken. Wij als Tweakers begrijpen nog wel enigszins wat er aan de hand is maar het grootste deel van de gebruikers hebben geen idee. Misschien gebruiken die vaak ook geen extensies maar ik installeer bij mijn ouders bijvoorbeeld ook een adblocker.
Hoop drukte bij de tweakers.
De bejaarden konden nog steeds browsen, alleen geen adblockers die de jeugd voor hen erop gezet had.
De meeste senioren vinden reclame leuk.
Ach, weekendje later en het werkt weer. Ze hebben het hier niet eens gemerkt. :)
Het was wat rottiger dat lastpass het ook niet meer deed... Die adblocker kan je wel een dagje zonder (liever niet natuurlijk)
Hoezo, was jave123 niet te onthouden? 8)7
Ur right, er is meer dan adblockers.
Is lastpass een beetje veilig? Heb hier Keepass, maar durf het na voorzichtig proberen nog steeds niet aan om te gaan gebruiken.
Firefox onthoudt ook de passwoorden, of doe jij dat anders?

[Reactie gewijzigd door pe0mot op 6 mei 2019 15:17]

Via precies dat venster, hij triggert automatisch een update als je "about" opent
ja mijn fout, zit op een Mac en dan moet je in de Mac balk naar Firefox, ipv het menu icoontje in Firefox zelf, daar zit wel Help maar About hebben ze daar weggelaten.

Op dit item kan niet meer gereageerd worden.


Apple iPhone 11 Nintendo Switch Lite LG OLED C9 Google Pixel 4 FIFA 20 Samsung Galaxy S10 Sony PlayStation 5 Google

'14 '15 '16 '17 2018

Tweakers vormt samen met Hardware Info, AutoTrack, Gaspedaal.nl, Nationale Vacaturebank, Intermediair en Independer DPG Online Services B.V.
Alle rechten voorbehouden © 1998 - 2019 Hosting door True