Cookies op Tweakers

Tweakers maakt gebruik van cookies, onder andere om de website te analyseren, het gebruiksgemak te vergroten en advertenties te tonen. Door gebruik te maken van deze website, of door op 'Ga verder' te klikken, geef je toestemming voor het gebruik van cookies. Wil je meer informatie over cookies en hoe ze worden gebruikt, bekijk dan ons cookiebeleid.

Meer informatie

Door , , 17 reacties
Bron: Sun, submitter: spil

Sun heeft weer een nieuwe versie van de Java uitgebracht. Dit wist spil ons te vertellen via de changelog bevat weer tal van verbeteringen en foutoplossingen in deze nieuwe versie. Hieronder een korte samenvatting hiervan:

As the first maintenance release to J2SE 1.4.0, over 2000 bug fixes were integrated in J2SE 1.4.1.

Additionally, changes and improvements have been made in the following areas:

Compiler and Class File Format Changes.
Javadoc
AWT
SWING
Java Naming and Directory InterfaceTM API
Networking
RMI
Internationalization
Security
Kerberos Service and DNS Name Lookup

Etc. etc.

Lees meer over

Versienummer:1.4.1
Besturingssystemen:Windows 9x, Windows NT, Windows 2000, Linux, BSD, Windows XP, Linux x86, DOS, Solaris, UNIX
Website:Sun
Download:http://java.sun.com/j2se/1.4.1/download.html
Licentietype:Voorwaarden (GNU/BSD/etc.)
Moderatie-faq Wijzig weergave

Reacties (17)

nu vraag'k me af of 1.4.1 WEL goed applets compileert. Ik heb een halve dag gezocht naar m'n fout dat IE geen class vond, en mozilla wel. compileren met 1.3 op andere PC (je kan al raden wat'k zo nog allemaal geprobeerd heb), en het werkte perfect!!
heeft iemand al getest??

* 786562 voodoochile
[[i]edit voor Shatter[/i]]
Mijn code was samengesteld met functies uit de 1.1(.8) documentatie. Na compileren met 1.3 jdk accepteerde de MS Virtual Machine hem foutloos, waar hij anders moeilijk deed over net dezelfde code gecompileerd door 1.4.
Hij gaf errors dat hij de klasse van mijn applet niet kon vinden. Ik heb nog mensen gehoord met dezelfde problemen
[/edit]
Welke VM gebruikte je in IE? De standaard MS JVM die IE meestal gebruikt is 1.1 compatibel. Sommige zaken zijn in 1.4 veranderd waardoor ze niet meer 1.1 compatibel zijn. Dat verklaart waarom je onder 1.3 gecompileerde applets soms wel onder IE aan de gang kunt krijgen, en niet met 1.4 gecompileerde classes. Gebruik de Java plugin (die standaard in Mozilla gebruikt wordt) en je hebt altijd dezelfde resultaten.
In de IE-settings kun je als je beide geinstalleerd hebt overigens kiezen welke VM je wilt gebruiken.

Girotel werkt bijvoorbeeld alleen met die oude MS-VM. Terwijl je voor alle andere dingen waarschijnlijk gewoon je Sun plugin wilt gebruiken.

Kweet eerlijk gezegd niet in welke IE versies deze keuze mogelijk is, maar onder IE6/XP kan het in ieder geval.
Moet je eerst de Ms Java VM er af gooien voordat je de Sun installeert? Zo ja, iemand een tip hoe dat dan gaat?
Zelf draai ik Windows XP met SP1 (waarin MS Java standaard geinstalleerd/geupdate wordt) en levert het installeren van de Sun Java SDK zonder de MS VM te uninstalleren geheel geen problemen op. Sterker nog, in de geavanceerde Internet-opties komt een extra item "Java (Sun)" erbij waarbij je een vinkje kunt zetten voor "Use Java 2 v.1.4.1 for <applet> (requires restart)". Lachen vind ik wel de tekst op de MS FAQ over hun Java VM:
Should I use Sun's Java virtual machine?
Microsoft is not licensed to distribute Sun's Java virtual machine and has not tested it for error-free operation with Microsoft products.
:D
Ter informatie: Girotel Online van de Postbank werkt met deze versie WEL correct. Bij 1.4.0 kwam er nog een melding dat de applet niet gestart kon worden, maar dat is met deze versie 'verholpen'.
die heeft het bij mij altijd al gedaan :)

ik heb (in xp) alleen af en toe van die applets die vaak updaten/refreshen, en als ik dan het startmenu open doe gaat die schaduw erachter heer irritant staan knipperen...

maar ja, kijken wat ie met deze doet :)
Hmm.. eens proberen dan..

Met 1.4.0 werkt het inderdaad niet. Het bekijken gaat wel, maar bij een betaling uitvoeren krijg je inderdaad foutmeldingen.

Dacht dat het aan het baggere Girotel online lag, maar blijkbaar zat er dus iets fout in de Java-plugin :)
Ontwikkelaars moeten echt even in de changes kijken (http://java.sun.com/j2se/1.4.1/changes.html). Belangrijke bugfixes en verbeteringen.

Weet iemand trouwens wat FCS betekend?
reactie op machiel:
FCS betekent 'First Customer Shipment', een term die volgens mij alleen door Sun gebruikt wordt om een final release mee aan te duiden.

Ik had deze update trouwens twee weken geleden al gepost :?
Euhm ja...installatie verloopt vlekkeloos op win2k.
In Windows XP (zowel met als zonder SP1) loopt de installatie vast bij "creating java JAR files". Het schermpje staat er wel zo mooi, maar verder gebeurd er dus absoluut niks. What gives??
Bij mij heeft java 1.4.1 mijn eerste crash van windowsXP opgeleverd! Ik had versie 1.4.0_1 en had nergens problemen mee.....

dus 1.4.1 gaat er bij mij weer af!
"Zoals we gewend zijn van Sun is het weer voor nagenoeg alle besturingssystemen beschikbaar."

Windows
Windows 64-bit (Itanium)
Linux RPM
Linux 64-bit (Itanium)
SolarisTM SPARCTM 32-bit
Solaris SPARC 64-bit
Solaris x86(Solaris 7, Solaris 8)

Operating Systems: DOS, FreeBSD, Irix, Linux, Linux x86, OpenBSD, Solaris, Windows 2000, Windows 9x, Windows NT, Windows XP

Toch wel een verschilletje.. grappig dat Solaris er *niet* bij staat.
Er is een nieuwe build uitgekomen van Java 2 Runtime Environment Standard Edition 1.4.1. Het downloadadres is hetzelfde gebleven.
vorige week stond deze al in de queue...
deze versie lijkt volgens mij sneller te werken dan de vorige en is nog niet vast gelopen wat de vorige nog wel eens wilde doen..

Op dit item kan niet meer gereageerd worden.



Apple iOS 10 Google Pixel Apple iPhone 7 Sony PlayStation VR AMD Radeon RX 480 4GB Battlefield 1 Google Android Nougat Watch Dogs 2

© 1998 - 2016 de Persgroep Online Services B.V. Tweakers vormt samen met o.a. Autotrack en Carsom.nl de Persgroep Online Services B.V. Hosting door True