Cookies op Tweakers

Tweakers maakt gebruik van cookies, onder andere om de website te analyseren, het gebruiksgemak te vergroten en advertenties te tonen. Door gebruik te maken van deze website, of door op 'Ga verder' te klikken, geef je toestemming voor het gebruik van cookies. Wil je meer informatie over cookies en hoe ze worden gebruikt, bekijk dan ons cookiebeleid.

Meer informatie

Door , , 11 reacties
Bron: UU.net, submitter: Priyantha Bleeker

Priyantha Bleeker FreeBSD 4.x
Linux x86
OpenBSD 3.0

Lees meer over

Versienummer:4.2.1
Besturingssystemen:BSD, Linux x86
Website:UU.net
Download:ftp://ftp.nl.uu.net/pub/XFree86/4.2.1/binaries/
Licentietype:GPL
Moderatie-faq Wijzig weergave

Reacties (11)

Zijn er ook memory leaks uitgehaald? Want soms vreet XFree86 4.2.0 opeens iets van 417 MB RAM, da's een beetje veel :(
Ik heb het idee dat dit meer te maken heeft je WM of andere software die X-resources opvraagt en niet vrijgeeft (dus leakt). Ik heb er namelijk helemaal geen last van.
Is het normaal dat ik met netstat zo'n 200 unix sockets zie? Vast niet eh ? :)
Wat hij bedoelt is dat het wsch. jou ligt dat XFree 4.2.0 bij jou zoveel vreet. Ik draai zelf XFree 4.2.0 met KDE 3.0.3 met 128 MB RAM en iets van 256 MB swap. Draait perfect, hoewel wat aan de krappe kant qua RAM.

Heb je het geprobeerd te debuggen?

PS: OpenBSD 3.0? Gekke versie, we zitten tegenwoordig bij 3.1; 3.0 is enigzins out of date.
[reactie 2 dystopia]
Ja okee, dat het aan mij ligt snapte ik uit zijn reactie. Maar is het normaal dat er 200 unix sockets open staan ofzo (vrijwel allemaal X tot voor zover ik even keek) of heeft de gemiddelde workstation er gewoon maar een paar? Ik draai overigens KDE 3.0.1, maar er draait ook nog wat Gnome-achtig spul zoals Evolution.
KDE is een resource-vreter, het kan best dat die dat doet. Probeer anders Gnome (dus niks van KDE draaien, ook geen KDE-programma's), en kijk wat het verschil is. Nogmaals, het lijkt me sterk dat het door X komt, want release 4.2.0 is behoorlijk lang de meest recente stabiele release geweest, en als het aan X lag, dan waren er in 4.2.1 veel meer dingen veranderd.
Cybje: wat voor distributie is het en hoe is X er op gezet? Zelf gecompiled of via binaries? Het is iig niet normaal dat-ie zoveel RAM en sockets gebruikt. Misschien is het makkelijker om dit op GoT/NOS te bespreken, daar krijg je denk ik meer feedback.

SvMp: sorry maar dat vind ik echt een flame hoor. GNOME is ook net zo goed een resource vreter. Misschien ietsje lichter. Maar wat is de laatste KDE versie die jij hebt geprobeerd dat je dat oordeel veltr? Dat weet Cybje denk ik ookwel dat KDE een limosine is ipv. een kleine simpele sportwagen. Als je een echte lightwight WM kun je eens Fluxbox proberen _bijvoorbeeld_. Da's bijv. leuk op een P1/166 ofzo, waar KDE3.x en GNOME niet lekker op zouden draaien.
Wat ik zou willen weten is of deze nieuwe versie ook een bijgewerkte versie van de Neomagic driver bevat.

Neomagic videochips komen in sommige laptops voor en de versie die met XFree86 versie 2.4.0 werd geleverd zou geen xv ondersteunen, hetgeen een aanzienlijke nadelige invloed heeft op het afspelen van video. :'(

Op de site van Mplayer is een versie met xv-ondersteuning apart te downloaden, maar ik hoop dus dat die verbeterde driver nu ook officieel deel uitmaakt van deze nieuwe versie 2.4.1.

Wie kan mij daar meer over vertellen? :?

Zie de volgende site voor meer info: http://www.mplayerhq.hu/DOCS/video.html#xv_neomagic

Alvast bedankt! :)
De BZ2-file van de Neomagic driver met xv-support die je kunt downloaden, bevat helaas alleen maar een .o-bestand van de driver en geen broncode. Dit maakt het onmogelijk om de driver op te nemen in de orginele XFree86-distributie, aangezien deze open source is en rechtstreeks vanuit een stuk source te compileren moet zijn.

Helaas komt dit probleem vaker voor. Ook bezitters van een kaart met NVidia-chip treffen het niet, omdat de driver die is meegeleverd bij XFree86 geen xv-support heeft. De reden: NVidia geeft niet voldoende informatie om het te implementeren. NVidia levert zelf een driver die het wel kan, maar ook daar is geen source van (alleen van een kernel driver). Op zich is dit voor Linux-gebruikers niet zo'n probleem, maar voor gebruikers van andere Unices, zoals FreeBSD, is het knap irritant, want die zijn aangewezen op de drivers van XFree86 zelf.

Maar voor motown n troost: Waarschijnlijk werkt die driver van jou k gewoon op XFree86-4.2.1. Gewoon proberen dus!
Ik heb nu de nieuwste release XFree86 op een Linux en een FreeBSD-machine draaien.

Afgelopen weekend stond deze versie al op de FTP van XFree, en was er ook gelijk een port van FreeBSD, wat de upgrade voor FreeBSD-gebruikers heel gemakkelijk maakte.

Er is geen complete source van XFree86 4.2.1 direct beschikbaar, maar er is een patch voor de source van XFree86 4.2.0, een veel grotere release. Je hebt de fixes van XFree86 4.2.0 (voor zlib security bug is al veel eerder een fix uitgekomen), die in de loop van de tijd zijn uitgekomen, niet nodig, je kunt gelijk de patch installeren van XFree86 4.2.1, omdat daar alle fixes die voor XFree86 4.2.0 in zijn verwerkt.
Yippie :)
Leuk dat de crew mijn submit heeft geplaats(al is het na 3 dagen maar goed > :) ).
Errug leuk hoor, dat moest ik er ff uit :D

Trouwens ik draai deze versie nu op mijn debian bak, en dat gaat op dit moment helemaal super hoor :)

Op dit item kan niet meer gereageerd worden.



© 1998 - 2016 de Persgroep Online Services B.V. Tweakers vormt samen met o.a. Autotrack en Carsom.nl de Persgroep Online Services B.V. Hosting door True