Cookies op Tweakers

Tweakers maakt gebruik van cookies, onder andere om de website te analyseren, het gebruiksgemak te vergroten en advertenties te tonen. Door gebruik te maken van deze website, of door op 'Ga verder' te klikken, geef je toestemming voor het gebruik van cookies. Wil je meer informatie over cookies en hoe ze worden gebruikt, bekijk dan ons cookiebeleid.

Meer informatie

Door , , 17 reacties
Bron: Mozilla Foundation, submitter: Nexico

Mozilla Firefox logo (75 pix)

Mozilla heeft de eerste update voor versie 5.0 van zijn webbrowser Firefox uitgebracht. Mozilla Firefox is beschikbaar voor Windows, Linux en Mac OS X, en is in een groot aantal talen te downloaden. Nieuw in versie 5.0 zijn onder andere verbeterde ondersteuning voor html 5 en de mogelijkheid tot het weergeven van css-animaties. Ook zijn er optimalisaties doorgevoerd die het openen van webpagina's moeten versnellen. In deze eerste update treffen we een oplossing aan voor twee problemen onder Mac OS X.

The latest version of Firefox has the following changes:
  • Worked around an issue in Mac OS X 10.7 that could cause Firefox to crash
  • Worked around an issue caused by Apple's "Java for Mac OS X 10.6 Update 5" where the Java plugin would not be loaded
You may be interested in the list of changes in the previous version.

De volgende downloads zijn beschikbaar:
*Mozilla Firefox 5.0.1 voor Windows (Nederlands)
*Mozilla Firefox 5.0.1 voor Linux (Nederlands)
*Mozilla Firefox 5.0.1 voor Mac OS X (Nederlands)
*Mozilla Firefox 5.0.1 voor Windows (Engels)
*Mozilla Firefox 5.0.1 voor Linux (Engels)
*Mozilla Firefox 5.0.1 voor Mac OS X (Engels)
*Mozilla Firefox 5.0.1 voor Windows (Fries)
*Mozilla Firefox 5.0.1 voor Linux (Fries)
*Mozilla Firefox 5.0.1 voor Mac OS X (Fries)

Mozilla Firefox 5.0 screenshot (481 pix)

Versienummer:5.0.1
Releasestatus:Final
Besturingssystemen:Windows 7, Windows 2000, Windows XP, Windows Server 2003, Windows Vista, Windows Server 2008
Website:Mozilla Foundation
Download:http://www.mozilla.com/en-US/firefox/all.html#languages
Bestandsgroottes:13,30MB t/m 28,20MB
Licentietype:GPL
Moderatie-faq Wijzig weergave

Reacties (17)

Waarom komt deze versie uit voor andere besturingssystemen dan OS X?
Wat IStealYourGun zei. Het was makkelijker om de scripts niet aan te passen, dat kan alleen maar dingen stuk maken. Wel is het zo dat huidige Win/Linux-gebruikers op 5.0 niet gebumpt worden naar 5.0.1.

Zie hier en daar
Om overal de zelfde versienummer te behouden.
Vermoedelijk is enkel de versie nummer omhoog gegaan bij de Windows & *Nix installaties, maar daarmee hebben alle os'en een 5.0.1 versie.
Ok, nu hebben we deze 5.0.1 (ik zie hem nog niet), en dan is het weer over naar Fx6, met allemaal kleine oninteressante veranderingen.

Dingen die ze van Chrome afkijken zijn legio, maar de dingen die ze moeten overnemen komen maar niet. Ik som op: - 2x zo snelle opstarttijd, ok niet makkelijk na te doen, wel heel wenselijk.
-ingebouwde pdf reader--- kunnen we Adobe wegsmijten.
-automatische flash update, ook wenselijk.
-gescheiden processen (tabs), boeit mij wat minder, maar wordt objectief als meer vergevorderd beschouwd.
-automatische update, doet Fx wel bij zo een 5.01, maar bij Fx 6 zal die weer gaan vragen of je het wil.. waarom dat? Fx6 is minor, sinds de invoering van snelle verversing, met ik zeg het nogmaals allemaal niet-boeiende vernieuwingen, die best hadden kunnen wachten tot een ouderwetse versie 4.1 was ingevoerd over 'n paar maanden.

Verder zou de kanalenkiezer die er even inzat, terugmoeten, kijk dat was wel onderscheidend van Chrome, dik pluspunt....nee hoor laten ze het in de Final 5.0 eruit..
kanalenkiezer was mogelijkheid in about:Firefox schermpje, om naadloos te kiezen tussen de Final, de Beta, of het Aurora channel, werd dan foutloos installt.

[Reactie gewijzigd door Sjah op 13 juli 2011 16:07]

Ingebouwde pdf reader is in ontwikkeling. Die komt er pas in te zitten als dat stable genoeg is en dat is nu nog niet het geval. Ik zie liever dat ze de standaard plugins gebruiken van het OS (Linux & MacOS X) of die van Adobe Reader (Windows). Voor OS X was er een plugin die keurig netjes gebruik maakte van de al aanwezige pdf plugin zoals Safari dat ook doet. Helaas is deze versie sinds Fx4 niet meer werkend. Ergens in de issuetracker staat nog wel een versie die werkt in de 32 bits versie van Fx4 (standaard is deze 64 bit in OS X) maar voor Fx5 is er geen werkende versie.

Automatische update van Flash is absoluut niet wenselijk! Flash is een algemene plugin die voor diverse browsers te gebruiken is. En zo hoort het ook te zijn: een plugin en niet onderdeel van de standard install van een webbrowser. Zeker niet gezien de vele security bugs die het heeft gehad en deels ook nog steeds heeft. Als men het gaat doen als Chrome betekent dat iedere webbrowser z'n eigen Flash heeft. Ik hoef niet tig Flash versies te hebben en te onderhouden. Doe maar lekker 1 versie die ik voor alle browsers kan gebruiken en die ik kan uitschakelen/uninstallen. In OS X is het sinds Flash versie 10.2 ofzo mogelijk om via de system preferences naar updates te zoeken. In 10.3 is dat niet gewijzigd. Als Adobe dat nou nog uitbreid zodat je ook vanuit die prefs de update kan installeren zou dat mooi zijn. Nu ga je nog naar de downloadpagina.

Gescheiden processen kent het al een tijdje. De plugin container en de browser zijn van elkaar gescheiden. Chrome doet het iets anders, die zet iedere tab in een apart proces. Of dat nou echt zo handig is valt te betwijfelen, niet iedereen vindt het handig.

De automatische update is iets wat sinds Fx4 er ook in zit voor zowel de browser zelf als de add-ons zoals de extensions en themes. Bij Fx5.0.1 gaat het om een paar kleine fixes om kleine bugs te verhelpen. Er is verder niets gewijzigd aan de functionaliteit en features van de browser. Daarom kun je deze ook automatisch pushen. Bij Fx6 kan dat niet omdat daar wel wijzigingen in de functionaliteit en features zijn gemaakt. Weliswaar niet zulke grote zoals we bij het vorig ontwikkelmodel gewend waren (Fx4 is niet voor niets meer dan een jaar in ontwikkeling geweest!) maar dat betekent niet dat iets als Fx6 dan ineens een minor versie is. Het idee van zoveel mogelijk functionaliteit en features in een release proppen is wat ze vroeger deden en wat ze nu hebben laten varen. Ze doen nu nog maar een kwart van dat aantal (om maar eens iets te noemen).

Die kanalenkiezer is verplaatst van browser naar website. Vanuit oogpunt van de gebruiker is dat een beter plan omdat die nu niet per ongeluk z'n browser naar een beta kanaal kan zetten en zodoende opgescheept raakt met niet werkende add-ons. Je moet nu bewuster kiezen. Dat is ook allemaal uitvoerig besproken in de bug.

[Reactie gewijzigd door ppl op 13 juli 2011 17:18]

pdf en flash, ik maak hier alleen maar een punt van omdat ik (en wat dacht je van echte n00bs, die helemaal) gek word van de updates die nodig zijn hiervoor, en ja ze ZIJN nodig, hoorde laatst iemand die nog een oude Adobe pdf had, en een pdf op internet opende en een virus had. Ik ga met je mee dat eigenlijk een syteem pdf en flash voldoende is. Dan is het aan Adobe om (en snel een beetje) te komen met een update-mechanisme dat silent pusht.

Gescheiden processen: ok die kant had ik nog niet gehoord, nogmaals ik vind gescheiden processen niet zo belangrijk, het crasht nooit bij mij.

Kanalenkiezer ben ik het gewoon mee oneens, mag dan wel in een bugreport besproken zijn, uiteindelijk worden ook in een bugreport keuzes gemaakt, ik zou iets anders gekozen hebben.

Tenslotte autom. updates: tja wat wil Mozilla nou, ook snel met vernieuwingen komen, en het idee dat versienummer belangrijk is (zoals vroeger) wegdrukken.... nou dan moeten ze ook all-the-way gaan en gewoon Fx 6,7 etc automatisch installen. Of je volgt Chrome's voorbeeld goed, of je doet het niet. Bijkomend argument is dat als Fx6 komt , Fx5 support bijna non-existent is, dus iedereen zal wel aan de Fx6 moeten, of met een ongepatchte browser achterblijven.
Eventueel alleen bij een dikke GUI-change zou je nog wel kunnen vragen of de gebruiker wil upgraden.
Ik vind het wel een beetje jammer, hoor.
De makers wllen juist zo'n automatisch patch-systeem, maar om de gebruikers ervan te overtuigen dat het echt werkt, moeten ze de gebruikers eerst gek maken met eindeloze patches en irritante bugs die op de lange baan worden geschoven.

Hoe je het ook wend of keert, een automagisch patchsysteem zit ik niet echt op te wachten. Zo verlaag je de internet kwaliteit, wanneer deze al laag is en je krijgt opeens problemen zonder dat je erom gevraagd hebt. Bijvoorbeeld memory leaks plotsklapseling of een menselijke fout van de devs die je prefs enzovoorts wr verwijderd.

Patches goedkeuren is 1 van de taken die een mens moet verrichten, want die gebruikt de computer namelijk, niet andersom.
Als dat automagisch systeem er was, dan waren we nu allemaal aan het mekkeren als schapen over de memory leaks en dat we liever voor een keuze stonden. 8)7


Waar we cht om moeten mekkeren is de magere kwaliteit van de huidige browsers.
Memory leak hier, memory leak daar, we kijken er niet meer naar om, totdat de browser opeens je geliefde add-on niet meer ondersteund. Dan huilen we alsof we rechten hebben.

[Reactie gewijzigd door Yezpahr op 15 juli 2011 00:42]

Hoe doe je handmatig een update in FF? Ik kan nergens in de menu's een "check for updates" vinden.
Menu -> Help -> About Firefox

dan zoekt hij automatisch naar updates
Hm deze update wordt nog niet automatisch gevonden... hij blijft bij 5.0!
Omdat er niks voor windows is veranderd, krijgen windows-gebruikers hem niet.
En wanneer worden de memory leaks voor de plugin-container aangepakt?
Zelfs in de 6.0 beta bestaan deze memory leaks nog. Ik hoop erg snel.
Zelf draai ik ook 6.0 en heb ik exact hetzelfde. maar dat komt (volgens mij) met name door flash. dus ik heb wat dumpfiles gepload naar het bug report systeem van adobe en ze zijn aan het kijken. Ik hoop dus stiekem dat het allemaal is opgelost bij de volgende flash versie :)
Als al eerder aangegeven dit komt pas in FF7, dus nog ongeveer 12 weken geduld.
Dat was voor firefox zelf, maar geldt dat ook voor de plugin-container?

Op dit item kan niet meer gereageerd worden.



Apple iOS 10 Google Pixel Apple iPhone 7 Sony PlayStation VR AMD Radeon RX 480 4GB Battlefield 1 Google Android Nougat Watch Dogs 2

© 1998 - 2016 de Persgroep Online Services B.V. Tweakers vormt samen met o.a. Autotrack en Carsom.nl de Persgroep Online Services B.V. Hosting door True