Software-update: Winamp iPod Plugin 3.10

Onlangs is versie 3.10 van de iPod-plug-in voor Winamp uitgekomen. Sinds versie 5.2 heeft Winamp ondersteuning voor mp3-spelers aan boord. Deze algemene pmp-ondersteuning komt van de voormalige ontwikkelaar van de Winamp iPod Plugin. Sinds hij echter voor Winamp zelf is gaan werken hebben anderen de ontwikkeling van de originele iPod-plug-in op zich genomen. Vooral voor iPod-bezitters is dat interessant, omdat deze meer functionaliteit biedt dan de algemene mp3-ondersteuning, zoals voor smartlists en podcasts. Tijdens de installatie wordt de ingebakken mp3-ondersteuning van Winamp (pmp_ipod.dll), indien aanwezig, verwijderd. Meer informatie kan in deze wiki worden gevonden. Hoewel de vorige versie alweer acht maanden oud is, laat het changelog slechts een handvol bugfixes zien:

Changes in version 3.10:
  • New: iPhone/iTouch support disabled by default, because newer devices and iTunes versions caused Winamp to crash. iOS 4 or 3 wasn't supported anyway, due to Apple's implemented protection to keep us out of the game. It can be re-enabled for older devices in the preferences, on the "Advanced" tab. You must restart Winamp after this change.
  • Fixed: bug that caused the scrolling title in newer Winamps to stop working (DrO)
  • Fixed: Don't show donation request on first launch (user should have some time to test with her device, first)
  • The support file "process.exe" is no longer bundled in the installer, as several virus scanners report this file as a potential threat. It is not, but it caused users to worry. We will provide a separate zip for this.
  • Still not supported (and probably never will): iPod nano 5G or 6G, iPhone with OS 3.x or 4.x, iPodTouch with OS 3.x or 4.x, iPod classic 6G. Thank Apple for their product philosophy
Winamp iPod Plugin screenshot (481 pix)
Versienummer 3.10
Releasestatus Final
Besturingssystemen Windows 7, Windows 2000, Windows XP, Windows Server 2003, Windows Vista, Windows Server 2008
Website SourceForge
Download http://sourceforge.net/projects/mlipod/files/mlipod/3.10/iPod_Support_v3_10.exe/download
Bestandsgrootte 1,49MB
Licentietype GPL

Door Bart van Klaveren

Downloads en Best Buy Guide

15-12-2010 • 09:40

12 Linkedin

Submitter: Anton

Bron: SourceForge

Reacties (12)

Wijzig sortering
Naar van Apple om dit tegen te werken.
Zoals ik het heb verstaan, gebruiken ze bij deze plug-in niet de api van apple en dat is niet toegelaten , een beetje zoals het PALM verhaal maanden terug.

Overigens zijn de extra features wel vrij verwaarloosbaar naar mijn mening. Er zit wel een mogelijkheid om lyrics er op te zetten, maar een transfer queue en unicode support zit er dan weer niet in.
Still not supported (and probably never will): iPod nano 5G or 6G, iPhone with OS 3.x or 4.x, iPodTouch with OS 3.x or 4.x, iPod classic 6G. Thank Apple for their product philosophy
Ja, dit is echt heel ergerlijk. Het heeft me na heel lang toch gedwongen op iTunes over te stappen toen ik laatste een Nano 5g kocht. Terwijl ik de manier waarop ik daar mijn muziek moet managen k*dt vind.

Daarvoor gebruikte ik altijd Winamp met de ml_ipod plugin (maar had ook gekund met deze, Winamp's eigen plugin). Lees ook het cynische verhaal [url="http://http://mlipod.sourceforge.net/wiki/Project_status"]hier[/url].

Gefeliciteerd Apple. Ik hoop dat Neelie spoedig achter jullie aankomt.

[Reactie gewijzigd door Ro-Maniak2 op 15 december 2010 10:46]

Ik hoop dat Neelie spoedig achter jullie aankomt.
Ah, de standaard Kroes-reply. We zijn weer zo close met onze beschermvrouwe (die al een tijdje geen mededinging meer doet) dat we haar bij voornaam mogen noemen.

Het is vrij algemeen bekend dat iTunes tot de systeemeisen van de iPod hoort. Staat ook op het doosje. Als je daar niet mee kunt leven, prima, maar doe jezelf en iedereen dan een lol en schaf meteen een speler aan die *wel* aan je eisen voldoet. Ik ga ook niet klagen dat een HP printer het het beste doet met HP drivers. Als je dit wilt negeren en andere software gebruiken, prima, maar ga niet huilen als dingen niet werken zoals je wilt.

Ik zou ook niet weten wat je wilt dat de EU ertegen doet. Dit valt niet onder koppelverkoop, en er zijn genoeg alternatieve mp3-spelers. Ik heb geen zin om voor de zoveelste keer de voorwaarden daarvoor te citeren.

Waarom schaf je een nano 5G aan als je bij voorbaat al weet dat je software nodig hebt die je niet wilt, en support voor andere software compleet NIET gegarandeerd is? Ik zie niet in wie je daar de schuld van kan geven buiten jezelf.
De vergelijking met drivers (zoals bij een printer) gaat mank. Bij een printer ben ik vrij in de keuze van de programma's die ik gebruik bij mijn printer. Het mooie van drivers is dat ik vanuit elke applicatie die die driver ondersteunt, het apparaat kan gebruiken.

Bij Apple is er technisch gezien geen bezwaar om drivers te ontwerpen. Apple of derden zouden prima drivers kunnen maken waardoor je je iPod zou kunnen gebruiken met de software die je wenst. Maar Apple weert dat zeer doelbewust. Apple wil helemaal niet dat jij zelf bepaalt dat jij jouw iPod met de software die jij wenst gebruikt. Reden is natuurlijk dat je Apple ervan uitgaat dat jij met iTunes muziek of andere media zult kopen, waar Apple aan verdient. Met software van derden loopt Apple die inkomsten mis.
Waar Apple helemal aan voorbij gaat, is dat veel consumenten een iPod kopen voor dat handige, mooi vormgegeven apparaatje. En die consument is helemaal niet geïnteresseerd in iTunes. Sommigen zullen iTunes een heerlijk programma vinden, anderen - zoals ik zelf - vinden iTunes een draak van een programma. Helemaal niet erg, mits je je iPod kunt gebruiken met software naar eigen keuze. Ik heb een Nano 4G en die werkt prima met WinAmp.

Met deze opstelling van Apple jaagt Apple gebruikers als ik alleen maar tegen zich in het harnas. Ik zal zeer zeker geen Nano 6G kopen, als ik weet dat ik die alleen met iTunes kan gebruiken. Erg jammer, want met het apparaatje zelf is weinig mis.
Apple wil helemaal niet dat jij zelf bepaalt dat jij jouw iPod met de software die jij wenst gebruikt. Reden is natuurlijk dat je Apple ervan uitgaat dat jij met iTunes muziek of andere media zult kopen, waar Apple aan verdient. Met software van derden loopt Apple die inkomsten mis.
Precies. En dat is dus wél koppelverkoop, closed shop, etc. ;) @Refriednoodle
De meeste scanners en printers bieden hele bundels aan. Alleen de scandriver of printerdriver vinden is bij de meeste consumenten producten helemaal niet meer mogelijk. Vaak worden er ook bepaalde applicaties gestart bij het starten van Windows die helemaal niet van belang zijn voor de driver.

Het dus helemaal niet ongewoon dat je randapparatuur verplicht moet bedienen met een speciaal daarvoor geschreven app. Zo bepaald de fabrikant zijn "ervaring" met het product.

Ik heb zelf helemaal niets met iTunes. Het is in mijn ogen een naar programma om mee te werken maar begrijp volledig waarom Apple het zo doet. Firmware updates worden bijvoorbeeld ook aangeboden via itunes. Uiteraard wordt er ook mega veel geld omgezet met de grootste muziekwinkel gekoppeld aan het meest succesvolste muziekspelers ooit.

Om er dan ook maar over te klagen is nutteloos. Koop die nano dan gewoon niet.....
Or be a man and suck it up :+
Meeste fabrikanten bieden hun printer drivers zonder zever gewoon aan op hun website.
En ook op hun CD staat die vaak gewoon "bloot" er op

Hoewel dat voornamelijk is om die automatisch te installeren binnen een bedrijfsomgeving.
hm jij bent niet een Tweaker dus...dat mag hoor..ik heb ook geen zin een hele reactie op te ratelen aan je maar ben het eens met Ro-Maniak2. Ik denk wel dat we het meer van tweakers moeten hebben dan van Neelie wat dit betreft.
[quote]Still not supported (and probably never will): iPod nano 5G or 6G, iPhone with OS 3.x or 4.x, iPodTouch with OS 3.x or 4.x, iPod classic 6G. Thank Apple for their product philosophy.[/qouote]

Eigenlijk is het vreemd, want mijn iPod 6G blijkt sinds een tijdje wel te werken in FooBar. Ik heb toen als de weerga het ding gereset, iTunes en alle andere Apple-software van mijn bak verwijderd en opgeschoond, en daarna heb ik de speler met FooBar opnieuw gevuld. Misschien kunnen de makers van ml_ipod eens contact opnemen met de ontwikkelaars van FooBar.

Prima MP3-speler, en de enige met 80+ gig aan opslag voor een haalbare prijs (nog steeds, na 3 jaar). Vanwege de manier waarop Apple alles wenst te controleren (wat naar mijn mening de laatste jaren erger is geworden), is het echter ook mijn eerste en laatste Apple product ooit.
Er is trouwens een tweede reden waarom ik geen iTunes gebruik voor m'n iPod: Veel van mijn muziek staat in flac-formaat op mijn computer. Met Winamp en deze plugin, kun je gewoon flacs naar je iPod kopiëren. De plugin converteert ook de flacs netjes naar het bestandsformaat op de iPod.
Anoniem: 150070
15 december 2010 13:50
misschien gewoon een idee : koop geen Ipod ,
zal ik nooit doen , waar haal je het zeg een mp3 speler die je verplicht om zijn app te gebruiken !
er zijn goeie mp3 spelers genoeg die je gewoon explorer gewijs dienen :)

Op dit item kan niet meer gereageerd worden.

Kies score Let op: Beoordeel reacties objectief. De kwaliteit van de argumentatie is leidend voor de beoordeling van een reactie, niet of een mening overeenkomt met die van jou.

Een uitgebreider overzicht van de werking van het moderatiesysteem vind je in de Moderatie FAQ.

Rapporteer misbruik van moderaties in Frontpagemoderatie.




Google Pixel 7 Sony WH-1000XM5 Apple iPhone 14 Samsung Galaxy Watch5, 44mm Sonic Frontiers Samsung Galaxy Z Fold4 Insta360 X3 Nintendo Switch Lite

Tweakers vormt samen met Hardware Info, AutoTrack, Gaspedaal.nl, Nationale Vacaturebank, Intermediair en Independer DPG Online Services B.V.
Alle rechten voorbehouden © 1998 - 2022 Hosting door True

Tweakers maakt gebruik van cookies

Tweakers plaatst functionele en analytische cookies voor het functioneren van de website en het verbeteren van de website-ervaring. Deze cookies zijn noodzakelijk. Om op Tweakers relevantere advertenties te tonen en om ingesloten content van derden te tonen (bijvoorbeeld video's), vragen we je toestemming. Via ingesloten content kunnen derde partijen diensten leveren en verbeteren, bezoekersstatistieken bijhouden, gepersonaliseerde content tonen, gerichte advertenties tonen en gebruikersprofielen opbouwen. Hiervoor worden apparaatgegevens, IP-adres, geolocatie en surfgedrag vastgelegd.

Meer informatie vind je in ons cookiebeleid.

Sluiten

Toestemming beheren

Hieronder kun je per doeleinde of partij toestemming geven of intrekken. Meer informatie vind je in ons cookiebeleid.

Functioneel en analytisch

Deze cookies zijn noodzakelijk voor het functioneren van de website en het verbeteren van de website-ervaring. Klik op het informatie-icoon voor meer informatie. Meer details

janee

    Relevantere advertenties

    Dit beperkt het aantal keer dat dezelfde advertentie getoond wordt (frequency capping) en maakt het mogelijk om binnen Tweakers contextuele advertenties te tonen op basis van pagina's die je hebt bezocht. Meer details

    Tweakers genereert een willekeurige unieke code als identifier. Deze data wordt niet gedeeld met adverteerders of andere derde partijen en je kunt niet buiten Tweakers gevolgd worden. Indien je bent ingelogd, wordt deze identifier gekoppeld aan je account. Indien je niet bent ingelogd, wordt deze identifier gekoppeld aan je sessie die maximaal 4 maanden actief blijft. Je kunt deze toestemming te allen tijde intrekken.

    Ingesloten content van derden

    Deze cookies kunnen door derde partijen geplaatst worden via ingesloten content. Klik op het informatie-icoon voor meer informatie over de verwerkingsdoeleinden. Meer details

    janee