Cookies op Tweakers

Tweakers maakt gebruik van cookies, onder andere om de website te analyseren, het gebruiksgemak te vergroten en advertenties te tonen. Door gebruik te maken van deze website, of door op 'Ga verder' te klikken, geef je toestemming voor het gebruik van cookies. Wil je meer informatie over cookies en hoe ze worden gebruikt, bekijk dan ons cookiebeleid.

Meer informatie

Door , , 26 reacties
Bron: Amd

ATi CrossFireX logo (75 pix) AMD heeft nieuwe Linux-drivers voor zijn ATI Radeon-videokaarten uitgebracht. De download is 96MB groot en kan voor zowel 32bit- als 64bit-omgevingen worden gebruikt. Versie 10.7 is geschikt voor Radeon HD 2400 en hoger, de FireStream 9170, 9250 en 9270, en de embedded E2400 en E4690. Verder worden versies 6.8 tot en met 7.5 van X.org, Linux-kernel 2.6 en hoger, en glibc-versies 2.2 en 2.3 ondersteund. Nieuw in deze release zijn ondersteuning voor Ubuntu 10.04 en ATI's Eyefinity, en voorlopige ondersteuning voor openSUSE 11.3. Het changelog toont verder enkele bugfixes en een lijst met bekende problemen waarvoor nog geen oplossing is.

New Features
  • Support for New Linux Operating Systems
    • Ubuntu 10.04 production support
    • openSUSE 11.3 early look support
  • ATI Eyefinity support
    • ATI Catalyst 10.7 delivers support for ATI Eyefinity technology under all supported Linux distributions
Resolved Issues
  • Applying display rotation using Catalyst Control Center or XRandR no longer causes display to turn blank with mouse cursor
  • Disabling the primary display in clone/dual-head mode no longer causes Catalyst Control Center not to launch after X restart
  • CrossFire can now be enabled properly on the first Gemimi card under a 2 Gemini multi-adapter configuration
  • Xserver no longer fails when applying "Maintain Aspect Ratio" option from GPU scaling at maximum resolution
  • [SUSE] Desktop corruption no longer visible after applying rotation using Catalyst Control Center and restarting X
  • Enabling a second ASIC without a monitor connected no longer causes black screen and X window not launching when startx is executed
  • [Ubuntu 10.04] X segmentation fault no longer occur at startup on multi-ASIC systems
  • Catalyst Control Center: Gamma control changes no longer affect the wrong display in clone mode
  • Switching to clone mode by pressing Fn+F4 now functions properly after connecting an external VGA monitor
  • X-window no longer fails with some ATI card plugged in NV's C51 IGP board
Known Issues
  • OpenCL 1.0 conformance tests have not been run with this version of the ATI Catalyst Driver Suite in conjunction with the ATI Stream SDK v2.2. If you require an OpenCL 1.0 conformant driver, we recommend that you install the ATI Catalyst 10.5 Driver Suite
  • "Glxgears/fgl_glxgears" full screen application may still remain on the desktop after they are closed using X button
  • Desktop arrangement area may appear empty and fail to display the icon number when Catalyst Control Center is relaunched after disabling or hot-unplugging the secondary display
  • X-server may fail when launching fullscreen OpenGL application with CrossFire enabled and secondary display selected for accelerated display
  • Catalyst Control Center may fail to launch due to segmentation fault error under a 2 Gemini ATI Radeon HD 5900 Series multi-adapter configuration
  • X-server may fail to start, or unusual behaviour may be observed, after applying various HDTV formats of 1080i30/25/p50 standard and optimized modes on DVI/DP displays
  • System may fail to display error message when improper position values are used in "aticonfig --tv-geometry" resulting in invalid "TVHPosAdj" and "TVVPosAdj" values in xorg.conf file
  • Rotated screen may fail to properly restore after running full-screen OpenGL application in dual-head mode; a switch VT will restore screen correctly
  • Mouse cursor might be blocked from entering the taskbar area after applying specific rotations
  • Segmentation fault may occur when running "Quake 4" and "Enemy Territory: Quake Wars" at 1280x1024 or resolutions higher than current desktop resolution
  • SUSE 11.2: With a DP display connected to the adapter, a hot-plugged DFP display may fail to light up in clone mode
ATi Catalyst  Linux Display Driver logo (410 pix)
Moderatie-faq Wijzig weergave

Reacties (26)

En nog altijd geen ondesteuning voor nieuwe Xserver. Dus ook geen support voor fedora 13.
Komt wel als Ubuntu eindelijk overstapt :/
Getuigd wel van kortzichtigheid en luiheid bij ATI IMO...

Als ze nou gewoon de nodige documentatie vrijgeven dan staat er binnen een half jaar een betere driver klaar dan ze zelf ooit hadden kunnen maken.
uhmmm, dat hebben ze gedaan. al een flinke tijd terug.

in januarie hebben ze de specs van hun hd5xxx serie ge-released, alle oudere kaarten al maanden(jaar? 2?) eerder.
de driverbouwers zijn hard aan het werk maar het duurt dus wel iets langer als 6 maanden.

3d support is er al wel voor veel oudere kaarten overigens.

[Reactie gewijzigd door Countess op 31 juli 2010 18:16]

openSUSE 11.3 staat er wel bij als supported en die gebruikt ook een x-server versie die voorheen niet ondersteunt werd.
Ik heb deze trouwens ondertussen uitgeprobeerd i.c.m. openSUSE 11.3 en er zijn wat repaint issues, sommige delen van je scherm worden zwart.

o.a. hier te zien : http://imagebin.ca/view/z1WiVSlj.html (niet m'n eigen screenshot, maar toont meteen aan dat ik niet de enige ben met het probleem)

Volgende keer toch maar een laptop met NVIDIA kaart
!!!!!!!!!!!!!!!!!!
Blijkbaar is men er toch in geslaagd dit in fedora aan het werk te krijgen.
Volg deze instructies.
Zowel 13 als vorige versies.

[Reactie gewijzigd door Punkie op 4 augustus 2010 10:55]

Link is in orde.
10.7 op ubuntu 10.04 los gelaten. Eindelijk vrijwel true color met de catalyst control center.
Red op 1.08
Green op 1.00
Blue op 0.75

(true color op windows vista hetzelfde behalve red op 1.10)

Kijk eens hier voor installatie.

http://ubuntuforums.org/s...s+guide+ati+linux+drivers

Succes
Tja.
Wat uiteindelijk volgens mijn idee het beste werkt is het volgende:
ubuntu 10.04/mint 9 ati 10.7

Ubuntu X Team's PPA

This is an excellent PPA, frequently updated, and run by Ubuntu veterans.

$ sudo add-apt-repository ppa:ubuntu-x-swat/x-updates
$ sudo apt-get update

At this point, you should install available updates and then you can install the driver:

$ sudo apt-get install fglrx-installer

DEZE sudo apt-get install fglrx-installer NIET OP DEZE MANIER: :o

Gebruik de installatie ati kaart MET de hardware drivers installer.
Kijk via package manager zoeken op ati naar de versie.

Mvg, :)
Heb die repo toegevoegd en fglrx-installer succesvol geinstalleerd, maar "aticonfig" kan niet gevonden worden? Enig idee waar dit aan ligt?
Helaas moet ik opnieuw tot de conclusie komen dat ATI/AMD er weer helemaal niets van maakt. Het is toch triest dat een fabrikant niet eens een beetje werkende drivers kan maken. Ik kan in ieder geval nog steeds compleet geen gebruik maken van deze drivers omdat video's nog steeds allemaal artefacten tonen, vooral als de resolutie wat hoger wordt (720p is nog net af te spelen, maar 1080p is onmogelijk, in Windows of met opensource drivers geen probleem). Ook is het verplaatsen van vensters nog steeds een halve onmogelijkheid, verplaatsen van een venster heeft namelijk nog steeds een seconde (of soms zelfs drie) nodig. En een game kan ik opstarten als ik zin heb in een diashow. En dat op een HD4850, daar mag je toch wel iets meer van verwachten.

Gelukkig zijn er tegenwoordig opensource drivers, want die draaien als een zonnetje, en ook al is de 3D ondersteuning nog niet helemaal goed volgens de ontwikkelaars, het werkt bij mij al veel beter dan de catalyst drivers.
Op mijn 4870 werkt het wel uitstekend
op mijn 4200 eveneens. ;) (evenwel heeft de laaste volledige update gisteren van opensuse 11.2 de grafische schil om zeep gehopen, straks even cli yast om te fiksen)
Het lijkt erop dat de hardware acceleratie bij jouw niet werkt.

Voer 'fglrxinfo' eens uit in een terminal. Er moet dan ergens een referentie staan naar ATI. Wanneer je geen ATI ziet, maar bijvoorbeeld Mesa, dan is je driver niet goed geinstalleerd of geconfigureerd.
Mijn voorkeur zou ook uitgaan naar de opensource drivers, maar dan heb je geen VAAPI en OpenCL ondersteuning volgens mij....
Dat is omdat als je Linux gebruikt, liever Nvidia hebt ;-)
Hoewel Nvidia momenteel betere drivers heeft, timmert ATi goed aan de weg hoor...
Ze hebben gewoon dezelfde updatecyclus als de Windows drivers, dus ik vind dat het iig de goede kant op gaat ;)
tenzij je alleen opensource drivers wilt. dan heeft ATI veruit de beste papieren door het open geven van de specs van hun GPU's.

nog even en ATI's eigen closed source drivers zijn alleen nog nodig voor net nieuwe kaarten waarschijnlijk.
Hmm, de Website-link gaat wel naar Nvidea in plaats van naar ATI ;)
Sinds kort heb ik Lucid Lynx draaien op mijn pc. Ik heb een ATi X1950pro. Nu staat er hier dat er support is voor 10.04, maar voor kaarten nieuwer dan HD2400. Welke drivers kan ik het beste downloaden?
9.4 catalyst iirc (wat niet altijd handig is qua kernel)

x1xxx is R500.

http://www.phoronix.com/s...em=ati_r300_current&num=1 geeft informatie over prestaties; je zou mesa het beste kunnen gebruiken.
Heeft iemand enig idee of deze driver ook hardware acceleration ondersteund voor vlc?

Op dit item kan niet meer gereageerd worden.



Apple iOS 10 Google Pixel Apple iPhone 7 Sony PlayStation VR AMD Radeon RX 480 4GB Battlefield 1 Google Android Nougat Watch Dogs 2

© 1998 - 2016 de Persgroep Online Services B.V. Tweakers vormt samen met o.a. Autotrack en Carsom.nl de Persgroep Online Services B.V. Hosting door True